LINUX.ORG.RU

Почему в свободных САПР не поддерживается формат DWG

 , , ,


0

3

В начале январе в разделе для нетехнических дискуссий ЛОР был задан очередной, двеститритысячипятисотый по счёту вопрос о поддержке в СПО проприетарного формата чертежей DWG.

Редакция проекта linuxgraphics.ru решила выяснить причины, по которым существующая библиотека LibreDWG не используется в таких активных проектах как LibreCAD и FreeCAD. Для этого были проинтервьюированы создатели библиотеки, авторы некоторых свободных САПР, соразработчик Open Assets Library, руководитель Blender Foundation и, наконец, представитель Free Software Foundation — правообладателя кода LibreDWG.

Исследование выявило несколько факторов, сформировавших существующее положение дел. Ключевыми авторы исследования считают два: неполнота спецификации на формат и лицензионная несовместимость библиотеки с ПО для конечных пользователей.

Первый фактор обусловил неполноту реализации поддержки форматов, второй — потерю одним из создателей LibreDWG интереса к разработке ввиду невозможности увидеть практическое применение результатов двух лет работы. Всё вместе это стало причиной приостановки разработки LibreDWG в январе 2011 года.

Обновление лицензии самих САПР до совместимости с GPLv3+ существенно осложнено ввиду использования унаследованного и третьестороннего кода, чья лицензия накладывает ограничения на лицензирование САПР.

В настоящее время авторы LibreDWG уже более месяца ведут переговоры с FSF о выработке оптимальной стратегии релицензирования библиотеки. Более точную информацию ни та, ни другая сторона представить пока не в состоянии.

Напомним, что поддержка DWG в свободном ПО была в 2008 году объявлена приоритетным проектом FSF. Несмотря на это, до сих пор FSF и Ричард Столлман высказывались категорически против релицензирования LibreDWG, тем самым препятствуя достижению поставленной ими же цели.

>>> Подробности

★★★★★

Проверено: JB ()

Ответ на: комментарий от AP

Какое-то это невзрослое отношение к своей работе.

Это неприятно. Поставь перед Столлманом задачу исправить вертикаль :) Я думаю и это разрешимо.

Evgueni ★★★★★ ()
Ответ на: комментарий от yurkis

Из - за юридических формальностей? Ну серьезно, выглядит диковато.

Да, именно из-за них. Но кое-кто, выпустив программу под GPLv2, лишил FSF как координатора этой деятельности, возможности исправить эти формальности. Одно дело — если кто не знает о FSF, тот не виноват, что его лицензия несовместима с GPL, хотя соответствует критериям свободного ПО. А другое дело, что человек знал о FSF, воспользовался придуманным ей механизмом копилефта, но при этом лишил FSF возможности устранить проблемы, вызванные этим инструментом.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Deleted

В данном случае проблема в FSF:

1. GPL2 несовместима с GPL3. Это реально проблема. 2. FSF требует передачи имущественных прав на код для ряда проектов (GCC самый известный из них). При этом не факт что распоряжаться этим кодом она будет разумно (как в данном случае). Это тоже оптимизма не добавляет.

Вкупе пп1 и 2 создают такие идиотские ситуации. Я понимаю, ничто не совершенно. Кого- то возможно это устраивает. Но, ИМХО, FSF нужно быть все-таки более гибкой.

yurkis ()
Ответ на: комментарий от baka-kun

А мне можно не хотеть DWG на этих условиях?

Ты хочешь патентнотроллить по отношению к блендеру с поддержкой DWG? Или тивоизировать девайсы с ним? Ну тогда что я могу сказать, FSF правы, что не делают послабления для этой библиотеки.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от yurkis

Да да, FSF виновата, что кто-то выбрал GPL X only лицензию. Прямо вот так вот лучами из космоса их заставила, ага.

Для чего создана GPL — для того и работает. Иначе можно набросать ядро GPL3 и прикрутить всё остальное версии 2. И смысл тогда?

Deleted ()
Ответ на: комментарий от Ttt

Но кое-кто, выпустив программу под GPLv2…

Лишил FSF возможности контролировать условия распространения не принадлежащего им произведения.

baka-kun ★★★★★ ()
Ответ на: комментарий от baka-kun

Лишил FSF возможности контролировать условия распространения не принадлежащего им произведения.

Вот же ж злобный пират.

O02eg ★★★★★ ()
Ответ на: комментарий от baka-kun

Смогут. Не лги и не распространяй FUD. Оригинальный код останется под GPLv2+, даже если его слинковать с кодом под другой совместимой лицензией, будь-то Modified BSDL или GPLv3+.

mihalych ★★★ ()
Ответ на: комментарий от yurkis

GPL2 несовместима с GPL3. Это реально проблема.

А FSF не рассчитывали, что люди будут массово выпускать программы под GPL2-only. Они предупреждали, что так делать не следует.

И как бы ты предложил исправить эту ситуацию, чтобы, с одной стороны, можно было выпустить программу, защищённую от тивоизации и патентного троллинга, а с другой — в которую можно было бы включать код под GPLv2 (при условии, что GPLv2 уже выпущена)? Добавить в GPLv3 пункт «можно включать в программу код под GPLv2» не прокатит, т.к. GPLv2 не допускает накладывать на производный код дополнительных юридических ограничений.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

Да, именно из-за них. Но кое-кто, выпустив программу под GPLv2, лишил FSF как координатора этой деятельности, возможности исправить эти формальности. Одно дело — если кто не знает о FSF, тот не виноват, что его лицензия несовместима с GPL, хотя соответствует критериям свободного ПО. А другое дело, что человек знал о FSF, воспользовался придуманным ей механизмом копилефта, но при этом лишил FSF возможности устранить проблемы, вызванные этим инструментом.

FSF как и любая другая организация несовершенна. И не вечна. И не обязана быть вечно адекватной. И не всегда разработчика устраивает GPL v3.

В ДАННОМ КОНКРЕТНОМ случае FSF могла бы проявить гибкость и перелицензировать проект под GPL v2. Это единственный выход. Крупные проекто иногда просто не могут перелицензироваться, у FSF же единоличные права на код. Но мне кажется что этого не будет. А это значит что проект мертв. И лично мне грустно что огромная работа проделана впустую не из- за технических проблем/недостатка времени программистов а из- за политических/религиозных взглядов евангелистов.

yurkis ()
Ответ на: комментарий от mihalych

Смогут.

Дырку от бублика. Распространять произведение они смогут только на условиях GPLv3+, несмотря на то, что части его останутся под BSDL или GPLv2+, как и раньше. Я рад, что хотя бы это ты наконец понял, но как вижу, ещё не до конца.

baka-kun ★★★★★ ()

Кстати, насколько я знаю, есть такая практика по обходу патентной монополии за счёт сборки продукта лично пользователем. Насколько она может быть применима в данном случае?

O02eg ★★★★★ ()
Ответ на: комментарий от Deleted

FSF заставляет их что ли? В горло пихает свою либу?

В очередной раз повторю, для невнимательных — «Нет». Но пусть не удивляются, что использовать её никто не будет.

baka-kun ★★★★★ ()
Ответ на: комментарий от baka-kun

Лишил FSF возможности контролировать условия распространения не принадлежащего им произведения.

Этот контроль будет выражен максимум в ослаблении копилефта. Ну а как ты ещё предлагаешь сделать? Автор программы захотел именно копилефт, так что вариант, что копилефт не нужен и BSDL рулит, не катит. Автор захотел именно копилефт. Но при этом фактически сказал, что не хочет включения в свою программу кода под другими копилефт-лицензиями, вне зависимости от того, нарушает ли это чьи-то интересы.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

А FSF не рассчитывали, что люди будут массово выпускать программы под GPL2-only.

Задолго до релиза GPLv3 было известно о множестве софта под GPLv2 only, включая Linux, предлагались пути решения проблемы, звучали аргументированные заявления о невозможности обновить лицензию…

RMS и FSF сделали вид, что не услышали, и сознательно сделали даже LGPLv3 совершенно несовместимой с [L]GPLv2. И кто после этого кто?

baka-kun ★★★★★ ()
Ответ на: комментарий от O02eg

Скорее всего вполне можно обойтись консольным конвертером вызывая его через system. Другое дело, что это довольно большой объём работы и все его тогда смогут запользовать, чего авторы libreDWG как раз не хотят.

Evgueni ★★★★★ ()
Ответ на: комментарий от Deleted

Никто это кто?

Не желающие менять свою лицензию ради сомнительного удовольствия использовать почти ничего не умеющую либу. Не согласные помогать её развивать на условиях FSF.

baka-kun ★★★★★ ()

Прежде, чем флудить, я бы посоветовал изучить вопрос.

Согласно найденному мной в интернете и скаченным исходникам, FreeCAD и Blender распространяются под GPL v2+. никаких проблем совместимости с LibreDWG у этих проектов нет.

Blender распространяeтся исключительно под GPL (что означает, любая версия по выбору, даже первая, но в исходниках всё же v2+). В FreeCAD есть код и под другими лицензиями, но я не увидел в репозитории git что-то несовместимое с GPL v3+. Если что-то не досмотрел, поделитесь своими находками.

Единственная проблема, насколько могу судить - с LibreCAD, который под GPL v2 only. Но, думаю, не составит труда попросить разработчиков LibreCAD перелицензировать свой код под «GPL v2 or GPL v3», если уж их по каким-то никому не ведомым причинам не устраивает стандартный GPL v2+. Кто-то из флудивших тут просил?

mihalych ★★★ ()
Ответ на: комментарий от Deleted

Да пожалуйста, чемодан, трактор, Windows. Их там таких много уже.

Ты не понимаешь одной простой вещи: библиотеке поддержка программ нужна даже больше, чем САПР-ам эта конкретная библиотека. Они жили без DWG, и дальше жить-не-тужить будут. А неиспользуемая либа — труп.

Вообще, чем шире используется библиотека, тем более библиотека файловых форматов, и не важно даже, если в коммерческом ПО тоже, тем лучше в первую очередь для библиотеки и сообщества. Какие-нибудь libz, libjpeg или libpng уже никто и не подумает переписывать, а развивает их весь мир по все три стороны ГНУнсой баррикады.

baka-kun ★★★★★ ()
Ответ на: комментарий от baka-kun

Брось лицемерить. Если так, то тогда BSDL - самая проблематичная лицензия (примени свою логику). Потому как её невероятно проблематично (твоя логика) линковать с кодом под другими (совместимыми) лицензиями. Потому как сделав это, уже невозможно будет распространять получившееся произведение под BSDL.

Вывод: baka-kun - распространитель фуда против свободных лицензий. :)

mihalych ★★★ ()
Ответ на: комментарий от mihalych

проблем совместимости с LibreDWG у этих проектов нет.

Они не хотят менять условия распространения проекта на GPLv3+. И их никто не заставляет, да?

baka-kun ★★★★★ ()
Ответ на: комментарий от mihalych

Потому как сделав это, уже невозможно будет распространять получившееся произведение под BSDL.

Не тупи. Попробуй на секунду избавиться от GPL-зомбирования и понять, что она этого не требует.

Но от того, что продукт распространяется под GPLv2+, например, код под BSDL в его составе не перестал быть BSD.

baka-kun ★★★★★ ()
Ответ на: комментарий от baka-kun

Я понимаю то, что ради сиюминутной выгоды ты готов сдать позиции. Зачем тогда барахтаться? Надо сдаться и плыть по течению как все, не?

Deleted ()
Ответ на: комментарий от Deleted

Я понимаю то, что ради сиюминутной выгоды ты готов сдать позиции.

Какие позиции? Я сторонник «пермиссивных», как их любят некоторые FUD-еры называть, лицензий. То есть тех, которые предоставляют получателям произведения больше прав, которые более свободны.

baka-kun ★★★★★ ()
Ответ на: комментарий от baka-kun

Но от того, что продукт распространяется под GPLv2+, например, код под BSDL в его составе не перестал быть BSD.

У тебя наметилось продвижение в логике. Но правильный вывод ты пока почему-то всё ещё не делаешь.

По аналогии с BSDL. От того, что код из проэктов CAD под GPL v2+ станут линковать с совместимой LibreDWG под GPL v3+, *ничего* для этих проектов не изменится. Код прекрасно может оставаться под GPL v2+. Ты действительно этого не понимаешь? Изучай GPL FAQ.

mihalych ★★★ ()
Ответ на: комментарий от mihalych

От того, что код из проэктов CAD под GPL v2+ станут линковать с совместимой LibreDWG под GPL v3+…

…кады как целое, равно как и любые их части, зависимые от LibreDWG смогут распространяться только на условиях GPLv3+.

Ты с этим не будешь спорить?

baka-kun ★★★★★ ()
Ответ на: комментарий от Evgueni

все его тогда смогут запользовать, чего авторы libreDWG как раз не хотят.

Интересно, если всё-таки это реализовать, введут ли в GPL ещё более анальные ограничения?

O02eg ★★★★★ ()

FSF всё правильно делает, а то этим людям дашь палец - руку откусят.

А кто лицензирует свой софт под GPLv2 only, тот латентный проприетарщик, и знает, на что идёт. Включая Линуса.

vasilenko ★★ ()
Ответ на: комментарий от O02eg

Какие именно ограничения, появившиеся в GPLv3 по сравнению с GPLv2, для тебя стали анальными?

vasilenko ★★ ()
Ответ на: комментарий от Evgueni

Таких:

Скорее всего вполне можно обойтись консольным конвертером вызывая его через system. Другое дело, что это довольно большой объём работы и все его тогда смогут запользовать, чего авторы libreDWG как раз не хотят.

O02eg ★★★★★ ()
Ответ на: комментарий от O02eg

Так нет никакого эксцесса: разработчики не хотят и не делают. Всё честно.

Что сказать то хотел? Ты говори-говори.

Evgueni ★★★★★ ()
Ответ на: комментарий от O02eg

Не знаю. Ты так ничего и не сказал. Пальцем ткнул куда-то и промычал что-то нечленораздельное.

Evgueni ★★★★★ ()
Ответ на: комментарий от O02eg

Кстати извиняюсь — не правильно прочитал твой пост на тему обхода патентной монополии путём сборки пользователем. Не поверил своим глазам, что может быть такая каша и автоматом поправил его в лучшую сторону.

Evgueni ★★★★★ ()
Ответ на: комментарий от baka-kun

предлагались пути решения проблемы

Какие?

LGPLv3 совершенно несовместимой с [L]GPLv2.

4.2. В одном проекте можно использовать одновременно код и под LGPLv2 и под LGPLv3. Даже код под LGPLv2 можно включить в проект под GPLv3, т.к. LGPLv2 допускает перелицензирование на GPLv2 и выше.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Evgueni

в смысле вместо патента автоподставил лицензию.

Evgueni ★★★★★ ()

Что-то я не могу понять проблемы. Вот есть у меня программа на Питоне на условиях GPL v3+, у моего товарища есть фортрановская либа по лицензии GPL v 2+, я не могу снею линковаться? Никак не могу, или только статически? Объясните мне выдержками из GPL, что не могу, потому что я сам понял иначе.

PS я не претендую, что стану считать его библиотеку частью своего проекта, я честно говорю, что это библиотека имени такого-то.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

Может быть засада, что фортрановская либа, кое где, использует код GPLv2 only и для линковки этот кусок нужно выкинуть или переписать. Если я правильно понял AP, то он именно на это и намекал.

Evgueni ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.