LINUX.ORG.RU

Сообщения zenkov

 

Google Stadia на Linux Mint

Галерея — Скриншоты

Так-то бы ещё скриншотов наделать, но когда игра не в фулл-скрине Стадия ругается и предлагает её закрыть. Про работу рассказать особо нечего. Она работает. Задержка там как-то хитро обрабатывается алгоритмом и в целом не ощущается. Никуда она однако не делась и в рейд Destiny я бы с ней не пошёл (в саму Destiny я тоже играл, всё хорошо, уже достаточно людно). В какие-нибудь нерасторопные игры вроде той же Red Dead Redmeption, думаю будет норм.

Завёл всё через ProtonVPN подружив его со своим Mikrotik. Дружил долго так как руки из одного места и в целом до конца не подружил.

Вот мой конфиг, может кому интересно будет.

/ip ipsec profile add name=ProtonVPN 

/ip ipsec proposal add name=ProtonVPN auth-algorithms=sha256 enc-algorithms=aes-256-cbc pfs-group=none

/ip ipsec policy group add name=ProtonVPN

/ip ipsec policy add dst-address=0.0.0.0/0 group=ProtonVPN proposal=ProtonVPN src-address=0.0.0.0/0 template=yes

/ip ipsec mode-config add name=ProtonVPN responder=no

/ip ipsec peer add address=se.protonvpn.com exchange-mode=ike2 name=ProtonVPN profile=ProtonVPN

/ip ipsec identity add auth-method=eap certificate="" eap-methods=eap-mschapv2 generate-policy=port-strict mode-config=ProtonVPN peer=ProtonVPN policy-template-group=ProtonVPN username=имя password=пароль

/ip ipsec profile add name="ProtonVPN" hash-algorithm=sha256 enc-algorithm=aes-256 dh-group=modp2048 lifetime=1d proposal-check=obey nat-traversal=yes dpd-interval=2m dpd-maximum-failures=5

/ip firewall address-list add address=мой-пк list=local  /ip ipsec mode-config set [ find name=ProtonVPN ] src-address-list=local 

В чём суть отсутствия дружбы. На любой сайт практически ничего нельзя загрузить. Upload просто мёртвый. Захожу на speedtest.net там всё по нулям, https://testmy.net/upload ещё хуже, просто виснет на середине. По какой-то одному богу известной странности файлы (вот этот вот скриншот) и вот этот текст и вообще всё, я могу загрузить только на LOR. Что происходит и почему работает лишь LOR я понять не могу. Стадия тоже понятное дело работает (нажатия же обрабатываются), но не факт, что войсчат заведётся (пока не смог никого найти чтоб проверить).

>>> Просмотр (1920x1080, 1961 Kb)

 , ,

zenkov ()

Canonical отвечает на вопросы про Ubuntu Netbook Remix

Новости — Ubuntu Linux
Группа Ubuntu Linux

Относительно недавнего релиза Ubuntu Netbook Remix журнал LAPTOP Magazine взял интервью у Джерри Карра, менеджера Canonical по продажам. Из интервью можно узнать, для чего конкретно создавался этот дистрибутив, каким образом он будет распространяться, его минимальные требования, а также подробности сотрудничества Canonical с Intel и их участие в проекте Moblin.

>>> Читать интервью

 , , ,

zenkov ()

ASUS Eee PC и IceWM

Галерея — Скриншоты

Меня вчера просили опубликовать скриншот, вот, сегодня публикую. Естественно здесь не скриншот любопытен, а скорее сам ASUS Eee PC (кто не знает, что это такое тем сюда http://wiki.eeeuser.com/eee_pc_701). Но в начале скриншот. На нём IceWM (оконный менеджер по умолчанию в 3ePC), mplayer (плеер по умолчанию, у которого я забыл убрать ненужную рамку с титлбаром) и xterm с bash (тоже по умолчанию), всё настроено. Домик это не аналог пуск, это какая-то тупо кнопка, толи все окна убирает, толи наоборот. Пуска здесь не было, да я его и делать не стал. Убрана юзерфрендли приблуда (огромная панель с табами заменяющая задний экран и перехватывающая некоторые комбинации клавиш). Все приложения запускаются либо автоматически либо по хоткеям (также регулируется громкость, яркость и т.д.). Клавиатура в устройстве очень и очень удобная. У меня прямо слов нет какая она удобная. Но за-то неудобный тачпед (как и везде), а потому всё рулится с клавиатуры. Правда до этого ещё копать и копать (из-за KDE приблуд), но к чему-то уже продвинулись. В таскбаре, как раз то, что регулируется кнопками (wi-fi, камера (пришлось написать скрипт на awk и заюзать чью-то приблуду для красивой иконки), сеть, зарядка, громкость, время, выключение).

Из неудобства. Alt почему-то нормально как Alt работает не всегда, а часто способствует вставке символов с диакритиками (локаль en_US.UTF-8, но тут может ещё какая левая хрень в системе установлена). Бесит ужасно. Явно может где-то исправить, но пока не знаю где. Потом. Глюк IceWM: Если "колупать" иконку слева в титлбаре, можно завалить любое окно. Не знаю как xterm при запуске растянуть по всей ширине. IceWM здорово это умеет делать и по Alt+F10 в том числе. Но как сделать так, чтоб он это делал автоматически, для xterm. Игры с geometry (и в конфигах icewm и в .Xresources) особо не помогли (всегда остаётся маленький промежуток справа). При первом запуске системы (с IceWM в качестве оконного менеджера), флешку подхватывает (и потом подхватывает) какой-то сервис KDE (какой?) и выводит свой дебильный диалог. Если перезагрузить Иксы, то когда стартует IceWM флешку уже никто не хватает, и потом тоже. Видимо в первый раз стартует какая-то хрень, а потом уже когда перезагружаешь иксы она не стартует. (Кстати можно сделать как-нибудь так чтоб диалог KDE подхватывающий флешку сразу закрывался или и вовсе не появлялся?) Там какая-то unionfs, от чего хорошего мало. Место на диске внятно не видно, прилады по умолчанию которые были установлены, удаляются "не удаляясь" и прочее в таком духе. Можно избавиться от этой unionfs, но это пляски с бубном. ASUS'овский репозитарий весьма мал. Народ во всю юзает уже и Xandros'овский и Debian'овский (кто похрабрей). Я пока ещё даже GCC не ставил.

MHz процессору занижают (есть beta-BIOS который позволяет выставить 900MHz, но потому видать он пока и beta, у меня последняя стабильная версия BIOS уже была установлена), есть ли под крышкой пустой слот miniPCIe не проверял. В некоторых моделях ASUS его убрали. Какая у меня, пока не знаю.

Сегодня подключал к нему монитор. Пока только с xrandr баловался. Всё отлично. Вероятно было бы ещё лучше если запустить второй screen или подружиться с Xinirama, но хорошего монитора под рукой не было, ради которого это хотелось бы сделать. Вообще вполне можно использовать как ПК, и запускается чертяка быстро, и выключается быстро. Как тонкий клиент самое оно.

Три USB. Проверял :) Подключал внешний HDD, флешки, всё подхватывает на лету (см. выше). Мышь тоже заработала. BT не проверял, и BT устройства тоже не проверял.

От батареи работает до трёх часов. Экран чуть-чуть свистит, но не больше чем другие недорогие экраны. В общем так он свистит, что в наушниках его не слышно. Иногда внутри начинает что-то техоньку жужжать и гнать горячий воздух влево, но это не мешает. Цвета передаёт своеобразно. На скрине например панель серая, а когда на экране смотришь, она такая же как титлбар. Есть вебкам и микрофон. Вебкам лучше чем все говорили, микрофон не довелось возможности проверить.

Ну вот и всё пока (всё-таки второй день только). Устройство (чёрного цвета) я заказал из Штатов. В Москве говорят, скоро будет.

>>> Просмотр (800x480, 238 Kb)

zenkov ()

Пользователи GNU/Linux и PS3 собирают подписи по поводу RSX

Новости — Игры
Группа Игры

Просим Sony дать нам возможность использовать RSX (графическая подсистема, производства nVidia) через другие ОС.

Пока что, из-за ограничений прошивки PS3 мы не можем... - Легко смотреть фильмы в различных форматах - Правильно использовать 2D приложения - Запускать маленькие 3D приложения

Бесполезное, когда это касается пиратства, ограничение - это проблема для честных пользователей, но не для пиратов: оно накладывает отпечаток, делая операционные системы вроде Linux не достаточно интересными, а такие проекты, как использование альтернативных ОС на PS3 похоже не нужными. Большое количество разочарованных комментариев в форумах доказывают это.

>>> Подробности

zenkov ()

... welcome back to NetHack!

Галерея — Скриншоты

Что-то давно здесь не появлялось NetHack или даже Angband, а стандартные картинки вида "Мой первый Knoppix", "Моя новая тема для KDE", "Настроил GNOME", "Fluxbox УРА!" уже надоели наверное не только мне.

И вот собственно NetHack. Игрушка замечательная и классическая. Не целостная как Angband. Там всё по теме и от того, больше похоже на компьютерную, может быть ролевую игру. Здесь всё совсем другое. Трудно сказать, что мне такой расклад нравится больше. Но он удивительный и действительно, вот это Hack уже какой год заставляет меня каждый раз возвращаться в мир Лабиринтов.

В окрестностях College Town видел gold golem и centipede. Не vortex конечно, думаю шутя справлюсь, но в будущем AC понизить всё-таки надо. Не дело это, хоть и caveman.

На Руси по NetHack ничего внятного нет (как нет и по милой сердцу некоторых ZONA).
Открыт вот публичный блог: http://www.livejournal.com/community/ru_nethack/
Приходите, если время будет. Лучше конечно сразу с интересным рассказом, а иначе смысла нет.

>>> Просмотр (1024x768, 251 Kb)

zenkov ()

Script-fu

Галерея — Скриншоты

Сразу скажу, это я не специально все окна вытащил на экран, мой десктоп действительно так выглядит, правда чаще всего окна сложены в "линеечку".

На экране можно видеть как я пишу скрипты в GNU Emacs, для различных эффектов по работе с текстом. Чаще всего это идеи не мои, они либо созданы уже какой-то компанией или дизайнером, а я их просто реализовываю на script-fu, правда даже GIMP'еры советуют уже писать на Python, но я уж как-то начал дак перестраиваться не хочется, опять же одно дело Python, Perl и всякие Tcl вещь сугубо опциональная, а SIOD он по умолчанию такой, Scheme ведь сама по себе диалект Lisp, на Lisp и похожа, а так я сам себе кажусь немного круче чем я есть, ну и Lisp я очень люблю тоже.

Два скрипта, для создания соответствующих эффектов со скриншота, можно взять здесь http://www.kholmsk.ru/hurd-wiki/images/other/lj/shrek-text.scm и здесь http://www.kholmsk.ru/hurd-wiki/images/other/lj/transparent-text.scm

Во время написания второго скрипта был найден и решён bug за номером #153635, исправления вошли в версию 2.0.5 (stable) которая вышла вчера и которую почему-то никто на LOR не заметил, хотя она очень важная и содержит множество исправлений, без неё даже transparent-text.scm работать не будет, потому советую пропатчить вашу версию до 2.0.5.

Относительно GIMP vs. Photoshop могу сказать, что практически GIMP разумеется хуже. В нём очень много, очень много, ОЧЕНЬ МНОГО ошибок (особенно начиная с 2.x), он ужасно документирован, в нём нет полной поддержки CMYK (по оптимистическим прогнозам, появится она там в 2006-ом году), его индексированная палитра с альфаканалом работает по типу GIF, даже если сохраняешь в PNG, таким образом в индексированном изображении невозможно добиться альфапрозрачности, он вообще очень плохо работает с PNG например, почему-то не может открывать MNG (в нём пока не реализована полная поддержка этого формата). Часть вопросов обещают решить в релизах 2.2 и 2.3, по предположением говорят что это будет нечто, но я не думаю что речь идёт о реальных доработках каких-то особенностей, за-то предполагаются какие-то супер навороченные плугины и много всяких абсолютно новых сладостей.

Именно с программной точки зрения GIMP мне кажется более силён чем Photoshop. Поддержка основных языков программирования, различные интерфейсы, библиотеки... Опять же Open Source! И хоть сообщество там не очень дружное, разработчики там хорошие, знают что людям работать надо и стараются исправить ошибку как можно скорее.

Вот так вот, он GIMP.

P.S. Надеюсь что данный пост, сподвигнет некоторых товарищей, оставить пустое дело постоянной сборки дурацких RPM'ок, DEB'ок, прочей фигни и заставит реализовать какую-нибудь возможность, исправить bug или разработать нормальный registry.gimp.org а то тот что сейчас, представляет из себя жалкое, убогое и глючное зрелище. В идеале было бы хорошо реализовать что-то по типу skill.ru с профилями пользователей, возможностями комментировать каждую работу, оставлять оценку, с рубрикатором и может быть даже с автоматическим предпросмотром результатов работы скрипта.

>>> Просмотр (1024x768, 216 Kb)

zenkov ()

Новый сайт о GNU Hurd

Новости — GNU's Not Unix
Группа GNU's Not Unix

Думали мы, думали и решили, что пора бы уже в свет выйти! Итак позвольте представить русскоязычный (преимущественно) проект о GNU Hurd, так сказать для тех кто хотел узнать, но боялся спросить, в частности о том, что такое l4ka Pistachio, как запустить один Hurd под другим и что это за звери такие "трансляторы" :-)

Материал мы собрали обширный, по большей части для пользователей. В процесс перевода от содержания оригинала отклонились сильно и продолжаем отклонятся в лучшую сторону каждый день.

На данный момент в переводе находятся FAQ и Debian GNU Hurd Doc's, после чего планируется взяться за Hurd Hacking Guide и GNU Hurd Reference Manual. Разумеется ожидается, что найдутся добровольцы готовые помочь нам прямо сейчас (благо любой желающий может создать раздел/страницу либо изменить/исправить уже существующий материал без какой бы то ни было регистрации на сайте).

Отдельное спасибо получит герой который возьмётся исправить наши ошибки русского языка и улучшить перевод.

Новички могут помочь нам, заполнив разделы о дистрибутивах Linux и BSD:

http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac...

И о китах индустрии в целом:

http://www.kholmsk.ru/cgi-bin/hurd?ac...
http://www.kholmsk.ru/cgi-bin/hurd?ac... (не путать с OpenBSD, FreeBSD и т.д.)
http://www.kholmsk.ru/cgi-bin/hurd?ac... (о ядре only)

Так же требуется информация о POSIX (желательно авторская):

http://www.kholmsk.ru/cgi-bin/hurd?ac...

Понятно, что порой к теме это не очень относится, но в тексте встречается, а потому должно быть заполнено.

Будем благодарны художникам готовым нарисовать оригинальный 'отечественный' логотип для сайта. А также поспособствуем жителям СНГ, для создания общего проекта на языках стран бывшего СССР.

Короче, присоединяйтесь.

>>> Сайт

zenkov ()

Загадка

Галерея — Скриншоты

Нет я в таких условиях не работаю, но поскольку давно уже здесь не светился решил таки засиять чем имеется.

Имеется как видите немного :-) Для нормальной деятельности мне хватает Firefox+WindowMaker+GNU/Emacs+Psi, для ЛОРа специально я открыл книжку и пошлую swf-игрушку.

Теперь собственно головоломка :-) Угадайте что, на каком языке и какими символами написано на заднем фоне?

Подсказки:

1) Язык один, символы же взяты из другого и специальным образом адаптированы.
2) Первый символ это w, второй s, третий m, четвёртый l, последний p.
3) Три точки вверху это a, "крючок" это o, одна точка это i, чёрточка это e, галочка u.

От вас требуется восстановить написание латиницей, а дальше думаю узнать, что это за язык будет не проблема (перевести тоже). Со шрифтами может быть немного сложней ;-) А может не быть...

>>> Просмотр (1024x768, 104 Kb)

zenkov ()

Десктоп охотника на драконов

Галерея — Скриншоты

Вот такая вот конструкция. Это очередной мой десктоп (два предыдущих вы уже скорей всего видели) на этот раз с Window Maker'ом. Нет Window Maker я использую не первый раз, но было это давно. Решил обновить память.

На самом деле всё вышеперечисленное чушь. Просто после того как я почти окончательно отвык от наркотической зависимости в лице своего старого, доброго серого fluxbox'а с MbdTeX и самодельным логотипом Lisp'а в правом верхнем углу и перешёл на куда более кричащий KDE в этаком апельсиновом стиле Kill Bill... Дак вот с того времени с KDE я намучился порядочно. Мучают даже сейчас, поскольку всё ещё использую некоторое ПО из него. Дал зарок, что не буду пользовать все эти интегрированные среды, хотя бы полгода.

Вообще выбор существующего, меня удручает. Ведь, что сейчас есть?

Эта поделка Икизы вечно кричащего революционные вещи, то о том, что структура UNIX не подходит для десктопа, то о том, что Си умер (для него), у меня всегда вызывала восторг (отрицательный конечно)? И вообще всё, что делала за эти годы Ximian у меня вызывало разные чувства, но только не радость. Mono этот дебильный... Тфу, пакость. А относительно GNOME как системы. То дак она IMHO создана не для программиста, а скорей для секретутки и домохозяйки. Всё бы пускай, да только профессиональной интегрированной среды у профессионалов так и не появилось.

Казалось бы KDE должна была такой стать, но та IMHO больше на desktop обычного пользователя, нацелена.

GNUStep вроде бы нормально но:

1. Этот Objective C, как бельмо на глазу.
2. Ничего революционного там нет.
3. Look & Feel, ужас.

Если первый аспект для хорошего программиста не проблема, то второй уже не радует. А третий в принципе, как сказать. С одной стороны красивости не нужны. Но с другой, надо же иметь вкус. Что это за отстой с самопальными иконками a la "с миру по нитке", scroll-bar'ом "железный Феликс" и прочими страшилками. Да и более того, сам GNU Step в два счёта может стать как тот же KDE или GNOME. Все его недостатки практически те же самые (причём по структуре он близок к убогому GNOME, чем к убогому KDE).

И того остаётся нормальным людям, как мне например, использовать всё подряд выбирая какой-нибудь оконный менеджер каковой не коснулась забота корпоративных индусов.

И так Window Maker (часть GNUstep надо заметить). На нём темка Dragons Tear, взята ясно откуда. Темку создала девушка (то есть мне хочется так думать, Весна всё-таки) стибрив/купив картинку с Zazzle.com. Я её (в смысле темку) доработал, придав выпуклость pixmap'ам. Поставил иконки Umicons (вообще классные иконки). Двое часов это не для пальцатости, просто мне так удобнее.

Есть и вопросы. У меня версия 0.80. Как на titlebar прилепить кнопки максимизации и минимизации?

P.S. Кнопочка с сердечком - это переключалка языков. Очень удобно :-)

>>> Просмотр (1024x768, 294 Kb)

zenkov ()

PNG: Простое введение в особенности формата

Новости — Open Source
Группа Open Source

Статья о замечательном свободном графическом формате PNG, о некоторых специализированных UNIX утилитах по работе с ним и о ряде недостатков известного свободного программного обеспечения.

>>> Статья

zenkov ()

Psi 9.1 vs. GAIM

Галерея — Скриншоты

Собственно десктоп мой все уже давно видели и старый Psi на нём тоже. Теперь поставил Psi новый. Были правда проблемы. Например в файл src/src.pro пришлось добавить INCLUDEPATH += . а также скомпилировать с поддержкой xscreensaver, без неё компиляться не захотело. Пришлось брать русский перевод с CVS, редактировать его на свой вкус в linguist, но это того стоило. Нет ничего особенно нового нет, но то, что было раньше стало лучше. Это радует.

P.S. А ещё радуют красивые смайлики :)

>>> Просмотр (1024x768, 111 Kb)

zenkov ()

Играть на GNU/Linux.

Новости — Игры
Группа Игры

Известно, что Linux для многих уже сама по себе игрушка. Встречаются и такие люди которые умудряются играть с mysql, freeradius, clamav. Но и им иногда это может надоесть. Ведь хочется же запустить старую добрую RTS и сразиться с другом!? Я знаю, что многим хочется, но сложилось такое мнение, что linux это не та платформа которую можно использовать для игр.

Я решил создать проект который окончательно, разрушит ложные стереотипы. Позвольте представить вам мой "Апельсиновый блокнот" (апельсиновый потому-что, должен приносить радость).

Цель у сайта благородная. Доказать, что GNU/Linux отличная платформа для качественных игр (в том числе и GPL). Показать пользователям Windows, что здесь тоже можно развлекаться и что поставив GNU/Linux вы не поставите крест на удовольствии.

Каждый день я один, отбираю только лучшие на мой вкус игры и подробно рассказываю о них на страницах своего проекта. Это нелегко и отнимает много времени. Своеобразный эксперимент над собой и над всем сообществом.

Так например уже сейчас не помешала бы определённая помощь. Многим разработчикам хотелось бы почитать мои статьи на английском. Я знаю английский, но у меня никогда не получалось на нём писать. Я могу перевести статьи, но мне нужен человек готовый исправить мои ошибки. Надеюсь мне удастся его найти.

И ещё, всем ведь известно, что наша жизнь игра и я надеюсь, что с играми о которых я рассказываю, Linux станет живым :-)

>>> Сайт

zenkov ()

На волне убитого Билла

Галерея — Скриншоты

Вот уже очень длительное время я использовал Fluxbox... Очень долго использовал... Так долго, что даже перешёл на Openbox... От чего мне стало только ещё хуже. Попытки сменить *box на что-то другое, терпели неудачу... Меня жутко ломало :-) Это был как наркотик, это был просто ужас какой-то... Дабы отвыкнуть от tabs'ов я и пересел на Openbox...

И вот я в KDE. Уж не знаю насколько здесь можно работать, но всё смотрится пока красиво... Опять же многое может делать karamba. Правда здесь я её почти не использую.

Ещё одной проблемой стал дизайн. Он очень уж какой-то... Пришлось как-то интегрировать GTK, чтоб оно не очень от программ на qt отличалось. В результате, GTK (даже первое) смотрится намного красивей :-)

А так вроде пока ничего... Не пойму толком зачем поставил... Но ломка проходит. Я почти выличился от Fluxbox'о зависимости... Да...

>>> Просмотр (1024x768, 112 Kb)

zenkov ()

Они тоже используют GDM

Галерея — Скриншоты

Фильм, надо сказать, достаточно не плохой хотя местами жутко стандартный да и короткий какой-то. Больно уж быстрое развитие. IMHO надо было 2 серии снять.

>>> Просмотр (640x730, 37 Kb)

zenkov ()

Изучаем OCAML :-)

Галерея — Скриншоты

В начале кратко о том, что на экране. На экране старый fluxbox, новый GNU/Emacs и тоже достаточно старая vmware. Но ду это всё не интересно, самое главное...

OCAML -- самое главное. Разбираться начал вчера. Что понравилось? Многое понравилось. Например реализация ФП порадовала (всякие там let, очень удобны). match любопытно, type интересно. Синтаксис вроде бы тоже приятный. Не Python конечно, но уже и не C++. Сам язык чем-то во многом схож с Lisp'ом, что тоже хорошо.

Ещё понравилось то, что к нему уже многое сделали :-) Тут тебе и компилятор, тут и интерпретатор... Красота. Порадовала также скорость. На сайте говорят, что он между C и C++. То есть я так понял, медленнее первого, но быстрей второго.

Из недостатков, отсутствие качественного GUI (у Java он есть) и нет библиотек по работе с OpenGL (есть, но староватые), реализации SDL вроде тоже нет. Но это всё дело поправимое. Самые же крупные минусы, это очень маленький объём документации на русском. Да и русских кэмл-гуру тоже трудно найти (в отличее от перловых или там сишных, тех пруд-пруди). Вопросы некому задать :-(

А ведь вопросов просто море. Например я плохо разобрался с match. Такая функция для меня так и осталась загадкой.

let min_rat pr = match pr with
((_,0), p2) -> p2
| (p1, (_, 0)) -> p1
| (((n1, d1) as r1), ((n2, d2) as r2)) ->
if (n1 * d2) < (n2 * d1) then r1 else r2 ;;

Тоже самое можно сказать и о:

let eq_rat cr = match cr with
((_,0), (_,0)) -> true
| ((_,0), _) -> false
| (_, (_, 0)) -> false
| ((n1, 1), (n2, 1)) when n1 = n2 -> true
| ((n1, d1), (n2, d2)) when ((n1 * d2) = (n2 * d1)) -> true
| _ -> false ;;

Что это ещё за ((_,0), (_,0)) ?

В остальном же всё нормально. Имеется "хорошая" книжка от O'Reilly (дочитал до Sum types) и прекрасный режим для Emacs'а (tuareg_mode).

>>> Просмотр (1024x768, 61 Kb)

zenkov ()

Gentoo: Да мы были на луне!

Галерея — Скриншоты

Вот, что случается с луной после установки на ней Gentoo-сервера :)

P.S. Картинку нарисовал мой друг Алексей Городнов.

>>> Просмотр (1024x768, 113 Kb)

zenkov ()

Новая версия gentoo.ru

Новости — Linux в России
Группа Linux в России

Несколько дней тому назад, вышла новая версия Gentoo.ru (немного отстали от slackware.ru). Мы не старались охватить всё. Целью проекта является только перевод Gentoo.org-Docs и написание своей, то есть русской, документации. Отличием же данной версии от предыдущей (которая всё ещё доступна), является поддержка XML и UTF, а также создание CVS репозитария, что позволило ускорить процесс разработки сего проекта.

К слову пользуясь случаем скажу, что сейчас сайту как раз требуется новая команда переводчиков еженедельных выпусков (GWN). Присоединяйтесь.

>>> Подробности

zenkov ()

Мой GNU/Emacs в работе.

Галерея — Скриншоты

В процессе перевод using_gnuhurd, он как раз сейчас в основном окне.
Сбоку перевод PROMT'а, на всякий случай (я далеко не профессионал, а
PROMT иногда подкидывает неплохие идеи). Внизу оригинал и Eshell
(здесь для пижонства, на самом же деле в нём можно grep'ать словари).

Эта картинка ещё во-многом ответ тем vim пользователям которые
обвиняют Emacs в монстроидальности интерфейса, мол кнопки лишние,
уродские menubar'ы и т.д. и т.п. Дак вот, это неправда!

Emacs может быть лёгким, утончённым и тонким редактором, в плане его
дизайна. Всё, что для этого нужно, дак это набрать; M-x
customize-face -- и потратить 15 минут на его настройку.

Так, что нечего гнать, на нас *Emacs-пользователей, тем более, что нас
заметно меньше. Ибо избранные всегда в меньшинстве.

P.S. Вот только не надо сейчас неуместных шуток про иные меньшинства ;-)

>>> Просмотр (1024x768, 48 Kb)

zenkov ()

Умер ещё один сайт об ОС LINUX

Новости — Linux в России
Группа Linux в России

Закрылся один из первых, Российских, действительно замечательных
сайтов о Линуксе, закрылся linux.org.ru. Нам не удалось связаться с
автором, но за-то мы смогли задать пару вопросов его доверенному
лицу. Вот, что он нам ответил на вопрос, о том почему закрывается
сайт:

-- Закрывается и всё тут! Прибыли нет, хотели ввести платные
анонимные акаунты, но потом решили, что и это нас не
спасёт. Закрываемся. Так всё диктофоны убрали... Ты чё б...
Я cказал убрали...

Я не знаю, что ещё можно написать в таком случае. Наверное то, что я
очень любил этот ресурс. Именно там люди, стоя плечём к плечу,
строили будущее Linux в России. Именно там рождалось и умирало,
множество OpenSource проектов. Я всё ещё помню задорный смех,
ясноглазых, жизнерадостных анонимусов и разумные речи бывалых,
потрёпанных зарегистрированых пользователей. Где они теперь? Этого
мы не узнаем никогда, но проект, проект под названием LOR будем
помнить вечно. Покойся с миром наш, друг.

>>> Подробности

zenkov ()

Первый в мире ONLINE сериал о GNU/Linux!

Новости — Linux в России
Группа Linux в России

Нам удалось соблюсти все законы жанра. Сериал нудный, однообразный и с
большим количеством рекламы, но в тот же самый момент он яркий,
смешной и согласитесь оригинальный :-)

Это первая пилотная серия, в зависимости от внимания к проекту (и от
ваших комментарие) мы поставим серии на конвейер чтобы уже
окончательно оправдать звание сериала :-)

Не обошлось и без проблем. Так например проекту очень не хватает
художников (работы которых мы будем активно продвигать), переводчиков
(на английский, французский и можно ещё японский), а так же свободных
гитаристов с оригинальными треками собственного сочинения. Люди
откликнитесь и мы подружимся, потому-что творчество не Муму :-)

С уважением студия "Дно/Унитаза".

>>> Посмотреть

zenkov ()

RSS подписка на новые темы