LINUX.ORG.RU

GNOME 3.26

 , ,


4

3

13 сентября состоялся релиз окружения рабочего стола GNOME 3.26. Релиз содержит в себе ряд важных улучшений и исправлений.

Список изменений:

  • Все компоненты GNOME обновлены до версии 3.26;
  • Переработан внешний вид GNOME Control Center;
  • Добавлена возможность изменять размер курсора (доступно 5 уровней);
  • Улучшенный тайлинг;
  • Теперь в режиме обзора (Overview) окна будут отображаться в полном размере;
  • Улучшен поиск и отображение результатов в Activities;
  • GNOME Tweak Tool переименован в GNOME Tweaks (пакет сохранил название gnome-tweak-tool);
  • В GNOME Photos добавлена возможность масштабировать изображения;
  • В GNOME Calendar добавлена возможность добавлять повторяемые события;
  • В Epiphany добавлена возможность синхронизации с Firefox;
  • В Simple Scan добавлена поддержка WebP;
  • Различные улучшения в GNOME Builder;
  • Различные улучшения в GNOME Maps;
  • Улучшена скорость работы GNOME Music;
  • В The Evince Document Viewer добавлена возможность обрабатывать файлы Adobe Illustrator;
  • Отказ от использования системного трея (области уведомлений). Можно дальше использовать Topicon Plus. Подробнее;
  • Улучшена работа Wayland;
  • Добавлена поддержка Unicode 10.0 в glib;
  • Пакеты GNOME теперь собираются с использованием Meson Build System;
  • В GTK+ добавлена поддержка Emoji;
  • В Polari добавлена возможность отправлять Emoji;
  • В Nautilus изменен механизм работы с архивами, Демонстрация;
  • Новые настройки дисплея;
  • В Mutter добавлена нативная поддержка Screencast и Remote Desktop. Подробнее.

>>> Подробности

★★★

Проверено: Aceler ()
Ответ на: комментарий от anonymous

А если у меня нет интернета, то никак гном не настроить?

Не только Gnome, а вообще всё.
И на этом форуме ничего не запостишь без интернента.
Только CD с дистрибутивами по рассылке, не знаю кто ещё этим занимается.

tp_for_my_bunghole ()
Ответ на: комментарий от templarrr

Да не, он вполне адекватен бывает, просто нас тут всех заносит.

Chelobaka ★★★ ()
Ответ на: комментарий от tp_for_my_bunghole

Устанавливаются прямо из браузера.

За это вообще убивать надо. Из какого еще браузера? Гном это что, веб-сервис? Ох уж эти утята с мобилой и вафлей вместо мозгов.

anonymous ()
Ответ на: комментарий от grem

В том, что трей остался (с урезанной поддержкой и хорошо, что исправили), а в гноме его не будет совсем.

Ты не прав. Поясню почему.

После того, как в KDE выпилили XEmbed-трей, доступ в этот лоток имели лишь системные KDE'шные приложения.

С приходом 3.26 в GNOME по сути образовалась точно такая же ситуация: «трей» есть, но только для системных GNOME-апплетов:

http://esxi.z-lab.me:666/~exl_lab/screens/GNOME3_fake_tray.png

Так что никаких передергиваний с моей стороны. Что там нормальный трей был выпилен тогда, что тут сейчас.

И много тогда довольных таким решением было?

Это уже другой вопрос. Лично я был тогда недоволен. Сейчас в GNOME 3 из таких приложений у меня остался лишь Telegram, но вроде как его обещали пропатчить на GNOME-уведомления.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)
Ответ на: комментарий от anonymous

Я бы заметил что...

По себе других не судят, но тебе, боюсь не понять.

Впрочем, если ты тему «мамок» хочешь продолжить, то не дашь ли телефончик своей? Если они ни чего так, то может ты меня ещё папкой называть будешь? Хоть я и не настаиваю.

Не нужно оскорбляться на мой вот этот вот проброс выше. Нужно просто своей башкой иной раз думать какую тему поднимать, а какую не стоит. Но тебе опять не понять, наверное?

anonymous ()
Ответ на: комментарий от alexferman

И отваливаются через каждые несколько мажорных релизов

И исправляются за несколько часов когда разработчик(и) расширения наход[и|я]т время.
Меня не впечатляет встроенный язык расширений - javascript, но есть другие варианты, и js компромиссный вариант.

tp_for_my_bunghole ()
Ответ на: Я бы заметил что... от anonymous

Re: Я бы заметил что...

Аа, зацепило? Понимаю. Строчи дальше свои фантазии, дитё.

anonymous ()
Ответ на: комментарий от tp_for_my_bunghole

И исправляются за несколько часов когда разработчик(и) расширения наход[и|я]т время

Глобально и надёжно, ничего не скажешь))

alexferman ()
Ответ на: комментарий от tp_for_my_bunghole

Не только Gnome, а вообще всё.

Не видел еще такого софта, который настраивается путем закачки исполняемого кода (!) через браузер (!!). Это какие то новые горизонты дебилостроения.

anonymous ()
Ответ на: комментарий от alexferman

Труъ Ынтерпрайс во все ворота!

anonymous ()
Ответ на: Re: Я бы заметил что... от anonymous

Re: Я бы заметил что...

Зацепило... что? Поток байт где-то на сервере в этих ваших инторнетах? То, что ты свёл дискуссию к более привычному тебе «мамка завтрак готовит»? Чувак, мы тут про DE вообще-то.

От себя лично просто намекну. Сегодня суббота. В православии это день родительский. Так что, не трогал бы ты, вафел, родителей. Хорошо? Намёк понял?

anonymous ()
Ответ на: комментарий от anonymous

Устанавливаются прямо из браузера.

За это вообще убивать надо. Из какого еще браузера? Гном это что, веб-сервис?

Ты просто идеолог анального огораживания.
Не многие знают, но FSF например продвигает систему в которой установка пакетов в ОС не требует допуска администратора. Guix, но при этом с возможностью отката любого крупного обновления.

tp_for_my_bunghole ()
Ответ на: комментарий от EXL

доступ в этот лоток

В какой ещё лоток? Он же не работал, согласно вашим визгам. Какой может быть доступ в отломанное и неработающее?

«трей» есть

Оооо, вот точно - у гномовцев всё в кавычках. «Трей». «Быстрый доступ». «Стабильность». «Эргономика и дизайн».

alexferman ()
Ответ на: Re: Я бы заметил что... от anonymous

Re: Я бы заметил что...

Так у тебя кроме буйной фантазии еще и ПГМ во все ворота? Занятный экземплярчик.

anonymous ()
Ответ на: комментарий от tp_for_my_bunghole

Не многие знают, но FSF например продвигает систему в которой установка пакетов в ОС не требует допуска администратора.

Интересно, какое это имеет отношение к идиотической идее установки дополнений рабочей среды (без которых она, кстати говоря, неюзабельна) через браузер.

alexferman ()
Ответ на: комментарий от anonymous

Не видел еще такого софта, который настраивается путем закачки исполняемого кода (!) через браузер (!!). Это какие то новые горизонты дебилостроения.

Все дистрибутивы Linux. Вообще всё.
Для установки расширений Gnome специальный плагин в web-браузере. Для пакетов в дистрибутиве Linux специализированные браузеры(как когда-то был Napster для музыки), или клиенты в терминале.

tp_for_my_bunghole ()
Ответ на: комментарий от tp_for_my_bunghole

Ты съехал с темы. Мы тут про элементарные настройки говорим, типа закрепить док на экране или поместить трей на панели. Причем тут вообще пакеты в дистрах?

anonymous ()
Ответ на: комментарий от alexferman

Не многие знают, но FSF например продвигает систему в которой установка пакетов в ОС не требует допуска администратора.

Интересно, какое это имеет отношение к идиотической идее установки дополнений рабочей среды (без которых она, кстати говоря, неюзабельна) через браузер.

По поводу «юзябилити» позвони в службу поддержки клиентов.
В случае с Gnome можно просто зайти в страшный браузер и почитать красивые техноблоги о различных вариантах расширений.

Для «юзабельного» купи себе что-то от Apple за 3 цены, будешь потом называть других нищебродами, психологический аутотренинг такой.

tp_for_my_bunghole ()
Ответ на: комментарий от tp_for_my_bunghole

Для установки расширений Gnome специальный плагин в web-браузере.

Который тоже ломается!

Для пакетов в дистрибутиве Linux специализированные браузеры
специализированные

Установленные и доступные из коробки.

templarrr ★★★★★ ()

Народ! Как заставить Gnome Web (Epiphany) использовать пароли к сайтам из Seahorse? С хромым все норм, а эта хрень даже не предлагает сохранить пароль при успешном логине куда угодно =(

nemec784 ()
Ответ на: комментарий от tp_for_my_bunghole

Кароч, Гном неюзабелен без расширений, да и с расширениями неюзабелен, лучше Мак купить.

alexferman ()
Ответ на: комментарий от alexferman

Во, типичный визг фрактальчика.

1. Трей из kUbuntu 15.04 (Plasma 5.2), умеющий только в системные KDE-апплеты и который фрактал считает, цитирую:

трей нормально работал

Разумеется, работал. Только сторонние программы отвалились.

http://esxi.z-lab.me:666/~exl_lab/screens/KDE_old_fake_tray.png

2. Трей из GNOME 3.26, умеющий только в системные GNOME-апплеты, который фрактал считают, цитирую:

что разрабатывающие Гном героинщики отломали трей полностью

по желанию пятки трей выкидывают?

http://esxi.z-lab.me:666/~exl_lab/screens/GNOME3_fake_tray.png

---

Ну что тут можно сказать? Крайняя степень фанатизма. В одном случае у пациента хороший и рабочий трей, а в другом — отломаный полностью и выкинутый. Почему? Потому что один трей сделали KDE'шники, а другой ненавистные ему разработчики GNOME. При этом, конечно же стоит заметить, что функциональность этих «треев» полностью одинаковая: отображают только системные компоненты.

Сестра! Три кубика разупорина!

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)
Ответ на: комментарий от alexferman

Так тебе на будущее, дополнения можно и через приложение Software устанавливать.

MaxPower ()
Ответ на: комментарий от EXL

умеющий только в системные KDE-апплеты

Что, даже KMail не отображался?

Plasma 5.2

GNOME 3.26

отломали часть, но быстро вернули

отломали полностью и не вернут, потому что так надо

Ну что тут можно сказать?

Действительно, что тут можно сказать? Визг и избирательная слепота, избирательная слепота и визг.

alexferman ()
Ответ на: комментарий от alexferman

Зачем ты врёшь, гном прекрасно юзабелен без расширений.

MaxPower ()
Ответ на: комментарий от anonymous

Ты съехал с темы. Мы тут про элементарные настройки говорим, типа закрепить док на экране или поместить трей на панели. Причем тут вообще пакеты в дистрах?

Пакеты в дистрах это же страшный исполняемый код! Устанавливаются через специализированный браузер!

Какого tray тебе не хватает?
Я использую Dash to Panel, с кучей настроек: https://www.youtube.com/watch?v=tGTJ_RgbC34

В дополнение AppKeys для доступа к открытым приложениям с клавиатуры как в Unity(Ubuntu 16).

tp_for_my_bunghole ()
Ответ на: комментарий от tp_for_my_bunghole

Пакеты в дистрах это же страшный исполняемый код! Устанавливаются через специализированный браузер!

А Блокнот это специализированная IDE, видимо

alexferman ()
Ответ на: комментарий от templarrr

Для установки расширений Gnome специальный плагин в web-браузере.

Который тоже ломается!

Устанавливай прямо с Github, если ломается. Я никогда его поломанным не видел.

Или обратись в службу поддержки клиентов.

tp_for_my_bunghole ()
Ответ на: комментарий от nemec784

Хранить пароли не безапасно. Если всё таки хочешь их хранить пользуюся фаерфоксом.

MaxPower ()
Ответ на: комментарий от tp_for_my_bunghole

У него всё ломаеться даже то что в принципе не ломаеться, это про него анекдот с двумя титановыми шарами в белой комнате.

MaxPower ()
Ответ на: комментарий от alexferman

Что, даже KMail не отображался?

Не знаю, KMail'ом не пользовался. Но судя по темам за 2015 на форуме KDE — действительно не отображался.

Кроме того, даже сейчас есть проблемы с KMail+KDE Tray: https://forum.kde.org/viewtopic.php?f=289&t=138357

отломали часть

отломали полностью

Фанатизм? Фанатизм.

EXL ★★★★★ ()
Ответ на: комментарий от MaxPower

Чтобы они устанавливались там же, отображаются и настраиваются, но это я уже слишком требователен к Гному. Его приходится даже за банальные вещи хвалить, как ребёнка с умственной отсталостью.

alexferman ()
Ответ на: комментарий от EXL

Не знаю

Отож.

Фанатизм?

Гадание по багтрекеру - да, оно самое и есть.

alexferman ()
Ответ на: комментарий от alexferman

Хотя чего это я? В гномовских настройках же нет никакого аплета для работы с расширениями. Если пользователь хочет привести среду в юзабельный вид, он должен вдоволь попердолиться.

alexferman ()
Ответ на: комментарий от alexferman

Кароч, Гном неюзабелен без расширений, да и с расширениями неюзабелен, лучше Мак купить.

Сказал тот кто Gnome не использует.
Да, Gnome «неюзабелен» без расширений, и НЕ должен был быть.
С расширениями Gnome для меня идеален, и я рад что это сталo дефолтной средой в самых лучших дистрибутивах.

Если тебе что-то непонятно, перестань обсирать на форумах то чем ты не пользуешься, или обратись в службу поддержки клиентов, потребуй refund или обмен.

tp_for_my_bunghole ()
Ответ на: комментарий от MaxPower

Именно!

А что надо? Что б они силой мысли устанавливались?

Именно! Причём, передача расширений с сервера на комп пользюка должна производиться не иначе как в соответствии с RFC 1149 или в более поздней редакции, с учётом IPv6, RFC 6214, голубиной почтой.

А иначе нещитово.

anonymous ()
Ответ на: комментарий от alexferman

Устанавливаться должно там где устанавливается, а не отображается и настраивается. Насидятся в этих кде, а потом ходят наркоманские претензии предъявляют.

MaxPower ()
Ответ на: комментарий от MaxPower

Устанавливаться должно там где устанавливается, а не отображается и настраивается

И гномеры ещё что-то кричат про клятое виндовое легаси, которое не даёт построить совершенный десктоп. А сами не видят ничего зазорного в том, чтобы собирать программы и апплеты вручную по всяким Интернет-пердям вместо того, чтобы несколькими движениями и кликами мыши сделать это в одной утилите.

alexferman ()
Ответ на: комментарий от tp_for_my_bunghole

Пакеты в дистрах это же страшный исполняемый код! Устанавливаются через специализированный браузер!

Але, мы все еще про настройки, соберись. Мне не нужны никакие гребаные пакеты из интернетов, я всего лишь хочу трей на панели. Везде это есть из коробки, толтко гномонаркоманы заставляют тащить скрипты через браузер для такой примитивнейшей настройки.

anonymous ()
Ответ на: комментарий от templarrr

кроме трея, который с тремя либами работал как раньше?

тремя либами

Да ты офигел? Для возврата отломанного в KDE трея в те времена нужно было поставить:

1. libappindicator-gtk2
2. libappindicator-gtk3
3. sni-qt
4. libappindicator-csharp
5. Пропатченный особым образом Qt 5
6. xembed-sni-proxy-white

И то это не всё, часть использующих трей приложений на сторонних тулкитах — отваливалась всё равно.

Ну и вишенка: кроме этих шести библиотек, необходимо было иметь их 32-битные версии. Потому что, например Skype'у, пофиг что ты установил sni-qt, так как ему нужен был lib32-sni-qt. И так далее.

И это только потом пришёл KDE-разраб и запилил единый костыль xembed-sni-proxy, который работает и сейчас.

Что еще намеренно сломали в KDE

Ты издеваешься? Да кучу всего там сломали: глобальное меню, полезные плазмоиды типа Veromix'а, Amarok до сих пор портировать на KF5 не могут и скорее всего дропнут этот плеер. Впрочем не вижу смысла выносить проблемы KDE в этот тред.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

в те времена

Как будто вас кто-то гнал на Плазму первых версий.

Да кучу всего там сломали

Давайте вспомним, что умел Гном до версии этак 3.6, и посмеёмся.

alexferman ()
Ответ на: комментарий от anonymous

Кого вообще волнует что нужно анонимусу? Пиши сам что тебе нужно. Немогёшь?! Ну тогда плати тем кто это сделает за тебя.

MaxPower ()
Ответ на: комментарий от alexferman

Что сомнительного? Ты же хочешь что бы было всё в одном месте? Вот тебе в одном месте. Ставишь софт и расширения из одного приложения. Вот даже в рифму.

MaxPower ()
Ответ на: комментарий от alexferman

Как будто вас кто-то гнал на Плазму первых версий.

Я просто обновлял дистрибутив и мне это счастье само прилетело. Ну и да, сегодня плазма от своих первых версий ушла не далеко.

EXL ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)