LINUX.ORG.RU

Выпуск Debian 10 «Buster»

 , ,


5

4

Участники сообщества Debian рады сообщить о выходе очередного стабильного выпуска операционной системы Debian 10 кодовое имя buster.

Данный релиз включает в себя более 57703 пакетов, собранных для следующих процессорных архитектур:

  • 32-битный ПК (i386) и 64-битный ПК (amd64)
  • 64-битный ARM (arm64)
  • ARM EABI (armel)
  • ARMv7 (EABI hard-float ABI, armhf)
  • MIPS (mips (с порядком байтов от старшего к младшему) и mipsel (с порядком байтов от младшего к старшему))
  • 64-битный MIPS с порядком байтов от младшего к старшему (mips64el)
  • 64-битный PowerPC с порядком байтов от младшего к старшему (ppc64el)
  • IBM System z (s390x)

По сравнению с Debian 9 stretch в Debian 10 buster добавлено 13370 новых пакетов, обновлено более 35532 пакетов (что составляет 62% дистрибутива stretch). Также, по различным причинам многие пакеты (более 7278, 13% дистрибутива stretch) были удалены из дистрибутива.

Debian 10 buster поставляется с различными окружениями рабочего стола, такими как GNOME 3.30, KDE Plasma 5.14, LXDE 10, LXQt 0.14, MATE 1.20, и Xfce 4.12. Также в репозитории имеются Cinnamon 3.8, Deepin DE 3.0, различные оконные менеджеры.



Огромное внимание при подготовке данного выпуска было уделено повышению безопасности дистрибутива:

  • В установщик Debian добавлена поддержка загрузки при помощи UEFI Secure Boot.
  • При создании зашифрованных разделов теперь используется формат LUKS2
  • Для новых установок Debian 10 по-умолчанию включена поддержка системы разграничения доступа приложений AppArmor. При установке будут загружены профили AppArmor только для очень ограниченного числа приложений, для добавления дополнительных профилей рекомендуется установить пакет apparmor-profiles-extra
  • В пакетном менеджере apt добавлена опциональная возможность использования изоляции устанавливаемых приложений при помощи механизма seccomp-BPF.


Немало в выпуске и иных изменений, связанных с поддержкой новых возможностей программного и аппаратного обеспечения:

  • Ядро Linux обновлено до версии 4.19.
  • Система управление межсетевым экраном netfilter изменена с Iptables на Nftables. При этом для желающих сохранена возможность использования Iptables с помощью iptables-legacy .
  • В связи с обновлением пакетов CUPS до версии 2.2.10 и cups-filters до версии 1.21.6 в Debian 10 buster теперь поддерживается печать без установки драйверов для современных IPP принтеров.
  • Базовая поддержка систем на основе SOC Allwinner A64.
  • При стандартной установке окружения рабочего стола Gnome по умолчанию задействован сеанс на основе прокола Wayland. При этом сохранена поддержка сеанса на основе X11.
  • Командой Debian-live созданы новые живые образы Debian на основе окружения рабочего стола LXQt. Также во все живые образы Debian добавлен универсальный установщик Calamares.

Изменения произошли и в установщике Debian. Так, претерпел изменения синтаксис файлов автоматизированной установки с помощью ответов, произведен перевод на 76 языков, в том числе полностью на 39 языков.

Как всегда Debian полностью поддерживает обновление с предыдущего стабильного релиза с помощью штатного пакетного менеджера apt.

Полная поддержка выпуска Debian 10 buster будет осуществляться на протяжении всего периода до выхода следующего стабильного выпуска плюс один год. Debian 9 stretch переведен в статус предыдущего стабильного релиза и будет поддерживаться командой безопасности Debian до 6 июля 2020 года, после чего будет передан команде LTS для дальнейшей ограниченной поддержки в рамках Debian LTS.

>>> Подробности

Ответ на: комментарий от anonymous

Спасибо за совет. Уже накатил на декстоп Devuan и на лаптоп Void. Единомышленник выше советовал. Первые впечатления как глоток кристально чистого горного воздуха после поцтерд. Особенно впечатлил Void с его простотой и божественным runit.

anonymous ()
Ответ на: комментарий от alexferman

Debian в релиз берет последнее longterm ядро. Сейчас это 4.19.

Для серверов и рабочих станций такой выбор оптимален.

ЗЫ Пользователь Fedora/CentOS.

anonymous ()
Ответ на: комментарий от alexferman

В частности поэтому. Красноглазики просто привыкли, «и так сойдёт».

anonymous ()
Ответ на: комментарий от mandala

Нет, о не был дефолтным ни в одном из релизов.
Рассматривали такую возможность, даже в тестинге
debian-installer некоторое время был, но отказались.

Так-то оно так, было так... не знаю насчёт официального решения, однако...

Да и причина была смехотворна – Gnome3 перестал
помещаться на CD1-installer,

Что показательно

попинали его и впихнули.

Кого, Гнум3?! Кгхм-м, просто оставлю это здесь: http://cdimage.debian.org/debian-cd/current/amd64/iso-cd/ Для труъ: debian-10.0.0-amd64-netinst.iso 2019-07-06 13:31 334M

debian-10.0.0-amd64-xfce-CD-1.iso 2019-07-06 13:32 641M

debian-edu-10.0.0-amd64-netinst.iso 2019-07-06 13:31 404M debian-mac-10.0.0-amd64-netinst.iso 2019-07-06 13:31 333M Других образов для CD среди ОФИЦИАЛЬНЫХ - нет, всякие другие сборочки имеют статус неофициальных, так-то можно и всякого рода образов с блоботой найти.

anonymous ()
Ответ на: комментарий от Unicode4all

к сожалению, и Федора, которая тоже болеет швабодкофилией

А как иначе? Это ж флагман СПО. Не забыл, мы тут типа линуксоиды собрались.

papin-aziat ()
Ответ на: комментарий от anonymous

99% пользователей плевать на эти мелочи, в винде ещё и не такую хрень встретить можно.

У линуксоидов постоянно какие-то комплексы на тему «ааааа, у нас тут надпись кривая, што люди скажут???», смешно

alexferman ★★ ()
Последнее исправление: alexferman (всего исправлений: 1)
Ответ на: комментарий от mandala

на основной установочный носитель кладут DE в виде гнома

Кто его сделал основным?

anonymous ()
Ответ на: комментарий от alexferman

У линуксоидов

Угу.

Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36

anonymous ()
Ответ на: комментарий от sena

При том что мейтейнеры дистрибутива не хотят данное ПО, но та ладно что я тут распинаюсь... Нормальной поддержки железа в Debian никогда не было и нормальной реализации Optimus не будет в Debian очень и очень долго.

fallout4all ★★★★★ ()
Ответ на: комментарий от anonymous

Лучше поставить Fedora и не ипать себе мозг
с постоянной сборкой, доводкой, миксом веток и т.д.

Тебе лучше, ты и ставь себе! Хочется жить на дистре, который всегда находится в состоянии тестовой площадки, ипать себе мозг тестировкой для красношляпы, да ещё которая больше года не живёт, ну-ну, расскажи ещё этих прохладных историй, дебианщики поржут!

anonymous ()

О, наконец-то /usr смерджили как во всех нормальных дистрибутивах. Помнится, в своё время, у противников systemd от этой идеи изрядно пригорало. Интересно, баттхёртиан осилит данное изменение откатить или как обычно ограничатся ребрендингом и «шутками» о взломе собственной инфраструктуры?

zabbal ★★ ()
Ответ на: комментарий от anonymous

Дебиашники должны ржать со своих приколов. Как так у вас с поддержкой транзакций в пакетом менеджере, все также система уходит в аут при сбое установки? Dnf спокойно отменяет установку, система не страдает и не замечает. А вы apt-get -f install и ещё 10 команд.

anonymous ()
Ответ на: комментарий от zabbal

/usr смержили, а /tmp засунуть в tpmfs осилить не смогли.

anonymous ()
Ответ на: комментарий от alexferman

Ты что то путаешь, это Qt тулкит без платформы, а gtk для линукса нативен. Так что Qt должен подстраиваться под gtk на линуксе.

Deleted ()
Ответ на: комментарий от anonymous

/usr смержили, а /tmp засунуть в tpmfs осилить не смогли.

Фигня, там один маунт-юнит скопировать и активировать - он вместе с systemd в комплекте. Хотя, конечно, некрасиво - то говно, что насрано в кривой по-умолчанию /tmp потом фик знает как удалить.

zabbal ★★ ()
Ответ на: комментарий от alexferman

Одинаково хренов для всех ниш?

Одинаково недопилен, и одинаково неискоробочен, но юзать можно, брат выживет, вполне комфортно можно юзать, если донапилить.

anonymous ()
Ответ на: комментарий от anonymous

Особенно впечатлил Void с его простотой и божественным runit.

То есть, Linux вам не нужен. Бывает.

Partisan ★★ ()
Ответ на: комментарий от Deleted

Так что Qt должен подстраиваться под gtk на линуксе.

Свят-свят, не хватало под это корявое говно подстраиваться. Там mixed HiDPI не то что не работает - даже планов его чинить нет. В Qt оно хоть как-то работоспособно: во всяком случае в плазме работает.

zabbal ★★ ()
Ответ на: комментарий от alexferman

Протухшее это 3.2, которое с поддержки сняли, а у меня еще остались машины с ним. Вот здесь можно погрустить, а неофильские страсти по циферкам пофиг. Опять же, скоро новье будет в бэкпортах, нет повода заламывать руки.

bread ()

Ждём 10.1 тогда и обновляем боевой сервер ^^)

Aroshigami ()
Ответ на: комментарий от anonymous

Больше нигде не дрочат

Есть такое, но воркстейшн без проблем предлагает активировать разную лютую проприетарщину, а вот почему fusion не предлагают, я не знаю.

papin-aziat ()
Ответ на: комментарий от fallout4all

нормальной реализации Optimus не будет в Debian очень и очень долго

Если производитель железа не осиливает поставить в комплекте нормальные дрова, то при чём здесь дистрибутив?

zabbal ★★ ()
Ответ на: комментарий от anonymous

Я думал, вы все вымерли, ан нет! Может ты прохладных историй про «тестировку», «ядрен полигон» и «больше года не живёт» расскажешь? А мы как раз поржём.

Unicode4all ★★★★ ()
Ответ на: комментарий от anonymous

а /tmp засунуть в tpmfs осилить не смогли.

осиль fstab, оно всегда было

pihter ★★ ()
Ответ на: удаленный комментарий

Manjaro
Свежий
выглядит шикарно
и не всем хочется смотреть на иконки и ущербные шрифты из 90х

Вся суть манжаристов (неосиляторов рача) Манжарист это эдакий линухоминтёр от мира рача

Manjaro
подходит как опытным так и новичкам
Не всем нужно пердолингом заниматься и
красноглазить что бы работали базовые вещи

Спасибо, поржал!

anonymous ()
Ответ на: комментарий от pihter

А чейта твои крутые дебианщики не осилили systemd mount, ну или даже на крайняк fstab. Почему для того, чтобы нормально пользоваться этой, как вы говорите, «установил и работай» системой, ее нужно напильником часами допиливать?

Unicode4all ★★★★ ()
Последнее исправление: Unicode4all (всего исправлений: 1)
Ответ на: комментарий от Polugnom

О, прям Debian описал. поставил и сразу пользуешься. Ну максимум драйвер проприетарный накатить придется.

Мда, ну, я допускаю, что ты ОЧЕНЬ нетребовательный человек и тебя дефолт Деба устраивает. Впрочем, любой другой Дебом побрезговал бы. Начнём с того, что несвободные репы отключены - лезем в sources.list и пердолимся с конфигами. Шрифты выглядят ужасно, ведь технологии сглаживания в опенсорс не завезли, - ок, лезем в local.conf и вбиваем туда странные заклинания, включающие нормальное сглаживание. Пытаемся поставить deb-пакет, скачанный из инета, - но нет, убогий глюкодром под названием Synptic не умеет устанавливать пакеты с диска, надо пердолиться с dpkg. Подключить смартфон и скачать с него фоточки, установить актуальную версию Лисы, воспользоваться sudo, установить flatpak-пакет, включить прокрутку на тачпаде двумя руками, установить Wine х32 - все эти действия требуют красноглазия в консольке!

Ну и зачем пользоваться этим откровенно сырым убожеством, если все эти действия я могу сделать парой кликов в каком-нибудь Минте или Манжаро?

meliafaro ★★★★ ()
Ответ на: комментарий от Polugnom

А вот это глупости.

Нет. Она стабильна как танк, а через 4-5 месяцев начинает подтухать, но роллинга не будет, ждем Silverblue, так что да, сидя на Демьяне, в окружении окаменелостей, почувствовать простую залежалость софта не получится, ясное дело.

papin-aziat ()
Ответ на: комментарий от papin-aziat

но роллинга не будет

Есть же Rawhide.

anonymous ()
Ответ на: комментарий от Prosto_user

Ноутбуки сейчас на арчах, на серверах дебиан, на роутерах wrt.

Молодец! А почему арч на десктопе? Чем он лучше дебиана оказался для тебя?

deepforest ★★★ ()
Ответ на: комментарий от anonymous

сомнительное заявление. человек, который хорошо разбирается в слаке уж в центосе то точно разберется

ttywizard ()
Ответ на: комментарий от anonymous

Есть же Rawhide.

Ну, у дебианщиков тогда есть sid, правда, наверное, ломатель игрушек на фоне Rawhide будет с конкретным душком.

papin-aziat ()
Ответ на: комментарий от ttywizard

человек, который хорошо разбирается в слаке

...разбирается только в слаке. И может любой другой дистрибутив превратить в слаку.

anonymous ()
Ответ на: комментарий от papin-aziat

Silverblue так и вовсе стабильнее ваших дебянов и прочих. Мало того что там с обновлением если получишь каких проблем, то можно откатиться, так это ещё и происходит централизованно. То есть, выпускают сырое какое-то минорное обновление, вскоре же выпустят, где версия этого пакета откатывается назад, потому как ostree позволяет это очень просто сделать. А при последующем оно просто обновляется на версию с фиксом перепрыгивая через проблемную.

Кстати, насчет роллинга. Все настолько это подходит для роллинга особенно учитывая безпроблемные обновления между релизами неотличимые от свежей установки, что вопрос роллинга возникает в сообществе. Просто сама федора с роллингами не работала никогда, для этого они не организованы ещё. Но позже вполне, возможно, что и rolling ветка появится, аналогично тому как это сделано в openSUSE.

anonymous ()
Ответ на: комментарий от meliafaro

Начнём с того, что несвободные репы отключены - лезем в sources.list и пердолимся с конфигами

Отключенные несвободные репозитории - это правильно и так должно быть. А про ковыряние в конфигах, software-properties-gtk завезли, если мне не изменяет память, в Debian 6. А может даже 5.

рифты выглядят ужасно, ведь технологии сглаживания в опенсорс не завезли, - ок, лезем в local.conf и вбиваем туда странные заклинания, включающие нормальное сглаживание.

Не знаю, у меня через гуй все включается

Пытаемся поставить deb-пакет, скачанный из инета, - но нет, убогий глюкодром под названием Synptic не умеет устанавливать пакеты с диска, надо пердолиться с dpkg.

Gnome-software прекрасно ставит deb пакеты. И при чем тут синаптик, которого уже лет 8 в стандартной поставке нету?

Подключить смартфон и скачать с него фоточки

Воткнул и снял.

установить актуальную версию Лисы

В репозитории всегда актуальная ESR-версия лисы.

воспользоваться sudo

Настраивается при установке в самом установщике

установить flatpak-пакет

В Debian тот же flatpak что и везде. И средства для управления ими те же что и везде.

включить прокрутку на тачпаде двумя руками,

работает изкаробки же.

установить Wine х32

Apt install wine мне всегда хватало. Но я чайник, может чего-то не понимаю что ты пытаешься сказать.

Ну и зачем пользоваться этим откровенно сырым убожеством, если все эти действия я могу сделать парой кликов в каком-нибудь Минте или Манжаро?

Потому что релиз-модель манжары и минта не всем подходит? Так трудно это понять?

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

А в манжарках будешь постоянно разгребать изменения
в форматов конфигов, изменения в поведении приложений,
необходимость ручного перезапуска сервисов,
неожиданные регресси в ПО и прочие радости РР.
Это годится для десктопа линукс-энтузиаста,
но никак не для обычного человека, далекого от IT.

Просто оставлю это здесь: http://www.opennet.ru/openforum/vsluhforumID3/117856.html#61 http://www.opennet.ru/openforum/vsluhforumID3/117856.html#105

anonymous ()
Ответ на: комментарий от Polugnom

В Debian тот же flatpak что и везде. И средства для управления ими те же что и везде.

Проблема с линуксами в том, что хоть гуй может и есть, им часто невозможно пользоваться. Да, под flatpak в дебьяне есть gnome-software и discover. Но без мата можно им пользоваться только в консольке.

anonymous ()
Ответ на: комментарий от Partisan

То есть, Linux вам не нужен. Бывает.

С чего бы это такие выводы?

anonymous ()
Ответ на: комментарий от kostyarin_

Xorg может быть запущен. Не вместе с Вялым, разумеется.

Конечно может, если ставить нормально, то иксы будут работать, у меня так, иксы+крыса, брат жив!

anonymous ()
Ответ на: комментарий от Deleted

gtk для линукса нативен

То что этот шлак появился на Линуксе - ничего не значит.

alexferman ★★ ()
Ответ на: комментарий от ne-vlezay

Седой и дебиан. Смотрите триллер в кинотеатрах!

targitaj ★★★★★ ()

Ну вот зачем они убрали старый установщик и впихнули туда calamares?(( Это ужасный установщик. Кривой и смену раскладки не поддерживает

CinnaFox ()
Ответ на: комментарий от Partisan

Линукс для тебя заключается в поцтерошлаке вроде Пшшш аудио системг, а также айбиэмовском вяленде.

anonymous ()
Ответ на: комментарий от mandala

Нет, я имею в виду такой сценарий: пользователь
нажимает на ссылку на моем вебсайте и далее ПО
дистра обрабатывает это нажатие и ставит моё ПО.
Естественно со спросом всех доступов,
но это не моя головная боль.

Ты описал винду

Если что: суся так умеет лет 10,

Ну так суся была виндой от мира линухов, до выход в популярность линухоминта

именно для флатпака это тоже давно реализовано.

Твой флатпак, (как и снап) «он нам и нахер не нужон, флатпак ваш», ибо ересь и дичь, разрабам софта достаточно выкладывать сорсы и делать один бинарь со статикой в архиве, на потрогать, остальное делают майнтейнеры!

Я спрашиваю про сунаптик: при должной настройке,
но без патчей в код, он умеет ставить флатпаки?
(с рантаймами и разруливанием потрохов)

Во 1ых синаптик это морда для apt, соответственно все вопросы прежде всего к нему, во 2ых боже упаси такое говно реализовывать через синаптик или apt, для хипсторов есть специальные костылики соответствующего качества!

anonymous ()
Ответ на: комментарий от pihter

Голословно, говоришь. Из одиного случая я делаю вывод, говоришь. Один раз - не пидорас, говоришь. Ещё раз: ВСЕ они пользуются новым софтом, они ВСЕ повара и директор, они ВСЕ не жрут то, что стряпают для других.

anonymous ()
Ответ на: комментарий от CinnaFox

Ну вот зачем они убрали старый установщик и впихнули туда calamares?

Никуда его не девали. Calamares только для живых образов, на обычных дисках его нет.

Polugnom ★★★★★ ()
Ответ на: комментарий от anonymous

То есть вы предпочитаете только самое свежее дерьмо?

Или не мамонта ;-)

anonymous ()
Ответ на: комментарий от daminatorus

планируются ли на лоре деревья комментов?

ненужно, если что есть lorify, за который спасиба создателю!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.