LINUX.ORG.RU

В Ubuntu 22.04 Firefox переезжает в Snap

 , , , ,


0

2

Сегодня вместо пакета с Firefox загружена заглушка, перенаправляющая на установку Snap-пакета Firefox с релизного канала.

В результате чего теперь на системах с миниатюрным объемом SSD-памяти (до 16 ГБ) использование Ubuntu теперь будет затруднительно, если вообще возможно, поскольку контейнер занимает существенный объем места на диске. Также становится невозможной комбинация Firefox ESR + Firefox Release штатными средствами, поскольку Firefox ESR и Firefox Release расположены в одном источнике, и канал нужно будет выбрать при установке.

Ранее это было возможно в виде варианта Firefox Snap ESR + Firefox Release Deb.

>>> Ссылка на "заглушки"

anonymous

Проверено: Dimez ()

На ком-то же надо это говно обкатывать… вот браузеры и переводят. Ибо браузеры ставят все.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Хоть бы написали причину, по которой это всё происходит.

Продвижение своих говноподелок и непринятие flatpak.

Skullnet ★★★ ()

Я из-за этого snap на хром от гугла перешел. В snap он так защищен, что никакие файлы на машину не возможно сохранить. Какой идиот до этого додумался?

Теперь FF придется искать из левых сборок.

alexru ★★★★ ()
Ответ на: комментарий от Mirage1_

А когда-то браузер запускался на 32 МБ памяти и Cyrix 80486/66 MHz (2004-2005 годы, Debian 2.2)

Ну так тот браузер и сейчас на том компе наверняка запускается.

hateyoufeel ★★★★★ ()

Да и хрен бы с ним, с этим браузером. Это десктопный софт. Вот скажите, нафига мне всю эту требуху тянуть за собой для установки какого-нибудь certbot??? Или у меня на VPS диск резиновый?

Feonis ★★ ()
Ответ на: комментарий от Mirage1_

Ну так сам браузер-то вполне возможно и запустится :)

Zhbert ★★★★★ ()

А кто мешает поставить файрфокс с сайта? Там такие же дебы.

Всегда ставлю оттудова. Очень хорошо работает, обновляется…

AVL2 ★★★★★ ()
Ответ на: комментарий от rupert

Вот как происходит у них найм: https://old.reddit.com/r/linux/comments/thsrcp/this_was_the_first_step_in_the_interview_process/

Ехехехех… охохохохохо… уахахахахахахах!

Слушай, я не удивлён. Это вообще частая тема в больших компаниях, когда рекрутеры пытаются сделать себя максимально полезными.

hateyoufeel ★★★★★ ()

Вовремя я с KDE Neon свалить решил. Рано или поздно они на новый LTS перейдут, и эта хрень сюда приедет.

Alden ★★★ ()
Последнее исправление: Alden (всего исправлений: 2)

22.04 в целом выглядит провалом как лтс - куски гтк4 в перемешку с гтк3, промежуточный релиз гнома, насилие снапа и дефолтный вяленый на невидии это бы смотрелось в не-лтс, но в лтс … дебиан 11 пока ещё не протух, я лично на него с 20.04 сваливаю

rukez ★★★ ()
Последнее исправление: rukez (всего исправлений: 1)

Ручную установку deb ещё никто не отменял. Пользуюсь фирефоксом 100, ночная сборка, все хорошо)

Zlo ★★★★ ()
Ответ на: комментарий от Clockwork

В моих только то что касается Linux ядра и Linux Foundation. Но даже если, отдельный дистрибутив — не показатель. Хотя, конечно, ситуация смешная.

mord0d ★★★★★ ()
Ответ на: комментарий от rupert

Вот как происходит у них найм:

В целом выглядит вполне логично - человек не способный за час ответить на эти вопросы не способен формально вести внутреннюю бюрократию, без которой в крупной конторе - тяжко.
Если человек не готов тратить час времени на предвариловку к резюме то он явно не стремится работать в конкретной компании или на конкретной вакансии
Ну и да, для вакансий на джуна широкого спектра в ойти компании реально нет смысла спрашивать технические вопросы - там половина кандидатов дерево а половина тугое дерево но с ещё и с чсв - а вот если дерево может работать в команде, учится и развиваться, то шанс расцвести у него вполне недурён.

rukez ★★★ ()

Пофиг. Я когда на шапке сидел, то FF с сайта был, ибо дистрибутивный слишком старый - не все сайты с ним нормально работали ближе к EOL (шапки).

mv ★★★★★ ()
Ответ на: комментарий от Feonis

certbot не нужно, это блоатварь само по себе хоть и не такое как снап

Есть куча нормальных клиентов для letsencrypt'а.

firkax ★★ ()

этот snap когда работает - неплохая задумка, только он не дружит с highdpi мониторами: заменяет курсоры мыши на свои итп.

никто не знает как это лечить?

rsync ★★ ()

я недавно увидел, какой срач создаёт snap в mtab’е. это поделие точно не заслуживает права на существование. почему по уму нельзя сделать?

eternal_sorrow ★★★★★ ()
Ответ на: комментарий от Feonis

Вот скажите, нафига мне всю эту требуху тянуть за собой для установки какого-нибудь certbot???

И certbot туда же??? Ну дела! Но ничего, есть dehydrated и acme.sh

Dimez ★★★★★ ()
Ответ на: комментарий от Feonis

Да, это уже слишком.

rhel как был оплотом стабильности, так и остается им.

i586 ★★★ ()

В snap очень не нравится, что я не могу контролировать обновления пакетов, а конкретно - я не могу отключить автоматические обновления. Разработчики говорят, что так и должно быть, что им виднее, но как-то меня это смущает. Привык сам запускать apt update && apt upgrade в то время, когда удобно, а не когда система решит так сделать.

Goganchic ★★ ()

Все «удобнее» и «удобнее»…

jackill ★★★★★ ()

Ну епт же!!! Идиоты настырныне. Ну сделайте вы либо всю систему на snap или все на apt. Но такие уродские скрещивания лепить…

Слава Богу, что ребята из Linux Mint отключают это недоразумение (snap). А браузер и собрать можно.

rumgot ★★★★★ ()
Последнее исправление: rumgot (всего исправлений: 1)
Ответ на: комментарий от rsync

этот snap когда работает - неплохая задумка, только он не дружит с highdpi мониторами: заменяет курсоры мыши на свои итп.

Да он в системе не пришей одному месту рукав. Вайбер из этого чёртового Снапа, например, в трее не отображается, хотя из deb пакета с офсайта – норм. Курсор вечно дефолтный иксовый, в 2 раза меньше системного, на темы ему тоже положить. С конкурентами его, кстати, та же фигня – Флатпак ничем не лучше

Alden ★★★ ()
Последнее исправление: Alden (всего исправлений: 2)
Ответ на: комментарий от AVL2

Там нет deb пакетов. Только тарболл. Впрочем, сам давно уже оттуда качаю и ставлю в /opt. Но Snap говно, Flatpak лучше (хотя тоже не идеал)

Sunderland93 ★★★★★ ()
Ответ на: комментарий от alexru

Официальный Билл уже не выкладывают? Или офф.сайт это левый источник ПО? Согласен, не по фен-шую, но уж лучше снапоподелки.

mandala ★★★★ ()
Ответ на: комментарий от eternal_sorrow

Я acme_tiny использую. Единственное не нравится что ему питон нужен (но в сравнении с certbot-ом это даже не повод размышлять). Весь исходник на 200 строк один файл.

firkax ★★ ()
Ответ на: комментарий от Mirage1_

А когда-то браузер запускался на 32 МБ памяти и Cyrix 80486/66 MHz

Были времена, когда Netscape запускался на 8 МБ памяти. А сейчас весь прикладной софт жиром оброс так, как сумоисты 80-го уровня.

hummer ()

Вроде бы для лисы была возможность статически собрать или уже выпилили?

ya-betmen ★★★★★ ()
Ответ на: комментарий от hummer

Были времена, когда Netscape запускался на 8 МБ памяти.

Кстати, да.

Ведь для графического редактора FullHD 24 бита без Undo вполне достаточно 6 МБ памяти.

1920*1080*3 = 6 220 800
Mirage1_ ()
Ответ на: комментарий от hummer

В 2004-м году? Ну... 15" могло принимать до 1280x1024 в принципе, начали появляться плоские TFT уже в 2005-м. А дизайнерские ЭЛТ были уже в то время на 1600x1200.

Mirage1_ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)