LINUX.ORG.RU

Сообщения Sunderland93

 

Защитные меры для Wine

Форум — Desktop

Привет все. Не знаю как точнее написать заголовок, но суть вот в чём: нужно ли для использования Wine как-то огораживать от него систему, вроде создания отдельного пользователя или типа того? Вообще есть ли какие-то рекомендации по поводу улучшения безопасности при использовании Wine?

 ,

Sunderland93 ()

Yuzu - первый в мире эмулятор Nintendo Switch

Форум — Talks

Команда разработчиков свободного эмулятора игровой консоли Nintendo 3ds - Citra, объявила об активной разработке эмулятора игровой консоли Nintendo Switch, выпущенной ровно 10 месяцев назад. Эмулятор развивается с весны прошлого года, начат как форк Citra, и также как он написан на C++, а графический интерфейс использует Qt5. Однако Yuzu пока не может запустить ни одну игру. Готова эмуляция аппаратного обеспечения, это даёт возможность запустить пару homebrew-приложений. Больше информации разработчики обещали предоставить позднее. Исходный код доступен на GitHub по лицензии GPLv2, поддерживается работа в Windows, Linux и macOS. Напомним, что гибридная игровая консоль Nintendo Switch построена на базе процессора Nvidia Tegra X1, имеет 4 гигабайта LPDDR4 оперативной памяти, а системное ПО построено на модификации FreeBSD.

Исходный код

Подробности

Перемещено jollheef из games

 , , ,

Sunderland93 ()

Что сложнее всего программировать?

Форум — Talks

Приветствую. Задался таким вопросом: а что сложнее всего в программировании? То есть что сложнее разрабатывать? Как мне кажется - это компиляторы или логические схемы на каком-нибудь Verilog. Так ли это?

 , , ,

Sunderland93 ()

Автоматизация сборки deb-пакетов

Форум — Admin

Доброго времени суток. Стоит задача: создать локальный репозиторий для Debian и периодически синхронизировать его с VPS через rsync. Для создания репозитория выбрал утилиту reprepro, как простую, гибкую и делающую всё, что нужно. Сборка пакетов будет осуществляться на локальной машине через pbuilder. Однако это весьма долго и мучительно, потому задумался об автоматизации. Присматриваюсь к Jenkins, слышал что он может заниматься сборкой deb-пакетов. Так ли это? Или есть вариант лучше? Также желательна такая опция, как автоматическая пересборка всех пакетов при обновлении хотя бы одной из их зависимостей (например Qt) в репозитории. В настоящее время использую OpenSUSE Build Service, но по ряду причин он мне не подходит

 , , , ,

Sunderland93 ()

Вопрос к пользователям i3-wm

Форум — Desktop

Привет всем! Однажды уже ставил i3, но времени на доводку не было. Сейчас решил плотнее изучить. Почему i3? Конфиги простые как дубина. Сейчас активно курю мануалы, но для себя решил собрать небольшую статистику и кое-что прояснить:

1) Какой файловый менеджер и эмулятор терминала принято использовать в i3?
2) Стоит ли заморачиваться с настройкой i3Status или лучше юзать Conky? Или что-то другое?
3) Насколько будет оправданным использование замены i3Bar в лице, скажем, xfce4-panel?
4) Этот вопрос вытекает из предыдущего: стоит ли юзать чистый i3, или лучше использовать его в качестве WM для какого-нибудь Xfce?

 , , ,

Sunderland93 ()

FreeBSD на десктопе: первые впечатления

Галерея — Скриншоты
FreeBSD на десктопе: первые впечатления

Наконец домучил я FreeBSD 11.1. Делюсь первыми впечатлениями, окончательное мнение о системе уже буду делать хотя бы через месяц активного юзания. Итак, начну с основного: графическое окружение. Из всего «многообразия», доступного на фре, выбрал Xfce, как самое наименее завязанное на Linux или вообще какое-либо окружение. Изначально хотел KDE 4, но там мне так и не удалось настроить монтирование дисковых накопителей по клику в файловом менеджере....да вообще никак не удалось, только через консоль. Настроить монтирование через HAL на современных фрях, как я понял, вообще невозможно, но без HAL хреново работают KDE 4 и GNOME. В Xfce без него не отображаются значки дисков в Thunar, потому решил сделать хоть что-то, тобы исправить ситуацию. По совету местных поставил Automount, так что флешки и внешний винт теперь монтируются сразу при подключении. Что поделать - нету в BSD аналога линуксового Udisks2.....хотя один из наших соотечественников пилит его аналог под названием bsdisks, но судя по всему - только для KDE Plasma 5 (в зависимостях Qt5). Так что вот так. В остальном же ощущение, будто юзаешь Линукс года эдак 2009, который при этом косит под Линукс-современный :) Не хочу никого обидеть, просто лучше описать это чувство не могу. При копировании или распаковке чего-то толстожопого, система может наглухо зависнуть, и потом ВНЕЗАПНО отвиснуть. Возможно я накосячил, делал всё по своей же статье. Рабочий опенсорсный софт работает не хуже, чем в Линуксе, настройка самой системы особых сложностей не вызывает. Пока так.

З.Ы. хотел поставить «родную» для FreeBSD графическую оболочку Lumina, но это просто эталон вырвиглазия и неюзабельности!

>>> Просмотр (1600x900, 112 Kb)

 , ,

Sunderland93 ()

Монтирование съёмных носителей во FreeBSD: помогите!

Форум — General

Всем привет! Продолжается моя эпопея по превращению FreeBSD в приличный десктоп. На этот раз я столкнулся с критической проблемой: монтирование носителей. А если быть точнее - внешних дисков с NTFS и своих линуксовых разделов. Установил я KDE 4 (после долгих раздумий), сделал всё по инструкциям, которые собирал по всему интернету и описал в своем блоге. Что мне нужно? Мне нужно чтобы я в Dolhpin кликнул по значку нужного мне диска - и он сразу смонтировался и открылся, как в Линуксе. Но вместо этого я получаю ошибку org.freedesktop.Hal.Device.Volume.UnknownFailure: mount: illegal option -- u usage: mount [-t fstype] [-o options] target_fs mount_point С помощью гуглежа проблему решить не удалось, зато наткнулся на сообщение разрабов PC-BSD, что это проблема KDE, точнее того, что оно завязано на Линукс и использует линуксоспецифичные команды монтирования дисков. Решил попробовать MATE - вообще никакой реакции на клик по диску в Caja. Собственно, вопрос очевиден: как сделать хорошо? Ибо монтирование всего подряд через консоль - это для меня уже предел извращенства.

 , , , ,

Sunderland93 ()

Ошибка загрузки системы: cannot get c/h/s values

Форум — General

Доброго времени суток. Поставил на один из дисков, с таблицей разделов GPT, FreeBSD 11.1. Добавил опцию загрузки в GRUB, загружаюсь - а мне пишет hd4: cannot get c/h/s values. Сперва думал что это потому что не создал на этом диске раздел bios_grub (у меня мать с BIOS), но это ни на что не повлияло. Хотя на системном диске этот раздел имеется. И ещё странно: в Gparted диск определяется как /dev/sde, но на самом деле он /dev/sdd (так его видит gdisk). В чём причина всего этого? Вывод gdisk:

GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sdd: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): F14F2323-D4EE-4397-B677-9868A039423A
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 1024-sector boundaries
Total free space is 373239157 sectors (178.0 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048      1496401919   713.5 GiB   8300  DATA
   2      1496401920      1496402943   512.0 KiB   A501  
   3      1496402944      1580287991   40.0 GiB    A503  freebsd

fdisk -l
Disk /dev/sdc: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xb0bacb76

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sdc1  *         2048    1026047    1024000   500M  7 HPFS/NTFS/exFAT
/dev/sdc2         1026048  235519999  234493952 111,8G  7 HPFS/NTFS/exFAT
/dev/sdc3       235522048 1953519884 1717997837 819,2G  7 HPFS/NTFS/exFAT


Disk /dev/sda: 55,9 GiB, 60022480896 bytes, 117231408 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1BA5848A-49E5-463F-9D15-EB32F522BA7A

Device     Start       End   Sectors  Size Type
/dev/sda1   2048      8191      6144    3M BIOS boot
/dev/sda2   8192 117229567 117221376 55,9G Linux filesystem


Disk /dev/sdd: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F14F2323-D4EE-4397-B677-9868A039423A

Device          Start        End    Sectors   Size Type
/dev/sdd1        2048 1496401919 1496399872 713,6G Linux filesystem
/dev/sdd2  1496401920 1496402943       1024   512K FreeBSD boot
/dev/sdd3  1496402944 1580287991   83885048    40G FreeBSD UFS

FreeBSD грузится через следующий конфиг:
menuentry "FreeBSD 11.1" --class freebsd --class bsd --class os {
    insmod ufs2
    insmod bsd
    insmod part_gpt
    set root='(hd4,3)'
    kfreebsd /boot/loader
}

 , , , ,

Sunderland93 ()

Выбор DE для FreeBSD

Форум — Talks

Всем привет! В очередной раз хочу поставить FreeBSD в качестве десктопа. Встал вопрос выбора DE. Собственно, вопрос прост - что из существующих DE лучше всего там работает? Странно, звучит конечно, но всё же. Пока присматриваюсь к Xfce и KDE 4, как сейчас дела с KDE 5? Насколько хорошо/криво работает Гном? В общем, жду мнений

 , ,

Sunderland93 ()

QtWebEngine отныне полноценно работает под Wayland

Форум — Talks

теперь такие браузеры как Qupzilla, Otter и Konqueror запускаются и работают нативно под Wayland

 , , , ,

Sunderland93 ()

AppArmor и SElinux в одной системе: возможно ли?

Форум — Admin

Привет всем. Однажды я уже создавал подобную тему, но ничего конкретного, к сожалению, не получил. Сейчас попробую поставить более чёткую цель: есть Flatpak и Snap. Первому для изоляции нужен SElinux, второму - AppArmor. Дистрибутив - Debian 9. AppArmor ставится и включается крайне просто, настройки не требует. И после установки snapd всё соответственно работает. Но Flatpak не умеет в AppArmor. Как быть если нужны оба этих формата пакетов? Возможно ли как-то вкорячить и AppArmor и SElinux на одну систему? Звучит конечно безумно, но всё же. И если кто в курсе - планируется ли в Snap поддержка SElinux, а во Flatpak - поддержка AppArmor?

 , , , ,

Sunderland93 ()

Почему протоколы (например Wayland) описываются в формате XML?

Форум — Development

Сабж. Почему XML? Прошу объяснить

 , ,

Sunderland93 ()

Blender не видит GPU (CUDA)

Форум — Multimedia

Всем привет! Такая проблема: Blender 2.78, установленный из штатного репозитория Debian 9, не видит GPU как CUDA-девайс, то есть в настройках Блендера, для рендеринга не доступен GPU. В том время как если поставить Blender с сайта или из Стима - всё в порядке. В чём может быть причина? Все нужные пакеты установлены

 , ,

Sunderland93 ()

Прошу посоветовать годный хостинг для репозитория

Форум — Admin

Всем привет! OBS меня в конец задолбал своей тупостью и ограничениями, потому задумался о переносе своего Debian-репозитория на отдельный хостинг, чтобы всё как у людей было. Критерии такие:

1) Оптимальная цена. В идеале не дороже 300 рублей в месяц, потолок 500.
2) Пропускная способность не ниже 100 мегабит.
3) Предоставляемое место не менее 2-3 гигабайт.

Также жду советов от тех, кто организовывал свои репозитории

 , ,

Sunderland93 ()

GNOME on Wayland на Nvidia-блобе. История успеха

Галерея — Скриншоты
GNOME on Wayland на Nvidia-блобе. История успеха

Итак, свершилось! Мне наконец-то удалось запустить Wayland-сессию Гнома на проприетарном драйвере Nvidia. Для тех, кто не в теме: начиная с версии драйвера 364.12, Nvidia реализовала в нём начальную поддержку Wayland, однако несовместимую с тем, что используется в Mesa. В Mesa применяется библиотека GBM - Generic Buffer Manager, аллокатор буферов изображений. Реализация Nvidia основана на расширениях EGLStreams и EGLDevice, являющихся кроссплатформенным открытым стандартом Khronos. В списке рассылки разработчиков Wayland, Nvidia представила патчи для композитного менеджера Weston, однако разработчики их не приняли и, можно сказать, послали Nvidia подальше. Зато эти патчи адаптировали для Mutter и Sway, но о качестве работы будет ниже. Nvidia же в прошлом году анонсировала новый аллокатор, разрабатываемый совместно с разработчиками Mesa, но с момента последней новости - тишина. Nvidia не хочет создавать что-то платформоспецифичное, так как ей проще поддерживать единую кодовую базу для всех ОС.

Поддержка EGLStreams обеспечена в GNOME 3.24, однако для этого, оконный менеджер Mutter должен быть собран с --enable-egl-device Как оказалось, в Fedora 26 он собран без этой опции, также из-за применения библиотеки GLvnd, получаются лютые тормоза и лаги мышки. Аналогично в Arch Linux.

Поэтому для тестов я выбрал альфа-версию Ubuntu 17.10. Итак, что для этого нужно проделать:

1) установить драйвер Nvidia (sudo apt install nvidia-375)
2) включить DRM/KMS (по умолчанию в блобе он выключен из-за недоделанности и проблем со SLI-конфигурациями). Для этого в /etc/default/grub, в секцию параметров ядра, добавляем строку nvidia-375-drm.modeset=1 Номер драйвера указывать только для Ubuntu! Признаком успешного запуска DRM/KMS является Xorg, запущенный от юзера (в этом можно убедиться в менеджере процессов)

По идее, если всё сделано правильно, но сразу после перезагрузки Гном должен запуститься на Wayland, однако меня встречало окно входа в систему, и сеанс с Wayland никак не грузился. Поэтому я переключился на пятую tty-консоль, и стартанул сессию командой dbus-run-session -- gnome-shell --display-server --wayland

И о чудо! Оно запустилось! Начну с приятных моментов. Отрисовка значительно быстрее, чем с блобом на иксах. Курсор не отстаёт от окна ни на пиксель, анимации плавненькие, ресайз окон не тормозит. Может немного лагануть меню приложений, но я грешу на старый тормозной HDD, на котором я всё тестировал. Flatpak-приложения работают, но не все. Видео работает без проблем. Собственно, на этом приятное заканчивается. Далее оглашаю список ограничений:

1) Первое и самое главное - не работает Xwayland. В большинстве приложений. Из иксовых приложений успешно запустились лишь Firefox, Clementine и Chromium, остальные падают в корку с ошибкой Could not initialize GLX Потому запуск возможен только нативных Wayland-приложений. Чтобы запустить что-то на Qt5, нужно добавить переменную окружения export QT_QPA_PLATFORM=wayland, но тут тоже есть неприятные моменты.

2) Не запускается панель управления Nvidia (потому на скринах её нет), не работают приложения, юзающие веб-камеру (правда я только Cheese запускал), и как следствие предыдущего пункта - не работает ни одна игра (кроме встроенных гномовских) или эмулятор игровых консолей.

3) Иногда грузит CPU на 100%. Баг широко известен в сети, но я не знаю что думает на этот счёт Nvidia. От апстрима Гнома ответа не дождался.

4) KMS работает частично, в частности переключение между виртуальным консолями происходит секунды 2, а возврат в графическую может проходить и все 5. На свободном драйвере всё происходит мгновенно. Да, если вдруг кто спросит - нет, KMS в блобе не даёт высокое разрешение в консоли. Нету драйвера для fbdev, хотя с efifb вроде как разрешение высокое.

5) Родная панель управления Гнома не работает в такой конфигурации, потому запускается её сильно кастрированный вариант (скрин ниже)

Итог: я не знаю почему в Mesa выбрали GBM вместо открытого стандарта. Ведь Нвидию, по сути, обвинить не в чем. В кое-то веки смогла в стандарты. Я не думаю что будут какие-либо серьёзные улучшения как работы блоба с EGLStreams, так и оконных менеджеров куда эти патчи добавили, ибо апрстрим не принял, и тестировать некому. Хотя посмотрим как оно будет. На данный момент вердикт - неюзабельно.

Ещё скриншоты:

Firefox и LibreOffice
Activities
SMplayer (Qt5) нативно в Wayland
Панель управления
Nautilus и Clementine

>>> Просмотр (1600x900, 453 Kb)

 , , , ,

Sunderland93 ()

Qt: компоновка формы фиксированного размера

Форум — Development

Привет всем! Извиняюсь за потенциально тупой вопрос, но: нужно ли компоновать виджеты на форме при помощи layout's, если окно формы будет фиксированного размера (то есть не будет растягиваться)?

 , ,

Sunderland93 ()

Странности с OpenWRT/LEDE

Форум — Admin

Всем привет. Имеется маршрутизатор TP-LINIK WR842N, прошитый на последнюю LEDE. К нему в USB вставлен 4G-модем, работающий в режиме Hilink (по сути тоже маршрутизатор, также и веб-морда есть, и IP с DNS раздаёт). Так вот. При таком способен подключения к сети, скорость приёма всегда максимальная, но скорость отдачи мизерная и всё время обрывается (невозможно что-то в сеть загрузить). При этом если воткнуть модем напрямую в комп - всё работает нормально. В чём может быть причина? Конфиг сетевых интерфейсов:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0b:e2b7:ad5a::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0 wlan0-1'
        option _orig_bridge 'true'
        option ifname 'eth0'
        option broadcast '192.168.1.255'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

config interface 'USB'
        option proto 'dhcp'
        option ifname 'eth2'

 , , , ,

Sunderland93 ()

Разработчики MATE планируют использовать дисплейный сервер Mir в качестве Wayland-композитора

Форум — Talks

Martin Wimpress, один из разработчиков MATE и создатель дистрибутива UbuntuMATE, поделился планами по обеспечению поддержки оконной системы Wayland в окружении MATE. В силу крайне малого количества разработчиков, а также их ограниченности во времени, которое они могут тратить на разработку MATE, было решено не писать свой Wayland-композитор с нуля, а использовать дисплейный сервер Mir, адаптировав его для работы в качестве Wayland-композитора. Причины, по которым они не хотят использовать, например GNOME Mutter он не назвал. Однако разработчики осознают, что при текущих темпах разработки MATE, поддержка Wayland там будет обеспечена спустя несколько лет, и чтобы этого не допустить - решено взять готовую разработку и лишь немного переделать

Источник: http://phoronix.com/scan.php?page=news_item&px=MATE-Mir-Possibilities

 , ,

Sunderland93 ()

В Fedora 27 планируется интеграция PipeWire - эффективной замены PulseAudio и JACK

Форум — Talks

В Fedora 27 планируется интегрировать PipeWire - новую подсистему, ранее известную как Pinos, или «pulseaudio for video». Задачей PipeWire будет объединение в себе не только функционала PulseAudio и JACK для предоставления высококачественной работы аудио, но и обеспечение работы с видеопотоками, что также позволит упростить вывод видео через Flatpak-приложения и предоставить API для захвата изображения в Wayland (наконец-то!) - скринкасты, шаринг экрана и так далее. Новая подсистема разрабатывается при участии ключевых разработчиков GStreamer и PulseAudio, и в скором будущем будет представлена в Fedora. Разработчики хотят превратить Fedora в «лучшее место для создания различного контента». Прям как в своё время Amiga

https://blogs.gnome.org/uraeus/2017/06/20/fedora-workstation-26-and-beyond/

P.S. Дабы не причинять боль разработчикам, планируется обеспечить полную совместимость с PulseAudio и прочим, дабы не пришлось ни коим образом модифицировать существующие приложения. Учитывая что обещает всё это не Canonical, а RedHat - это всё правда

 , , , ,

Sunderland93 ()

Тестовые сборки Ubuntu переведены по умолчанию на GNOME

Форум — Talks

Субж http://www.omgubuntu.co.uk/2017/06/ubuntu-17-10-daily-builds-gnome

P.S. не так уж плохо смотрится, моё мнение. Хотя непонятно почему LightDM а не GDM?

 , , ,

Sunderland93 ()

RSS подписка на новые темы