LINUX.ORG.RU

Поддержка Flash в Mozilla Firefox прекращается 26 января 2021

 , , ,


1

2

Как и было заявлено в 2017 году, Mozilla Firefox прекратит поддерживать Flash 26 января 2021 года, начиная с Firefox 85, а уже с 12 января плагин Adobe Flash прекратит воспроизведение Flash контента. Таким образом, Firefox 84 будет последней версией Firefox, поддерживающей Flash. Пост, напоминающий об этом, был опубликован в Mozilla Blog.

>>> Подробности

забавно, что за все эти годы так и не смогли функциональность флеша реализовать с должной производительностью. то, что работало без тормозов почти 20 лет назад чуть ли не на п1, сейчас ставит раком современные процессоры, будучи переписанным на js/css/svg/…

anonymous ()
Ответ на: комментарий от anonymous

А у меня ведь где-то валяется диск 20-летней давности с Масяней во флеше. Если он, конечно, ещё читается. Проверить влом, потому что дивидюк хоть и стоит в корпусе, но не подключён.

gremlin_the_red ★★ ()
Ответ на: комментарий от EXL

Потому что план релизов

On January 26, 2021 when we release Firefox version 85, it will ship without Flash support, improving our performance and security. For our users on Nightly and Beta release channels, Flash support will end on November 17, 2020 and December 14, 2020 respectively.

Прочитать сможешь или перевести?

anonymous ()
Ответ на: комментарий от Im_not_a_robot

Сейчас сам адоб объявил о прекращении новых выпусков (возможно даже ссылки уберут) в декабре 2020.

Жаль, столько всего понаделали, непонятно чем теперь воспроизвести.

grem ★★★★★ ()
Ответ на: комментарий от grem

Adobe Flashplayer Standalone является рекомендованным способом просмотра Flash контента. Он поддерживается и (насколько мне известно) планов на прекращение поддержки нет и не предвидится. Речь идет о прекращении воспроизведения Flash в браузерах.

Siborgium ()
Ответ на: комментарий от Siborgium

Есть нативный бинарник и для Linux.

Пока есть. Его могут перестать обновлять и не известно сколько времени после этого он будет продолжать работать.

Win32 - это железная стабильность на века.

X512 ()
Последнее исправление: X512 (всего исправлений: 1)
Ответ на: комментарий от X512

Про вечность работы под виндой это смешно

Если под линухой у меня работают игры выщенные LokiGames во времена ядер 2.0.x, то под виндой ПО для XP часто не работает под 10кой, а порой даже и ПО под 7ку под 10кой не взлетает

anonymous ()
Ответ на: комментарий от anonymous

забавно, что за все эти годы так и не смогли функциональность флеша реализовать с должной производительностью. то, что работало без тормозов почти 20 лет назад чуть ли не на п1, сейчас ставит раком современные процессоры, будучи переписанным на js/css/svg/…

Главное чтобы как и в дырка-флеш не забывали подвозить уязвимости. А на производительность пофигу. Если что, просто можно вынудить пользоватлей обновлять железо почаще.

kostyarin_ ★★ ()
Ответ на: комментарий от X512

Всё у некоторых руки чешутся что-то поломать.

Так оно еще два года назад:

Firefox окончательно удаляет поддержку GTK+2

Сопля в виде GTK+2 висит в зависимостях (при сборке) браузера именно из-за Flash Player’а и NPAPI.

EXL ★★★★★ ()
Ответ на: комментарий от fornlr

ибо там нонсенс про совместимость и всё такое

Нативные игры от LokiGames фигеют от твоих баек, но продолжают работать, хоть выпущены до твоего рождения.

anonymous ()

Полагали, что NPAPI из лисы выдернули с корнями ещё во времена квантовизации. Позже обнаружили, что не совсем.

И хрен с ними, уж из палемуна NPAPI в обозримом будущем никуда не денется, а из Opera Presto он чисто технически никуда деться не может ;)

Сами пишем из LuaKit с замороженным WebKitGTK+ 2.24: как раз ради GTK+2 NPAPI-плагинов (в том числе флеша) и лимита на многопроцессность, которые выкинуты в 2.26 ;)

mertvoprog ()