LINUX.ORG.RU

Представлен график релизов перед выпуском XFCE 4.14

 


3

4

Релиз-менеджер легковесной среды рабочего стола XFCE Саймон Штайнбайсс (Simon Steinbeiss) в почтовой рассылке проекта опубликовал планируемый график выхода предварительных и финального выпусков XFCE версии 4.14. Команда разработчиков будет придерживаться традиционной модели выпуска новой версии: сначала будут выложены три пре-релиза, за которыми последует финальная стабильная сборка. Сам график выглядит так:

  • 19 мая: 4.14-pre1

  • 30 июня: 4.14-pre2

  • 28 июля: 4.14-pre3 (если он все-таки не потребуется, то в этот день будет представлен 4.14-final)

  • 11 августа: 4.14-final

Если верить краткому плану по задачам на релиз 4.14, то всё уже готово: среда полностью переписана на GTK3 с учетом сохранения совместимости со старыми темами xfwm4, рендеринг через GdkGC заменен на cairo, добавлена поддержка XInput2.

Желающие протестировать текущие сборки могут запустить xfce 4.14 из docker-контейнера. Обратная связь приветствуется!

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Ответ на: комментарий от Vsevolod-linuxoid

Нет никакого 4.2

Все, что связанно с apt-*, dpkg и разными tui/gui к ним, является порнографией с элементами bdsm. За примерами идем в интернет и бложики разработчиков Debian.

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

вывсёврёти.цфг

Апт может полсистемы снести просто при подключении бэкпортов. Примеры даже приводить не буду, ты сам их встречал здесь множество раз.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

А если бекпорты подключать в Arch?

anonymous ()
Ответ на: комментарий от meliafaro

вывсёврёти

Примеры даже приводить не буду

Кто бы сомневался.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Ярый защитник apt*/dpkg, в ваши apt*/dpkg завезли поддержку транзакций? Вы все так же страдаете от {пакет Х тянет за собой 20 зависимых пакетов, установка 10 зависимого пакета завершилась сбоем (разные причины), установка пакета Х прервана, система сломана}?

anonymous ()
Ответ на: комментарий от anonymous

Понятия не имею. Если ты старадаешь - завези. Я не страдаю.

Polugnom ★★★★★ ()
Ответ на: комментарий от meliafaro

Все что угодно из репозитория main. А там много что есть.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Если тебе не нужен свежий, несвободный или редкий софт и устраивает то, чем тебя кормят мейнтейнеры деба, не надо экстраполировать свою ситуацию на всё комьюнити и давать дурные советы.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

Если тебе не нужен свежий, несвободный или редкий софт

Я использую Debian stable. Уж наверно я знаю на что иду и ради чего.

чем тебя кормят мейнтейнеры деба, не надо экстраполировать свою ситуацию на всё комьюнити и давать дурные советы.

А где я экстраполирую? Не нравится - ну насильно мил не будешь. Только когда я попрошу назвать надежный, предсказуемый и полностью свободный дистрибутив, то неожиданно окажется, что выбора у меня особо и нет.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Если ты старадаешь - завези.

В Debian основные разработчики ничего нового завести не могут, хорошие идеи тонут в бюрократическом болоте. Мне-то и подавно со своим говнокодом нечего делать в Debian.

Черепахи из Debian по 10 лет принимают решения даже по такой теме как добавление двоичных префиксов в разметку диска установщика.

Если есть желание, возможность, знания, то лучше помочь Fedora, ну или Archlinux.

anonymous ()
Ответ на: комментарий от anonymous

Черепахи из Debian по 10 лет принимают решения даже по такой теме как добавление двоичных префиксов в разметку диска установщика.

В каждой теме, где хоть немного упоминается Debian, появляется этот нытик со своими двоичными префиксами в установщике, не осиливший калькулятор...

Встречный вопрос: какие дистрибутивы в установщике поддерживают одновременно двоичные и десятичные префиксы?

anonymous ()
Ответ на: комментарий от Polugnom

Ну тут мы опять переходим в область свободы ПО, патентов и прочих мутных вещей. Но вот начиная с 10 не будет никакой разницы.

Debian к патентам не имеет отношения, поскольку не попадает под юрисдикцию США. Поэтому в нём всегда воспроизводились MP3 «из коробки» и работало субпиксельное сглаживание.

anonymous ()
Ответ на: комментарий от meliafaro

Апт может полсистемы снести просто при подключении бэкпортов

У backports стоит приоритет, исключающий автоматическую установку оттуда чего-либо. Так что просто подключение backports ну никак не может привести к удалению половины системы.

Если же вы имели в виду установку чего-то из backports, то прошу привести пример, когда это был такой факап.

Примеры даже приводить не буду

Ну конечно. Ведь тогда окажется, что это был не APT, или не backports, или вообще не Debian.

anonymous ()
Ответ на: комментарий от anonymous

пакет Х тянет за собой 20 зависимых пакетов, установка 10 зависимого пакета завершилась сбоем (разные причины), установка пакета Х прервана, система сломана

Если ошибка произошла при распаковке пакета, то у вас проблема посерьёзнее пакетного менеджера.

Если же ошибка произошла при настройке пакета, то никакая система от этого не сломается.

anonymous ()
Ответ на: комментарий от Polugnom

И где здесь указано про политику Debian относительно патентных ограничений? Это обычная обзорная статья, рассказывающая про патенты на ПО в целом и вопросы, возникающие в связи с этим. Тем не менее, MP3 воспроизводится, субпиксельный рендеринг (aka ClearType) работает - несмотря на наличие соответствующих патентных ограничений.

anonymous ()
Ответ на: комментарий от Polugnom

И тем не менее, MP3, subpixel rendering и всё остальное - работает. Как вы это объясняете?

anonymous ()
Ответ на: комментарий от anonymous

И тем не менее, MP3, subpixel rendering и всё остальное - работает. Как вы это объясняете?

Я так понимаю, реализации в Debian не подвержены патентным рискам.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Я так понимаю, реализации в Debian не подвержены патентным рискам.

В Debian не свои особые реализации, а такие же, как у всех. Те же самые куски кода в Fedora, например, выпилены, поскольку нарушают американское патентное законодательство.

anonymous ()
Ответ на: комментарий от anonymous

Те же самые куски кода в Fedora, например, выпилены, поскольку нарушают американское патентное законодательство.

Позиция Debian вполне разумна: если поступает информация о патентной угрозе, то пакет, подвергающий опасности пользователей, удаляется сразу же. А то что в Red Hat бздядт на всякий случай, оно и понятно, им в отличии от Debian есть что терять. Хотя гугл подсказывает, что все патенты на mp3 истекли два года назад.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от anonymous

Поэтому в нём всегда воспроизводились MP3 «из коробки» и работало субпиксельное сглаживание.

Если попердолиться. Собственно, как и в любом другом дистрибутиве.

meliafaro ★★★★ ()
Ответ на: комментарий от Polugnom

Я использую Debian stable. Уж наверно я знаю на что иду и ради чего.

Понятия не имею, что ты там используешь. Лично мне нужно много софта, которого нет в репах, или он есть, но двухлетней давности. И таких пользователей огромное количество, настолько огромное, что этим вашим линупсом на декстопе никто и не пользуется, кроме совсем уж нетребовательных людей, которым хватает main Дебиана.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

Тебе нужно -> ты мейнтейнер -> линукс готов для десктопа. Всегда так было. В чем проблема?

anonymous ()
Ответ на: комментарий от meliafaro

Если попердолиться. Собственно, как и в любом другом дистрибутиве.

Сразу видно, что о Debian вы имеете лишь весьма отдалённое представление.

Ну вот ставлю я VLC - он играет MP3, сразу. Это пердолиться?

Захожу в настройки и включаю субпиксельное сглаживание. Ничего не доустанавливая. Это пердолиться?

Понимаю, вы проецируете свой опыт с вашим дистрибутивом, и вам кажется, что так везде, - но пора вылезти из раковины и познать мир во всём его многообразии.

anonymous ()
Ответ на: комментарий от meliafaro

Лично мне нужно много софта, которого нет в репах,

Много это сколько?

или он есть, но двухлетней давности

А еще вода мокрая, трава зеленая и снег холодный. К чему это?

И таких пользователей огромное количество

Ну я за них рад. Хотя кого я обманываю, мне все равно.

этим вашим линупсом на декстопе никто и не пользуется

И что?

Кроме совсем уж нетребовательных людей, которым хватает main Дебиана.

Я как раз очень требовательный. И именно поэтому использую main Дебиана.

Polugnom ★★★★★ ()
Ответ на: комментарий от anonymous

Сразу видно, что о Debian вы имеете лишь весьма отдалённое представление.

Если за два года плотного использования о дистрибутиве можно получить лишь весьма отдалённое представление, это определённо не тот дистрибутив, который можно посоветовать ближнему.

Ну вот ставлю я VLC - он играет MP3, сразу. Это пердолиться?
Захожу в настройки и включаю субпиксельное сглаживание. Ничего не доустанавливая. Это пердолиться?

Testing? Рад за вас, что вам наконец-то завезли сглаживание и mp3 из коробки. Это уже следует рассматривать как аргумент за переход с Убунту, где всё это давно было, на Деб, или ещё нет?

Понимаю, вы проецируете свой опыт с вашим дистрибутивом

С каким именно? Много их у меня было и есть, включая Деб, Убунту и несколько производных.

meliafaro ★★★★ ()
Последнее исправление: meliafaro (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Много это сколько?

Ну вот пример прямо по теме треда: хочу себе xfwm 4.13 - там завезли нормальную вертикальную синхронизацию и наконец-то побороли тиринг. Пользователи Бубунту в таких случаях подключают PPA. Пользователи Арч ставят из AUR. Пользователи Slackware правят одну строчку в слакбилде и парой команд в терминале пересобирают пакет. Пользователи Дебиан берут за щеку.

Я как раз очень требовательный. И именно поэтому использую main Дебиана.

Ясно, не продолжай.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

Пользователи Арч ставят из AUR

Ахаха, да у них Xfce4 стабильно неработает! Да и разве есть проблема в том что бы сделать свой .deb?

VarfolomeyKote4ka ()
Ответ на: комментарий от VarfolomeyKote4ka

Ахаха, да у них Xfce4 стабильно неработает!

стабильно неработает

Отличный слоган для Debian Stable.

Да и разве есть проблема в том что бы сделать свой .deb?

Да. Проще .exe собрать и под Вайном запустить, чем красноглазить со сборкой деба. Более корявой, запутанной и костыльной системы сборки пакетов в принципе не существует.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

Отличный слоган для Debian Stable.

Однако для Arch это тоже применимо.

Да. Проще .exe собрать и под Вайном запустить, чем красноглазить со сборкой деба.

Вроде бы в пару команд собирается, я думаю можно просто скачать архив сырцов для .deb, заменить архив с xfwm и прописать пару комманд.

VarfolomeyKote4ka ()
Ответ на: комментарий от meliafaro

Testing? Рад за вас, что вам наконец-то завезли сглаживание и mp3 из коробки.

Stable. Но всё это работало и в oldstable aka jessie.

за два года плотного использования

Ога, оно и видно.

anonymous ()
Ответ на: комментарий от meliafaro

Ну вот пример прямо по теме треда: хочу себе xfwm 4.13 - там завезли нормальную вертикальную синхронизацию и наконец-то побороли тиринг. Пользователи Бубунту в таких случаях подключают PPA. Пользователи Арч ставят из AUR. Пользователи Slackware правят одну строчку в слакбилде и парой команд в терминале пересобирают пакет. Пользователи Дебиан берут за щеку.

https://ibb.co/NTpsKxf

В результате за щёку взял meliafaro.

anonymous ()
Ответ на: комментарий от meliafaro

Ну вот пример прямо по теме треда: хочу себе xfwm 4.13 - там завезли нормальную вертикальную синхронизацию и наконец-то побороли тиринг.

Хоспаде, да неужели, не прошло и 20 лет.
Ну да ладно, вон анонимус снизу все тебе расписал насколько твой пример убог и спокойно решается в Debian. Но у нас свобода и ты можешь и дальше копаться по ppa и ауро-помойкам ради всякой ерунды.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от meliafaro

наконец-то завезли сглаживание и mp3 из коробки

Сглаживание именно как в Ubuntu есть только в Ubuntu. Сама возможность сглаживания и mp3 из коробки в Debian уже много лет.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от meliafaro

Пользователи Арч ставят из AUR

Ни к чему, оно прямо в официальном репе лежит под именем xfwm4-gtk3

alexferman ()
Ответ на: комментарий от anonymous

Stable. Но всё это работало и в oldstable aka jessie.

4.2. Надо было пердолиться с local.conf. Впрочем, я не знаю, что для тебя есть нормальное сглаживание, пользователи Дебиан привыкли есть различные сорта.

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

4.2. Надо было пердолиться с local.conf

В чём именно? Конкретные настройки, что вам пришлось менять, укажите.

пользователи Дебиан привыкли есть различные сорта

Судя по обилию такого рода заявлений, у вас фиксация. Обратитесь за профессиональной помощью.

anonymous ()
Ответ на: комментарий от anonymous

В чём именно? Конкретные настройки, что вам пришлось менять, укажите.

Посмотри скрин предыдущего онанимуса. Вот это и есть дефолт. Если это сглаживание, по вашему, я нахожу дальнейшую дискуссию бессмысленной.

meliafaro ★★★★ ()
Ответ на: комментарий от anonymous

И вертикальная синхронизация работает, тиринг попячен?

meliafaro ★★★★ ()
Ответ на: комментарий от meliafaro

Посмотри скрин предыдущего онанимуса. Вот это и есть дефолт. Если это сглаживание, по вашему, я нахожу дальнейшую дискуссию бессмысленной.

Пример правильного на ваш взгляд сглаживания - в студию!

anonymous ()
Ответ на: комментарий от meliafaro

И вертикальная синхронизация работает, тиринг попячен?

Это виртуалка.

anonymous ()
Ответ на: комментарий от meliafaro

На скриншоте нет опции с вертикальной синхронизацией. Та же версия xfwm4 в федоре - аналогично, нужно compton поднимать

Midael ★★★★★ ()
Ответ на: комментарий от Midael

Разумеется. Ведь вертикальную синхронизацию довели до ума и закономерно убрали с видного места кнопку с единственно оставшимся смыслом «сделать плохо».

anonymous ()
Ответ на: комментарий от meliafaro

Да. Проще .exe собрать и под Вайном запустить, чем красноглазить со сборкой деба. Более корявой, запутанной и костыльной системы сборки пакетов в принципе не существует.

Самое печальное то, что разработчики Debian знают о проблеме с опакечиванием и при этом они ничего предпринимать не будут.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.