LINUX.ORG.RU

Ядро Linux 3.2 получило статус длительной поддержки (LTS)

 , , ,


0

1

22 апреля 2012 года Грег Кроа-Хартман (Greg Kroah-Hartman) сообщил о выходе ядра 3.2.16. В этом же сообщении он известил, что это последний релиз ветки 3.2, который он поддерживал, в дальнейшем поддержку ветки 3.2 будет осуществлять Бен Хатчингс (Ben Hutchings).

Бен Хатчингс (Ben Hutchings) в свою очередь сообщил, что ядро версии 3.2 получает статус долговременной поддержки (long-term support). Однако не уточнил, как долго будет осуществляться такая поддержка.

Ранее Бен Хатчингс (Ben Hutchings) уже сообщал, что предстоящий релиз Debian 7.0 Wheezy будет использовать ядро версии 3.2.

Ядро реального времени для Debian Wheezy также будет основано на версии 3.2. Об этом сообщил его разработчик Стивен Ростедт (Steven Rostedt).

Ожидается, что Бен Хатчингс (Ben Hutchings) будет поддерживать ядро версии 3.2 до окончания жизненного цикла Debian 7.0 Wheezy.

Кроме Debian 7.0 Wheezy ядро версии 3.2 используется в вышедшей в конце апреля Ubuntu 12.04 LTS, для которой срок поддержки заявлен в пять лет.

>>> Подробности

Новость для пиара ubuntu и debian?

Зачем Linux 3.2 пиарить, когда стабильно на 100% Linux 3.3.4. Проверено лично - под Gentoo и NixOS.

Используем NixOS в нем доступны все версии ядра, и том числе и 3.3.4. Не смотря на версию самой NixOS 0.1pre - все работает на рабочих станциях стабильно. Сервер пока еще на Gentoo, так как многое незнакомо для меня после Gentoo, чтобы быстро перенести все веб-приложения и их настройки на NixOS.

Deleted ()
Ответ на: комментарий от Ltm

Аватарка для Hydra.

Мне пиарить их смысла нет, я изучаю их и рассматриваю как замену для используемой мною Gentoo.

Deleted ()

'vmalloc failure 0 bytes' при подгрузке модулей так и не пофикили

anonymous ()
Ответ на: комментарий от Deleted

NixOS отлично трудится и на Lenovo X200 Tablet не только у авторов системы, но и у меня, под ядром Linux-3.3.4.

Даже не смотря на мои нулевые познания функционального языка nix (ценность его такая же как Python для Gentoo), затраты времени на развертывание и сама сложность в десяки, если не сотни раз ниже чем для Gentoo. В начале знакомства я пробывал и Gentoo и Debian и еще ряд дистрибутивов. Остановился (в 2005 году) на Gentoo. Kubuntu и Ubuntu не смотря на всю их кажущуюся простоту установки аля Windows отбросил сразу же, но попробывать попробывал - и сделал вывод - не для меня и не для программистов они.

Deleted ()
Ответ на: комментарий от holka

Че, правда? Тогда винде точно капец! у нас же багов не осталось кроме #1.

AlexCones ★★★ ()
Ответ на: комментарий от holka

Этот 12309 походу проявляется у особей с особо кривыми руками и носит характер детектора криворукости, так что поэтому его и оставили.

anonymous ()

Какой-то странные LTS получается. Кстати, действительно зря они в Debian не взяли ядро 3.3, всем было бы легче.

Vudod ★★★★★ ()
Ответ на: комментарий от ZuBB

А ты знатно не прочитал ни то, ни другое.

Чукча не читатель, но писатель?

doluphio ()
Ответ на: комментарий от Ltm

Пост для пиара NixOS?

У него почти все сообщения - сплошной пиар этой недоделки. Удивляюсь, почему этот спам-бот ещё не забанен.

max_udoff ()
Ответ на: комментарий от Deleted

Мне пиарить их смысла нет, я изучаю их и рассматриваю как замену для используемой мною Gentoo.

Хочу напомнить, что это все еще топик о ядре 3.2.

Kubuntu и Ubuntu ... не для программистов они.

Ударной волной от шлепка, который прозвучал от прикладывания руки к лицу, выбило окна в доме на против. С каких пор из реп убунты удалили текстовые редакторы\иде\компиляторы?

Ltm ()
Ответ на: комментарий от Deleted

Ubuntu еще как для программистов, gcc 4.6.3, clang 3.0, все IDE последние, работать в ней удобно. А чем эта ваша NixOS может похвастаться?

z00ke ()
Ответ на: комментарий от PrikPavel

В IDE обычно много всяких элементов в меню, HUD помогает осуществлять в них поиск и быстрое ориентирование. Приходится держать открытыми достаточно много окон, множество хоткеев и удобная юнити помогает со всем этим работать достаточно быстро и без нервотрепки. Ну и так далее.

z00ke ()
Ответ на: комментарий от Deleted

> Новость для пиара ubuntu и debian?

Только Debian'а - то, что решит сделать Debian, логично отобразится на Ubuntu. Уверен, что разработчики других дистрибутивов выпустят новые версии энтерпрайсных дистрибутивов именно с ядром 3.2 - но в новости пока об этом не напишешь, потому что неизвестно, какие это будут дистрибутивы.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от z00ke

Тем же самым, а таже возможно gcc 4.7.0 когда я смогу сам писать nix сценарии. IDE я не использую, так как IDE для программиста это как костыли.

# nix-env -qa '*' | grep -i gcc
gcc-wrapper-4.6.3
# gcc -v
Используются внутренние спецификации.
COLLECT_GCC=/nix/store/fghwm2dz41sz9b2l87ffgv11zadq7dxr-gcc-4.6.3/bin/gcc
COLLECT_LTO_WRAPPER=/nix/store/fghwm2dz41sz9b2l87ffgv11zadq7dxr-gcc-4.6.3/libexec/gcc/x86_64-unknown-linux-gnu/4.6.3/lto-wrapper
Целевая архитектура: x86_64-unknown-linux-gnu
Параметры конфигурации: 
Модель многопоточности: posix
gcc версия 4.6.3 (GCC)
Deleted ()
Ответ на: комментарий от Deleted

XMonad надо еще настраивать и разбираться(Хотя в Ubuntu его можно поставить и пользоваться, как и остальные тайловые WM), при том еще и хотя-бы немного вникнуть в хаскелль, а в Unity это уже есть сразу. Я в принципе тоже IDE не пользуюсь, а редактором(ST2). Тык

z00ke ()
Ответ на: комментарий от PrikPavel

Не повезло тебе наверное...

Релизную ставил, обновил, не ломал ничего по советам Петросянов?

Для тех, кто кодит надо, чтобы инструмент своё дело делал, а не требовал постоянного ухода и ковыряния. Тем, кто работает, а не делает вид, что работает постоянно напиливая свой любимый дистр, Ubuntu подходит.

thunderamur ()
Ответ на: комментарий от z00ke

а я замечал

на бете. на релизе ещё ни разу, мб это от того, что не ломаю ничего.

thunderamur ()
Ответ на: Не повезло тебе наверное... от thunderamur

Я знаю Linux уже три года и знаю, как в нем нужно работать. Даже 9.04 не падала у меня, даже Арч после обновлений. А вы мне лепите бабушку про некие советы Петросянов. Убунту для меня давно умерла, хотя я и надеялся, что LTS-релиз не подведет.

PrikPavel ()
Ответ на: комментарий от z00ke

На кой эти сраные IDE нужные? Лучше бы нормальный мултиарч допилили и следили бы за тухлостью девелоперского софта и библиотек. Например, racket в 12.04 включен полугодовалой (!!!) давности. Не для программистов бунта, это я тебе как программист говорю.

Reset ★★★★★ ()
Ответ на: комментарий от Reset

racket в 12.04 включен полугодовалой (!!!) давности

Акуеть!!!111

tailgunner ★★★★★ ()
Ответ на: комментарий от max_udoff

Да уж, он задолбал уже к месту и ни к месту этот NixOS втыкать. Может можно сделать так, чтобы анонимусам его сообщения не показывались?

anonymous ()
Ответ на: комментарий от holka

Они вообще 3.0 сначала хотели

Да что вы с ним так возитесь, ума не приложу.

kost-bebix ★★ ()

У меня это самое глючное ядро за год использования linux. Сломали nouveau, WiFi на двух ноутбуках и USB на одном... а еще 12309 во все поля. Примечательно, что в 3.3 все это (включая 12309) пофиксили и оно работает безупречно.

ArtKun ★★★★★ ()
Ответ на: комментарий от Deleted

IDE для программиста это как костыли.

и самолет для человека - это костыли, потому что летать, зараза, не умеет.

vasaka ★★★ ()
Ответ на: комментарий от Alve

Я пиар не делаю, а сообщаю в ответ на пиар ubuntu что есть более достойная на мой взгляд альтернатива.

Неделя пиара ведется как раз по ubuntu.

Deleted ()
Ответ на: комментарий от Reset

Не думаю, что такая политика помешает им включить 3.2. Да и какая разница, половина разработчиков ядра сидит в Red Hat.

ArtKun ★★★★★ ()
Ответ на: комментарий от Reset

Я тоже программист, с мэйнстримовыми sdk/библиотеками проблем не наблюдается, да и невозможно контролировать свежие версии всяких ноунейм, вроде racket. Выше писал, что IDE не использую. Если мультиарч хочешь, то тебе в дебиан.

z00ke ()
Ответ на: комментарий от vasaka

Когда можно ходить на ногах нужно ходить на ногах. Тем более что это зачастую быстрее чем часами в пробках стоять, да и для общего развития в том числе и физического полезно. А то знакомые и двух метров пройти не могут.

А про самолеты - то налетался - стараюсь избегать их, падают слишком часто, как и IDE.

Deleted ()
Ответ на: комментарий от Reset

так как не было и не будет Федоры на 3.2.

Внезапно, в Fedora 16 ядро было 3.1 и постепенно в процессе накатки апдейтов поднялось до 3.2, а теперь и до 3.3.

no-dashi ★★★★★ ()
Ответ на: комментарий от true_admin

> В 3.3 12309 пофиксили же

этот баг будет жить вечно

Ну да. В линуксе две беды - kernel API nonsence и неосиляторы. А 12309 это не третья беда линукса, а следствие из второй :-)

no-dashi ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.