LINUX.ORG.RU

Debian 9 «Stretch»

 ,


3

2

После 26 месяцев разработки представлен стабильный выпуск Debian 9 с кодовым именем «Stretch», который будет поддерживаться в течение следующих 5 лет.

Релиз посвящён памяти основателя проекта Иана Мёрдока, который ушёл из жизни 28 декабря 2015 года.

Основные изменения:

  • Вариантом MySQL по умолчанию теперь является MariaDB.
  • Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.
  • Команда dmesg теперь требует права root.
  • Для запуска дисплейной системы X более не требуются права root.
  • Пакеты отладки перенесены в новый репозиторий и имеют окончание -dbgsym вместо -dbg. Репозиторий можно добавить в список источников APT:
    deb http://deb.debian.org/debian-debug/ stretch-debug main
    

Новые версии ПО:

  • Apache 2.4.25;
  • Asterisk 13.14.1;
  • Chromium 59.0.3071.86;
  • Firefox 45.9 (в пакете firefox-esr);
  • GIMP 2.8.18;
  • GNOME 3.22;
  • GCC 6.3;
  • GnuPG 2.1;
  • Golang 1.7;
  • KDE Frameworks 5.28, KDE Plasma 5.8, KDE Applications 16.08 и PIM-компоненты 16.04;
  • LibreOffice 5.2;
  • Linux 4.9;
  • MariaDB 10.1;
  • MATE 1.16;
  • OpenJDK 8;
  • Perl 5.24;
  • PHP 7.0;
  • PostgreSQL 9.6;
  • Python 2.7.13 и 3.5.3;
  • Ruby 2.3;
  • Samba 4.5;
  • systemd 232;
  • Thunderbird 45.8;
  • Tomcat 8.5;
  • Xen Hypervisor;
  • Xfce 4.12.

Debian «Stretch» содержит более 51 000 других готовых к использованию пакетов ПО, собранных из немногим более 25 000 пакетов с исходным кодом.

Всего поддерживается десять архитектур: amd64, i386, ppc64el, s390x, armel, armhf, arm64, mips, mipsel, mips64el. Поддержка powerpc в «Stretch» прекращена.

>>> Подробности

★★★★★

Проверено: Klymedy ()
Ответ на: комментарий от m1ke

Давай не будем врать?!

Ок, не ври.

у 8 и выше нет официальной возможности вернуть интерфейс и поведение к тому виду, какое было на 7

Нет официальной(?) возможности ≠ нет возможности, врунишка. Впрочем, у гнома тоже нет официальной возможности вернуть всё как было.

Все что ты можешь - поставить СТОРОННИЙ софт

И?

Но гарантий на 100% совместимость лук&фила нет!

В линуксе разве есть? Иначе о чём спор?

Раскрою тебе секрет: в дебиане тоже никакая программа из официального репозитария не притащит ничего и не поломает.

У чувака из того треда таки поломала, а значит ты продолжаешь врать.

Ну так - а у чувака из твоего примера проблемма в инсталяторе той софтины - какая глобальная разница?

Глобальная разница в том что из-за кривого инсталлятора студии поломалась лишь студия. В том треде же после того как человеку понадобилась новая версия софтины — из-за порочной системы зависимостей поломался XFCE.

У тебя есть примеры что в дебиане gcc из коробки не собирает kernel из коробки? вот именно это и называется дистрибутив системы - когда все компоненты подогнаны максимально друг к другу.

Зачем мне собирать уже собранное ведро? Ты что, с помощью gcc собираешь лишь то что уже есть в твоём дистрибутиве?

ты с самого начала только этим и занимаешься - вранье и передергивание чужих слов

Нет, ты.

есть ситуация (которая и покрывает 95% потребностей рядового пользователя) когда лучше держать один набор либ в системе и софт, который на них завязан

1% пользователей линукса на десктопе говорит о том что не покрывает, а значит ты опять врёшь.

Но разработчикам то никто не мешает собирать и распространять из софт как они хотят - хоть с нужными либами, хоть жирным бинарником - нормальным людям плевать чем там развлекается разработчик.

Разработчику xscreensaver об этом расскажи.

Судя по тому, что не слышно воя в интернетах - они угадали.

Просто у тебя уши заложило. См. google: debian update php

ну печалька для пыхеров - что я могу сказать.

Это скорее для десктопного линукса в целом печалька.

погоди, но под венду же ты сбегал?

Сбегал. Сборочка есть, никого пинать не пришлось.

в чем принципиальное отличие то?

См. выше.

Но ты - в меньшинстве.

На самом деле нет. Просто ты ошибочно думаешь что ты в большинстве.

НО и сообщество дебиана не подписывалось решать твои проблемы

Уж взялся за гуж — не ной что не дуж.

Дебиан не запрещает тебе куда-то бежать, где-то что-то брать и ставить.

Я где-то писал что он что-то мне запрещает, врунишка?

Ну поищи там же под дебиан9 - в чем проблема то?

В том что под дебиан нет. Почему — я уже расписал в предыдущих сообщениях.

Потому что твое ЭГО требует от тебя обновить систему

Нет.

Ну давай ты не будешь советовать что мне надо?!

Я ещё даже советовать не начал, лишь спросил — а ты уже злой. Видишь до чего зависимости доводят.

У нас стоял вопрос: является ли виндовс системой с неограниченными возможностями в которой пользователь может решить любую проблему с помощью установки софта (это декларировал ты).

Где? Ссылочку, пожалуйста.

Когда тебя ткнули носов с твое же говнецо что даже микрософтовские либы ты переустановить не можешь - началось ко-ко-ко оно никому не нужно! Так что по этому вопросу слив тебе тоже уже засчитан!

Ок, попердолиться в винде с дотнетом не получится, засчитывай.

Ты его можешь поменять? НЕТ!

Я и format C: не могу сделать. Тем не менее я не считаю это недостатком, критически влияющим на работу.

Если его покалечить каким-либо образом система (вин10) нормально функционировать

Не распарсил.

сможешь ли ты ее починить? НЕТ!

Не ври, ссылку на утилиту для починки я тебе уже дал.

Проблема в том, что пердолишься только ты

Нет же, у меня винда на десктопе.

h578b1bde ★☆ ()
Ответ на: комментарий от NextGenenration

Да, так как используешь винду, которая не может обновить весь софт за раз

Мне это не нужно. Впрочем, никто тебе не запрещает поставить пакетный менеджер и ставить софт оттуда.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

Отлично! ты положил свою копию gtk рядом с vim, свою копию с firefox, свою копию с libreoffice, свою копию с evince, ну и отдельную для eog. Их конечно же будет больше, ну да бог с ним, пусть будет только 5 для простоты. Тут внезапно обнаруживается секьюрити баг в gtk - твои действия?

Читаю об уязвимости, если её можно эксплуатировать через жирнолис — обновляю жирнолис и, опционально, либру. На всё остальное скорее всего будет насрать из-за отсутствия возможных векторов атаки

Во-первых, ври убедительней. Ты не следишь за всеми либами, с которыми собран софт! более того: при такой постановке вопроса ты даже знать не будешь какие именно версии либ у тебя лежат с каким софтом - потому что кроме пакетного менеджера за этим никто не следит нормально.

Во-вторых, пусть уязвимость эксплуатируется через просмотр специального jpg. И тут фигак! внезапно нужно обновить практически всю систему: фаерфокс - потому что он лазит в инет, либру - потому что в ней может быть встроен jpg, просмотрщики всякие evince и eog - потому что они тоже под атакой. Файловый менеджер - потому что он превьюшки кажет. И хренову тучу всего, о чем ты можешь даже не догадываться.

Дело конечно твое, но нормальным людям есть чем заняться, кроме как отслеживать все обновления безопасности для всех либ руками с последующим обновлением всего софта также руками.

Хотя, кому мы врем - ничего ты отслеживать не будешь и при первом удобном случае будет у тебя обычный рассадник, но ты то будешь уверен что все сделал правильно и у тебя все хорошо.

Мякотка в том как было проведено голосование, учитывая предыдущие результаты.

Голосование было? Было. Варианты были равны. Выбор был сложный. Причины выбора адекватным людям могут и не нравиться, но понятны. Кого не устраивает - вариант в виде девуана никто не отменял. Могут даже профинансировать свою гражданскую позицию. Я для себя решил, что мне проще быть в мейнстриме и жить с systemd, тем более, что в тех 2-х моих сервисах, для которых мне пришлось писать конфиг, все оказалось достаточно элементарно и по трудозатратам сравнимо с написанием инита. А учитывая, что я избавился от необходимости всех этих форков с отвязыванием от терминала - можно сказать, что этот переход даже сделал мою жизнь легче.

Напомни, пожалуйста, не ты ли выше упоминал про поддержку дебианом Hurd и kFreeBSD?

Не я, поскольку считаю эти ветки мертворожденными. И если боль kFreeBSD от второй системы инициализации в дебиане еще как-то можно понять, то Hurd на столько отличается во всем, что разница между системами инициализации не столь уже важна. Ну и да. Формально, Debian/kFreeBSD это не Debian/Linux - это другая система, так почему в ней не может быть другой системы инициализации? То, что версии софта совпадают - приятный бонус.

Ага, мы тут вам забагованный сырой комбайн в стейбл завезли, кушайте.

А теперь внимательно слушаю тебя по багам, которые приехали в стейбл с systemd или причисляем тебя к врунам. На счет комбайна претензий нет. Ну, не он первый, не он последний.

Тупой здесь только ты если до сих пор не осилил прочитать причину, по которой человек сам лично начал процесс обновления.

Да нет, я то как раз все не только прочитал, но, в отличии от тебя, еще и понял: чувак не нашел какого-то говна и решил обновить систему. В новой версии ему что-то не понравилось, он устроил истерику в интернете.

Нет, если бы он нашёл статически слинкованную софтину, которая ему была нужна, то обновляться и страдать от нового XFCE ему бы не пришлось.

Стопэ! Никто за чувака не сделал работы - не собрал статический бинарь. У самого чувака на это руки из жопы и он решил менять систему. А виноват во всем дебиан. Я ничего не упустил?

Пердолинг ради пердолинга — это не развитие, прекращай заниматься самообманом.

Тебе виднее - пердолингом у нас занимаешься ты.

Ну т.е. раз уж нужно городить дополнительные костыли — получается что система дистрибуции софта в линуксе хреново выполняет свои задачи? ЧТД.

Нет, с логикой у тебя по прежнему все плохо. Это не проблема системы дистрибуции. Это ЕЩЕ ОДИН ДОПОЛНИТЕЛЬНЫЙ способ добиться желаемого результата. Причем способ на столько универсальный, что (с небольшими оговорками) подойдет даже для переноса твоей поделки между разными ОС. Но никто не запрещает тебе линковать что угодно и как угодно - линкуй свой php статически и носи с собой - все будет работать также.

И поэтому апт порой пытается вынести полсистемы, лол.

С 2003 года я помню лишь один раз, когда будучи на unstable апт пытался при обновлении вынести иксы со всем остальным добром. Проблема решилась не обновлением в этот день, а обновлением в следующий. На стабильной версии такого небыло ни разу. Текущая система установлена где-то в 2007 году (сразу после обновления компа на amd64 архитектуру) и постоянно обновляется (регулярно бывают уходы на тестинг и анстейбл). Но ни разу не страдала на столько, чтобы ее нельзя было восстановить. Через нее прошла куча проприетарного софта, начиная от всяких VMWare и заканчивая IBM Lotus Notes. Никогда наличие пакетного менеджера не служило помехой в моем желании установить какой-либо софт. Видимо, только виндо-теоретики испытывают какую-то боль пониже поясницы при упоминании апт-гета

m1ke ()
Ответ на: комментарий от cuss

Это тема про Debian vs. шиндошс. Приверженцев винды в последнее время стало слишком много, непонятно, что они делают на ЛОРе. Раньше было поспокойнее, и школоты было поменьше, и виндузятников, а разумных людей было больше.

eugeno ★★★★★ ()
Ответ на: комментарий от m1ke

Меня устраивает, что кодеки у меня обновляются самостоятельно, мне не нужно следить чтобы при просмотре котиков с ютуба мне не прилетел какой-нить троянчик в нагрузку через багу в кодеке.

Главное следить чтобы вместе с обновлением через багу в кодеке не прилетела печалька в виде невозможности посмотреть котиков с ютуба.

У меня нет времени страдать по отсутствию какой-то нужной версии чего-то.

Правильно, нет возможностей — нет проблем. Истинно красноглазый подход фанатика.

Мне не положили в пакетах свежих версий firefox, golang, node.js с npm и чего-то еще что было надо для работы - я это собрал сам в рабочее время.

Работать надо в рабочее время, а не пакеты собирать.

Я давно уже отошел от максимализма и не жду что все мои проблемы кто-то порешает

А я что, жду?

Весь твой скулеж тут как раз от того, что как раз ты жрешь то, что дают. Собрали под венду php5.4 - хорошо, будешь пользоваться, не собрали - поскулишь и пойдешь искать либо по помойкам либо на новую версию пыхи. Также и с ХП - сдохнет твой комп, а под новый проц и мать не будет дров - поскулишь и пойдешь жрать что дадут микрософт на тот момент. Собирать нужный тебе инструмент самостоятельно у тебя нет ни знаний ни опыта. Как мы выяснили ранее, учиться ты не хочешь. Печалька для тебя одним словом...

Я уже тебе говорил что экстраполировать свои проблемы на других — не выход.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

В винде модули не отваливаются после каждого обновления ведра.

И это как раз не заслуга модульности (хотя, венда тоже далека от микроядерности), а именно стабильность АПИ позволяет драйверам работать нормально при обновлении ядра. Ну так, грубо говоря, у тебя с вероятностью в 99% при обновлении безопасности дебиана 9 тоже модули не будут отваливаться. А именно это и происходит у тебя в венде - никто там не переписывает ядро такими кусками постоянно, как это делается в линуксе. Фиксятся баги. Т.е. можно сказать, что в рамках дебиан 9 kernel API is stable.

Так что как видишь, никакое не 4.2 - либо ты не улавливаешь причинно следственных связей (от сего происходит поломка ядра), либо ты не можешь связать 2-х слов. Я склоняюсь к первому выводу, поскольку он более вероятен после дискуссии с тобой

m1ke ()
Ответ на: комментарий от m1ke

А именно это и происходит у тебя в венде - никто там не переписывает ядро такими кусками постоянно, как это делается в линуксе.

Именно. В переписывании ядра огромными кусками нет необходимости просто потому что само ядро там довольно хорошо структурировано и без проблем разбирается на отдельные мелкие модули. В том и состоит косвенное преимущество гибридного ядра для конечного пользователя.

h578b1bde ★☆ ()
Последнее исправление: h578b1bde (всего исправлений: 1)
Ответ на: комментарий от h578b1bde

А вдруг мейнтейнер дистрибутива не прочитал новость и не пересобрал либру?

А ему и не надо читать новости про все баги. Мейнтейнер либры читает рассылку только либры. А баги в гтк поправит мейнтейнер гтк. и оно исправится сразу везде. Именно так это и работает в нормальных системах.

m1ke ()
Ответ на: комментарий от h578b1bde

Главное следить чтобы вместе с обновлением через багу в кодеке не прилетела печалька в виде невозможности посмотреть котиков с ютуба.

Сколько раз на тебя динозавры нападали?

NextGenenration ()
Ответ на: комментарий от h578b1bde

Вот только в дебиане доступного софта меньше, а его версии прибиты гвоздями к версии системы.

Очередной бред вендузятника. Менше чем где? Чем в венде? Какого именно софта? Как мы будем считать весь этот софт? Давай уже сойдемся, что некоторого софта (Photoshop, CorelDraw, Консультант может быть, не слежу уже давно) под линуксом нет (также, как большей его части нет и под Mac допустим). И если для тебя этот софт критичен - не надо себя мучать, пользуйся вендой. Точно также у меня на ноуте стоит венда 10 исключительно для запуска раз в месяц Starcraft2. У меня нет ни времени ни желания разбираться как это все запустить на wine. Венда лицензионная, пусть хоть для чего-то будет. НО! если считать софт линуксовый - то ты снова ВРЕШЬ! (как всегда в прочем). Дебиан ни в коей мере не ограничивает тебя в установке софта. Достаточно большую часть за тебя даже собрали. Остальное - самостоятельно, никто не подписывался решать все твои проблемы.

m1ke ()
Ответ на: комментарий от eugeno

Это тема про Debian vs. шиндошс. Приверженцев винды в последнее время стало слишком много, непонятно, что они делают на ЛОРе. Раньше было поспокойнее, и школоты было поменьше, и виндузятников, а разумных людей было больше.

Вот именно, предлагаю поехавшим XP-вантузятникам отправиться обсуждать свою дебильную винду на винфак! Это ЛОР, тема про дебиан. Имейте совесть, загадили своей дебильной системой весь мир, так теперь еще и последний оплот разума, ЛОР, с каждым днем все глубже и глубже погружается в пучину. На каждую тему, каждую новость набегает толпа виндузятников и начинает свою вонь!

Товарищи вантузоиды, проследуйте пожалуйста, на свой тематический форум раз и навсегда, черти вас раздери!

curufinwe ★★★★ ()
Ответ на: комментарий от m1ke

Во-первых, ври убедительней.

Начни с себя.

Ты не следишь за всеми либами, с которыми собран софт! более того: при такой постановке вопроса ты даже знать не будешь какие именно версии либ у тебя лежат с каким софтом

За этим следят разработчики, которые в случае чего выкатывают новую версию.

потому что кроме пакетного менеджера за этим никто не следит нормально.

Что-то я не вижу потока новостей о систематических заражениях через сторонние библиотеки. Наверное потому что за этим никто не следит.

Во-вторых, пусть уязвимость эксплуатируется через просмотр специального jpg. И тут фигак! внезапно нужно обновить практически всю систему: фаерфокс - потому что он лазит в инет, либру - потому что в ней может быть встроен jpg, просмотрщики всякие evince и eog - потому что они тоже под атакой. Файловый менеджер - потому что он превьюшки кажет. И хренову тучу всего, о чем ты можешь даже не догадываться.

А завтра мы перепишем всё с нуля из-за фатального недостатка, вследствие чего появляется уязвимость, эксплуатируемая через просмотр специального png. Типичный жизненный цикл софта в Linux.

Хотя, кому мы врем - ничего ты отслеживать не будешь и при первом удобном случае будет у тебя обычный рассадник, но ты то будешь уверен что все сделал правильно и у тебя все хорошо.

Почему же его до сих пор нет?

Не я, поскольку считаю эти ветки мертворожденными.

Но ведь поддерживать их тоже кто-то должен. Или там такая же поддержка как у модулей wi-fi?

Формально, Debian/kFreeBSD это не Debian/Linux - это другая система, так почему в ней не может быть другой системы инициализации?

Может, только теперь по-хорошему нужно поддерживать две системы инициализации.

А теперь внимательно слушаю тебя по багам, которые приехали в стейбл с systemd или причисляем тебя к врунам. На счет комбайна претензий нет. Ну, не он первый, не он последний.

Я об этом глюкодроме столько расписывал что мне уже реально лень. Можешь засчитывать слив, да.

Да нет, я то как раз все не только прочитал, но, в отличии от тебя, еще и понял: чувак не нашел какого-то говна и решил обновить систему.

У меня проблем с пониманием прочитанного нет, в отличие от тебя. Чувак прямым текстом написал что какая-то софтина захотела более новую версию уже существующей в системе библиотеки, поэтому прекращай врать и сочинять басни.

Стопэ! Никто за чувака не сделал работы - не собрал статический бинарь. У самого чувака на это руки из жопы и он решил менять систему. А виноват во всем дебиан.

Ну ведь не 95% выбирающих более универсальные системы пользователей виноваты.

Тебе виднее - пердолингом у нас занимаешься ты.

Нет.

Нет, с логикой у тебя по прежнему все плохо. Это не проблема системы дистрибуции.

Почему это не проблема? Я хочу софтину версии X.Y, в то время как репозитарий дебиана предлагает мне xscreensaver лишь версии A.B. Получается что такая система дистрибуции не может эффективно решить задачу получения нужного мне софта, а значит её нужность сомнительна.

Это ЕЩЕ ОДИН ДОПОЛНИТЕЛЬНЫЙ способ добиться желаемого результата

Ну раз основного способа нет — остаётся выкручиваться лишь через дополнительные, да.

h578b1bde ★☆ ()
Последнее исправление: h578b1bde (всего исправлений: 1)
Ответ на: комментарий от h578b1bde

Я и не страдаю, я же не больной, читать всю вашу переписку на стопятсот страниц. Я просто высказал общую мысль, которая накапливалась уже месяцами. Я не собираюсь спорить насчет технических преимуществ и недостатков винды, но все же надо иметь совесть. Какую цель ты преследуешь, доказывая на тематическом форуме по линуксу, что линукс - задница?

Для вас же специальный сайт был - слор.

curufinwe ★★★★ ()
Последнее исправление: curufinwe (всего исправлений: 1)
Ответ на: комментарий от curufinwe

Какую цель ты преследуешь, доказывая на тематическом форуме по линуксу, что линукс - задница?

JFF. Я всего лишь указал на недостатки существующей системы дистрибуции софта при помощи системы зависимостей, кто-то приплёл сюда винду и пошло-поехало.

h578b1bde ★☆ ()
Ответ на: комментарий от curufinwe

Дабы не быть голословным — вот первые упоминания винды в данном треде:
www.linux.org.ru/news/debian/13485642?cid=13487950
www.linux.org.ru/news/debian/13485642?cid=13488978
www.linux.org.ru/news/debian/13485642?cid=13489045

Получается что сами линуксоиды и дебианщики в частности без холивара про другие ОС не могут.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

Может быть, но это же линукс.орг.ру. Мне например глубоко все равно, если в новости о новой винде на винфаке будут с грязью мешать дебиан. Но почему-то каждый любитель винды считает своим святым долгом делать обратное на этом форуме.

Вообще защита винды тобой выглядит несколько комично. Ты же используешь XP? А почему не десятку, вот ответь?

curufinwe ★★★★ ()
Ответ на: комментарий от curufinwe

Вообще защита винды тобой выглядит несколько комично. Ты же используешь XP? А почему не десятку, вот ответь?

Потому что я установил XP когда десятки ещё не было, и сейчас она меня вполне устраивает.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

Нет официальной(?) возможности ≠ нет возможности, врунишка. Впрочем, у гнома тоже нет официальной возможности вернуть всё как было.

Решение по приведению 10 в 100% look&feel хотя бы 7 (не будем говорить про ХП сейчас) в студию или ты ВРУН

Но гарантий на 100% совместимость лук&фила нет!

В линуксе разве есть? Иначе о чём спор?

Да ты уже склерозить начал на глазах прямо? Хорошо, я освежу твою память (но на будущее - начинай пить витаминки, я чуствую, что рановато тебе склерозить). Спор как раз о том, что дебиан плохой, пересобирает свой софт как ему вздумается, пользователь не может остаться на нужной ему версии. Тебе рассказали уже несколько вариантов как этого добиться, но да, они требуют ручного труда ибо таких извращенцев единицы, и все из них не хотят ничего делать, хотят только потреблять. Ты встал весь в белом и заявил на всю палату, что в самой чудной системе таких проблем априори нет, ты все можешь поставить сбоку со стороны и микрософт тебе не указ. Когда тебя ткнули носом во вранье, ты начал выворачиваться, что да, ты не можешь вернуть нужное поведение со 100% гарантией, но этого нельзя и в линуксе - как всегда пытаешься выкручиваться и перевирать чужие слова.

У чувака из того треда таки поломала, а значит ты продолжаешь врать.

Да нет, это ты продолжаешь тупить. Там не поломки. Там есть новая система с новым look&feel. Нравится она чуваку или нет - дело десятое, никого особо не чухает. Чувак сам apt-get набирал или через что он там апдейтился - его и трудности.

Глобальная разница в том что из-за кривого инсталлятора студии поломалась лишь студия. В том треде же после того как человеку понадобилась новая версия софтины — из-за порочной системы зависимостей поломался XFCE.

Глобальная разница в том, что чувак не смог без проблем поставить ОФИЦИАЛЬНЫЙ дистрибутив на ОФИЦИАЛЬНО поддерживаемую систему. В том треде ничего не поломалось - оно так задумано программистами xfce. Они посчитали, что такое поведение достойно быть зарелизеным. Нет никакой разницы, поставил бы он этот xfce из реп нового деба или собрал бы сам - ничего бы не изменилось. То, что чувак для установки новой версии софтины не нашел ничего лучше, как обновить всю систему, - характеризует его тоже не с лучшей стороны. То, что он не понял что произошло и пошел плакаться на форум ЛОРа - еще печальней. На какую помощь он там рассчитывал?

Зачем мне собирать уже собранное ведро? Ты что, с помощью gcc собираешь лишь то что уже есть в твоём дистрибутиве?

Собирать уже собранное ядро может быть нужным по разным причинам. Опять твой скудный жизненный опыт дает о себе знать. Для такого виндузятника и пыхера как ты, я могу пояснить, что любой компилятор вовсе не обязан собирать что угодно для этого языка. Есть версии стандарта языка. Есть определенная поддержка набора стандартов компилятором в определенной версии. Если твой исходник содержит что-то, что в этой версии компилятора не поддерживается - оно не соберется. Я не знаю (да и не хочу знать) что используется в ядре 4.9 (достаточно новом) чего не хватает в компиляторе 5.4 (достаточно старом). Но я тебе могу точно сказать, что у микрософтового компилятора ситуация ничуть не лучше - некоторое время назад (не знаю как сейчас), когда меня интересовала сборка мозиллы под винду, требования к версии студии были вплоть до сервис-пака. и ни в коем случае не использовать более новую - стабильность не гарантировалась. Догадываешься почему или пыхеры такие вещи не осиливают?

есть ситуация (которая и покрывает 95% потребностей рядового пользователя) когда лучше держать один набор либ в системе и софт, который на них завязан

1% пользователей линукса на десктопе говорит о том что не покрывает, а значит ты опять врёшь.

Опять ты тупишь: система динамической линковки применяется во всех текущих мейнстримных системах: windows, mac os x, linux. Различатется лишь кол-во софта, которое можно поставить из официального источника: windows - 0 (ок, там сейчас тоже есть магазин, но я не знаю что там продают, да и нашего любителя обмазаться теплой ХП это не касается особо), mac os x - apple store, дебиан - официальная репа. Будем сравнивать где кол-во больше? Распространять софт в виде слинкованных статично бираней можно под любой системой. В виде бинаря + либы - тоже можно под любой. То, что под дебианом так мало кто делает - значит оно нафиг никому не нужно.

Разработчику xscreensaver об этом расскажи.

Вот не хотел ходить, но... Объясняю тебе ситуацию: разработчик xscreensaver накодил некий софт и, не оттестировав как следует, зарелизил его в прод. На момент релиза дебиана лучше ничего небыло. Его версия вошла в релиз. Тут выяснилось, что его версия - глюкавое говно. К нему пошли пользователи и в лучших традициях стали объяснять откуда у него растут руки. Но разработчику было влом выяснять что есть баг а что есть фича и он начал дальше клепать версии в надежде, что проблема сама рассосется. А чтобы пользователи отстали - добавил тупейшее сообщение о необходимости обновляться. Когда это дело заметили дебиановцы, они, как всякий здравомыслящий человек, решили, что лучше иметь некое стабильное кол-во багов и пытаться их править, чем непонятного кодеда, лабающего релиз за релизом, причем без гарантий качества - поскольку поддерживать свою поделку чувачек оказался не в состоянии. Так вот: если бы автор xscreensaver действительно заботился о своей репутации, то он бы не лепил релизы как придется. А делал бы отдельные ветки под фичи и под багфиксы. И продолжал бы поддерживать то, что накодил. Вот это и есть проблема линкуса (но и не только его) - никому не интересно фиксить баги, все хотят пилить фичи. И проблема статической линковки ничего не решила бы. Поскольку чуваку то никто не запрещал слинковать свой сейвер статически и распространять со своего сайта. Опять ты привел не тот пример

Просто у тебя уши заложило. См. google: debian update php

Специально для тебя я ввел этот запрос - на первой странице гугла нет ни слова про дебиан 9! НИ ЕДИНОГО УПОМИНАНИЯ проблемы пыха в девятке! Ты опять СОВРАЛ! все, что там есть - как поставить более новую версию на 6 и 7 версию дебиана! Видима проблема с пятым пыхом в дебе 9 действительно серьезна!

Это скорее для десктопного линукса в целом печалька.

Это не проблема десктопного линукса. У него куча других проблем, но не эта! Никто не запрещает распространять софт статически слинкованным. Не ври!

m1ke ()
Ответ на: комментарий от h578b1bde

Сбегал. Сборочка есть, никого пинать не пришлось.

в чем принципиальное отличие то?

См. выше.

смотреть на что? как разработчики пыха положили на тебя болт, а ты продолжаешь винить в этом дебиан? так печальное зрелище, мы тут тебе всем лором уже 14 страниц сопереживаем.

На самом деле нет. Просто ты ошибочно думаешь что ты в большинстве.

Я пользуюсь дистром, который входит в 10 крупнейших, дистром - который один из старейших. Политика распространения софта в дебиане совпадает со всеми крупнейшими дистрибутивами линукса. Так почему бы мне не считать себя в большинстве? То, что пользователи других ОС превращают свои системы в дырявые помойки меня ни коим образом не касается - я сделал свой выбор осознанно, результатом доволен.

Уж взялся за гуж — не ной что не дуж.

О, вот и открылась твоя дурно пахнущая душонка - не ублажили тебя понимаешь ли на халяву. Пословицу он вспомнил.. Мальчик, иди уже займись делом - никто здесь за тебя не будет решать твои проблемы. Либо решай сам либо плати кому-то - других путей не дано!

Я где-то писал что он что-то мне запрещает, врунишка?

Ты тут уже который пост подряд пишешь, что злые дебиановцы своими зависимостями не дают тебе поставить пых пятый. причем почему-то считаешь, что проблема в зависимостях, а не в том, что разработчики пыха положили на твои желания. Так и кто тут врет?

В том что под дебиан нет. Почему — я уже расписал в предыдущих сообщениях.

Нет, ты только ноешь что все на тебя положили болт. Давай так - что мешало разработчикам пыха собрать версию под деб? Может быть то, что 5.4 уже деприкейтед и разбираться с твоими проблемами не хотят даже они?

У нас стоял вопрос: является ли виндовс системой с неограниченными возможностями в которой пользователь может решить любую проблему с помощью установки софта (это декларировал ты).

Где? Ссылочку, пожалуйста.

Ты реально думаешь, что мне больше нечем заняться, кроме как перечитывать 14 листов твоего скулежа? нет, спасибо.

Я и format C: не могу сделать. Тем не менее я не считаю это недостатком, критически влияющим на работу.

странно, когда я пользовался - вроде можно было, неужно и это запретили в самой свободной системе?

Если его покалечить каким-либо образом система (вин10) нормально функционировать

Не распарсил.

Какой ты непонятливый. Если каким-либо образом фреймворк побился - сможешь ли ты восстановить его? скорее всего нет. поскольку утилита восстановления - это не установка заведомо исправного софта, а мертвому припарок.

Нет же, у меня винда на десктопе.

Венда на десктопе, а такая попоболь... А у меня вот все на линуксе и никаких проблем уже много лет. Я даже не хожу по вендовозным форумам рассказывать как хорошо в линуксе - прикинь?

m1ke ()
Ответ на: комментарий от eugeno

Это тема про Debian vs. шиндошс. Приверженцев винды в последнее время стало слишком много, непонятно, что они делают на ЛОРе. Раньше было поспокойнее, и школоты было поменьше, и виндузятников, а разумных людей было больше.

Так банить их надо! Посмотрел по паре постов, что не несет пациент адекватнотного светлого и доброго - ну и в бан его. А то вот в кои то веки зашел почитать на лор про любимый дистр, мнения людей и все такое - а тут какие-то сопли непонятные от вендузятника с опытом школоты, но зашкаливающими амбициями... ну и какой адекватны человек потом придет на ресурс еще раз? Жестче надо быть с неадекватами!

m1ke ()
Ответ на: комментарий от h578b1bde

А баги в гтк поправит мейнтейнер гтк

Или не поправит.

Это только в вашем мирке баги не поправят. В нашем - даже если что-то случилось и мейнтейнер не может исправить это сам (хотя для более или менее крупной системы он там не один), то исправят другие и выпустять nmu-апдейтом.

Твои познания в линуксак, дистрибутивах, разработке да и во всем остальном (ну может кроме венды - тут я судить не берусь) на столько скудны, что даже противно с тобой вести дискуссию. Зачем ты пришел сюда позориться?

Именно так это и работает в нормальных системах.

Это в каких?

Ты видимо не поверишь, но - везде! и даже в твоей венде. Или ты думал, что апдейты для vcredist идут исключительно ради системы?

m1ke ()
Ответ на: комментарий от Vinni_Pooh

Я так давно себе поставил и настроил Дебиан, что за столь долгое время пользования системой изредка консолью обновлял и устанавливал нужные пакеты.А большего и не надо было.Так я забыл совсем что такое починка системы

Убедил, поробую таки этот ваш Дебиан.

anonymous ()
Ответ на: комментарий от m1ke

Решение по приведению 10 в 100% look&feel хотя бы 7 (не будем говорить про ХП сейчас) в студию или ты ВРУН

https://www.google.com/search?q=make windows 10 look like windows 7

Да ты уже склерозить начал на глазах прямо? Хорошо, я освежу твою память (но на будущее - начинай пить витаминки, я чуствую, что рановато тебе склерозить). Спор как раз о том, что дебиан плохой, пересобирает свой софт как ему вздумается, пользователь не может остаться на нужной ему версии. Тебе рассказали уже несколько вариантов как этого добиться, но да, они требуют ручного труда ибо таких извращенцев единицы, и все из них не хотят ничего делать, хотят только потреблять. Ты встал весь в белом и заявил на всю палату, что в самой чудной системе таких проблем априори нет, ты все можешь поставить сбоку со стороны и микрософт тебе не указ. Когда тебя ткнули носом во вранье, ты начал выворачиваться, что да, ты не можешь вернуть нужное поведение со 100% гарантией, но этого нельзя и в линуксе - как всегда пытаешься выкручиваться и перевирать чужие слова.

И как эта простыня относится к ранее обсуждаемому нами вопросу о look&feel?

Да нет, это ты продолжаешь тупить. Там не поломки. Там есть новая система с новым look&feel. Нравится она чуваку или нет - дело десятое, никого особо не чухает.

А ему не нужна была новая система. Ему была нужна свежая версия библиотеки, при наличии которой установка новой системы с вероятностью 99,9% не понадобилась. У тебя проблемы с выявлением причинно-следственной связи, да?

Чувак сам apt-get набирал или через что он там апдейтился - его и трудности.

Классическое „не было печали — апдейтов накачали”, угу.

Глобальная разница в том, что чувак не смог без проблем поставить ОФИЦИАЛЬНЫЙ дистрибутив на ОФИЦИАЛЬНО поддерживаемую систему.

Это баг.

В том треде ничего не поломалось - оно так задумано программистами xfce. Они посчитали, что такое поведение достойно быть зарелизеным. Нет никакой разницы, поставил бы он этот xfce из реп нового деба или собрал бы сам - ничего бы не изменилось. То, что чувак для установки новой версии софтины не нашел ничего лучше, как обновить всю систему, - характеризует его тоже не с лучшей стороны. То, что он не понял что произошло и пошел плакаться на форум ЛОРа - еще печальней. На какую помощь он там рассчитывал?

Как по мне он особо и не рассчитывал на помощь. Нет ничего плохого в том чтобы обсудить недостатки и факапы какой-либо системы, твои же личные комплексы при этом никому не интересны.

Собирать уже собранное ядро может быть нужным по разным причинам. Опять твой скудный жизненный опыт дает о себе знать. Для такого виндузятника и пыхера как ты, я могу пояснить, что любой компилятор вовсе не обязан собирать что угодно для этого языка. Есть версии стандарта языка. Есть определенная поддержка набора стандартов компилятором в определенной версии. Если твой исходник содержит что-то, что в этой версии компилятора не поддерживается - оно не соберется.

Хорошо, раз ты такой умный — объясни, как мне собрать этот исходник не перекатываясь на другую систему? Ну кроме варианта с компиляцией компилятора, лол.

Опять ты тупишь: система динамической линковки применяется во всех текущих мейнстримных системах

Тупишь здесь только ты. Я ничего не говорил о применимости её где либо, я лишь затронул вопрос прикладного софта.

Объясняю тебе ситуацию: разработчик xscreensaver накодил некий софт и, не оттестировав как следует, зарелизил его в прод. На момент релиза дебиана лучше ничего небыло. Его версия вошла в релиз. Тут выяснилось, что его версия - глюкавое говно. К нему пошли пользователи и в лучших традициях стали объяснять откуда у него растут руки. Но разработчику было влом выяснять что есть баг а что есть фича и он начал дальше клепать версии в надежде, что проблема сама рассосется.

А почему же мейнтейнеры дебиана спали и не бэкпортировали изменения? Вдруг там уязвимость какая была и пользователи годами жили в опасности.

непонятного кодеда
JWZ, один из изначальных авторов Netscape Navigator и Mozilla


лабающего релиз за релизом

Что в этом плохого?

Так вот: если бы автор xscreensaver действительно заботился о своей репутации, то он бы не лепил релизы как придется. А делал бы отдельные ветки под фичи и под багфиксы.

Зачем ему это? Разве мейнтейнеры существуют не для этого?

И проблема статической линковки ничего не решила бы. Поскольку чуваку то никто не запрещал слинковать свой сейвер статически и распространять со своего сайта.

В данной ситуации это никак не помогло бы решить проблему — пользователи по инерции всё равно продолжали ставить стабильно глючное говно мамонта из репозитария.

на первой странице гугла нет ни слова про дебиан 9! НИ ЕДИНОГО УПОМИНАНИЯ проблемы пыха в девятке!

И что? Это лишь показывает что вчерашний тестинг пока никому особо не нужен.

Ты опять СОВРАЛ!

Нет, ты. Я тебя уже спрашивал о версии для джесси.

все, что там есть - как поставить более новую версию на 6 и 7 версию дебиана!

Поменяй в запросе слово „upgrade” на „downgrade”, делов-то. Хотя если бы ты мог думать то уже давно понял суть проблемы и без этих лишних действий.

Это не проблема десктопного линукса.

1% — не проблема, ок.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

За этим следят разработчики, которые в случае чего выкатывают новую версию.

Разработчики не следят ни за чем - там очень много таких же раздолбаев, как и ты. «Какая новая версия? а вдруг моя чудесная софтинка с ней не соберется - зачем мне этот геморой». Так что Порядка в системе не будет гарантированно!

Что-то я не вижу потока новостей о систематических заражениях через сторонние библиотеки. Наверное потому что за этим никто не следит.

А я не вижу суслика. Но вижу постоянные новости, как через незалатанные дыры венды начинается очередная эпидемия. И да, микрософт включило принудительные обновления на 10 явно не от хорошей жизни.

Во-вторых, пусть уязвимость эксплуатируется через просмотр специального jpg. И тут фигак! внезапно нужно обновить практически всю систему: фаерфокс - потому что он лазит в инет, либру - потому что в ней может быть встроен jpg, просмотрщики всякие evince и eog - потому что они тоже под атакой. Файловый менеджер - потому что он превьюшки кажет. И хренову тучу всего, о чем ты можешь даже не догадываться.

А завтра мы перепишем всё с нуля из-за фатального недостатка, вследствие чего появляется уязвимость, эксплуатируемая через просмотр специального png. Типичный жизненный цикл софта в Linux.

Ты не поверишь, но это типичный цикл разработки любого ПО. Почитай хотябы Брукса для начала. И да, как это подкрепляет твою теорию о замечательности распространения софта вместе с либами? Или ты не подумал и привел пример, когда твой способ опять делает только хуже - ведь при дырке с png тебе опять надо отследить весь софт, который использовал libpng и обновить его руками, вместо того, чтобы пакетник вытянул один пакет из репы с фиксами?

Почему же его до сих пор нет?

А откуда такая уверенность что нет? опять максимализм прет из всех щелей? вот если бы я сидел на не поддерживаемой системе, пользовался непонятными браузерами с запашком, в которых не работает половина защитных механизмов, обновлял бы софт только когда петух клюнет - я бы не был так уверен.

Но ведь поддерживать их тоже кто-то должен. Или там такая же поддержка как у модулей wi-fi?

Может, только теперь по-хорошему нужно поддерживать две системы инициализации.

Должен. Они и поддерживают. Это их выбор, чего ты так переживаешь за них? Или ты им все никак простить не можешь, что sysvinit для kFreeBSD они собрали, а php5.3 для тебя - не стали?

Я об этом глюкодроме столько расписывал что мне уже реально лень. Можешь засчитывать слив, да.

Ты что-то там расписывал, а я сидел на тестинге - и никаких проблем небыло. Ок, слил так слил.

У меня проблем с пониманием прочитанного нет, в отличие от тебя. Чувак прямым текстом написал что какая-то софтина захотела более новую версию уже существующей в системе библиотеки, поэтому прекращай врать и сочинять басни.

Да ты упоролся уже на ночь глядя! заставил меня отлистывать назад и искать твою ссылку! вот тебе цитата:

По воле случая, пришлось обновить Debian Jessie до Stretch (какая-то софтина из testing просила новую libstd++, а он тянет пол-системы апдейтов, вот и решил; да и релиз через неделю обещают).

Специально для тебя читаю по слогам и объясняю смысл написанного:

По воле случая, пришлось обновить Debian Jessie

запоминай - у чувака 8 версия дистрибутива. ВОСЬМАЯ, Карл, стабильная, выпущенная более 2-х лет назад.

какая-то софтина из testing просила новую libstd++

чуваку понадобилась софтина из тестинга (ага, это на тот момент как раз наш топик) и он сам, своей головой решил смиксовать стабильную и тестируемую ветку. Заметь, нет никаких рассказов о попытках найти статически собранную версию его софтины, ни попыток поискать ее в бэкпортах, ни предыдущих тем с просьбами помочь ему бэкпортировать нужную версию. Нет, чувачек смело ринулся в бой. Тем более, что он решил, что «да и релиз через неделю обещают» - что в общем-то с головой в нем выдает такого же недавно набежавшего, ибо все, кто пользуется дебианом хоть пару релизов знают, что обещание релиза дебиана через неделю - это как встреча на улице динозавра - либо будет либо нет.

Ребутнулся, и теперь хочется выколоть себе глаза.

Я бы ему еще и руки отрубил, а не только глаза выколол, ну да хрен с ним.

Дальше список его проблем: маленький шрифт на переключателе раскладки, некрасивый переключатель окон, сломались темы в gtk3. И конечно же во всем этом виноваты разработчики debain. Это они, нехорошие люди, специально в xfce пропихнули патчи, чтобы пользователи ломали глаза на мелкий шрифт, изуродовали переключатель окошек и пришли к разрабам GTK3 с пистолетом, захватили их семью в заложники пока они не сломают обратную совместимость с темами! Если это все его проблемы при обновлении с версии ОС на новую - то я аплодирую разработчикам дебиана стоя: ничего не сломалось, никакие настройки не полетели, все прошло в штатном режиме. Этого сложно добиться, но они смогли. То, что пользователю не нравится как выглядит новый xfce - ну пусть он им и напишет. или в спортлото...

А теперь я задам тебе вопрос, раз уж ты утвердаешь, что с пониманием у тебя все окейно:

Чувак прямым текстом написал что какая-то софтина захотела более новую версию уже существующей в системе библиотеки, поэтому прекращай врать и сочинять басни.

Где именно он написал (прямо выдели цитатой), что версия из стейбла при апдейте захотела обновить ему половину системы? Если ты опять выдал свои влажные фантазии за действительность - завязывай с этим.

Стопэ! Никто за чувака не сделал работы - не собрал статический бинарь. У самого чувака на это руки из жопы и он решил менять систему. А виноват во всем дебиан.

Ну ведь не 95% выбирающих более универсальные системы пользователей виноваты.

О чем ты снова? или у тебя память как у рыбки - на 2 минуты только? Там я тебе написал, что у чувака был вариант получения желаемой версии без замены системы на новую (может конечно и небыло, возможно та программа действительно использовала какие-то фичи новой libc и жить без них не может, но чувак, видимо дабы не позориться основательно, решил не уточнять этот момент). И да, 95% пользователей именно устраивает универсальная система. Но всегда найдутся те, кто ищет новых версий - им на стейбле возможно делать нечего (если их потребности уникальны и они не хотят самостоятельно прикладывать усилия по сборке)

Почему это не проблема? Я хочу софтину версии X.Y, в то время как репозитарий дебиана предлагает мне xscreensaver лишь версии A.B. Получается что такая система дистрибуции не может эффективно решить задачу получения нужного мне софта, а значит её нужность сомнительна.

опять логика хромает. система дистрибуции - это dpkg + apt. Оно не запрещает тебе использовать не официальные версии репозитариев. Если хочешь другую версию - это твоя проблема и твоя забота ее найти. Ищешь репу. Если нет репы - ищешь на сайте разработчика версию в пакете или хотябы статически линкованную. Если все забили болт на твои хотелки - ну ты сам же понимаешь: либо умерь свое непомерно раздутое ЭГО и пользуйся что есть либо собери нужную версию сам. Это так сложно для твоего понимания?

Ну раз основного способа нет — остаётся выкручиваться лишь через дополнительные, да.

Основной способ отлично работает для всех, кроме особо упоротых дебилов

m1ke ()
Ответ на: комментарий от h578b1bde

просто потому что само ядро там довольно хорошо структурировано и без проблем разбирается на отдельные мелкие модули

И правда. Не осилили структурировать свою помойку на 300 гигов и дажезапилили расширение для гит, чтобы можно было хоть как-то работать с ЭТИМ, но вот архитектуру нормальную они конечно же навяли, да.

anonymous ()
Ответ на: комментарий от pyometra

Уже месяц на нем сижу, все отлично. Только часы в плазме маленькие. В новых версиях плазмы исправили, но в дебиане ж заморозка, попала плазма с маленьким шрифтом часов. Но это лечится правкой qml файла элементарно.

curufinwe ★★★★ ()
Ответ на: комментарий от m1ke

ты продолжаешь винить в этом дебиан?

Нет, я продолжаю винить в этом прочно въевшуюся порочную систему зависимостей.

Я пользуюсь дистром, который входит в 10 крупнейших, дистром - который один из старейших. Политика распространения софта в дебиане совпадает со всеми крупнейшими дистрибутивами линукса. Так почему бы мне не считать себя в большинстве? То, что пользователи других ОС превращают свои системы в дырявые помойки меня ни коим образом не касается - я сделал свой выбор осознанно, результатом доволен.

Всё это никак не относится к вопросу о большинстве и меньшинстве.

Ты тут уже который пост подряд пишешь, что злые дебиановцы своими зависимостями не дают тебе поставить пых пятый. причем почему-то считаешь, что проблема в зависимостях, а не в том, что разработчики пыха положили на твои желания.
проблема в зависимостях

Именно.

Так и кто тут врет?

Ты.

Давай так - что мешало разработчикам пыха собрать версию под деб?

В таком случае им также пришлось бы собирать версию под федору, зюзю, центось и прочее. Кроме этого, пришлось бы поддерживать несколько версий — для стейбла, тестинга, анстейбла и т.п., и так для каждого дистрибутива. Помимо этого нужно обеспечивать работоспособность с различными веб-серверами — apache, nginx, lighttpd в разных режимах работы — mod-php, fastcgi и т.д. в каждом из этих дистрибутивов, что для любого разработчика является слишком сложной задачей. Т.е. мешает зоопарк.

Ты реально думаешь, что мне больше нечем заняться, кроме как перечитывать 14 листов твоего скулежа? нет, спасибо.

Слив засчитан, врунишка.

странно, когда я пользовался - вроде можно было

В 90-х?

Если каким-либо образом фреймворк побился - сможешь ли ты восстановить его? скорее всего нет.

Не знаю, в отличие от тебя я не обладаю настолько сильным даром предсказания.

Венда на десктопе, а такая попоболь...

У тебя или у кого? А то как я уже заметил выше — не я первым затронул эту тему, так что попоболь скорее у кого-то другого.

А у меня вот все на линуксе и никаких проблем уже много лет. Я даже не хожу по вендовозным форумам рассказывать как хорошо в линуксе - прикинь?

Но зачем тогда на линуксовом форуме рассказываешь как плохо в винде, лол?

h578b1bde ★☆ ()
Ответ на: комментарий от m1ke

Это только в вашем мирке баги не поправят. В нашем - даже если что-то случилось и мейнтейнер не может исправить это сам (хотя для более или менее крупной системы он там не один), то исправят другие и выпустять nmu-апдейтом.

Xscreensaver.

Твои познания в линуксак, дистрибутивах, разработке да и во всем остальном (ну может кроме венды - тут я судить не берусь) на столько скудны, что даже противно с тобой вести дискуссию. Зачем ты пришел сюда позориться?

Пока что позоришься лишь ты.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

За этим следят разработчики, которые в случае чего выкатывают новую версию.

То-то на винде можно встретить openssl либу версии 0.9.х.
Потому что так следят, так следят ...

anonymous ()
Ответ на: комментарий от m1ke

Разработчики не следят ни за чем - там очень много таких же раздолбаев, как и ты. «Какая новая версия? а вдруг моя чудесная софтинка с ней не соберется - зачем мне этот геморой». Так что Порядка в системе не будет гарантированно!

Наверное как-то так думали мейнтейнеры xscreensaver.

Но вижу постоянные новости, как через незалатанные дыры венды начинается очередная эпидемия.

После того как дырку уже залатали, как обычно.

А откуда такая уверенность что нет?

Из объективных источников.

Где именно он написал (прямо выдели цитатой), что версия из стейбла при апдейте захотела обновить ему половину системы?

Где именно я написал что версия была из стейбла? Опять же, почему я должен жрать лишь ту версию которую запихнули в стейбл?

Там я тебе написал, что у чувака был вариант получения желаемой версии без замены системы на новую (может конечно и небыло, возможно та программа действительно использовала какие-то фичи новой libc и жить без них не может, но чувак, видимо дабы не позориться основательно, решил не уточнять этот момент).

Чувак пользователь, ему вообще должно быть насрать на фичи новой libc.

если их потребности уникальны

Чушь.

h578b1bde ★☆ ()

Юзаю пару месяцев уже на основном десктопе, полёт отличный, кстати, весь гуй бегает как раз без рута, из-за использования gdm3:

ps aux | grep X
Debian-+   957  0.0  0.2 297240 48704 tty1     Sl+  чер19   0:00 /usr/bin/Xwayland :1024 -rootless -noreset -listen 4 -listen 5 -displayfd 6
{username}      1587  1.5  0.7 436800 128988 tty2    Sl+  чер19   6:33 /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/{uid}/gdm/Xauthority -background none -noreset -keeptty -verbose 3

anonymous ()
Ответ на: комментарий от h578b1bde

Где я это отрицал?

Что никакой мнимой свободы выбора нет, ибо большинство DE уже намертво прибиты гвоздями к systemd. В общем, кушайте что дают.

Есть, конечно. Вот только время твоей жизни ограничено, поэтому Москва будет построена примерно никогда.

Ну так не строй Москву. Для жизни и работы вполне себе хватит дома.

Ну так свобода строить свой город не гарантирует что это легко

Не знаю как там в вашем коммунизме, а мне чтобы сходить в магазин города строить не нужно.

ЯННП. Мне при коммунизме тоже не надо город строить. И даже в магазин ходить не надо. Надо только сказать СИМ САЛАБИМ VLC УСТАНОВИСЬ! И Vlc установится. У вас в виндах так до сих пор нльзя, а ты мне рассказываешь что я пердолюсь

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

На твоём кардридере шильдик „работает в Windows 10” как в вики дебиана есть или нет?

ну нет нету! производитель выпускает ноутбук в котором аппаратные компоненты не совместимы с новыми виндами! да такое ж на каждом углу!

ЗЫ на картридер шильдики ж не вешают. А спорим бук заявлен как совместимый?

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Спорим я щас найду сообщения на форумах где у людей не работает железо (после покупки или апдейта) на оффтопике? причем найду без труда

Давай, только так чтобы шильдик с версией оффтопика соответствовал версии используемого оффтопика.

Берем мой ноутбук, смотрим ему в зад, там наклейка Windows8

Берем гугл, набираем «hp envy dv6 windows 8 не работает» и, вот ведь неожиданность, начинаем лупяндрить на сообщения о том что не работает то-то и то-то.

Как я это сделал если в виндах все работает, когда заявлена поддержка и соблюдается версия винды?

Правда думаешь что кто-то в это поверит? Тут типа все такие матерые линуксоводы что и винды никогда не видели?

pihter ★☆ ()
Ответ на: комментарий от anonymous

Ноутбук dell latitude d820 - на родной хр беспроводная сетевуха (ака вафля, она же броадком) ни в какую не взлетала, даже с дровами и тд, на debian 7 взлетела без проблем.

А на такое никто не смотрит. Это все потому что линуксоиды красноглазые и пердолятся с каждой софтиной.

А я все чаще замечаю случаи, когда в дебиане что-то заводится как положено, а в виндах нужно в бубен бить. Пару недель взад на работе был случай когда нужно было старый принтер на семеру. Так вот специалист (!) безопасник (!) с красным дипломом (!) тру видовод — не осилил. А вот начинающий дебиановод за часок разобрался как завести его под дебианом. (правда потом подсказали что можно дрова от висты попробовать и принтер под семерой таки завелся, но это ж не пердоленье, чейта я)

pihter ★☆ ()
Ответ на: комментарий от pihter

СИМ САЛАБИМ VLC УСТАНОВИСЬ!

Ага, ага. Только он в дебианах вечно заморозится на самой глючной версии, в которой аппаратное декодирование полурабочее.

fornlr ★★★★★ ()
Ответ на: комментарий от h578b1bde

Зачем из-за системной либы пересобирать прикладной софт? Это разве что в линуксе может быть такой пердолинг, здесь достаточно поставить апдейт от микрософта.

Ну ты ж предлагаешь все либы такскать с каждой программой. А ну как завтра выяснится что одна из либ дырявая? Получится что почти во всех программах дырка. И как исправлять? Пересобирать все программы где есть эта либа. Это тебе прелести статической линковки, за которую ты так топишь

здесь достаточно поставить апдейт от микрософта.

Так апдейт от майкрософта что пофиксит? Системную библиотеку, к которой весь софт динамически прилинкован. Иначе не пофиксит. Не может же апдейт от майкрософта исправить все инстолляторы всх программ? Получается что в светлой и чистой винде сделано так же как в богомезких линуксах?

Спроси это у туповатого линукс-пользователя со старым браузером выше.

Вот сейчас обидно сказал! Он не старый (в плане безопасности). Он же у меня и репозитория (о где еще регрессивная технология!!!) у меня на него обновления безопасности приходят.

pihter ★☆ ()
Ответ на: комментарий от anonymous

эта железяка то везде работает, кроме 9-го деба.

я таки не возьму в толк как так получилось. На восьмом работала, на инсталляторе работала, а в 9 дебе нет. Ты б хоть выхлопы lsusb и dmesg-а показал уже что-ли...

покушаться на нашу святую корову?

святая корова у тебя в штанах :)

pihter ★☆ ()