LINUX.ORG.RU

Debian 9 «Stretch»

 ,


3

2

После 26 месяцев разработки представлен стабильный выпуск Debian 9 с кодовым именем «Stretch», который будет поддерживаться в течение следующих 5 лет.

Релиз посвящён памяти основателя проекта Иана Мёрдока, который ушёл из жизни 28 декабря 2015 года.

Основные изменения:

  • Вариантом MySQL по умолчанию теперь является MariaDB.
  • Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.
  • Команда dmesg теперь требует права root.
  • Для запуска дисплейной системы X более не требуются права root.
  • Пакеты отладки перенесены в новый репозиторий и имеют окончание -dbgsym вместо -dbg. Репозиторий можно добавить в список источников APT:
    deb http://deb.debian.org/debian-debug/ stretch-debug main
    

Новые версии ПО:

  • Apache 2.4.25;
  • Asterisk 13.14.1;
  • Chromium 59.0.3071.86;
  • Firefox 45.9 (в пакете firefox-esr);
  • GIMP 2.8.18;
  • GNOME 3.22;
  • GCC 6.3;
  • GnuPG 2.1;
  • Golang 1.7;
  • KDE Frameworks 5.28, KDE Plasma 5.8, KDE Applications 16.08 и PIM-компоненты 16.04;
  • LibreOffice 5.2;
  • Linux 4.9;
  • MariaDB 10.1;
  • MATE 1.16;
  • OpenJDK 8;
  • Perl 5.24;
  • PHP 7.0;
  • PostgreSQL 9.6;
  • Python 2.7.13 и 3.5.3;
  • Ruby 2.3;
  • Samba 4.5;
  • systemd 232;
  • Thunderbird 45.8;
  • Tomcat 8.5;
  • Xen Hypervisor;
  • Xfce 4.12.

Debian «Stretch» содержит более 51 000 других готовых к использованию пакетов ПО, собранных из немногим более 25 000 пакетов с исходным кодом.

Всего поддерживается десять архитектур: amd64, i386, ppc64el, s390x, armel, armhf, arm64, mips, mipsel, mips64el. Поддержка powerpc в «Stretch» прекращена.

>>> Подробности

★★★★★

Проверено: Klymedy ()

Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.

Чего это они вдруг бросили бороться за «чистоту свободы»...или «свободу чистоты»?

Что, «Stretch» как «пифагоровы штаны» — во все стороны?..

DeVliegendeHollander ★★ ()
Ответ на: комментарий от m1ke

Отлично! ты положил свою копию gtk рядом с vim, свою копию с firefox, свою копию с libreoffice, свою копию с evince, ну и отдельную для eog. Их конечно же будет больше, ну да бог с ним, пусть будет только 5 для простоты. Тут внезапно обнаруживается секьюрити баг в gtk - твои действия?

Читаю об уязвимости, если её можно эксплуатировать через жирнолис — обновляю жирнолис и, опционально, либру. На всё остальное скорее всего будет насрать из-за отсутствия возможных векторов атаки

Вопрос голосования и выбора системы инициализации - больная тема для всех дистрибутивов

Мякотка в том как было проведено голосование, учитывая предыдущие результаты.

По сути, вопрос ставился так: либо мы унифицируемся с остальными дистрибутивами и уменьшаем объем своих трудозатрат, либо мы топаем своей дорожкой и с каждым годом нам становится жить все тяжелее, а софт поддерживать все сложнее - а ресурсов на эту работу больше не станет.

Напомни, пожалуйста, не ты ли выше упоминал про поддержку дебианом Hurd и kFreeBSD?

Но хочется заметить, что истерики от его внедрения тоже преувеличены - брат жив, все дела...

Ага, мы тут вам забагованный сырой комбайн в стейбл завезли, кушайте.

Ты либо туп либо стараешься нас обмануть! Человек сам лично написал, что он начал процесс обновления системы с джеси на стретч и к нему пришли новые версии софта, которые ему не понравились.

Тупой здесь только ты если до сих пор не осилил прочитать причину, по которой человек сам лично начал процесс обновления.

Или ты думаешь, что если бы он нашел статически слинкованный xfce и поставил бы его в свою систему это как-то магически сказалось бы на размере шрифта переключалки раскладки?

Нет, если бы он нашёл статически слинкованную софтину, которая ему была нужна, то обновляться и страдать от нового XFCE ему бы не пришлось.

Хоть себе не ври - хреново когда человек не развивается.

Пердолинг ради пердолинга — это не развитие, прекращай заниматься самообманом.

сношаться - это выучить 3-4 дополнительных команды?

Ну т.е. раз уж нужно городить дополнительные костыли — получается что система дистрибуции софта в линуксе хреново выполняет свои задачи? ЧТД.

Система зависимостей дистрибутива позволяет контролировать целостность системы.

И поэтому апт порой пытается вынести полсистемы, лол.

h578b1bde ★☆ ()
Ответ на: комментарий от m1ke

Так если сборка модульная - какая нам, как рядовым пользователям разница?

В винде модули не отваливаются после каждого обновления ведра.

А вот тут наш эксперт (теперь уже по ядрам) в очередной раз налажал - он не знает разницы между монолитностью ядра и микроядерностью

4.2

проблема не в монолитности, а в стабильности АПИ ядра

Про то что в линуксе stable API is nonsense все уже давно знают.

h578b1bde ★☆ ()
Ответ на: комментарий от NextGenenration

Зато мусора будет как в одной знаменитой области

Московской?

Кстати сможешь поставить последние студии на случайный комп на xp не подключённый к сети?

Хз, не пробовал.

h578b1bde ★☆ ()
Ответ на: комментарий от NextGenenration

Ни разу не менял железо ради линукса.

Что разломалось в дебиане из моего железа с апдейтами софта, ибо когда-то работало.

1) сканер - не работают кнопки на передней панели

2) к роутеру в принципе нельзя получить нормальный доступ, из-за того, что нномеры с радостью отломали устаоевший NTLMv1

PS: подтвержденные багрепорты есть само собой. Стоимость решение проблемы действительно тянет на покупку нового железа.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 3)
Ответ на: комментарий от h578b1bde

А зачем устанавливать то что уже установлено?

Кто-то не переписал в одной компании вовремя на новый .net, и у них начались проблемы. Под новым не работает, старое ставится со скрипом.

NextGenenration ()
Ответ на: комментарий от NextGenenration

В ней работает ВЕСЬ софт?

Разумеется, весь установленный мной софт работает.

Даже к примеру хром?

Не пользуюсь хромогом, палемун работает. Хотя что мешает работать поддерживающей XP версии хромога мне не понятно.

h578b1bde ★☆ ()
Последнее исправление: h578b1bde (всего исправлений: 1)
Ответ на: комментарий от NextGenenration

Кто-то не переписал в одной компании вовремя на новый .net, и у них начались проблемы. Под новым не работает, старое ставится со скрипом.

Повторюсь — старый .NET установлен изкоробки.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

Читаю об уязвимости, если её можно эксплуатировать через жирнолис — обновляю жирнолис и, опционально, либру. На всё остальное скорее всего будет насрать из-за отсутствия возможных векторов атаки

А вдруг автор либры не прочитал новость и не пересобрал либру?

И поэтому апт порой пытается вынести полсистемы, лол.

Только у рукожопов

NextGenenration ()
Последнее исправление: NextGenenration (всего исправлений: 1)
Ответ на: комментарий от h578b1bde

Хз, не пробовал.

А вот попробуй. Сначало инсталятор долго распаковывая архивы обнаружит что у тебя старая версия осла. Понятное дело что осёл идёт отдельно. Потом что у тебя старая версия компонента, который тоже идёт отдельно. Для того чтобы найти следующий компонет мешающий установке нужно подождать как минимум поиск, установку предыдущего(хорошо если он не от чего не зависит), и не быструю распаковку установщика.

NextGenenration ()
Ответ на: комментарий от NextGenenration

Ну это же у тебя usb зависит от ethernet или наоборот. А у мнея они живут отдельно, просто разьёмы не совпадают.

отдельно

Тогда зачем ты их приплёл в разговоре о зависимостях?

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

Вот только в дебиане доступного софта меньше, а его версии прибиты гвоздями к версии системы.

Бекпорты, сборка руками, контейнеры, репозитории от доброго васи слижком сложно для понимания и запоминания

NextGenenration ()
Ответ на: комментарий от NextGenenration

Бекпорты, сборка руками, контейнеры, репозитории от доброго васи слижком сложно для понимания и запоминания

Конечно сложно, мне же в винде достаточно скачать нужную версию.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

По этому поводу я тебе ответил другим сообщением. Пример твой жутко странен (как, в общем то и все твои доводы). Если судить по нему - то виндовс вообще полный пипец - там при переходах между версиями не просто темка отвалилась да переключатель стал не того размера - там весь рабочий стол перехреначили без возможности вернуть как было.

Возможности есть.

Давай не будем врать?! у 8 и выше нет официальной возможности вернуть интерфейс и поведение к тому виду, какое было на 7! Я тут уже читал драму о том, что при переходе между версиями венды в проводнике возврат на уровень вверх по бэкспейсу заменили на назад по истории - так человек откатывал систему целиком - для него критическая функция системы оказалась. Все что ты можешь - поставить СТОРОННИЙ софт, который В МЕРУ СВОИХ СИЛ будет стараться сделать похоже! Но гарантий на 100% совместимость лук&фила нет!

Не превращается. В виндовс какая-либо прикладная программа не притащит мне апдейтов, от которых вся система поломается, поэтому там всё более предсказуемо.

Раскрою тебе секрет: в дебиане тоже никакая программа из официального репозитария не притащит ничего и не поломает. И в 90% случаев если ты решишься ставить софт с левого tar.gz тебе тоже ничего не прилетит в систему. А вот если ты пытаешься использовать 2 разных версии системы одновременно - да, проблемы могут быть. Но и под вендой если ты попробуешь закинуть в 10 половину ХП или наоборот - в ХП половину 10 - результат будет крайне непредсказуем. Кстати, как там у вас - научились ставить DX11 или какой он там у вас на младшие оси? а то мы тут о php да о php...

Таки нет. В описываемом случае проблема в инсталляторе студии.

Ну так - а у чувака из твоего примера проблемма в инсталяторе той софтины - какая глобальная разница? А, знаю! Микрософт вроде как гарантирует установку своего поделия на разные версии венды, а дебиановцы рассчитывали только на стретч.

Хватит уже двойных стандартов! Проблемы с версиями библиотек есть везде! И однозначного решения пока не найдено нигде.

Это который даже свежий линукс скомпилировать не может или таки менее актуальная более старая версия?

У чувака там генту. что он и как собирал - один он ведает. У тебя есть примеры что в дебиане gcc из коробки не собирает kernel из коробки? вот именно это и называется дистрибутив системы - когда все компоненты подогнаны максимально друг к другу. На сколько смогли, да. Но не так, что захотелось версию А компилятора скрестить с версией Б ядра и вышел облом.

Скажу тебе больше: компилятор, как и любой другой софт, может содержать баги (которые могут мешать собираться и ядру) и не поддерживать новые стандарты. Именно по первой причине на ванильный tar.gz накладывается тонна патчей от разработчиков - чтобы это привести в целостную картину системы, а не беспорядочный набор 0 и 1 на винте.

Чтобы перестать врать для начала нужно начать врать, поэтому нет.

ты с самого начала только этим и занимаешься - вранье и передергивание чужих слов

Таки он единственно верный.

Опять твой максимализм выдает скудный опыт... Нет единственно верного пути. Есть ситуации, когда выгодней статическая сборка, есть ситуации, когда выгодней положить нужные либы с бинарем, а есть ситуация (которая и покрывает 95% потребностей рядового пользователя) когда лучше держать один набор либ в системе и софт, который на них завязан

Сборкой софта должны заниматься разработчики, т.к. они лучше всех знают что нужно для корректной работы их софта.

Софт, который работает только на машине разработчика - крив by design! Благодаря этому подходу мы уже получили гном, который не собирается без systemd. Но разработчикам то никто не мешает собирать и распространять из софт как они хотят - хоть с нужными либами, хоть жирным бинарником - нормальным людям плевать чем там развлекается разработчик.

Т.е. мы тут за вас решили что вам лучше, поэтому кушайте что дают и не нойте.

Нет, они решили, что большей части хватит 7 версии. Судя по тому, что не слышно воя в интернетах - они угадали. Меньшей части, которой нужно что-то особое - goto к разработчикам.

Полностью — нет. К тому же php был взят лишь как один из возможных примеров.

ну печалька для пыхеров - что я могу сказать. Лично я от потери питона 3.4 и замены его на 3.5 вообще не потерял ничего.

Предлагаешь мне к каждому разработчику софта бегать? Но зачем если сборки под винду уже есть?

погоди, но под венду же ты сбегал? так почему бы и под дебиан не сбегать? в чем принципиальное отличие то?

Нинужна, как это обычно и бывает у фанатиков.

Пойми, никто не отрицает, что может тебе и надо именно версия 5.4. Может тебе нужна вообще версия именно с конкретной четвертой цифрой в версии (говорят, у джавистов и не такое бывает). Но ты - в меньшинстве. Твои проблемы не решил микрософт - ты вынужден бежать к разработчикам. НО и сообщество дебиана не подписывалось решать твои проблемы - ты точно так же вынужден бежать к разработчикам. Хватит врать, что есть хоть какая-то разница! Дебиан не запрещает тебе куда-то бежать, где-то что-то брать и ставить.

Мой тебе совет: если ты так застрял на конкретной версии пыхи - смотри в сторону контейнеров - это гарантирует тебе повторяемость твоего уникального окружения в любой ситуации + переносимость.

Поискал, на официальном сайте разработчика софта. Больше никого искать не пришлось.

Ну поищи там же под дебиан9 - в чем проблема то?

Сложно понять зачем мне платить больше.

Как зачем? Потому что твое ЭГО требует от тебя обновить систему, твоя ЛЕНЬ мешает тебе оттестировать свое поделие под php7 (хотя, как говорят, там отличный прирост по скорости) или найти себе нужную сборку. Отсюда и проистекает эта необходимость.

Ты не озвучил причину по которой тебе это понадобилось. Если что, желание попердолиться — не причина.

Ну давай ты не будешь советовать что мне надо?! У нас стоял вопрос: является ли виндовс системой с неограниченными возможностями в которой пользователь может решить любую проблему с помощью установки софта (это декларировал ты). Когда тебя ткнули носов с твое же говнецо что даже микрософтовские либы ты переустановить не можешь - началось ко-ко-ко оно никому не нужно! Так что по этому вопросу слив тебе тоже уже засчитан!

А на самом деле ты просто не хочешь сказать прямо, что вот это вот версия фреймворка - основа построения венды и именно поэтому он ЖЕСТКО ПРИБИТ ГВОЗДЯМИ. Потому что замена его на другую версию может полностью сломать венду до неработоспособности и невозможности ничего починить.

Конечно не хочу. Зачем мне хотеть признавать явную ложь?

давай по пунктам: фреймворк прибит гвоздями? ДА. Ты его можешь поменять? НЕТ! является ли это зависимостью? ДА! Если его покалечить каким-либо образом система (вин10) нормально функционировать, сможешь ли ты ее починить? НЕТ!

Разница в том что мне не нужно пердолиться с дотнетом дабы использовать прикладной софт нужной мне версии.

Проблема в том, что пердолишься только ты. Постоянно, по разным поводам. Это дело на любителя, может тебе нравится. Но выносить это на публику...

m1ke ()
Ответ на: комментарий от h578b1bde

А вдруг мейнтейнер дистрибутива не прочитал новость и не пересобрал либру?

Чувак, ты окончательно доказал свою непрофпригодность. Я всё читал, читал тред, который сам же и запустил, удерживался от комментариев, но здесь уже не могу не съязвить. Ты действительно думаешь, что при обновлении динамически слинкованной библиотеки нужно пересобирать целевой софт? Тогда я не удивлён, почему ты думаешь, что динамические либы зло.

eugeno ★★★★★ ()
Ответ на: комментарий от anonymous

Мой анонимный друк, я на ней и сидел до последнего. Просто в моем бандустане под названием украинщина закрыли доступ до яндекса, с которого тянула обновления RFR, а бегать по халявным впн-ам поднадоело. Поэтому и сделал крамолу-перескочил на деб. Увидел, что тут, как всегда, косяков не меньше, чем в других дистрах. Красноглазить уже как-то не тянет, поэтому пошел по пути меньшего сопротивления-поставил оригинальную федорку. За полчаса доставил отсутстующие плюшки типа vlc с флешем, и продолжил жить счастливо и радостно. его и всем желаю.

anonymous ()
Ответ на: комментарий от h578b1bde

Просто тебя устраивает всё что тебе дают, меня же по определённым причинам — нет.

Меня устраивает полностью рабочая система, в которой работает весь нужный мне софт. Меня устраивает, что кодеки у меня обновляются самостоятельно, мне не нужно следить чтобы при просмотре котиков с ютуба мне не прилетел какой-нить троянчик в нагрузку через багу в кодеке. У меня нет желания чкаться по инетам и искать свежий к-лайт или чем вы там сейчас пользуетесь и чтоб без регистрации и СМС. мне надо работать. А когда не работать - то отдыхать. У меня нет времени страдать по отсутствию какой-то нужной версии чего-то. Мне не понравился gnom3 - я ушел на cinnamon. Мне не положили в пакетах свежих версий firefox, golang, node.js с npm и чего-то еще что было надо для работы - я это собрал сам в рабочее время. И да мне это время оплачивали как и время основного кодинга, поскольку мне были нужны именно этим версии. Я давно уже отошел от максимализма и не жду что все мои проблемы кто-то порешает - вот и вся наша разница. Весь твой скулеж тут как раз от того, что как раз ты жрешь то, что дают. Собрали под венду php5.4 - хорошо, будешь пользоваться, не собрали - поскулишь и пойдешь искать либо по помойкам либо на новую версию пыхи. Также и с ХП - сдохнет твой комп, а под новый проц и мать не будет дров - поскулишь и пойдешь жрать что дадут микрософт на тот момент. Собирать нужный тебе инструмент самостоятельно у тебя нет ни знаний ни опыта. Как мы выяснили ранее, учиться ты не хочешь. Печалька для тебя одним словом...

m1ke ()