LINUX.ORG.RU

Debian 9 «Stretch»

 ,


3

2

После 26 месяцев разработки представлен стабильный выпуск Debian 9 с кодовым именем «Stretch», который будет поддерживаться в течение следующих 5 лет.

Релиз посвящён памяти основателя проекта Иана Мёрдока, который ушёл из жизни 28 декабря 2015 года.

Основные изменения:

  • Вариантом MySQL по умолчанию теперь является MariaDB.
  • Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.
  • Команда dmesg теперь требует права root.
  • Для запуска дисплейной системы X более не требуются права root.
  • Пакеты отладки перенесены в новый репозиторий и имеют окончание -dbgsym вместо -dbg. Репозиторий можно добавить в список источников APT:
    deb http://deb.debian.org/debian-debug/ stretch-debug main
    

Новые версии ПО:

  • Apache 2.4.25;
  • Asterisk 13.14.1;
  • Chromium 59.0.3071.86;
  • Firefox 45.9 (в пакете firefox-esr);
  • GIMP 2.8.18;
  • GNOME 3.22;
  • GCC 6.3;
  • GnuPG 2.1;
  • Golang 1.7;
  • KDE Frameworks 5.28, KDE Plasma 5.8, KDE Applications 16.08 и PIM-компоненты 16.04;
  • LibreOffice 5.2;
  • Linux 4.9;
  • MariaDB 10.1;
  • MATE 1.16;
  • OpenJDK 8;
  • Perl 5.24;
  • PHP 7.0;
  • PostgreSQL 9.6;
  • Python 2.7.13 и 3.5.3;
  • Ruby 2.3;
  • Samba 4.5;
  • systemd 232;
  • Thunderbird 45.8;
  • Tomcat 8.5;
  • Xen Hypervisor;
  • Xfce 4.12.

Debian «Stretch» содержит более 51 000 других готовых к использованию пакетов ПО, собранных из немногим более 25 000 пакетов с исходным кодом.

Всего поддерживается десять архитектур: amd64, i386, ppc64el, s390x, armel, armhf, arm64, mips, mipsel, mips64el. Поддержка powerpc в «Stretch» прекращена.

>>> Подробности

★★★★★

Проверено: Klymedy ()
Ответ на: комментарий от h578b1bde

Тем не менее если прикладная программа не завязана на какие-либо специфические для конкретной версии ОС вещи — она будет работать.

вон у меня перед глазами прога: интерфейс к телеграфному модему. от системы ей нужно возможность работать с ком-портом, лпт-принтером (опционально) и файловой системой. год выпуска 92

Давай я те дистрик скину а ты мне ее под десяткой заведешь? или под хрюнделем хотя бы?

А хошь я те покажу прогу 92 года, которой от системы нужен ком-порт и файловая система? И чтоб она и в 92-м году работали и сегодня под линуксом? Хочешь? А любая! Потому что с древнейших времен у нас ком-порт — цэ файл. Давай, парируй!

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

у виндовс проблемы с некоторым софтом из-за несовпадения версий VCRedist

Никогда таких проблем не видел, кстати.

Ну это ж значит что их нет!!! Я вот с дебианом не пердолюсь тоже, тебя ж такой ответ не устраивает.

Упс, ну кроме современного браузера...

Я бы расстроился разве что если бы пришлось сидеть на линуксе 2001 года выпуска.

не-не, ты ответь! ты ж тут второй день дебиан с ведра поливаешь что там старый php на новый дебиан без пердолинга не поставишь, а как насчет нового хрома на ХР-ху? ответь, ответь! может у вас там те же яйца, только в профиль (и мейл ру агентом), не?

Дебиан, как и большинство других дистрибутивов линукса, модульный по самое немогу. Никто не запрещает тебе менять системные либы или софт.

В винде мне тоже никто не запрещает менять софт. Причём без пердолинга.

Чета по твоим сообщениям начинает складываться впечатление что что-б не происходило в винде — оно без пердолинга, а что бы ни происходило в дебиане — оно с пердолингом. (уже нотариально заверены посты с динамической линковкой и заменой dll-ок)

Микрософт виноват в том что ты там у себя наворотил? Ну так свободу действий у тебя никто и не отбирал

Погоди-погоди, когда у человека вафля не заводилась — это дебиан виноват, а когда на свежей винде офис не ставится — это человек сам наворотил и шоколадмайкрософт ни в чем не виноват?

Где можно по щелчку пальцев получить именно нужную версию софта?

В винде. Ибо там есть где развернуться, в отличие от прибитой гвоздями крышки гробового ящика зависимостей.

Ставь офис 97 на восьмерку или получается что лжец ты

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Такое случается крааайне редко

Хорош байки рассказывать.

Ну пользователю ХР виднее чем мне, как я тут поспорю?

в репах не оказалось (я был весьма удивлен, но стерпел и на винду не убежал). Гуглишь название библиотеки, находишь ее родную страничку, там ссылка на гитхаб. На гитхабе качаешь бинарик под свою архитектуру, распаковываешь, запускаешь инсталл-скрипт, который тупо раскладывает уже готовые so-шки по папочкам и ставит симлинки куда надо. Один из трех инсталляторов был с ошибкой и раскладывал неправильно — подправил.

ЧТД.

это исключение, а не правило. я это описал, чтоб показать что секс весьма умеренный. и пусть в меня бросит камень тот виндузятник, который ни разу dll-ку не подкладывал никуда за 10 лет

Если говнософта с панельками нету в дебиане — это не значит что его обязательно нужно тащить в винде.

Не не значит. Это значит что в дебиане нет назойливой установки говнософта рекламного, а в винде есть. И, (ща глумиться буду), мне не нужно пердолится с убиранием десятка галочек при установке каждой программы, что ты мне на это ответишь? что в этом вопросе дебиан лучше винды? или извернешься как-нибудь и не будешь этого признавать? порадуй меня!

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

В случае с зависимостями софта в 70-х, когда 640К наверняка хватило бы всем — так и было. Зависимости же в XXI веке — это как передвижение на конной повозке вместо автомобиля. Ездить можно, конечно, но зачем?

тебе ж русский языка объяснили про обновления безопасности, которые возможны в случае динамической линковки и невозможны в случае статической? парируй этот довод: игнорировать некрасиво!

pihter ★☆ ()
Ответ на: комментарий от pihter

Такое случается крааайне редко. Я десять годиков сижу за дебианом и могу припомнить раз 5 когда я таким занимался.

Ну ты это, значит с очень ограниченным юзеркейсом. Бывает конечно.

fornlr ★★★★★ ()
Ответ на: комментарий от m1ke

А то почитает кто-то про твой опыт и решит что так и надо.

Тут я грешен: я ленивая жопа. :) но в свое оправдание я скажу что я потом запустил анинсталл скрипт и все so-шки убрал из мест где им быть не надова. Просто переименовал как надо и положил прям в каталог где нужны. Так кошерно

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Баги есть везде, да. Одиночный случай на определённой конфигурации — не показатель,

о как мы запели! А всю дорогу другое говорил! На тебе еще, про пердоленье, как ты любишь https://geektimes.ru/post/31623/ известная паста в которой пердолится с виндой сам Билл Гейтс!

pihter ★☆ ()
Ответ на: комментарий от pihter

Да не сорьтесь, девочки.

Пердолинг есть везде. Только размер его разный. Под macOS меньше всего, под увындовс побольше, под дебианом намного больше.

fornlr ★★★★★ ()
Ответ на: комментарий от Twissel

nftables — подсистема ядра Linux, обеспечивающая фильтрацию и классификацию сетевых пакетов/датаграмм/кадров. Включена в ядро Linux, начиная с версии 3.13, выпущенной 19 января 2014 года. Является проектом по замене фреймворков iptables, ip6tables, arptables[en], ebtables в межсетевом экране Netfilter. За счёт объединения функциональности фреймворков, в nftables присутствует меньшее дублирование кода при построении правил для Netfilter и низкоуровневая оптимизация

В отличие от iptables, в nft вместо IP-адреса можно указывать доменное имя !!!

daminatorus ()

пару вопросов - вдруг кто ответит

1. Как правильно обновить с Debian 8? И стоит ли, или на десктопе это делать или проще переставить с нуля?

2. Перейдя на Debian 8 стал использовать LXDE. Стоит ли с переходом на Debian 9 перейти на LXQt как на нечто пришедшие на замену LXDE или лучше не мучится и поставить более менее стабильный XFCE, который сожрет побольше ресурсов старого компьютера, но не нужно будет сидеть ночью с красным глазами для того, чтобы получить обычный рабочий стол в стиле KDE2/KDE3 или Win2k...

azorg ()
Ответ на: комментарий от h578b1bde

драйвер свободного VirtualBox, любящий отваливаться после обновления ведра.

хотелось бы примеров с обновлением ядра винды, да так чтоб виртуал бокс не отвалился. нам ядро приходилось обновлять не по разу в жизни, поэтому у нас и механизмы для это имеются.

// я извиняюсь за стрлочничество, но раз пошла такая пьянка )

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Хотя что мешает работать поддерживающей XP версии хромога мне не понятно.

ну имей же честь признать уже поражение по вопросу хрома а не извиваться.

я подскажу. через N времени в нем неизбежно обнаружится уязвимость. еще через N времени появятся готовый эксплойты и пользоваться тем хромом станет все равно что отдать свой компьютер под контроль любому желающему. не смущает? зато пердолится не надо

pihter ★☆ ()
Ответ на: комментарий от pihter

Да не, не враньё - то что apt при установке, обновлении, удалении пакетов нередко хочет вынести полсистемы, это его очередная коронная фишка, наряду с падениями от ошибок в скриптах обработки.

alexferman ()
Ответ на: комментарий от alexferman

Падение, это от кривых рук пакетоклепателей. А пол-системы выносит обычно aptitude, не надо им пользоваться. Если не пытаться с системы на систему перелезть несколькими пакетами, обычно граблей нет. А если такое делать, может быть разное, например вынос нужных пакетов. Но оно обычно пишет что собирается делать. Часто помогает указать эти нужные тоже для апдейта - тогда не удалит, если они ещё есть в системе и ни с чем не конфликтуют. Безопаснее сделать полный апдейт или втащить из бакопортов, если от apt-get видится огромный список на remove. Иногда апгрейд требует выноса пакетов и доустановки, что невозможно сделать простым обновлением пары пакетов, апдейт системы не всегда тривиален.

slapin ★★★★ ()
Ответ на: комментарий от pihter

Хоть мне и нравится больше всех дебиан, и на оффтопик я не вернусь, но доля истины в этом есть. Иногда из-за зависимостей реально полсистемы планирует сбежать (яркий пример - пакеты at-spi, которые для людей с плохим зрением), а нарушение зависимостей приводит к тому, что из-за отсутствующей зависимости для влц-плеера, например, невозможно поставить блокнот (хотя какая между ними связь?), а поскольку еще добавили системд, мне пришлось свалить с дебиана на генту, где можно выпиливать что угодно, не затрагивая остальное. Слака, кстати, тоже этим хороша. Да, я знаю, что можно заставить dpkg работать без учета зависимостей, но он качать пакеты с интернета не умеет

anonymous ()
Ответ на: комментарий от h578b1bde

Именно. В переписывании ядра огромными кусками нет необходимости просто потому что само ядро там довольно хорошо структурировано и без проблем разбирается на отдельные мелкие модули. В том и состоит косвенное преимущество гибридного ядра для конечного пользователя.

Очень смешно! Конечному пользователю (домохозяйке) вообще по барабану какое там ядро. А отсутствие нормального развития именно ядра привело к тому, что ваше ядро тормозное глюкалово, которое сраной метлой выперли с TOP500, с рынка веб-серверов. Единственная ниша, которая у него осталась - корпоративный сегмент с АД. Но и в том нет никакой заслуги гибридного ядра. Ну и на счет структуризации ядра - уровень твоей компетенции уже давно понятен, можешь не продолжать...

m1ke ()
Ответ на: комментарий от h578b1bde

а какая тебе собственно разница? ничего не отваливалось, ничего не ломалось. Мы же не спрашиваем у тебя, сколько раз менялся у тебя в ХП тот единственный кодек, что шел в комплекте? да ты и не знаешь - тебе ведь не отчитываются, ты жрешь что дают.

m1ke ()
Ответ на: комментарий от h578b1bde

JFF.

выставлять свою тупость на всеобщее обозрение - сомнительный фан для нормальных людей.

Я всего лишь указал на недостатки существующей системы дистрибуции софта при помощи системы зависимостей, кто-то приплёл сюда винду и пошло-поехало.

Эти недостатки - только у тебя в голове голоса нашептывают. Тебе уже было на пальцах показана проблемность твоего метода, но ты это проигнорировал. Тебе несколько раз было сказано, что в дебиане не отрицается даже твой метод дистрибуции. Но тебе на все пофиг - ты пришел сюда троллить

m1ke ()
Ответ на: комментарий от Vinni_Pooh

Проблема после обновления на Debian9 www.linux.org.ru/forum/general/13491131

Ну, понеслась!

И че там куда понеслось? Ты хоть попробовал полистать (не вчитываясь) в то, что там написано?

-rw-r--r-- 1 root root 204918 апр 6 19:28 config-4.10.0-19-generic

в дебиане 9 НИКОГДА за время тестинга небыло ядра 4.10. Наличие этих фекалий свидетельствует что человек развлекался с установкой непойми чего непойми как.

в принципе, ему там даже написали:

В Debian нету такого ядра, такая схема версий используется только в Ubuntu.

Т.е. что на что он там обновлял - вообще большой вопрос!

Просто примонтировать раздел и записать на него куда-нибудь.

не получается.Видит папку home, а в ней пусто.

Т.е. чувачек не может выполнить простейших действий под диктовку?! Да его знания сейчас находятся на уровне «сосед Вася поставил систему и приказал ничего не трогать», а он лезет ядра в системе менять. Может ему стоит для начала почитать умных книжек и статей, а лишь потом осторожно начинать экспериментировать?

Ну а вам стоит перед тем как писать о чужих проблемах с апгрейдами нормальной системы разобраться - а действительно ли виноват инсталлятор системы или там пользователь деревянный попался, а то аргументы с пруфами как у h578b1bde прямо

m1ke ()
Ответ на: комментарий от h578b1bde

Хотя что мешает работать поддерживающей XP версии хромога мне не понятно.

погоди-погоди, не далее как вчера ты называл меня туповатым за то что я использую «старый» браузер из «протухших» реп дебиана (и это не смотря на тот факт что мне обновления безопасности падают в отличии от хрома на ХР)

объяснись! уж не двойные ли стандарты ты исповедуешь?

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Вот только в дебиане доступного софта меньше

меньше чем где? в виндах? в других дистрах?

а его версии прибиты гвоздями к версии системы.

ты вот либо не шаришь, либо лжешь. ниче тут не прибито. в гораздо меньшей степени завистит чем виндах твоих. тебе вторые сутки талдычат: «нужен php3» скачай и установи (гугление + секс) точно так же как и в винде. Не нашел — собери сам (точно так же как и в винде). Почему при этом у нас пердоленье а у вас благодать — ты мне скажи.

pihter ★☆ ()
Ответ на: комментарий от daminatorus

Шо ви таки хочетете мне сказать? Шо дебиан подходит только для С и С++? Я вас умоляю.

Загляни на какой-то активно развивающийся язык(к примеру rust)и сравни текущую версию и версию в репах(разумеется не только что вышедшего дистра). Не популярные языки в дистре вообще отсутствуют.

NextGenenration ()
Ответ на: комментарий от h578b1bde

В XP я, так и быть, поставлю дотнет, очевидно же.

но это не пердоленье, это только в дебиане пердолятся, а в виндах и так все работает и никакого депенденси хелл

pihter ★☆ ()
Ответ на: комментарий от h578b1bde

Решение по приведению 10 в 100% look&feel хотя бы 7 (не будем говорить про ХП сейчас) в студию или ты ВРУН

https://www.google.com/search?q=make windows 10 look like windows 7

И ты готов забиться, что выполнив эти манипуляции я получу 100% поведения и внешнего вида 7? что различий я никаких не найду? И как там на счет возможности установки после этого любого софта для 7 - тоже все будет работать?

Да ты уже склерозить начал на глазах прямо? Хорошо, я освежу твою память (но на будущее - начинай пить витаминки, я чуствую, что рановато тебе склерозить). Спор как раз о том, что дебиан плохой, пересобирает свой софт как ему вздумается, пользователь не может остаться на нужной ему версии. Тебе рассказали уже несколько вариантов как этого добиться, но да, они требуют ручного труда ибо таких извращенцев единицы, и все из них не хотят ничего делать, хотят только потреблять. Ты встал весь в белом и заявил на всю палату, что в самой чудной системе таких проблем априори нет, ты все можешь поставить сбоку со стороны и микрософт тебе не указ. Когда тебя ткнули носом во вранье, ты начал выворачиваться, что да, ты не можешь вернуть нужное поведение со 100% гарантией, но этого нельзя и в линуксе - как всегда пытаешься выкручиваться и перевирать чужие слова.

И как эта простыня относится к ранее обсуждаемому нами вопросу о look&feel?

Ты опять дурачка включил? лук и фил мы обсуждаем тут лишь в контексте того, что при обновлении системы он может меняться и это не всегда может нравиться пользователю. Твой тезис о том, что в венде ты все всегда можешь вернуть как было - не состоятелен хотя бы просто потому, что возвращаешь ты не установкой старого софта, а новым сторонним - который может быть как угодно близок по лук энд фил, но не копирует со 100% точностью вплоть до багов. Но такому ограниченному дурню это никогда не понять - иконки поменялись и ладно.

А ему не нужна была новая система. Ему была нужна свежая версия библиотеки, при наличии которой установка новой системы с вероятностью 99,9% не понадобилась. У тебя проблемы с выявлением причинно-следственной связи, да?

Да нет, у меня все в порядке, в отличии от тебя. Чуваку не была нужна новая версия, но он ее поставил - кто ему виноват? Кто ему мешал ставить статичный бинарь своей софтины. Покажи как на это ругался пакетный менеджер (если он ругался матом - забикай звездочками). Если пакетный менеджер не ругался на установку статического бинарника - хватит тут из себя идиота корчить.

Классическое „не было печали — апдейтов накачали”, угу.

Нет уж, это удел исключительно виндузятников.

Как по мне он особо и не рассчитывал на помощь. Нет ничего плохого в том чтобы обсудить недостатки и факапы какой-либо системы, твои же личные комплексы при этом никому не интересны.

Тут нет недостатка системы дистрибуции вообще! но в твою тупенькую голову эта мысль никак не приходит. Обсуждать же проблемы надо было не высираясь на форуме лора, а сходить в багтрекер xfce и оставить там баг, что поведение в версии такой-то никуда не годится. Штатных телепатов разобрали давно в микрософт, если не писать баги, то разрабы xfce о них никогда и не догадаются. Но вендузятникам то этого никогда не понять - им некуда писать баги, а на все их вопли микрософт клал болт.

Хорошо, раз ты такой умный — объясни, как мне собрать этот исходник не перекатываясь на другую систему?

Про какой исходник ты вообще говоришь? про абстрактного коня в вакууме?

Ну кроме варианта с компиляцией компилятора, лол.

Чувак, ЛОЛИЩЕ позорное в этой ситуации только ты. В том посте у товарища Gentoo - прикинь, он УЖЕ СОБРАЛ СЕБЕ КОМПИЛЯТОР. Если он собрал что-то не той версии, если за совпадением версий в его системе никто не следит (даже он) - причем тут Debian вообще?! Или ты опять засклерозил какую систему мы с тобой обсуждаем?

Я ничего не говорил о применимости её где либо, я лишь затронул вопрос прикладного софта.

Ох, хорошо же тебе жить - разговариваешь сам с собой, других не слышишь, в нужный момент забываешь что сам говорил полчаса назад. Ты тут с пеной у рта доказываешь, что система зависимостей зло, единственный верный путь - распространять весь софт со своим комплектом либ. Когда тебя ткнули мордой в то, что в венде система зависимостей еще жестче, когда тебе объяснили на пальцах все негативные последствия твоего метода, когда тебе 100 раз сказали, что никто не запрещает тебе ставить в систему что угодно по твоему методы - ты все это проигнорировал и продолжаешь тупить тут про вопросы прикладного софта. Чувак, ты не просто не компетентен - ты неадекватен!

А почему же мейнтейнеры дебиана спали и не бэкпортировали изменения? Вдруг там уязвимость какая была и пользователи годами жили в опасности.

Прикинь - им нет прикола ковыряться во всем, что этот писатель понаваял, если он сам не может отделить багфиксы от фичрелизов! Посмотри на мозиллу - у них есть четкое деление где фиксят баги и где новые версии с новыми фичами и новыми багами. И мейнтейнеры следят за своевременным обновлением - прикинь? А выполнять чужую работу и разбираться в чужом коде «а что это там автор хотел сделать вот этими изменениями» - никому интереса не представляет. Автор сам забил на своих пользователей болт - ну и бог с ним.

непонятного кодеда
JWZ, один из изначальных авторов Netscape Navigator и Mozilla

И что? Нетскейп был тормозным говном и профукал рынок IE чуть более чем полностью. После чего попытался сделать хорошую мину при плохой игре - отдал исходники в сообщество. Спасибо им за это. Но если бы они не профукали рынок - они никогда бы этого не сделали. И не надо тут петь песни про монополии и распространение софта с вендой. Нетскейп был на каждом диске с софтом! Но он сливал начисто IE по скорости работы. Но ты то этого не застал и можешь пытаться жалко тролить тут...

лабающего релиз за релизом

Что в этом плохого?

Конкретно в этом - ничего плохого. А вот в том, что он не поддерживает свои предыдущие релизы - показатель качества его программистских скилов и отношения к пользователям. Почему мозиловцы правят баги в своих релизах, а он - нет?

Зачем ему это? Разве мейнтейнеры существуют не для этого?

Действительно - ему не за чем, он просто положил болт на пользователей. JFF пилю что хочу, пусть жрут что есть или ПНХ. Мейнтейнеры существуют совсем для других целей - явно не для того, чтобы прибирать дерьмецо за другими. Но тебе этого не понять.

В данной ситуации это никак не помогло бы решить проблему — пользователи по инерции всё равно продолжали ставить стабильно глючное говно мамонта из репозитария.

Нет, это как раз таки помогло бы - как минимум с его сайта можно было бы скачать то, что он считает правильным. Еще он мог бы сходить к мейнтейнерам дебиана и попросить не класть его глючную поделку в репозитарий - они с удовольствием пошли бы на встречу. Они и так часто выкидывают софт из репы, если некому его поддерживать в актуальном состоянии. Но они то надеялись на адекватность разработчика - но не срослось...

m1ke ()
Ответ на: комментарий от h578b1bde

на первой странице гугла нет ни слова про дебиан 9! НИ ЕДИНОГО УПОМИНАНИЯ проблемы пыха в девятке!

И что? Это лишь показывает что вчерашний тестинг пока никому особо не нужен.

Это показывает, что проблему ты высосал из пальца или откуда ты там ее насасывал с твоим то вечным пердолингом...

Нет, ты. Я тебя уже спрашивал о версии для джесси.

Ты сам пользоваться поиском не умеешь? Вот держи ссылку чтобы больше не задавал глупых вопросов. Специально посмотрел - 5.3 вышла 8 лет назад! ВОСЕМЬ, КАРЛ! и 2 года назад оно уже было не актуально! Как и версия 5.4!

PHP 5.4.45 is the last scheduled release of PHP 5.4 branch.

Все, чувак, наступил EOL для ветки 5.4. Баги никто не будет править! Слезай с нее по срочному! Не плоди нам ботнеты по интенетам своими поделиями!

все, что там есть - как поставить более новую версию на 6 и 7 версию дебиана!

Поменяй в запросе слово „upgrade” на „downgrade”, делов-то. Хотя если бы ты мог думать то уже давно понял суть проблемы и без этих лишних действий.

Перед тем, как давать какие-то указания - неплохо бы самому попробовать это сделать. Потому как результат НИКАК НЕ МЕНЯЕТСЯ! нет на данный момент такой проблемы! Ты опять испачкал свои штанишки напрасно!

m1ke ()
Ответ на: комментарий от m1ke

В общем, завязываю я кормить данного тролля. Думаю, что всем уже достаточно информации, чтобы сделать вывод, что данный субъект неадекватен чуть более, чем полностью, не разбирается ни в одном вопросе, использует софт, поддержка которого давно уже закончилась и баги никто не правит. Да и просто врун и вендовый тролль.

m1ke ()
Ответ на: комментарий от h578b1bde

В XP я, так и быть, поставлю дотнет, очевидно же

Вот жаль что тебе не пришлось без интернета ставить на винду софт. Который разбит на кусочки и втайне надеется что у тебя уже есть какой-то апдейт.

NextGenenration ()
Ответ на: комментарий от NextGenenration

Ну так для активно развивающихся велосипедистов есть testing. C# и Swift, например, тоже не во всех ОС есть. Кроме того есть масса людей которые не брезгают питоном 2.7 и прочими «стабильными» версиями других языков, особенно в продакшене.

daminatorus ()
Ответ на: комментарий от h578b1bde

Т.е. мы тут за вас решили что вам лучше, поэтому кушайте что дают и не нойте.

Аргумент парня, который ни за что не станет юзать старый хром на ХРхе потому что так за него кто-то решил и он будет вынужден съесть что дают!

А мне вот кажется что ты тоже самый обычный человек и надеваешь по одной штанине за раз, а корчишь из себя Чака Норриса, да такого, что это политика Хрома прогнется под тебя, а не ты под нее, слишком уж ты свободный

pihter ★☆ ()