LINUX.ORG.RU

Debian 9 «Stretch»

 ,


3

2

После 26 месяцев разработки представлен стабильный выпуск Debian 9 с кодовым именем «Stretch», который будет поддерживаться в течение следующих 5 лет.

Релиз посвящён памяти основателя проекта Иана Мёрдока, который ушёл из жизни 28 декабря 2015 года.

Основные изменения:

  • Вариантом MySQL по умолчанию теперь является MariaDB.
  • Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.
  • Команда dmesg теперь требует права root.
  • Для запуска дисплейной системы X более не требуются права root.
  • Пакеты отладки перенесены в новый репозиторий и имеют окончание -dbgsym вместо -dbg. Репозиторий можно добавить в список источников APT:
    deb http://deb.debian.org/debian-debug/ stretch-debug main
    

Новые версии ПО:

  • Apache 2.4.25;
  • Asterisk 13.14.1;
  • Chromium 59.0.3071.86;
  • Firefox 45.9 (в пакете firefox-esr);
  • GIMP 2.8.18;
  • GNOME 3.22;
  • GCC 6.3;
  • GnuPG 2.1;
  • Golang 1.7;
  • KDE Frameworks 5.28, KDE Plasma 5.8, KDE Applications 16.08 и PIM-компоненты 16.04;
  • LibreOffice 5.2;
  • Linux 4.9;
  • MariaDB 10.1;
  • MATE 1.16;
  • OpenJDK 8;
  • Perl 5.24;
  • PHP 7.0;
  • PostgreSQL 9.6;
  • Python 2.7.13 и 3.5.3;
  • Ruby 2.3;
  • Samba 4.5;
  • systemd 232;
  • Thunderbird 45.8;
  • Tomcat 8.5;
  • Xen Hypervisor;
  • Xfce 4.12.

Debian «Stretch» содержит более 51 000 других готовых к использованию пакетов ПО, собранных из немногим более 25 000 пакетов с исходным кодом.

Всего поддерживается десять архитектур: amd64, i386, ppc64el, s390x, armel, armhf, arm64, mips, mipsel, mips64el. Поддержка powerpc в «Stretch» прекращена.

>>> Подробности

★★★★★

Проверено: Klymedy ()
Ответ на: комментарий от anonymous

ЕМНИП начиная с Wheezy такая рекомендация была, но по факту я всегда без проблем с aptitude в интерактивном режиме обновлялся.

apt-get upgrade принимает только безопасные решения и гарантирует, что в результате его действий не будет удалён ни один пакет.

То есть, не трогает ту область, где нужна интерактивность.
Посмотрим, поможет ли это aptitude.

aidaho ★★★★★ ()
Ответ на: комментарий от Polugnom

When upgrading from Jessie to Stretch, it can be a good idea to purge old packages before the first reboot.

Be aware that any non-Debian packages on your system may be removed during the upgrade because of conflicting dependencies.

Шёл 2017 год, а в дебиане по-прежнему ломались зависимости из-за сторонних пакетов. Dependency hell как он есть.

h578b1bde ★☆ ()
Ответ на: комментарий от das_tier

а где шаг

apt-get upgrade ?

8-м пунктом идёт. Он не обязателен, если уже dist-upgrade выполнен. Только лишний шаг, по сути.

Что воoбще там сейчас рекомендуют: apt, apt-get, aptitude?

Вообще, рекомендуют уже apt, но для тех, кто печатает вслепую 10-пальцевым методом, это не имеет значения: apt или apt-g[Tab] — выигрыш по времени напечатания команды настолько мизерный, что просто несерьёзно на него обращать внимание. Я печатаю apt-get — его система всегда поймёт, независимо от Debian-based дистрибутива. Пока не вижу причин избавляться от этой хорошей привычки). Вот когда жёстко отменят apt-get, и его заменят полностью на apt, тогда да, придётся использовать такой синтаксис.

Desmond_Hume ★★★★ ()
Ответ на: комментарий от h578b1bde

Кушай анончик что дают и не выделывайся.

Я кушаю только качественную и проверенную пищу. Если ни один повар в мире не в курсе про существование твоего стороннего блюда, то я его есть побрезгую.

anonymous ()
Ответ на: комментарий от anonymous

Я кушаю только качественную и проверенную пищу. Если ни один повар в мире не в курсе про существование твоего стороннего блюда, то я его есть побрезгую.

О, так ты у нас элитка? Кушай-кушай, не отвлекайся.

h578b1bde ★☆ ()

Есть один ноут с убунтой в нем 450мб пользовательский «основной» раздел с home и собственно пользовательской папской, где хранятся всякие фильмы и т.д. Также имеется 50гб раздел самой системы убунту.раздел под свап и мелкий 200мегабайтный раздел с efi.

Вопрос: можно ли установить Дебиан просто указав на этот 50гб раздел? Подтянится ли у меня все остальные разделы?

Quasar

Ну да, нужно было ещё пол годика пофиксить баги, а к тому времени обнаружилось ещё немало багов и дыр в безопасности, которые пришлось бы править. Затянулся бы релиз на лет так 5)))

Не переживайте. В Debian 9.1 некоторые вещи допилят, что не успели.

maslakovvi ()
Ответ на: комментарий от maslakovvi

Вопрос: можно ли установить Дебиан просто указав на этот 50гб раздел? Подтянится ли у меня все остальные разделы?

Укажи этот раздел как / с форматированием. Для home раздела, укажи /home без форматирования.

anonymous ()

Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.

Интересно было бы почитать про мотивы появления Iceweasel и Icedove и последующего убирания.

Pro100User ()

Интересно было бы почитать про мотивы появления Iceweasel и Icedove и последующего убирания.

Mozilla не разрешала Debian использовать их товарные знаки из-за отличающегося цикла разработки. Поэтому в Debian просто поменяли названия и иконки. Но потом Mozilla признала, что Debian очень надежен и стабилен и не повлияет на репутацию бренда.

anonymous ()
Ответ на: комментарий от votafak

как то так - apt-get update apt-get upgrade

обновляешь ключи - apt-get install debian-keyring debian-archive-keyring apt-key update

смотришь список не полностью установленных пакетов с состоянием Half-Installed или Failed-Config - dpkg --audit

смотришь список отложенных пакетов - dpkg --get-selections | grep 'hold$'

решаешь выявленные на двух прошлых этапах проблемы, после чего удостоверяешься, что в общем списке все пакеты имеют статус 'ii' в первой колонке - dpkg -l| grep -v 'ii'| less

потом удали забытые пакеты: apt-get autoremove

подготовительная фаза завершена, далее обновление до Debian Jessie.

меняешь список репозиториев в /etc/apt/sources.list с «jessie» и «stable» на «stretch».

апдейтишь список доступных в Debian Stretch пакетов apt-get update

важный нюанс - апгрейдишь в две стадии - на первой выполняется замена только пакетов, не приводящих к удалению или установке других пакетов, а на второй выполняется полное обновление всех версий с учётом зависимостей - apt-get upgrade apt-get dist-upgrade

удаляешь старые пакеты Jessie - apt-get autoremove

и все, вуаля!!! я обычно всегда делал именно так

Zlo ★★ ()
Ответ на: комментарий от Twissel

Мне почему то казалось, если память не отшибло - Iceweasel и Icedove были только в Дебе, а востальных не было такого. Тогда получается, остальные дистростроители клали большой корень на Мазиллу?

Pro100User ()
Ответ на: комментарий от h578b1bde

Шёл 2017 год, а в дебиане по-прежнему ломались зависимости из-за сторонних пакетов.

У тебя проблемы с английским? Где там хоть слово про поломку зависимостей?

Polugnom ★★★★★ ()
Ответ на: комментарий от Pro100User

Честно говоря, не интересовался данным вопросом так глубоко.

Возможно, что другие дистростроители сотрудничали с Мозилла в процессе опакечивания их программ для своего дистра, сохраняли копирайты или что-то вроде того. Уже точно не помню. Загугли.

Twissel ★★★★★ ()
Ответ на: комментарий от Polugnom

Ну не обновляй. Или ты думаешь в других ОС как-то по другому?

Конечно. Там где нет жёсткой зависимости между системой и прикладным софтом всё будет хорошо.

h578b1bde ★☆ ()
Ответ на: комментарий от Chelobaka

надо слоновье терпение, чтобы не спрыгнуть через полгода на «нестабильный»

Во-первых, не согласен. Мне «тестируемого» хватало.

А во-вторых, почему вы это так говорите, будто это что-то плохое.

Zmicier ★★★★ ()
Ответ на: комментарий от Polugnom

То есть Microsoft гарантирует работу всех программ после обновления Windows XP до Windows Vista (или Vista до 7 , или что там дальше)?

Не гарантирует. Тем не менее если прикладная программа не завязана на какие-либо специфические для конкретной версии ОС вещи — она будет работать.

h578b1bde ★☆ ()

Уже 9 версию выпустили, а дрова на ноуты с графикой от nvidia из официального сайта всё так же через одно место устанавливаются. Да и ещё с перспективой последствий, потому что не из родных реп... Печально.

cheshire_cat ()
Ответ на: комментарий от Zmicier

А какие там у Линукса есть зависимости? kmod и initramfs-tools?

Филиал кривого зеркала в другой вкладке.

С чем они у вас там конфликтуют?

Там выше товарищ с драйверами для невидии отписался.

h578b1bde ★☆ ()
Ответ на: комментарий от Desmond_Hume

Каждый правоверный линуксоид знает, что «конёк» Debian не новизна версий пакетов, а стабильность.

Поэтому Debian хороший выбор для серверов, для системных администраторов и, возможно, пользователей. Но вот разработчикам, которые хотят пробовать новые фишки и программировать в ногу со временем, Debian подходит слабо.

EXL ★★★★ ()

Re: Firefox и Thunderbird заменили Iceweasel и Icedove, поставлявшиеся в течение более чем 10 лет.

Мотивы были в MPL, когда код модифицировать вне апстрима без смены торговой марки было нельзя. Но позже дебиан сам стал апстримом, в итоге сий костыль убрали, ибо требовать у самого апстрима соответствия апстриму-глупость.

anonymous ()