LINUX.ORG.RU

Pale Moon 30.0.0

 


1

1

Pale Moon — браузер с открытым исходным кодом, который является форком Mozilla Firefox. Код проекта распространяется под лицензией MPLv2.

В этом релизе Pale Moon отказывается от своего собственного GUID в пользу GUID Firefox. Это сделано для того, чтобы обеспечить максимальную совместимость со старыми и неподдерживаемыми расширениями Firefox.

Теперь пользователь имеет больше свободы в использовании потенциально несовместимых (старых/небезопасных) расширений браузера, однако проблемы с безопасностью придётся решать самостоятельно.

Прекращена поддержка UXP. Вместо этого браузер собирается на GRE (Goanna Runtime Environment™), уделяя больше внимания движку рендеринга Goanna и отказываясь от поддержки неподдерживаемых компонентов и целевых платформ.

Причиной таких существенных изменений в этом выпуске стали результаты опроса пользователей на предмет того, чего они ожидают от проекта.

Другие изменения:

  • реализован механизм Global Privacy Control, пришедший на смену «DNT» (Do Not Track);
  • элементы управления в настройках «Браузер по умолчанию» был перемещены во вкладку «Общие»;
  • поддержка эмодзи обновлена до Twemoji 13.1;
  • для совместимости с сайтами реализованы queueMicroTask() и Selection.setBaseAndExtent().

Для разработчиков дополнений:

  • возвращена прямая поддержка устаревших расширений Firefox;
  • браузер больше не находится в директории дистрибутива browser;
  • appinfo.platformVersion заморожен для обеспечения обратной совместимости, для определения версии платформы используйте appinfo.gre.

Исправлены уязвимости: CVE-2022-22760, CVE-2022-22759, CVE-2022-22756, CVE-2022-26485.

Важно: после обновления, профиль пользователя нельзя будет использовать со старыми версиями браузера.

>>> Подробности

★★★

Проверено: xaizek ()

и отказываясь от поддержки неподдерживаемых компонентов и целевых платформ.

??? Что поддерживали неподдерживаемое кем?

mandala ★★★★ ()

> Прекращена поддержка UXP. Вместо этого браузер собирается на GRE (Goanna Runtime Environment™)

По-моему, это самое важное изменение. Фактически, крупное обновление кодовой базы. О том, что такое UXP, можно почитать здесь, первым релизом с ним был 28.0

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от rupert

Да-да, а еще из того же треда понятно, что там ни одного нормального разработчика в проекте нет.

lealxe ()

Форков мозиллы можно по пальцам пересчитать

kto_tama ★★★★★ ()

Прекращена поддержка UXP. Вместо этого браузер собирается на GRE (Goanna Runtime Environment™)

По ссылке со слова «GRE» рассказывается про то, что для использования Goanna надо использовать UXP.

firkax ★★ ()
Ответ на: комментарий от mandala

и отказываясь от поддержки неподдерживаемых компонентов и целевых платформ.

??? Что поддерживали неподдерживаемое кем?

В оригинале там «unmaintanable». Не знаю как одним словом перевести, но там речь о том, что код либо настолько плохой, либо настолько оторван от реалий, что его сложно поддерживать. Например сборку под какую-нить мёртвую платформу, которой уже ни у кого нет.

firkax ★★ ()
Ответ на: комментарий от firkax

Повторюсь, из того, что писали члены этого проекта на форумах, для них любой код unmaintainable.

lealxe ()
Ответ на: комментарий от UriZzz

Кто пользует, отпишитесь.

Лично я использую как отдельный браузер под конкретную задачу - «терминал» доступа к веб-интерфейсам кучи виртуалок под OpenWrt. Настроил в боковой панели закладок ссылки с автовходом и теперь могу заходить на них простым кликом.

Раньше ещё использовал, чтобы сохранять веб-страницы в MHT-архив. Сейчас чаще в PDF сохраняю.

Желания использовать его как «постоянный» браузер не возникает.

Rakshas ()

Что то стал скудный он на темы, которых теперь почему то нет, "В настоящее время нет доступных дополнений этого типа. " Словари, тоже нет, сплошная повсеместная оптимизация

maldik ()

Теперь пользователь имеет больше свободы в использовании потенциально несовместимых (старых/небезопасных) расширений браузера, однако проблемы с безопасностью придётся решать самостоятельно.

То есть наконец можно ставить любые аддоны для FF<57, без их явного портирования под Pale Moon? Или насколько «старых», что под этим понимать?

bodqhrohro_is_back ()
Ответ на: комментарий от UriZzz

Пользуюсь как основным с 2017 года, по мне так годный браузер, продолжатель дела классического огнелиса, использую вместе с pentadactyl. Правда, он подтормаживает, если много жирных страниц открыть, не хватает многопроцессности, конечно. И гитлаб нормально не отображается.

nemixer ()
Ответ на: комментарий от darkenshvein

Это вброс только тогда когда его таким образом воспринимают. Я когда то ставил сей браузер. Как раз таки отсутствие русской локали и помешало мне нормально потыкать его палочкой. Я не настолько хорошо знаю английский, и стараюсь на софт всегда по возможности ставить русскую локаль. И не надо ни кого банить, что за привычка вообще???

UriZzz ()
Последнее исправление: UriZzz (всего исправлений: 3)
Ответ на: комментарий от darkenshvein

А в чем дело,? на забан обосновать если так, по чесноку надо, а то что русской локалии не было обновлено с обновлением Pale Moon ранее, позабросил его, вот и спросил как сейчас с этим делом, люди выше дали ссылку, за что отдельное спасибо, установил все хорошо, а дальше что от вас именно ? под забан? ну так делай что собрался уже, меньше слов, законы физики и небосвода никто не отменял, жизнь тоже банит, только сурово за лож

maldik ()
Последнее исправление: maldik (всего исправлений: 1)
Ответ на: комментарий от MozillaFirefox

сервер с дополнениями

Так из файла же.

Даже из старых профилей лисы они выковыриваются легко.

bodqhrohro_is_back ()
Ответ на: комментарий от UriZzz

Я не настолько хорошо знаю английский

Это поправимо. Отсутствие локализации — как раз хороший мотиватор.

bodqhrohro_is_back ()
Ответ на: комментарий от nemixer

И гитлаб нормально не отображается

Patches are welcome, тащемта. Если по идейным причинам не отвергнут. Форкать гитлаб — дело бесперспективное, пожалуй.

bodqhrohro_is_back ()

С этими истеричками лучше не связываться. А учитывая последние события с самим Firefox, вообще надо хорошо задуматься над тем что оставить этот проект заниматься своими стремными делами без нас.

tommy ★★★★★ ()

Мне одному кажется, что это безполезная хрень?

petyanamlt ★★★★ ()
Ответ на: комментарий от UriZzz

Я когда то ставил сей браузер. Как раз таки отсутствие русской локали и помешало мне нормально потыкать его палочкой.

Это в каком году было?

kolja ★★ ()
Ответ на: комментарий от MozillaFirefox

Прямо сейчас ставить по сути ничего нельзя, т.к. один из разрабов психанул и вырубил сервер с дополнениями.

🤦‍♀️🤦‍♀️🤦‍♀️

mandala ★★★★ ()
Ответ на: комментарий от mandala

Ой, да пофиг вообще. Пусть они там хоть в попы друг друга сношают паровозиком, переодеваясь при этом в фуррей, крича при этом песни из май литл пони, и всё это под русский рэп. И каждые две недели удаляя нафиг проект из-за того что парень бросил и не поставил скобочку в конце сообщения. Пофиг. Это их личная жизнь. В разы хуже корпорасты с их этой телеметрией, у которых браузеры меняют контрольную сумму при скачивании с сервера. Мне важно, что есть актуальный и до сих пор развивающийся браузер с поддержкой современных веб-стандартов. А чем там разработчики занимаю.тся, мне пофиг

ZenitharChampion ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей