LINUX.ORG.RU

Intel сертифицировала поддержку OpenGL в Khronos Group

 , ,


3

2

Khronos Group cертифицировала поддержку OpenGL 4.5 в драйверах для встроенных графических модулей Intel.

Khronos Group также сертифицировала Vulkan и OpenGL ES.

На сегодняшний день это единственные полностью открытые сертифицированные драйверы с поддержкой всех вышеприведенных стандартов.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

это типа у них теперь всё опен сурс ? АМД когда родят OpenGL и Vulkan ? :((( Хотя точно не в этом году, да.. Или, по крайней мере, до выхода ядра 4.12

mphuZ ()

Забавно. У меня Pentium N3710. И Vulkan 1.0 и OpenGL 4.5 есть. Может и не тянет, но поддержка API есть - приятно.

Deleted ()
Ответ на: комментарий от mphuZ

о чем ты болезный? 4.5 еще раньше чем у интела было, причем не в 2 последних поколениях а в картах 2011 года, с вулканом как же, по сути они делят львиную часть кода.

Novell-ch ★★★★★ ()

Ебилды уже есть или ждём?

Harald ★★★★★ ()
Ответ на: комментарий от mphuZ

АМД когда родят OpenGL и Vulkan ?

Если ты про открытые дрова то не скоро - в толксах пролетала ссылка на то что не принимают открытые дрова amd ядро, по причине того, что они запилили какой то свой велосипед, а не использовали тот что уже есть в ядре.

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

Я фороникс тоже читаю)) И там вроде разговор не про дрова был, а про какую-то другую систему кода. Вроде про открытие кода они толком ещё и не думают :((

mphuZ ()
Ответ на: комментарий от mphuZ

Они код не открывают они по сути пилят альтернативную ветку дров.

Ygor ★★★★★ ()
Ответ на: комментарий от mphuZ

А нафига то, чего такого волшебного есть в закрытом попенгл, по сути это даже даунгрейд, нет ни вяляного, ни найна, ни апаратного энкодера. Ну ладно вулкан там, хотя не вижу ничего страшного поставить 2 пакета и пользоваться про вулканам вместе с месой без всяких проблем.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

честно, не знаю всех тонкостей «нафига», но раньше их об этом часто просили))

mphuZ ()

Ну кто так пишет новости, надо как минимум упомянуть, что в свободных драйверах mesa реализована OpenGL 4.5 для всех распространенных производителей видеокарт, как для Intel, так и для AMD и Nvidia. А то, что сейчас произошло - это всего лишь официальная сертификация.

Displacer ★★ ()
Ответ на: комментарий от Displacer

Ну кто так пишет новости, надо как минимум упомянуть, что в свободных драйверах mesa реализована OpenGL 4.5

Новость о драйверах для чипов Intel, не о Mesa. Впрочем, если говорить о Mesa - https://mesamatrix.net/ показывает, что и в Mesa OpenGL 4.5 реализован только для Intel.

А то, что сейчас произошло - это всего лишь официальная сертификация.

Новость так и озаглавлена. Претензии непонятны.

tailgunner ★★★★★ ()
Ответ на: комментарий от tailgunner

лол, это такие условные семейства, ну тогда радеоны никогда не получал 4.5 с такой логикой, увы rage не держит 4.5 опенгл. И вопрос на засыпку, по твоей логике все интелы держат 4.5, есть пруф?

Novell-ch ★★★★★ ()
Последнее исправление: Novell-ch (всего исправлений: 1)
Ответ на: комментарий от Novell-ch

лол, это такие условные семейства

Тогда зачем ты их приводишь как ответ в разговоре о производителях?

И вопрос на засыпку, по твоей логике все интелы держат 4.5, есть пруф?

Спроси авторов mesamatrix.

tailgunner ★★★★★ ()
Ответ на: комментарий от tailgunner

radeonsi это драйвер который поддерживает все карты AMD начиная с семейства Southern Islands (грубо говоря с 2012 по настоящее время)

r600 это драйвер который поддерживает карты AMD с R600 до Northern Islands (грубо говоря с 2007 по 2012)

И кстати, драйвер intel поддерживает OpenGL 4.5 только архитектурах Haswell или моложе.

platerx ()
Ответ на: комментарий от tailgunner

Твой тупизм в комменте. i965 поддерживает начиная с GMA HD 4500 ( Где все застряло на opengl 3.1 (кажется), с остальными семействами все так же само)

timdorohin ★★★ ()
Ответ на: комментарий от tailgunner

Если в колонке intel подвести указатель к конкретному расширению(выделенному штриховкой), то отображается, архитектура начиная с которой оно поддерживается.

Например если подвести указатель к GL_ARB_query_buffer_object то будет укажывается hsw+ что значит что это расширение, которое является обязательными для OGL 4.4 и 4.5, поддерживается начиная с Haswell

platerx ()
Последнее исправление: platerx (всего исправлений: 1)
Ответ на: комментарий от Novell-ch

ладно, с тобой все ясно, ты о Месе знаешь не больше чем я о пилотируемых полетах на марс

Если ты по какой-то причине решил, что знаю больше, чем указано в mesamatrix, на которую я сослался, это проблема твоего восприятия.

tailgunner ★★★★★ ()
Ответ на: комментарий от timdorohin

а i965 - это производитель видеокарт?

Что заставило тебя так подумать?

Твой тупизм в комменте.

Если тупизм других заставляет тебя галлюцинировать... плохо быть тобой.

tailgunner ★★★★★ ()
Ответ на: комментарий от tailgunner

Ну если тебе говорят что ты не прав, если не умеешь читать mesamatrix и постишь явное 4.2 которое вводит людей в заблужение,

Novell-ch ★★★★★ ()
Последнее исправление: Novell-ch (всего исправлений: 1)
Ответ на: комментарий от tailgunner

Он заставляет меня издеваться над другими. К сожалению, многие социопатические личности в текстовой форме не понимают, а ЛОР не позволяет передавать выражение лица и интонацию говорящего...

timdorohin ★★★ ()
Ответ на: комментарий от timdorohin

Он заставляет меня пытаться издеваться над другими.

/fixed

ЛОР не позволяет передавать выражение лица и интонацию говорящего...

Что за дешевые отмазки. ЛОР позволяет опубликовать ссылку на фото или видеоролик.

tailgunner ★★★★★ ()
Ответ на: комментарий от Deleted

Не хотел ставить Steam, но могу и проверить. Погоди пару часиков, займусь.

да нахер тебе это нужно, лучше сходи погуляй

anonymous ()
Ответ на: комментарий от timdorohin

дотка нормально работает с вулканом, если серия больше чем хасвел, особого прироста нет, так же само медленно.

Novell-ch ★★★★★ ()
Ответ на: комментарий от anonymous

Самому любопытно. Когда-то тестил на Haswell'е и не запустилось.

Deleted ()
Ответ на: комментарий от Deleted

не скажу точно, у самого ивик, там еще все хуже, интел обычно тянет максимум это текущая линейка-1, на остальное забивается, хотя я запускал доту как только появилась поддержка для ивиков, было куча артефактов, но оно работало.

Novell-ch ★★★★★ ()
Ответ на: комментарий от wolph

MOBA, шутеры простые. У интела сейчас производительность iGPU прилично выросла. Так что играбельно на минимально-средних в родном разрешении экрана.

Deleted ()
Ответ на: комментарий от wolph

Даже если оно сейчас средне-плохое это же не значит что оно будет таковым всегда? Intel в своё время выпускали вполне себе AGP карты, насколько я помню.

Ygor ★★★★★ ()

Типа думец запустить можно?

TooPar ()
Ответ на: комментарий от timdorohin

Учитывая что Intel Pentium N3710 (OpenGL даёт ~20 fps, Vulkan ~23 fps). Разница небольшая. Тем не менее запустился и работает.

Deleted ()
Ответ на: комментарий от Deleted

Интересно только сравнить с виндой... Поменяю винт, поставлю семерку -отпишусь...

Дотка значит осталась полуиграбельная...

timdorohin ★★★ ()
Ответ на: комментарий от Deleted

i5 Haswell, OpenGL в доте даёт в 1.5 раза больше FPS, чем вулкан.

devorg ()

Intel сертифицировала

Khronos Group cертифицировала

Так кто из них сертифицировал?

slonopotamus ()
Ответ на: комментарий от platerx

И кстати, драйвер intel поддерживает OpenGL 4.5 только архитектурах Haswell или моложе.

Да? И в какой системе такое счастье можно увидеть? В Debian Stretch + HD4600 (i5 haswell) я наблюдая только OpenGL 3.0 и Mesa 13.0.3.

OpenGL version string: 3.0 Mesa 13.0.3
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.3

devorg ()
Ответ на: комментарий от devorg
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) Haswell Desktop  (0x412)
    Version: 13.0.3
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 13.0.3
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
devorg ()

Khronos Group cертифицировала поддержку OpenGL 4.5 в драйверах для встроенных графических модулей Intel.

На ивиках в апстриме до сих пор 3.3. И чёрт его знает, когда будет 4.0.

robus ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.