LINUX.ORG.RU

Pale Moon 27.1

 


0

1

Стал доступен выпуск Pale Moon 27.1 — web-браузера, являющегося форком Mozilla Firefox, модифицированным для минимизации потребления памяти и предоставления дополнительных возможностей настройки, и сохраняющего классический интерфейс.

Из удалённых компонентов можно отметить DRM, Social API, WebRTC, просмотрщик PDF, Сrash Reporter, код для сбора статистики, интерфейс группировки вкладок Panorama, средства для родительского контроля и помощи людям с ограниченными возможностями. Из улучшений выделяется поддержка инструкций SSE2, оптимизация для процессоров Atom, дополнительные варианты восстановления сеанса и возможность отключить загрузку изображений. На уровне поддержки базовых web-технологий и тем оформления браузер совместим с Firefox. Сборки подготавливаются для Windows и GNU/Linux (x86 и x86_64).

Новый выпуск примечателен восстановлением совместимости с дополнениями, созданными с использованием Add-on SDK (расширения JetPack на базе стандартных web-технологий). Восстановлена совместимость с большинством дополнений, работавших в Pale Moon 26, но оказавшихся неработоспособными после удаления JetPack из Pale Moon 27. Более того, с помощью инструмента Moon Tester можно адаптировать для Pale Moon некоторые дополнения, написанные для нового интерфейса Firefox, если они не слишком сильно привязаны к Aurora. Для работы подобных расширений в состав добавлен модуль «PMkit», требующий конвертации SDK-дополнений от Firefox и SeaMonkey в формат дополнений Pale Moon.

Другие изменения:

  • Изменён метод остановки скриптов после применения диалога «unresponsive script» (теперь останавливаются все скрипты в данной вкладке), что позволило избежать зависаний браузера.
  • Возвращён обработчик HTML5 API для буфера обмена (разрешено только копирование в буфер, вставка из буфера блокируется из соображений безопасности).
  • Расширено число прав, устанавливаемых через менеджер контроля полномочий (about:permissions).
  • Удалён код поддержки интерфейса Metro, нестандартных блоков let и выражений.
  • Исправлены проблемы при работе с Facebook.
  • Возвращена настройка network.stricttransportsecurity.enabled для управления включением HSTS.

На opennet.ru

>>> Подробности



Проверено: jollheef ()

Изменён метод остановки скриптов после применения диалога «unresponsive script» (теперь останавливаются все скрипты в данной вкладке), что позволило избежать зависаний браузера

Может просто засунуть вкладку в отдельный процесс чтоб одна вкладка не тормозила весь браузер?

и нестандартных блоков let и выражений

Ух сюрприз будет юзеру, когда js скажет «привет»

Исправлена ошибка, вызывавшая проблемы при работе с Facebook

О_о

NextGenenration ★★ ()
Ответ на: комментарий от h578b1bde

А её когда-либо оттуда вывозили? Если же ты про хромогую многопроцессность, то она не нужна.

Кто там чинил подвисания одного процесса? Даже в ченджлоге записали.

NextGenenration ★★ ()

Кто-нибудь пробовал его собрать шестым gcc? Получилось что-нибудь?

anonymous ()
Ответ на: комментарий от the_electric_hand

Такие вещи, как средства для людей с ограниченными возможностями, выпиливать из софта просто нельзя. Это оскорбление, плевок. У разработчиков этого говна проблемы с Моралью

Не нельзя, а нужно. Какая доля этих пользователей, а? Если меньше процента, то дропнуть их можно без зазрений совести. И это если еще не учитывать маргинальность пельменя.

А поддерживать кодовую базу трем с половиной школьникам со всякими аксессибилити/ретардАПИ ну просто не осилить. Такие вещи только для организаций с финансированием и кодерами на зарплате - либо проприетарных (кому дропнуть 1% может быть менее выгодно, чем поддерживать), либо богадельням по типу Mozilla Foundation.

ЗЫ. Счастливый пользователь лисы с 0.5beta, не течет и не жиреет.

moooV ()
Ответ на: комментарий от Inshallah

Ну, собирается оно с поддержкой pthreads, так что вероятно да.

raven_cler ★★ ()

не, ну как в кин-дза-дзе — «Играйтесь, играйтесь, мужички»

demidrol ★★★★★ ()
Ответ на: комментарий от chukcha

- нет, оказалось, что прежний ленгпак для 27 подошел и для 27.1

chukcha ★★★ ()
Ответ на: комментарий от anonymous

gstreamer всё. Теперь ffmpeg нужен, включен по умолчанию.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Bfgeshka

ну тут без разницы - забыл откусить/забыл вписать в зависимости - итог один, я уж свой запилил, у тебя теперь вот так:

These are the packages that would be merged, in reverse order:

Calculating dependencies | * ERROR: www-client/palemoon-27.1.0-r1::octopus failed (depend phase):
 *   EXPORT_FUNCTIONS: palemoon-2_pkg_pretend is not defined
 * 
 * Call stack:
 *                   ebuild.sh, line 611:  Called source '/var/lib/layman/octopus/www-client/palemoon/palemoon-27.1.0-r1.ebuild'
 *   palemoon-27.1.0-r1.ebuild, line   9:  Called inherit 'palemoon-2' 'git-r3' 'eutils' 'flag-o-matic' 'pax-utils'
 *                   ebuild.sh, line 347:  Called die
 * The specific snippet of code:
 *   					declare -F "${ECLASS}_$x" >/dev/null || \
 *   						die "EXPORT_FUNCTIONS: ${ECLASS}_$x is not defined"
 * 
 * If you need support, post the output of `emerge --info '=www-client/palemoon-27.1.0-r1::octopus'`,
 * the complete build log and the output of `emerge -pqv '=www-client/palemoon-27.1.0-r1::octopus'`.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/tmp/portage/www-client/palemoon-27.1.0-r1/work/palemoon-27.1.0'           
anonymous ()
Ответ на: комментарий от anonymous

Да, я переименовать забыл. Просто добавил в прошлый класс лишнее условие для проверки, можно попробовать со шлангом собирать, сча поправим.

А paludis этот ебилд спокойно скомпилял и не сказал ничего.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Bfgeshka

спелинг еще выпилить можно:

REQUIRED_USE="system-spell? ( spell )" 

if ! use spell; then
        mozconfig_enable extensions=-spellcheck
fi

ну и еще там есть по мелочи.

anonymous ()
Ответ на: комментарий от anonymous

вкладки без спроса округлились.

Их уже и в паленом округлили. Как вернуть прямые углы? :)

bohm ★★★★★ ()
Ответ на: комментарий от lolrd

Как оно по сравнению с chrome и ff?

Никак...

- Сайты криво показывает, например https://mail.google.com/mail/mu/mp/746/ Когда говоришь о проблемах с отображением сайтов, пускают пузыри об аууустралисе... - моль не наши проблемы ;)

- Расширений почти нет, только старые. Кривую поддержку оных (jetpack), то включают, то выключают... Бред и шатание, и то через их голимую прослойку pmkit и кривое расширение «Moon tester tool»...

- Только в 27.1 сделали поддержку ffmpeg без gst и стало возможным нормально html5 видос получать.., и т.д.

В общем кривое поделие, но без аууустралиса и расширений... Без оного можно жить и с xombrero/luakit и т.д.

bohm ★★★★★ ()
Последнее исправление: bohm (всего исправлений: 4)
Ответ на: комментарий от h578b1bde

Никакой, геко форкнули давно.

Как это никакой, как форкнули так на ней и остановились :)

bohm ★★★★★ ()
Ответ на: комментарий от nempyxa

одинаковые, нормальные кнопки

Это в каком месте? Если маленькие кнопки в панели использовать - не на всех расширениях работает. К тому же в панели вкладок значки на меньшие не переходят и высота вкладок меньше не становится. В итоге жесть какая-то с фейсем.

А локализация тотала вся о очепятищях годами, да и самого браузера через ж...

bohm ★★★★★ ()
Ответ на: комментарий от h578b1bde

ещё результат тяжёлой наркомании

нормально там все, кроме невозможности убрать надписи к кнопкам из коробки... Тут многие заявляют, что даже это меню а-ля хром не в состоянии найт... Так кто тут макоеды, разрабы или пользоблонди?! ;)

bohm ★★★★★ ()
Ответ на: комментарий от aidaho

Отличная новость, пошёл обновляться.

Кривая и брехливая часть новости. JetPack там ОООчень частичный и через кривое дополнение «moon test tool». Горбато, но хоть что-то начинает работать из расширений. Так что не сильно радуйся. Тем более что их уже не правят и не обновляют, да и новые делать уже не будут.

bohm ★★★★★ ()
Ответ на: комментарий от bohm

Сайты криво показывает, например https://mail.google.com/mail/mu/mp/746/

У меня перечёркнутая ссылка, так и должно быть? А вообще логиниться в гугль чтобы посмотреть современные высеры хипстеров неохота, у меня и гмейла-то нет.

Когда говоришь о проблемах с отображением сайтов, пускают пузыри об аууустралисе...

Хз, я сразу поменял юзерагент на какой-то от жирнолиса и на всех используемых мною сайтах УМВР. А убогий авсралис не нужон, да.

нормально там все, кроме невозможности убрать надписи к кнопкам из коробки...

Я и с надписями не смог там ничего найти пока не вытер глаза от крови, а ты ещё и надписи хочешь убрать. Как им вообще тогда можно будет пользоваться?

Тут многие заявляют, что даже это меню а-ля хром не в состоянии найт...

Не знаю что там в хромоге, но то что это объективно неюзабельное говно понятно и без сравнений с чем-либо.

Это в каком месте? Если маленькие кнопки в панели использовать - не на всех расширениях работает.

NoScript, Session Manager, Firebug — иконки одного размера.

h578b1bde ★☆ ()
Ответ на: комментарий от h578b1bde

убогий авсралис не нужон, да.

Мне и стандартная тема pm не нравится. Со значками проблема, вкладки огромные и закругленные. Поставил тему maxi4 и доволен. Надо будет и мне поменять юзерагент, но не думаю что простенький сайтец «gmail mobile» заработает от этого корректно в pm.

Ссылку лор зачеркнул...

bohm ★★★★★ ()
Ответ на: комментарий от aidaho

Все мои JetPack-аддоны заработали безупречно.

Если не лукавишь, то рад за тебя. А мне всего-то два-три надо, но не судьба...

bohm ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.