LINUX.ORG.RU

какая интересная новость. Vivu la Qt!

MikeDM ★★★★★ ()

А оно реально кому-то на маке нужно?

Polugnom ★★★★★ ()

Причиной названа плохая поддержка мака со стороны GTK.

Правильно. Даешь для мака только гламурный софт! А то домохозяйки пугаются...

abcarado ()

Юзать это будут только продвинутые домохозяйки? Пусть запилят мануал в комиксах, а то вдруг не разберутся...

abcarado ()

Давно пора. А то я фалломорфировал от его жуткого гуя на гтк.

Akamanah ★★★★★ ()
Ответ на: комментарий от Polugnom

А оно реально кому-то на маке нужно?

Есть альтернативы?

CrossFire ★★★★★ ()

А плохая поддержка винды со стороны gtk их не волнует?

Reset ★★★★★ ()
Ответ на: комментарий от CrossFire

Да я только благодаря этому треду узнал что это такое, уж не говоря о знании альтернатив.

Polugnom ★★★★★ ()

Qt на маке тоже, как УГ выглядит.

gensym ★★ ()

ГТК-капец всё ближе, тулкитофобы взбудоражены.

Manhunt ★★★★★ ()
Ответ на: комментарий от Reset

А плохая поддержка винды со стороны gtk их не волнует?

Почему их должны волновать вендопроблемы?

Manhunt ★★★★★ ()

Причиной названа плохая поддержка мака со стороны GTK.

Вообще-то причиной названо вообще отсутствие мультиплатформенности. Ну оно и нормально, кто хочет переносимого кода пишет на qt или на wxWidgets.

morse ★★★★★ ()
Ответ на: комментарий от Reset

Вендузятники адаптивные, у них не возникает судорог по причине некоторых различий в look\feel софта.

thesis ★★★★★ ()

Отлично же. Базовую функциональность вроде запилили уже, что вообще круто.

thesis ★★★★★ ()

Ещё один гвоздь в крышку гроба Gtk.

AX ★★★★★ ()

Причиной названа плохая поддержка мака со стороны GTK.

Интересно, много новых пользователей они ожидают?

Ладно, главное, чтобы этот рефакторинг не подкосил проект. А внешний вид для такого класса ПО абсолютно не важен.

router ★★★★★ ()
Ответ на: комментарий от gensym

Qt на маке тоже, как УГ выглядит.

Выглядит весьма прилично, особенно на фоне gtk. А если уж напиильник взяяять!

CrossFire ★★★★★ ()

Wireshark переходит с GTK на Qt

«И это - хорошо!»

Igorrr ★★★★ ()
Ответ на: комментарий от Reset

gtk вообще не нужен. Хз как сейчас, но пару месяцев назад в виндовс gtk не мог горячие клавиши.

Если я правильно понимаю, transmission в os x тоже на qt. Или я путаю?

ekzotech ★★★★ ()
Ответ на: комментарий от AX

Гвозди и доски уже готовят сами разработчики gtk, прогибаясь под планшеты и забивая на трационный функционал иксов. А это так, мелкая неприятность.

router ★★★★★ ()
Ответ на: комментарий от FRCTLL

фууу, смотрите, смотрите, он не знает, что такое wireshark

Harald ★★★★★ ()
Ответ на: комментарий от Deathstalker

wireshark - анализатор траффика. Возможность перехвата в нём второстепенна.

router ★★★★★ ()

не знаю, вроде гткшный интерфейс вайершарка привычнее, работает - не трожь, с другой стороны в последних версиях его диалоги у меня в экран не влазят

Harald ★★★★★ ()

NaN, так что ты там говорил про смерть Qt? :}

Deleted ()
Ответ на: комментарий от Deleted

Turbo Pascal был переписан на Turbo Vision. Ну и где сейчас этот Turbo Vision?

NaN ()
Ответ на: комментарий от NaN

Turbo Vision был тулкитом какой-то ОС? От ты лолищще.

Deleted ()
Ответ на: комментарий от Deleted

Можно и так сказать. И должен заметить, что тулкит был весьме неплохой. Другое дело, что он был на 100% завязан на дос и со смертью доса умер и TV, дав потомство в виде VCL.

Tweaker ★★★★ ()
Ответ на: комментарий от Reset

Вспомнилось: http://sourceforge.net/p/mcomix/feature-requests/24/

2011-08-21

I gave GTK3 and the new GObject introspection interface a try a few months ago, but the overall experience was horrible. In the end, I couldn't even get the main window to start up due to various strange import errors somewhere deep in the gi API.

I might give it a shot again some time in the future, but for now, the Python interface to GTK3 is still considered alpha quality. Obviously, that's not something users will want to deal with.

2013-05-21

Two years later, still no working PyGObject port for Windows, and apparently no one who actively works on the same.

aidan ★★★★ ()
Ответ на: комментарий от das_tier

вот они себя и закопают

ой не думаю. правильно всё делают.

KennyMinigun ★★★★★ ()
Ответ на: комментарий от Polugnom

Да я только благодаря этому треду узнал что это такое, уж не говоря о знании альтернатив.

О таких программах не должно знать слишком много людей :)

KennyMinigun ★★★★★ ()
Ответ на: комментарий от Tweaker

Нельзя так сказать. Все писали свои. Полтора землекопа погоды не делают. А у нас тут массовый исход намечается.

Deleted ()
Ответ на: комментарий от Polugnom

А оно реально кому-то на маке нужно?

Мак - де-факто стандартная платформа для хороших специалистов. Венда для домохозяек, а линукс для тех, кто не смог купить макбук, т.е. молодняк и плохие специалисты.

h31 ★★★★ ()
Ответ на: комментарий от AX

чего радуешся? тебе потом аву обновлять. лишняя работа же

ZuBB ★★★★★ ()
Ответ на: комментарий от Polugnom

А оно реально кому-то на маке нужно?

Ну я пользовался пару лет назад, когда была такая необходимость. Гуй был мерзотным до невозможности, это правда.

Apple-ch ★★ ()

cast yanka

Затроллили уже бедную девушку... Или админа косящего под девушку.

ncrmnt ★★★★★ ()
Ответ на: комментарий от gensym

Qt на маке тоже, как УГ выглядит

Нее, по сравнению с гтк кьют на маке няша. VLC, VBox, QtCreator — то, чем я часто пользуюсь, выглядит вполне прилично. Т.е. видно, что оно не совсем родное, но придраться особо не к чему.

Apple-ch ★★ ()
Ответ на: комментарий от Apple-ch

Qt на маке выглядит как родное ИМХО. Видимо, именно поэтому ты принял нативный (с офсайта) интерфейс VLC, написанный на Cocoa, за Qt :)

P.S.

/Applications/VLC.app/Contents/MacOS$ otool -L VLC 
VLC:
	@loader_path/lib/libvlc.5.dylib (compatibility version 9.0.0, current version 9.2.0)
	@loader_path/lib/libvlccore.5.dylib (compatibility version 7.0.0, current version 7.1.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)
	/usr/lib/libiconv.2.dylib (compatibility version 7.0.0, current version 7.0.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1094.0.0)

 otool -L libvlccore.5.dylib 
libvlccore.5.dylib:
	@loader_path/lib/libvlccore.5.dylib (compatibility version 7.0.0, current version 7.1.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)
	/usr/lib/libiconv.2.dylib (compatibility version 7.0.0, current version 7.0.0)
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 635.21.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1094.0.0)
asaw ★★★★★ ()
Последнее исправление: asaw (всего исправлений: 2)
Ответ на: комментарий от Harald

слишком толсто

Два факта:
1) Пройди по ссылке, там совсем немного текста. Явно видно, что разраб перешел на мак.
2) Нынешняя аудитория ЛОРа.

h31 ★★★★ ()
Ответ на: комментарий от h31

Хорошие специалисты любят зонды и страдать? Ну, ok.

Deleted ()

бугага! можно подумать, у qt хорошая поддержка мака :)

waker ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.