LINUX.ORG.RU

Что делать? Не могу ничего установить... вообще...

 , ,


0

1

Всем доброго дня! Хотел перейти с OpenOffice на LibreOffice. В общем удалил пакет OpenOffice, но, видимо, не корректно, потому что остались ярлыки программ... Теперь вот такая ошибка:

Error while installing package: попытка перезаписать «/usr/bin/soffice», который уже имеется в пакете openoffice-debian-menus 4.1.6-9790

Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Вы можете запустить «apt --fix-broken install» для исправления этих ошибок. Следующие пакеты имеют неудовлетворённые зависимости: libreoffice-style-galaxy : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.5) но он не будет установлен libreoffice-style-tango : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.5) но он не будет установлен python3-uno : Зависит: libreoffice-core (= 1:6.0.7-0ubuntu0.18.04.5) но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Может кто-нибудь поможет, как с этим разобраться?.. Заранее очень благодарен!

Ответ на: комментарий от Deleted

Да, пробовал:

Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libreoffice-common
Следующие НОВЫЕ пакеты будут установлены:
  libreoffice-common
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 17 пакетов.
Необходимо скачать 0 B/24,9 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 79,2 MB.
Хотите продолжить? [Д/н] д
(Чтение базы данных … на данный момент установлено 255227 файлов и каталогов.)
Подготовка к распаковке …/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.5_all.deb …
Распаковывается libreoffice-common (1:6.0.7-0ubuntu0.18.04.5) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.5_all.deb (--unpack):
 попытка перезаписать «/usr/bin/soffice», который уже имеется в пакете openoffice-debian-menus 4.1.6-9790
rmdir: не удалось удалить '/var/lib/libreoffice/share/prereg/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/share/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/program/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Вот так…

Matvey_975 ()

В любой непонятной ситуации советую восстанавливаться из бэкапа. Если ошибка повторится, то тогда, и только тогда идти на форум по проблеме, с конкретным списком/алгоритмом действий повлекших проблему.

anonymous ()
Ответ на: комментарий от Matvey_975

Как именно через терминал?

aptitude search ~c что выдает? Удаляй то что выдал через apt purge, но не remove. Затем apt-get update && apt-get upgrade и лишь потом устанавливай что нужно.

anonymous ()
Ответ на: комментарий от Vsevolod-linuxoid

Спасибо! Но при попытке удалить пакеты, появляется следующее:

sudo apt remove --purge openoffice-ru-math
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:6.0.7) но он не будет установлен
 libreoffice-style-galaxy : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.5) но он не будет установлен
 libreoffice-style-tango : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.5) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

Пакетов, кстати, много:

apt list --installed | grep -i openoffice

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

openoffice-base/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-calc/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core01/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core02/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core03/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core04/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core05/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core06/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-core07/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-debian-menus/now 4.1.6-9790 all [установлен, локальный]
openoffice-draw/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-gnome-integration/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-graphicfilter/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-images/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-impress/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-javafilter/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-math/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ogltrans/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-onlineupdate/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ooofonts/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ooolinguistic/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-pyuno/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-base/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-calc/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-draw/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-help/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-impress/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-math/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-res/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ru-writer/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-ure/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-writer/now 4.1.6-1 amd64 [установлен, локальный]
openoffice-xsltfilter/now 4.1.6-1 amd64 [установлен, локальный]

:(

Matvey_975 ()