LINUX.ORG.RU

gcc и g++

 ,


0

1

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
gcc : Зависит: gcc-4.8 (>= 4.8.2-5~) но он не будет установлен
lazarus:i386 : Зависит: libgtk2.0-dev:i386 (>= 2.6.0) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
jashka@jashka-K55VM ~/Рабочий стол $ sudo apt-get install g++
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
g++ : Зависит: gcc (>= 4:4.8.2-1ubuntu6) но он не будет установлен
Зависит: g++-4.8 (>= 4.8.2-5~) но он не будет установлен
Зависит: gcc-4.8 (>= 4.8.2-5~) но он не будет установлен
lazarus:i386 : Зависит: libgtk2.0-dev:i386 (>= 2.6.0) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

gcc зависит от gcc — это круто. арч так не умеет.

crowbar ()
Ответ на: комментарий от Solace

ну я удалять lazarus не собираюсь, я его еле поставил и он мне нужен так же как и qt

jashka ()
cd /var/cache/apt/archives/
ls -1 | grep ^gcc
quest ★★★★ ()
Ответ на: комментарий от fijiol

слушай если бы это было так легко, я бы не задавал вопрос, умник, не один ты так гуглом пользуешься

jashka ()
Ответ на: комментарий от jashka

пробовали: sudo apt-get install build-essential ? если у вас действительно убунта, а иначе почему бы не написать название дистрибутива

п.с. и не нужно обижаться и оскорблять друг друга пожалуйста :)

fijiol ()
Ответ на: комментарий от fijiol

проблема в том что qt установлен с mysql, но ошибка при подключении: драйвер не загрузился
QSqlDatabase: QMYSQL driver not loaded
QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QPSQL QPSQL7

QT += core gui QT += sql

greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

TARGET = qsqlmysql TEMPLATE = app

SOURCES += main.cpp\ widget.cpp

HEADERS += widget.h

FORMS += widget.ui

win32:CONFIG(release, debug|release): LIBS += -L$$PWD/release/ -lqsqlmysql else:win32:CONFIG(debug, debug|release): LIBS += -L$$PWD/debug/ -lqsqlmysql else:unix: LIBS += -L$$PWD/ -lqsqlmysql

INCLUDEPATH += $$PWD/ DEPENDPATH += $$PWD/

jashka ()

У нас появился новый qulinxao, который говорит цитатами?

Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

Не вижу выхлопа сего.

Deleted ()
Ответ на: комментарий от crowbar

Это ж убунта. Там gcc и gcc-4.8 — это разные пакеты. В дебьяне так же. Рач так не умеет, потому что мэйнтейнеры рача не хранят более одной версии. Вышел новый баг от кривых разрабов — извольте хавать.

Deleted ()
Ответ на: комментарий от crowbar

Арчеводы и читать не умеют.

gcc - это метапакет, зависящий от текущего gcc, в данном случае - gcc-4.8

Рекомендую в таких случаях пробовать установить зависимости явно, чтобы посмотреть почему они не могут быть установлены, то есть например, попробовать apt-get install gcc-4.8

anonymous ()
Ответ на: комментарий от anonymous

В арче есть метапакеты, группы, виртуальные пакеты и при этом все это не глючит, конфликтов почти не бывает (я не помню, были ли вообще). deb глючный, с невнятным выхлопом менеджера пакетов, сборка пакетов вообще bdsm. конфликты, нежелающие обновлятся пакеты (linux-kernel will be kept back, lol). последнее предложение в ОП-посте раскрывает его суть.

crowbar ()
Ответ на: комментарий от crowbar

Молодец. А теперь установи linux-mainline, удали linux и попробуй установить virtualbox.

deb глючный, с невнятным выхлопом менеджера пакетов, сборка пакетов вообще bdsm

Какое-то истеричное 4.2.

Deleted ()
Ответ на: комментарий от Deleted

конечно он не поставится, в linux-mainline provides не прописан. проблема ауровского майнтейнера

crowbar ()
Ответ на: комментарий от crowbar

все это не глючит, конфликтов почти не бывает

Давай, расскажи мне, как у тебя в линуксе не бывает конфликтов пакетов.

Aswed ★★★★★ ()

Поставь федору и не страдай фигней

vzzo ★★★ ()

Поставь Debian unstable и не страдай фигней!

quest ★★★★ ()

Сноси ты этот Минт, а то у тебя одни проблемы с ним.

AlexVR ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.