LINUX.ORG.RU

Ошибка Sudo apt-get install update && apt-get upgrade

 


1

1

в общем ошибка такая: в конце выдает

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:

Пакеты, имеющие неудовлетворённые зависимости: libstdc++6-arm64-cross : Зависит: gcc-4.8-aarch64-linux-gnu-base (= 4.8.2-13ubuntu1cross0.11) но 4.8.4-2ubuntu1~14.04.1cross0.11.1 будет установлен

E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

ты попытался?

anonymous ()
Ответ на: комментарий от mkm-2014

Попытайтесь выполнить «apt-get -f install», не указывая имени пакета

anonymous ()
Ответ на: комментарий от anonymous

аа даа, но там Хотите продолжить? [Д/н] Д (Чтение базы данных … на данный момент установлено 263337 файлов и каталогов.) Подготовка к распаковке …/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb … Распаковывается libstdc++6-arm64-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) на замену (4.8.2-13ubuntu1cross0.11) … dpkg: ошибка при обработке архива /var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb (--unpack): попытка перезаписать «/usr/share/gcc-4.8/python/libstdcxx/__init__.py», который уже имеется в пакете libstdc++6:i386 4.8.4-2ubuntu1~14.04.1 dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала) При обработке следующих пакетов произошли ошибки: /var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

mkm-2014 ()
Ответ на: комментарий от mkm-2014

Лоркод для форматирования используй. В твоём месиве строк никто копаться не будет.

Radjah ★★★★★ ()
Ответ на: комментарий от mkm-2014

apt-get -f install после выходит

Хотите продолжить? [Д/н] Д

(Чтение базы данных … на данный момент установлено 263337 файлов и каталогов.)

Подготовка к распаковке …/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb … Распаковывается libstdc++6-arm64-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) на замену (4.8.2-13ubuntu1cross0.11) …

dpkg: ошибка при обработке архива /var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb (--unpack):

попытка перезаписать «/usr/share/gcc-4.8/python/libstdcxx/__init__.py», который уже имеется в пакете libstdc++6:i386 4.8.4-2ubuntu1~14.04.1

dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)

При обработке следующих пакетов произошли ошибки:

/var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

mkm-2014 ()
Ответ на: комментарий от mkm-2014

Уже лучше.

libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
попытка перезаписать «...», который уже имеется в пакете libstdc++6:i386 4.8.4-2ubuntu1~14.04.1

У тебя в системе месиво. i386 руками ставился что ли?

Попытайтесь выполнить «apt-get -f install», не указывая имени пакета

Radjah ★★★★★ ()
Ответ на: комментарий от gssomi

Чтение списков пакетов… Готово

Построение дерева зависимостей Чтение информации о состоянии… Готово

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».

Пакеты, имеющие неудовлетворённые зависимости:

libstdc++6-arm64-cross : Зависит: gcc-4.8-aarch64-linux-gnu-base (= 4.8.2-13ubuntu1cross0.11) но 4.8.4-2ubuntu1~14.04.1cross0.11.1 уже установлен

E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

mkm-2014 ()
Ответ на: комментарий от gssomi

apt-get -f install после выходит

Чтение списков пакетов… Готово

Построение дерева зависимостей Чтение информации о состоянии… Готово

Исправление зависимостей… Готово

Будут установлены следующие дополнительные пакеты:

libstdc++6-arm64-cross

Пакеты, которые будут обновлены:

libstdc++6-arm64-cross

обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 15 пакетов не обновлено.

не установлено до конца или удалено 1 пакетов.

Необходимо скачать 0 B/220 kB архивов.

После данной операции, объём занятого дискового пространства возрастёт на 77,8 kB.

Хотите продолжить? [Д/н] Д

(Чтение базы данных … на данный момент установлено 263337 файлов и каталогов.)

Подготовка к распаковке …/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb …

Распаковывается libstdc++6-arm64-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) на замену (4.8.2-13ubuntu1cross0.11) …

dpkg: ошибка при обработке архива /var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb (--unpack):

попытка перезаписать «/usr/share/gcc-4.8/python/libstdcxx/__init__.py», который уже имеется в пакете libstdc++6:i386 4.8.4-2ubuntu1~14.04.1

dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)

При обработке следующих пакетов произошли ошибки:

/var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

mkm-2014 ()
Ответ на: комментарий от Radjah

До этого проблем не было, уже год как пользуюсь линукс убунту 14.04 i386. Но глубже я не заходила, не очень то знаю систему, пользуюсь только для программирования (c++, cc, fortran, mpi тут легко компилируется ) и для интернета. но сегодня какая то ошибка вышла fatal error: mpi.h: Нет такого файла или каталога

#include <mpi.h> ^ compilation terminated. и решила обновить mpi после эти ошибки не могу обновить никакую программу и каталог

mkm-2014 ()
Ответ на: apt-get -f install после выходит от mkm-2014

Это баг в пакете libstdc++6-arm64-cross. В нем содержатся файлы с теми же именами, что и в libstdc++6, поэтому вместе их нельзя установить (хотя пакет libstdc++6-arm64-cross по идее как раз и предназначен для установки вместе с уже установленной библиотекой и заодно заголовками libstdc++-4.8-dev). Багрепорт можно увидеть тут: https://bugs.launchpad.net/ubuntu/+source/gcc-4.8-arm64-cross. Он, правда, довольно бессмысленный, так как никакого ответа там нет, и когда починят, неизвестно.

Насколько я могу судить, перекрываются одинаковые файлы, поэтому можно <<починить>> установку так: 1) для начала удалить пакет libstdc++6-arm64-cross

dpkg -P libstdc++6-arm64-cross
2) потом установить его с помощью dpkg, а не apt-get:
dpkg -i --force-overwrite --force-overwrite-dir /var/cache/apt/archives/libstdc++6-arm64-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
При этом dpkg должен перезаписать существующие файлы без лишних возражений.

Пакет вроде безобидный, так что все сломаться при его установке не должно...

TeopeTuK ★★ ()
Ответ на: комментарий от TeopeTuK

Спасибо большое ))))) вроде эта ошибка прошла но после хотела обновить apt-get upgrade

не установлено до конца или удалено 1 пакетов.

После данной операции, объём занятого дискового пространства возрастёт на 0 B.

Хотите продолжить? [Д/н] Д

Настраивается пакет oracle-java8-installer (8u77+8u77arm-1~webupd8~1) …

Downloading Oracle Java 8... --2016-03-28 11:46:33-- http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar.gz

Распознаётся download.oracle.com (download.oracle.com)… 188.43.74.145, 188.43.74.144

Подключение к download.oracle.com (download.oracle.com)|188.43.74.145|:80... соединение установлено.

HTTP-запрос отправлен. Ожидание ответа... 302 Moved Temporarily

Адрес: https://edelivery.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.ta... [переход] --2016-03-28 11:46:36-- https://edelivery.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.ta...

Распознаётся edelivery.oracle.com (edelivery.oracle.com)… 23.61.230.140

Подключение к edelivery.oracle.com (edelivery.oracle.com)|23.61.230.140|:443... соединение установлено.

HTTP-запрос отправлен. Ожидание ответа... 302 Moved Temporarily

Адрес: http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar.... [переход]

--2016-03-28 11:46:39-- http://download.oracle.com/otn-pub/java/jdk/8u77-b03/jdk-8u77-linux-i586.tar....

Подключение к download.oracle.com (download.oracle.com)|188.43.74.145|:80... соединение установлено.

HTTP-запрос отправлен. Ожидание ответа... 416 Requested Range Not Satisfiable

Файл уже получен полностью; нет действий.

Download done.

Removing outdated cached downloads...

sha256sum mismatch jdk-8u77-linux-i586.tar.gz

Oracle JDK 8 is NOT installed.

dpkg: ошибка при обработке пакета oracle-java8-installer (--configure):

подпроцесс установлен сценарий post-installation возвратил код ошибки 1

При обработке следующих пакетов произошли ошибки: oracle-java8-installer

E: Sub-process /usr/bin/dpkg returned an error code (1)

mkm-2014 ()
Ответ на: комментарий от TeopeTuK

но мне эта программа совсем не нужна oracle java8 откуда оно взялось незнаю

mkm-2014 ()
Ответ на: комментарий от mkm-2014

Если не нужна, то удаляйте. Только надо внимательно прочитать, что она при удалении потянет за собой. А то вам не нужна, а кому-нибудь нужна.

TeopeTuK ★★ ()
Ответ на: комментарий от TeopeTuK

Не могу удалить, не удаляется и не устанавливается (((((( ошибка и не обновляется. Ошибка указала выше

mkm-2014 ()
Ответ на: комментарий от mkm-2014

Что имеется в виду под <<не могу удалить>>? Что именно запускалось для удаления? apt-get remove oracle-java8-installer? dpkg -r oracle-java8-installer? Или еще что-нибудь?

TeopeTuK ★★ ()

Вопрос не по теме

Что сделать попыталась?

Ты девушка?

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от gssomi

привет, isden? с сисями :3

Разумеется.

Сиси не обязательно голые )

Ну а ты-то уже предъявляла своё «удостоверение девушки ЛОРа»? )

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu

Ну а ты-то уже предъявляла своё «удостоверение девушки ЛОРа»?

нет еще =)

gssomi ★★ ()

да кстати, ты уже решила?

gssomi ★★ ()
Ответ на: комментарий от LongLiveUbuntu

Такое чувство что меня допрашивают. Трудностей нет, но я не хочу вот и все =)

gssomi ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.