LINUX.ORG.RU

Установка apache1.3 + php5


0

0

Доброго времени суток. Уже который день бьюсь над установкой Апача и пхп. Уже не помню с чего все началось. Но помоему с удаления Апача-2 и попытки поставить Апач-1.3 В общем уже не пойму что он от меня хочет. Система Дебиан.

Вот что он выдает: oleg:/home/oleg# apt-get install apache-common Чтение списков пакетов... Готово Построение дерева зависимостей... Готово Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install': Пакеты, имеющие неудовлетворённые зависимости: libapache2-mod-php4: Зависит: apache2-mpm-prefork (> 2.0.52) но он не будет установлен или apache2-mpm-itk но он не будет установлен Зависит: apache2.2-common но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение). oleg:/home/oleg# apt-get install php5 Чтение списков пакетов... Готово Построение дерева зависимостей... Готово Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install': Пакеты, имеющие неудовлетворённые зависимости: libapache-mod-php4: Зависит: apache-common (>= 1.3.34) но он не будет установлен libapache2-mod-php4: Зависит: apache2-mpm-prefork (> 2.0.52) но он не будет установлен или apache2-mpm-itk но он не будет установлен Зависит: apache2.2-common но он не будет установлен php5: Зависит: libapache2-mod-php5 (>= 5.2.0-8+etch1) но он не будет установлен или libapache-mod-php5 (>= 5.2.0-8+etch1) но он не будет установлен или php5-cgi (>= 5.2.0-8+etch1) но он не будет установлен Зависит: php5-common (>= 5.2.0-8+etch1) но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

anonymous

Re: Установка apache1.3 + php5

Большого толку от Апача версии 1.3.3 нету. Ставь старый Апач 2. Насчет зависимостей: ставь сперва Апач, потом все остальное. Можно на страх и риск без учета зависимостей. обрати внимание: Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета.

Zalman ()
Ответ на: Re: Установка apache1.3 + php5 от Zalman

Re: Установка apache1.3 + php5

Спасибо за ответ. Частично apt-get -f install помогло. Поставилось несколько пакетов, но остановилось как обычно на ошибке с libapache2-mod-php4 : Настраивается пакет libapache2-mod-php4 (4.4.4-8+etch1) ...

/usr/bin/ucf: line 330: getopt: command not found

dpkg: не удалось обработать параметр libapache2-mod-php4 (--configure):

подпроцесс post-installation script возвратил код ошибки 127

При обработке следующих пакетов произошли ошибки:

libapache-mod-php4

libapache2-mod-php4

E: Sub-process /usr/bin/dpkg returned an error code (1)

anonymous ()
Ответ на: Re: Установка apache1.3 + php5 от anonymous

Re: Установка apache1.3 + php5

по поводу apache2 говорят он не стабилен, потому и хочу поставить 1.3. ЗЫ: apt-get update / upgrage делал, не помогло. Пакеты ставятся "стабильные"

anonymous ()
Ответ на: Re: Установка apache1.3 + php5 от anonymous

Re: Установка apache1.3 + php5

Мне думается, что пакеты повреждены, либо взяты неизвестно откуда, и сделаны неизвестно кем. Так же может быть, что программа apt-get, могла быть установлена с поврежденного диска. Могу ошибаться. Но я так думаю, что в любом случае нужно выполнить установку этих пакетов с репозитария: apt-get install программа. ИМХО: с зависимостями должны париться только разработчики, а не юзеры и админы. Тем более в Debian.

Zalman ()
Ответ на: Re: Установка apache1.3 + php5 от Zalman

Re: Установка apache1.3 + php5

Да вроде пакеты не "с рынка". В sources.list только ftp.corbina да сам ftp.debian. apt-get до этого все ставила нормально (сижу уже около полугода). Пробывал поудалять все и поставить заново, так при apt-get remove или dpkg -r возникают те же ошибки с зависимостями. Нельзя ли как-нибудь очистить все что понаставлено связанное с апачем и пхп-ой? Сорри я в линуксе недавно и первый раз столкнулся с подобным...

anonymous ()
Ответ на: Re: Установка apache1.3 + php5 от anonymous

Re: Установка apache1.3 + php5

Можно. Но насколько я знаю только вручную. Опять таки без учета зависимостей. Опция --force-all. Могу крайне осторожно посоветовать установить Апач 1.3.3 из Slackware 11. Там другой менеджер пакетов. Я бы сделал вот что: собрал все из исходников, и не мучался.

Zalman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.