LINUX.ORG.RU

коряво удалил phpmyadmin как удалить инфу о нем


0

1

коряво удалил phpmyadmin, sudo apt-get autoremove phpmyadmin пишет:
Удаляется пакет phpmyadmin ...
.: 5: Can't open /usr/share/dbconfig-common/dpkg/prerm.mysql
dpkg: не удалось обработать параметр phpmyadmin (--remove):
подпроцесс установлен сценарий pre-removal возвратил код ошибки 127
.: 35: Can't open /usr/share/dbconfig-common/dpkg/postinst.mysql
dpkg: ошибка при очистке -
подпроцесс установлен сценарий post-installation возвратил код ошибки 127
При обработке следующих пакетов произошли ошибки:
phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get install apache2 php5 mysql-client mysql-server libapache2-mod-php5 libapache2-mod-auth-mysql php5-mysql пишет:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install':
Пакеты, имеющие неудовлетворённые зависимости:
apache2 : Зависит: apache2-mpm-worker (= 2.2.16-1ubuntu3.1) но он не будет установлен или
apache2-mpm-prefork (= 2.2.16-1ubuntu3.1) но он не будет установлен или
apache2-mpm-event (= 2.2.16-1ubuntu3.1) но он не будет установлен или
apache2-mpm-itk (= 2.2.16-1ubuntu3.1) но он не будет установлен
Зависит: apache2.2-common (= 2.2.16-1ubuntu3.1) но он не будет установлен
libapache2-mod-auth-mysql : Зависит: apache2.2-common (>= 2.2.3-3) но он не будет
установлен libapache2-mod-php5 : Зависит: apache2-mpm-prefork (> 2.0.52) но он не будет установлен или
apache2-mpm-itk но он не будет установлен
Зависит: apache2.2-common но он не будет установлен
Рекомендует: php5-cli но он не будет установлен
phpmyadmin : Зависит: php5-mcrypt но он не будет установлен
Зависит: dbconfig-common но он не будет установлен
Зависит: libjs-mootools (>= 1.2.4.0~debian1-1) но он не будет установлен
Рекомендует: php5-gd но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).

apt-get -f instal ничего недает

Ответ на: комментарий от anonymous

Настраивается пакет nginx (0.7.67-3ubuntu1) ...
При обработке следующих пакетов произошли ошибки:
libapache2-mod-php5
php5-cli
php5-fpm
php5-mcrypt
php5-mysql
phpmyadmin
E: Sub-process /usr/bin/dpkg returned an error code (1)

sersne ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.