LINUX.ORG.RU

[debian]lighttpd вместо apache


0

1
$ aptitude show  zabbix-frontend-php
...
...
Зависимости: debconf (>= 0.5) | debconf-2.0, apache2 | httpd, php5, php5-mysql | php5-pgsql, php5-gd, ucf, dbconfig-common (>= 1.8.19), libjs-prototype (>= 1.6.0.3), libjs-scriptaculous (>= 1.8.2), ttf-dejavu-core
Рекомендуются: zabbix-server-mysql | zabbix-server-pgsql, mysql-server (>= 4.0.16-2) | postgresql
...
...
$ aptitude show httpd
Нет в наличии или подходящей версии для httpd    
Пакет: httpd
Состояние: не реальный пакет
Предоставляется: aolserver4-core, aolserver4-daemon, apache2-mpm-event, apache2-mpm-itk, apache2-mpm-prefork, apache2-mpm-worker, boa, bozohttpd, cherokee, dhttpd, ebhttpd, lighttpd, mathopd, micro-httpd, mini-httpd, monkey, nginx-extras, nginx-full, nginx-light,
                                ocsigen, thttpd, tntnet, webfs, yaws
$ sudo aptitude install zabbix-frontend-php lighttpd
Следующие НОВЫЕ пакеты будут установлены:        
  apache2-mpm-prefork{a} apache2-utils{a} apache2.2-bin{a} apache2.2-common{a} dbconfig-common{a} fping{a} javascript-common{a} libapache2-mod-php5{a} libapr1{a} libaprutil1{a} libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a} libdbd-mysql-perl{a} libdbi-perl{a} 
  libgd2-xpm{ab} libhtml-template-perl{a} libiksemel3{a} libjs-prototype{a} libjs-scriptaculous{a} libmysqlclient16{a} libnet-daemon-perl{a} libonig2{a} libopenipmi0{a} libplrpc-perl{a} libqdbm14{a} libsensors4{a} libsnmp-base{a} libsnmp15{a} libterm-readkey-perl{a} 
  libterm-readline-perl-perl{a} lighttpd mysql-client-5.1{a} mysql-common{a} mysql-server{a} mysql-server-5.1{a} mysql-server-core-5.1{a} php5{a} php5-cli{a} php5-common{a} php5-gd{a} php5-mysql{a} php5-suhosin{a} snmpd{a} spawn-fcgi{a} ssl-cert{a} 
  wwwconfig-common{a} zabbix-frontend-php zabbix-server-mysql{a} 
0 пакетов обновлено, 48 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 41,6 MB архивов. После распаковки 107 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libgd2-noxpm: Конфликтует: libgd2 который является виртуальным пакетом.
                Конфликтует: libgd2-xpm но устанавливается 2.0.36~rc1~dfsg-5.1.
  libgd2-xpm: Конфликтует: libgd2 который является виртуальным пакетом.
              Конфликтует: libgd2-noxpm но установлен 2.0.36~rc1~dfsg-5.1 
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     libgd2-noxpm           


Принять данное решение? [Y/n/q/?]

Вопрос - как установить zabbix-frontend-php без apache?

p.s. корм для граммар-наци:

Состояние: не реальный пакет

или это правильно?

★★★★★

Правильно: «виртуальный пакет» :)

Sheridan ()

Видимо, дело в php5, который:
> Зависимости: libapache2-mod-php5 (>= 5.3.6-12) | libapache2-mod-php5filter (>= 5.3.6-12) | php5-cgi (>= 5.3.6-12) | php5-fpm (>= 5.3.6-12), php5-common (>= 5.3.6-12)

[17:50:35][aitap@Tarkus ~]> aptitude -s install  httpd lighttpd zabbix-frontend-php php5-cgi
Следующие НОВЫЕ пакеты будут установлены:
  dbconfig-common{a} fping{a} libdbd-mysql-perl{a} libdbi-perl{a} libgd2-xpm{ab} libiksemel3{a} libjs-prototype{a} libjs-scriptaculous{a} libnet-daemon-perl{a} libonig2{a}
  libopenipmi0{a} libplrpc-perl{a} libqdbm14{a} libsnmp-base{a} libsnmp15{a} mysql-client-5.1{a} mysql-server{a} mysql-server-5.1{a} mysql-server-core-5.1{a} php5{a} php5-cgi
  php5-common{a} php5-gd{a} php5-mysql{a} php5-suhosin{a} snmpd{a} zabbix-frontend-php zabbix-server-mysql{a}
0 пакетов обновлено, 28 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 36,9 MB архивов. После распаковки 93,3 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libgd2-noxpm: Конфликтует: libgd2 который является виртуальным пакетом.
                Конфликтует: libgd2-xpm но устанавливается 2.0.36~rc1~dfsg-5.1.
  libgd2-xpm: Конфликтует: libgd2 который является виртуальным пакетом.
              Конфликтует: libgd2-noxpm но установлен 2.0.36~rc1~dfsg-5.1
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     libgd2-noxpm



Принять данное решение? [Y/n/q/?]
Следующие НОВЫЕ пакеты будут установлены:
  dbconfig-common{a} fping{a} libdbd-mysql-perl{a} libdbi-perl{a} libgd2-xpm{a} libiksemel3{a} libjs-prototype{a} libjs-scriptaculous{a} libnet-daemon-perl{a} libonig2{a}
  libopenipmi0{a} libplrpc-perl{a} libqdbm14{a} libsnmp-base{a} libsnmp15{a} mysql-client-5.1{a} mysql-server{a} mysql-server-5.1{a} mysql-server-core-5.1{a} php5{a} php5-cgi
  php5-common{a} php5-gd{a} php5-mysql{a} php5-suhosin{a} snmpd{a} zabbix-frontend-php zabbix-server-mysql{a}
Следующие пакеты будут УДАЛЕНЫ:
  libgd2-noxpm{a}
0 пакетов обновлено, 28 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 36,9 MB архивов. После распаковки 92,6 MB будет занято.
Хотите продолжить? [Y/n/?]
Эти пакеты были бы загружены/установлены/удалены.
[17:51:22][aitap@Tarkus ~]> 
AITap ★★★★★ ()
Ответ на: комментарий от AITap

Спасибо! [br]
А просто запретить апач в системе можно? В генту можно через USE-флаги...

Sheridan ()
Ответ на: комментарий от Sheridan

> запретить апач в системе
Попробуйте поставить hold на apache2.2-common.

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.