LINUX.ORG.RU
ФорумAdmin

apache2 + mod_рhp5


0

0

Привет всем!
Может кто-нибудь сталкивался с такой проблемой.
Стоит ALT Linux 4 server.
[root@spring conf]# rpm -qa | grep apache2
apache2-common-2.2.6-alt2
apache2-2.2.6-alt2
apache2-mod_ssl-2.2.6-alt2
apache2-mod_php5-5.2.2-alt1
apache2-httpd-worker-2.2.6-alt2
apache2-manual-2.2.6-alt2
apache2-devel-2.2.6-alt2

[root@spring conf]# rpm -qa | grep php
php-base-2.2-alt1
php5-libs-5.2.2-alt1
php5-5.2.2-alt1
php5-curl-5.2.2-alt1
php5-dom-5.2.2-alt1
php5-mbstring-5.2.2-alt1
php5-mysqli-5.2.2-alt1
php5-rrdtool-5.2.2-alt1
php5-zip-5.2.2-alt1
apache2-mod_php5-5.2.2-alt1
php5-suhosin-0.9.19-alt1
php5-calendar-5.2.2-alt1
php5-dba-5.2.2-alt1.1
php5-exif-5.2.2-alt1
php5-gd2-5.2.2-alt1
php5-mysql-5.2.2-alt1
php5-openssl-5.2.2-alt1
php5-simplexml-5.2.2-alt1

При попытке стартовать apache...он вываливается и пишет:
[root@spring conf]# /etc/init.d/httpd2 start
\Starting httpd2 service: [Thu Nov 19 19:02:23 2009] [crit] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP.
Pre-configuration failed



Есть ли какие-нибудь варианты без пересбора php вручную?


apache2 + mod_рhp5

Попробуй поискать нечто вроде apache2-httpd-prefork и накатить его (при этом должно удалиться apache2-httpd-worker).

А вообще я бы посоветовал менять дистр. Ибо криворукость дистростроителей в данном случае просто эпическая.

nnz ★★★★ ()
Ответ на: apache2 + mod_рhp5 от nnz

apache2 + mod_рhp5

Спасибо огромное!
Всё заработало :)

BusTeR ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.