LINUX.ORG.RU

etch->lenny


0

0

Решил обновится до ленни, прописал в соурлист репы ленни. В консоле apt-get update. Потом пишу ddr:/home/ddr# apt-get upgrade Чтение списков пакетов... Готово Построение дерева зависимостей... Готово Возможно, для исправления этих ошибок вы захотите воспользоваться `apt-get -f install'. Пакеты, имеющие неудовлетворённые зависимости: climm: Зависит: libc6 (>= 2.5-0ubuntu1) но 2.3.6.ds1-13etch4 уже установлен Зависит: libgcc1 (>= 1:4.1.2) но 1:4.1.1-21 уже установлен Зависит: libstdc++6 (>= 4.1.2) но 4.1.1-21 уже установлен E: Неудовлетворённые зависимости. Попытайтесь использовать -f. С ключом -f тоже не хочет пахать, как можно обновиться все пакеты зависимые каскадно? И как можно дообновится до ленни? Заранее благодарю за ответ.

★★

Re: etch->lenny

> libc6 (>= 2.5-0ubuntu1)

?? O_O

isden ★★★★★ ()

Re: etch->lenny

> libc6 (>= 2.5-0ubuntu1)

Ты чего за репозиторий прописал и при чём тут пакет из Ubuntu?

grad ()
Ответ на: Re: etch->lenny от DDR

Re: etch->lenny

А, тогда ясно: approx не предназначен для одновременной работы с репозиториями и Debian'a и Ubuntu, так как он не видит разницы между пакетами из разных репозиториев, но у которых совпадает версия. Поэтому, часто бывает так, что approx выдаёт дебианщикам убунтовский пакет и наоборот.

grad ()
Ответ на: Re: etch->lenny от grad

Re: etch->lenny

Оч хорошее описание))) А проблему как решить не подскажешь?

DDR ★★ ()
Ответ на: Re: etch->lenny от DDR

Re: etch->lenny

> А проблему как решить не подскажешь?

Подскажу: подключи нормальный официальный репозиторий, иначе такие проблемы будут возникать постоянно, т.к. версии пакетов в testing/unstable и ubuntu очень часто совпадают.

grad ()

Re: etch->lenny

>apt-get upgrade

Кроме уже сказанного, надо делать
apt-get dist-upgrade

sdio ★★★★★ ()
Ответ на: Re: etch->lenny от sdio

Re: etch->lenny

тогда уж aptitude safe-upgrade

или в etch еще нет такой команды?

maloi ★★★★★ ()
Ответ на: Re: etch->lenny от sdio

Re: etch->lenny

Вторую команду (apt-get dist-upgrade) тоже делал, получил примерно тоже самое, оф репа не подойдет, ибо трафик платный. С этим можно чтонить запинать?

DDR ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.