LINUX.ORG.RU

Не могу обновить Debian

 , ,


0

1

Привет ЛОР!

Не могу выполнить apt-get upgrade

При его выполнении:

Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libc6 : Зависит: libc-bin (= 2.13-38+deb7u4)
 libc6:i386 : Зависит: libc-bin:i386 (= 2.13-38+deb7u4)
 libc6-dev : Зависит: libc6 (= 2.13-38+deb7u6) но 2.13-38+deb7u4 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

В системе нет левых реп, до этого я только ставил ia32-libs таким путем:

dpkg --add-architecture i386
apt-get update 
apt-get install ia32-libs

При попытке apt-get -f install

Чтение журнала изменений... Выполнено                 
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44, <DEBCONF_CONFIG> chunk 3.
...
debconf: DbDriver "config": mkdir :No such file or directory
dpkg: ошибка при обработке параметра /var/cache/apt/archives/libc6_2.13-38+deb7u6_i386.deb (--unpack):
 подпроцесс новый сценарий pre-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libc6_2.13-38+deb7u6_amd64.deb
 /var/cache/apt/archives/libc6_2.13-38+deb7u6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Что можно еще сделать?


dpkg --clear-selections не помогает?

Meyer ★★★ ()

системе нет левых реп

небось со stable до testing/unstable обновить пытаешься?)

Meyer ★★★ ()
Ответ на: комментарий от Woklex

При попытке apt-get -f install

Попробуй aptitude. Ну, как вариант - удалить libc:i386. И заодно архитектуру. dpkg --remove-architecture i386

Meyer ★★★ ()
Последнее исправление: Meyer (всего исправлений: 1)
Ответ на: комментарий от Meyer

aptitude тоже не помогает. Удалять пока ничего не буду, может кто еще чего предложит.

Woklex ()
Ответ на: комментарий от turtle_bazon

Как решить проблему? Почему когда мне понадобились 32-битные либы, то это в итоге привело к не рабочему дистрибутиву?

Получается я сломал дебиан вот такими командами:

dpkg --add-architecture i386
apt-get update 
apt-get install ia32-libs

Какой-то он не особо стабильный.

Woklex ()
Ответ на: комментарий от turtle_bazon

Так и подумал что сделали что-то не так, просто натыкался что именно так и ставили.

Woklex ()
Ответ на: комментарий от turtle_bazon

А как в итоге ставить ia32-libs на будущее? Что-то много где сейчас читаю, ставят как я выше.

Woklex ()
Ответ на: комментарий от Meyer

Если попытаться удалить libc6, то также проблемы с зависимостями.

dpkg: проблемы с зависимостями не позволяют удалить пакет libc6:i386:
 libxau6:i386 зависит от libc6 (>= 2.1.3).
 libssh2-1:i386 зависит от libc6 (>= 2.4).
 libkrb5-3:i386 зависит от libc6 (>= 2.9).
 libwrap0:i386 зависит от libc6 (>= 2.11).
 libcap2:i386 зависит от libc6 (>= 2.3).
 libxt6:i386 зависит от libc6 (>= 2.7).
 libasyncns0:i386 зависит от libc6 (>= 2.3.6-6~).
 libgphoto2-port0:i386 зависит от libc6 (>= 2.4).
 libstdc++5:i386 зависит от libc6 (>= 2.3).
 libstdc++6:i386 зависит от libc6 (>= 2.11).
 libxcursor1:i386 зависит от libc6 (>= 2.3).
 libpng12-0:i386 зависит от libc6 (>= 2.11).
 libxxf86vm1:i386 зависит от libc6 (>= 2.1.3).
 libsm6:i386 зависит от libc6 (>= 2.1.3).
 libselinux1:i386 зависит от libc6 (>= 2.8).
 libp11-kit0:i386 зависит от libc6 (>= 2.4).
 libjson0:i386 зависит от libc6 (>= 2.8).
 libesd0
Woklex ()
Ответ на: комментарий от Woklex

Ну если что-то помимо libc6 поставлено в i386, то, чтобы этот libc6 удалить, надо и всё остальное удалить.

turtle_bazon ★★★ ()
Ответ на: комментарий от Woklex

Надо не ia32-libs ставить, а нужные библиотеки, которых не хватает (соответствующие пакеты). А посмотреть с помощью ldd можно что нужно. Или ставить 32-битный деб пакет.

turtle_bazon ★★★ ()
Ответ на: комментарий от Woklex

А конкретно у тебя libc6-dev либо удали, либо установи версию 7u4

turtle_bazon ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.