LINUX.ORG.RU

обновление пакетов debian - не поддерживается dpkg


0

1

Столкнулся с такой проблемой. Хочу обновить версии софта на debian. Например при установке с диска поставился named 9.3.4 Хочу обновить. В /etc/apt/sources.list Добавил национальное зеркало debian, одно из указанных на сайте. Даю значит команду: apt-get install bind9 получаю в результате: dpkg: regarding .../libc-bin_2.11.2-10_i386.deb containing libc-bin: package uses Breaks; not supported in this dpkg dpkg: error processing /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb (--unpack): unsupported dependency problem - not installing libc-bin configured to not write apport reports Errors were encountered while processing: /var/cache/apt/archives/libc-bin_2.11.2-10_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Думаю обновить сам dpkg - получается таже фигня. В результате немогу ничего обновть. Что делать?

not installing libc-bin configured - копай чего ставить!

ipwww ★★ ()

Это вы через 2 релиза Debian'a прыгнули, что ли? Никогда так больше не делайте.

Что ж.

1) Делаете aptitude download dpkg, либо ручками качаете пакет отсюда: http://packages.debian.org/stable/dpkg (ссылки внизу).
2) Делайте dpkg -i <скачанный_файл.deb>.

Если установит без ошибок - вам повезло и можно работать дальше.

JackYF ★★★★ ()
Ответ на: комментарий от Eurofighter

Да, ты прав, этот флаг тоже может понадобиться.

JackYF ★★★★ ()
Ответ на: комментарий от JackYF

наверное через два релиза. Интеркаляционный диск очень старый. не повезло:

dpkg -i dpkg_1.15.8.10_i386.deb dpkg: regarding dpkg_1.15.8.10_i386.deb containing dpkg, pre-dependency problem: dpkg pre-depends on libc6 (>= 2.6) libc6 is installed, but is version 2.3.6.ds1-13. dpkg: error processing dpkg_1.15.8.10_i386.deb (--install): pre-dependency problem - not installing dpkg Errors were encountered while processing: dpkg_1.15.8.10_i386.deb

sidewinder ()
Ответ на: комментарий от Eurofighter

сделал. Теперь вообще не запускается: dpkg update dpkg: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.6' not found (required by dpkg)

Теперь хоть бы старую версию вернуть, а то так ничего не будет работать

sidewinder ()
Ответ на: комментарий от sidewinder

И уже не поможет.

Бэкапь всё и переустанавливай stable. Можно поизвращаться, но так будет быстрее и правильнее всего.

JackYF ★★★★ ()
Ответ на: комментарий от sidewinder

Как вариант извращения:
1. загрузиться с livecd (что-нибудь на основе debian)
2. смонтировать root в /target
3. забекапить /var/lib/{dpkg,apt,aptitude}
4. сделать debootstrap stable /target http://ftp.ru.debian.org/debian/
5. заменить содержимое /var/lib/{dpkg,apt,aptitude} на данные из бекапа
6. загрузиться в систему и обновиться.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Спасибо. Лучше уэ тогда не восстанавливать а поставить новую версию сразу.

sidewinder ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.