LINUX.ORG.RU

FTP


0

1

Надо поставить ftp

aptitude install proftpd и выдает...

Preconfiguring packages ... warning, in file '/var/lib/dpkg/status' near line 4647 package 'plesk-key-custom': missing description (Reading database ... 81204 files and directories currently installed.) Unpacking proftpd-basic (from .../proftpd-basic_1.3.3a-6squeeze1_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze1_amd64.deb (--unpack): trying to overwrite '/etc/pam.d/proftpd', which is also in package psa-proftpd 1.3.3e-debian6.0.build1012110621.18 configured to not write apport reports dpkg-deb: subprocess paste killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover: warning, in file '/var/lib/dpkg/status' near line 4647 package 'plesk-key-custom': missing description

Дистрибутив, его версию, содержимое /etc/apt/sources.list телепаты, естественно, должны угадать, верно?

adriano32 ★★★ ()
Ответ на: комментарий от kostik87

root@server:~# apt-get update Hit http://security.debian.org squeeze/updates Release.gpg Ign http://security.debian.org/ squeeze/updates/main Translation-de Ign http://security.debian.org/ squeeze/updates/main Translation-en Hit http://security.debian.org squeeze/updates Release Hit http://security.debian.org squeeze/updates/main Sources Hit http://security.debian.org squeeze/updates/main amd64 Packages Hit ftp://ftp2.de.debian.org squeeze Release.gpg Get:1 ftp://ftp2.de.debian.org/debian/ squeeze/contrib Translation-de Ign ftp://ftp2.de.debian.org/debian/ squeeze/contrib Translation-de Get:2 ftp://ftp2.de.debian.org/debian/ squeeze/contrib Translation-en Ign ftp://ftp2.de.debian.org/debian/ squeeze/contrib Translation-en Hit ftp://ftp2.de.debian.org/debian/ squeeze/main Translation-de Get:3 ftp://ftp2.de.debian.org/debian/ squeeze/main Translation-en Ign ftp://ftp2.de.debian.org/debian/ squeeze/main Translation-en Get:4 ftp://ftp2.de.debian.org/debian/ squeeze/non-free Translation-de Ign ftp://ftp2.de.debian.org/debian/ squeeze/non-free Translation-de Get:5 ftp://ftp2.de.debian.org/debian/ squeeze/non-free Translation-en Ign ftp://ftp2.de.debian.org/debian/ squeeze/non-free Translation-en Hit ftp://ftp2.de.debian.org squeeze Release Hit ftp://ftp2.de.debian.org squeeze/main amd64 Packages Hit ftp://ftp2.de.debian.org squeeze/contrib amd64 Packages Hit ftp://ftp2.de.debian.org squeeze/non-free amd64 Packages Reading package lists... Done root@server:~# apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

ensirius ()
Ответ на: комментарий от kostik87

Не видишь, у него plesk-панель установлена, ты ему сейчас с -i что-то перезапишешь, и человек будет тебе очень благодарен.

Пусть забэкапит сперва /etc/ и /var.

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

Вообщем понятно.Этот плеск панель моит мозги.

The following packages will be REMOVED: plesk-core plesk-key-custom plesk-l10n pp-sitebuilder psa psa-atis psa-atmail psa-backup-manager psa-cs-gs psa-fileserver psa-firewall psa-health-monitor psa-horde psa-imp psa-ingo psa-kronolith psa-migration-agents psa-migration-manager psa-mimp psa-mnemo psa-passwd psa-proftpd psa-spamassassin psa-turba psa-updates psa-vhost psa-vpn psa-watchdog sshterm 0 upgraded, 0 newly installed, 29 to remove and 1 not upgraded. After this operation, 459 MB disk space will be freed.

Удлаять можно как я понимаю:?

ensirius ()
Ответ на: комментарий от adriano32

Я не знаю что выбрать.Логического выбора гугл транслит не дает

Eine neue Version der Konfigurationsdatei /etc/proftpd/proftpd.conf ist │ │ verf??gbar, aber die installierte Version wurde ver??ndert. │ │ │ │ Wie wollen Sie mit der ge??nderten Konfigurationsdatei proftpd.conf │ │ verfahren? │ │ │ │ Version des Paket-Betreuers installieren │ │ aktuell installierte Version behalten │ │ Unterschiede zwischen den Versionen anzeigen │ │ Unterschiede zwischen den Versionen nebeneinander anzeigen │ │ die Angelegenheit in einer neu gestarteten Shell untersuchen

ensirius ()
Ответ на: комментарий от ensirius

Version des Paket-Betreuers installieren

Пускай ставит из коробки

adriano32 ★★★ ()
Ответ на: комментарий от ensirius

Выложи туда же конфиг proftpd.conf, который сейчас имеется

insserv: warning: script 'K01drwebd' missing LSB tags and overrides
insserv: warning: script 'psa-vpn' missing LSB tags and overrides
insserv: warning: script 'psa-firewall' missing LSB tags and overrides
insserv: warning: script 'drwebd' missing LSB tags and overrides
insserv: warning: script 'psa-firewall-forward' missing LSB tags and overrides
И DRWEB ещё стоит? О_о

psa-* надо будет поубирать

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

Последние строки в рекомендованом конфиги не нравятся.

- Fatal: unknown configuration directive 'DisplayFirstChdir' on line 53 of '/etc/proftpd/proftpd.conf' failed!

ensirius ()
Ответ на: комментарий от ensirius

Закомментируй, там указаны файлы, в которых тексты приветствий залогинившемуся. Или создай их и внеси какой-нибудь текст.

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

Starting ftp server: proftpd - warning: unknown/unsupported LANG environment variable 'ru_RU.UTF-8', ignoring . root@server:~#

Вроде запустили.Ошибка из за того что я пытался сделать с немецкого русский +D

ensirius ()
Ответ на: комментарий от adriano32

root@server:/sbin# ps aux | grep proftp root 3749 0.0 0.0 9860 752 pts/0 S+ 16:17 0:00 grep proftp

В бразуере не чего) а еще я заметил что у меня апачь стоит какова то хера))

ensirius ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.