LINUX.ORG.RU

Ubuntu apt-get ошибка при установки программ

 


0

1

Здравствуйте, при попытки установить «atop»

test@test:~$ sudo apt-get install atop
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 linux-headers-generic : Зависит: linux-headers-3.13.0-73-generic но он не будет установлен
 linux-image-generic : Зависит: linux-image-extra-3.13.0-73-generic но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
test@test:~$ 

И в чём проблема выполнить apt-get -f install?

Deleted ()

Сломал ты свой дистр уже.

Переустанавливай все.

bookman900 ★★★★★ ()
Ответ на: комментарий от Deleted

Подробности не вспомню, но лично у меня было такое, что apt-get -f install не помогал.

По теме - начинай с

sudo apt-get install -f
Если будет ошибка - давай сюда выхлоп.

ekzotech ★★★★ ()
Ответ на: комментарий от bookman900

И нафиг так делать? Может человек новичок в линуксе и вообще первый раз в жизни ubuntu тыкает?

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

Значит дотыкался.

Для новичков есть «Центр Приложений Ubuntu»

Как бэ зря новичков на терминальчик направляют.

bookman900 ★★★★★ ()
Ответ на: комментарий от bookman900

но если их не направлять по правильному пути они ничему так и не научатся. Потыкают, сломают, починят и намотают на ус. Ведь вы тоже, когда то были таким же новичком.

gssomi ★★ ()

А вам следует научиться гуглить.

gssomi ★★ ()
Ответ на: комментарий от gssomi

Я и щас если получаю такие ошибки переустанавливаю дистр — благо не винда. С пиратсвом мзды не получишь.

Мне например быстрее переустановить, чем пытаться восстановить систему, когда случайно не ту либу прокачал, а при попытке удаления получаю сообщение о потенциальном сносе половины DE.

bookman900 ★★★★★ ()
Ответ на: комментарий от gssomi

Убунта — не арч и не гента. Не надо над ней мудохаться. Она для домохозяек.

bookman900 ★★★★★ ()
Ответ на: комментарий от bookman900

Линукс всегда остается линуксом. вот допустим вы установили себе какой нибудь дистр (пусть будет убунта), настроили под себя. И тут у вас вышла ошибка, которую может можно было исправить одной командой. Вы снесете всю настроенную систему только из-за того что у вас выскочила одна ошибка?

gssomi ★★ ()
Ответ на: комментарий от gssomi

Какой командой? Install -f?

А кто потом будет разгребать зависимости?

Линукс же не сможет за тебя перенастроить зависимости. И одним удалением ломающей либы не управишься. Система запайпила все линки к этой либе.

Один раз я хотел переустановить Atril на самую свежую версию. Пытался скачать все либы с pkgs.org. Скачал. Последовательно поставил. В одной из либ вскочила ошибка. Я нашал install -f. Atril не запустился. Через Synaptic удаляю либу, а она мне в ответ пишет, что половину MATE снесет к сену.

Итог: Сижу теперь на KDE. И больше без надобности apt-get не делаю.

bookman900 ★★★★★ ()
Ответ на: комментарий от bookman900

бгггг. Ну видимо это от человека и его терпения зависит.

gssomi ★★ ()
Ответ на: комментарий от bookman900

ты стрелял-стрелял себе в ногу, прострелил шнурок и перешел на два протеза? гениально. а что это доказывает?

t184256 ★★★★★ ()
Ответ на: комментарий от bookman900

Мне например быстрее переустановить, чем пытаться восстановить систему, когда случайно не ту либу прокачал, а при попытке удаления получаю сообщение о потенциальном сносе половины DE.

Пожалуйста, скажи, что ты меня троллишь. Сколько ты раз в день систему переставляешь тогда?

ekzotech ★★★★ ()
Ответ на: комментарий от bookman900

А кто потом будет разгребать зависимости?

Пакетный менеджер. Ну может тебе понадобится ещё пару пакетов указать.

Пытался скачать все либы с pkgs.org. Скачал. Последовательно поставил. В одной из либ вскочила ошибка. Я нашал install -f. Atril не запустился. Через Synaptic удаляю либу, а она мне в ответ пишет, что половину MATE снесет к сену.

Ты серьёзно? Ты превратил систему в бардак, поломал зависимости - и «оно само поломалось»?

Для таких вещей нужно использовать ppa. Если ppa нет - собирай сам .deb на замену. Или используй генту или арч.

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

раз в год, когда запарываю либу. В остальное время я просто работаю, и система просто работает.

bookman900 ★★★★★ ()
Ответ на: комментарий от ekzotech

О, а ты не линуксоид. Линуксоид знает, что на pkgs.org бинарники и хранятся

bookman900 ★★★★★ ()

Сколько клоунов понабежало

в студию

uname -a

Если версия младше требуемой

apt-get dist-upgrade

anonymous ()
Ответ на: комментарий от ekzotech

Ты превратил систему в бардак, поломал зависимости - и «оно само поломалось»?

Одна конфликтующая либа lib6.so не может быть объектом ломки всего. А вот пакетный манагер так не думает. эПоэтому для установки свежего софта да, юзать Арч.

bookman900 ★★★★★ ()
Ответ на: комментарий от bookman900

по барабану, хотя если выпуск старый, то возможно придется апгрэйдить

anonymous ()
Ответ на: комментарий от bookman900

а бэкпорты в lts уже отменили что ли?

ТС куда то слился

SevikL ★★★★ ()
Ответ на: комментарий от bookman900

когда-нибудь и ты научишься в apt-cache policy и установку нужной версии прямо из «убогого пакетного менеджера»

SevikL ★★★★ ()
Ответ на: комментарий от bookman900

не может быть объектом поломки всего
libc

Да, я никогда так не ржал.

DeadEye ★★★★★ ()
Ответ на: комментарий от bookman900

И ты берёшь пакет с либой и ставишь его, ломая все зависимости? И потом удивляешься, почему пакетный менеджер сходит с ума?

ekzotech ★★★★ ()
Ответ на: комментарий от bookman900

Одна конфликтующая либа lib6.so не может быть объектом ломки всего.

А поломанные зависимости - очень даже.

ekzotech ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.