LINUX.ORG.RU

конфликт зависимостей

 


0

1

ubuntu 12.04. Невозможно ничего установить, требует исправить. Не могу понять как исправить. Пишет, что установлена уже версия 100, но требует версию 46 и не может установить. -f пробовал - бестолку. Ктото пробовал удалить мешающие ядра, так система совсем сдохла. Есть идеи?

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 linux-generic-pae : Зависит: linux-headers-generic-pae (= 3.2.0.38.46) но 3.2.0.86.100 уже установлен
 linux-image-generic-pae : Зависит: linux-image-3.2.0-38-generic-pae но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.

Ну так а выхлоп "-f" где?

dvrts ★★★ ()

«sudo apt-get install -f»

Если не поможет, то делай apt-get purge на все «linux-headers», «linux-image» и прочие extras в системе. Потом ставь «linux-image» нужный без версии и «linux-headers» так же.

Я так какую-то убунту от старых ядер чистил, которые почему-то при обновлении не сносились.

Совет ни ахти какой. :)

Radjah ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.