LINUX.ORG.RU

Исправления ошибок при настройках системы

 


1

1

Следую рекомендуемым настрокам после установки ОС, вот ссылка на их https://losst.ru/nastrojka-debian-9-posle-ustanovki , не получаеться выполнить все согласно инструкции, так ка при работе с терминалом возникают ошибки. Итак, первый шаг: вводим кманду hrebynakha@debian:~$ su после чего попадаем на права суперпользувателя root root@debian:/home/hrebynakha# , далее вводим команды на обновления сисетмы у установку этих обновлений apt-get update apt-get upgrade, и на этапе установки apt-get upgrade возникает следующая ошибка: root@debian:/home/hrebynakha# apt-get upgrade Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install». Пакеты, имеющие неудовлетворённые зависимости: 0ad : Зависит: 0ad-data (>= 0.0.21) но он не установлен Зависит: 0ad-data (<= 0.0.21-2) но он не установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение). Вопрос: как исправить данную ошибку E

Ответ на: комментарий от Vsevolod-linuxoid

не так все просто...

apt install -f 

E: Работа dpkg прервана, вы должны вручную запустить «dpkg --configure -a» для устранения проблемы.

 dpkg --configure -a 

Настраивается пакет docbook-xsl (1.79.1+dfsg-2) …
Обрабатываются триггеры для sgml-base (1.29) …
Настраивается пакет libglade2-0:amd64 (1:2.6.4-2) …
dpkg: зависимости пакетов не позволяют настроить пакет 0ad:
 0ad зависит от 0ad-data (>= 0.0.21), однако:
  Пакет 0ad-data не установлен.
 0ad зависит от 0ad-data (<= 0.0.21-2), однако:
  Пакет 0ad-data не установлен.

dpkg: ошибка при обработке пакета 0ad (--configure):
 проблемы зависимостей — оставляем не настроенным
Настраивается пакет libattica0.4:amd64 (0.4.2-2) …
Настраивается пакет libkdeui5 (4:4.14.26-2) …
Настраивается пакет libkrosscore4 (4:4.14.26-2) …
Настраивается пакет libgnomecanvas2-0:amd64 (2.30.3-3) …
Настраивается пакет libnepomuk4 (4:4.14.26-2) …
Настраивается пакет libkio5 (4:4.14.26-2) …
Настраивается пакет libnepomukquery4a (4:4.14.26-2) …
Настраивается пакет libkcmutils4 (4:4.14.26-2) …
Настраивается пакет planner (0.14.6-5) …
Настраивается пакет libknewstuff3-4 (4:4.14.26-2) …
Настраивается пакет libnepomukutils4 (4:4.14.26-2) …
Настраивается пакет kdelibs-bin (4:4.14.26-2) …
Настраивается пакет libkparts4 (4:4.14.26-2) …
Настраивается пакет libktexteditor4 (4:4.14.26-2) …
Настраивается пакет libkatepartinterfaces4 (4:4.14.3-4) …
Настраивается пакет katepart (4:4.14.3-4) …
Обрабатываются триггеры для libc-bin (2.24-11+deb9u1) …
При обработке следующих пакетов произошли ошибки:
 0ad
hrebynakha ()
Ответ на: комментарий от Radjah

Извенения

Прошу прощения, я новичок, с правилами оформления только ознакомливаюсь. Спасибо за понимание!

hrebynakha ()
Ответ на: комментарий от Vsevolod-linuxoid

0ad

на сколько я все правильно понимаю, то ошибка кроеться в неком пакете 0ad, едитнственно что у меня связывает с этим пакетом, это установленое приложения (игра стратегия) по умолчанию, которая так и называеться 0.a.d

hrebynakha ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.