LINUX.ORG.RU

Пакеты, имеющие неудовлетворённые зависимости:

 ,


0

1

Недельку назад установил Linux Deepin, устанавливал разный софт из магазина, при установке LibreOffice вышла какая то ошибка, теперь не могу установить вообще ничего. Помогите пожалуйста!

sudo apt-get install synaptic
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:6.0.4) но он не будет установлен
 libreoffice-help-ru : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-java-common : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-l10n-ru : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-ogltrans : Зависит: libreoffice-common но он не будет установлен
 libreoffice-report-builder : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-script-provider-bsh : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-script-provider-js : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-script-provider-python : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-style-galaxy : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 libreoffice-style-tango : Зависит: libreoffice-common (= 1:6.0.4-1) но он не будет установлен
 synaptic : Зависит: libept1.5.0 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).

Ответ на: комментарий от Vsevolod-linuxoid
sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 fonts-sil-gentium fonts-sil-gentium-basic
  libbsh-java libcdr-0.1-1 libfreehand-0.1-1 libmspub-0.1-1 libpagemaker-0.0-0 libqxp-0.0-0 libreoffice-avmedia-backend-gstreamer libreoffice-calc
  libreoffice-draw libreoffice-impress libreoffice-librelogo libreoffice-nlpsolver libreoffice-ogltrans libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-wiki-publisher libvisio-0.1-1 libzmf-0.0-0 lp-solve
Для их удаления используйте «sudo apt autoremove».
Будут установлены следующие дополнительные пакеты:
  libreoffice-common
НОВЫЕ пакеты, которые будут установлены:
  libreoffice-common
Обновлено 0 пакетов, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 28 пакетов.
Необходимо скачать 0 B/26,2 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 84,4 MB.
Хотите продолжить? [Д/н] Д
(Чтение базы данных … на данный момент установлено 371900 файлов и каталогов.)
Подготовка к распаковке …/libreoffice-common_1%3a6.0.4-1_all.deb …
Распаковывается libreoffice-common (1:6.0.4-1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libreoffice-common_1%3a6.0.4-1_all.deb (--unpack):
 попытка перезаписать «/usr/bin/soffice», который уже имеется в пакете openoffice-debian-menus 4.1.5-9789
rmdir: не удалось удалить '/var/lib/libreoffice/share/prereg/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/share/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/program/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a6.0.4-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
kodyatemirov ()

Вальни libreoffice-core с помощью 'apt purge', потом 'apt update' и попробуй поставить снова, если он тебе нужен.

WitcherGeralt ★★ ()

Это ты на аватарке?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.