LINUX.ORG.RU

Установлены ли у вас приложения при помощи пакетов snap, flatpak или appimage?

 , ,


0

2

Опрос не ставит целью узнать, какой формат пакетов лучше, мы прекрасно с этим справимся в комментах (на самом деле, разумеется, нет). Просто – пользуетесь или не пользуетесь, а если пользуетесь, насколько глубоко.

  1. таких приложений не установлено458 (65%)

    ********************************************************************************************************************************************************************************************************************************************************************************************************************************

  2. установлено до 5 приложений191 (27%)

    *************************************************************************************************************************************

  3. установлено до 10 приложений37 (5%)

    *************************

  4. установлено 25 и больше8 (1%)

    *****

  5. установлено до 20 приложений7 (1%)

    ****

  6. установлено до 15 приложений5 (1%)

    ***

  7. установлено до 25 приложений2 (0%)

    *

Всего голосов: 708

>>> Проголосовать

★★★★★

Проверено: Satori ()

Ответ на: комментарий от James_Holden

Кстати, если кто не видел — древний не совсем прямо аналог, но похожий концепт: https://0install.net/

Там нет оверхеда на контейнеризацию и есть упор на поддержку разных архитектур, включая винды и BSD. Но и стабильность нижележащей платформы не гарантирована из-за этого. Хотя в то время контейнеры не были в тренде. В принципе, я думаю, довольно легко допиливается до контейнеров без потери совместимости с уже опубликованными артефактами.

Если бы тот же Шатл лет 10 назад поддержал эту уже существующую активную разработку, а не строил планы по захвату мира, проблемы из области «а в других сферах задница» могли бы закончиться намного раньше.

wandrien ()
Последнее исправление: wandrien (всего исправлений: 1)

Установлены Kube и Neochat (через flatpak), хотя не пользуюсь.

aspotashev ★★★ ()
Последнее исправление: aspotashev (всего исправлений: 1)
Ответ на: комментарий от tereshchenko

Как ребенок. Ubuntu 18.04 и 20.04

Red Hat Enterprise Linux 7-8 Остальные соберут сами по образцу.

А зачем хамить, и притом еще писать чушь?

До свидания.

James_Holden ()
Ответ на: комментарий от James_Holden

Извиняюсь, не ожидал, что обижу. Честно не понимаю плач разработчиков во многих ветках про сложность пакетирования.

tereshchenko ★★ ()

ungoogled-chromium-appimage с AUR считается?)

d09 ()
Ответ на: комментарий от Desmond_Hume

Я так понял, в основном, возражения в том, что:

  • Разрабатывается кривыми ручками Каноникла.
  • Детали реализации ОС активно протекают в снап-пакеты. Во флатпаке такого нет.

Я бы еще добавил к этому, что есть неиллюзорный шанс, что Каноникл выкинет проект на мороз, как было с предыдущими её великими проектами типа Mir.

wandrien ()
Последнее исправление: wandrien (всего исправлений: 1)
Ответ на: комментарий от James_Holden

один deb пакет подходит только под одну версию своего же дистрибутива

Неправда. Это в основном из-за того, что делают по дедовским правилам – со всеми разбиваниями по зависимостями. Вот там Boost засунем определённой версии как пакетную зависимость, то, сё…

Из вне этого мира плевали на это - Opera, Chrome, VirtualBox, Steam.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 3)
Ответ на: комментарий от Tanger

«Anyway it’s free software!» © Stallman

Нечего тут стыдиться, дистрибы разные нужны, дистрибы разные важны. Чем бы дитя не тешилось, лишь бы не Windows )

Aceler ★★★★★ ()
Ответ на: комментарий от James_Holden

А что в этом плохого? Во Flatpak во многом так и есть. И жрёт он будь здоров места.

Только вот сделан накось какось. Но надо разделять — тут умные линуксоиды, а там глупые вендузятники.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)
Ответ на: комментарий от fornlr

А что в этом плохого?

По-моему, ничего. Я наоборот люблю такие deb пакеты, их можно автоматически перепаковывать под все. Единственный недостаток - нет гарантий отвязанности от системы, от пряморукости зависит.

Только вот люди негодуют, выше там по треду например.

И жрёт он будь здоров места.

Ну уж точно в разы меньше чем все это самодостаточными deb пакетами ставить.

James_Holden ()
Ответ на: комментарий от James_Holden

Сомнительно. И тебе прилетит полным набором KDE рантайм с огромной локализацией (когда у тебя GNOMe), и GNOMe рантайм, и Nvidia рантайм.

Столько фигни будет, что мало не покажется.

fornlr ★★★★★ ()
Ответ на: комментарий от wandrien

Всем. Уже раньше писал и много раз.

Что требовать от проекта, который сам себе даже сайт поправить не может?

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Сомнительно. И тебе прилетит полным набором KDE рантайм с огромной локализацией (когда у тебя GNOMe), и GNOMe рантайм, и Nvidia рантайм.

Он тянет пакеты частично. Ни один мейстримовый пакетный менеджер в дистрибутивах такого не умеет.

Локализация идёт отдельным пакетом и по дефолту выкачивается только для языка текущей локали. Хочешь другие — добавляешь в конфиг флатпака, и он автоматом докачивает.

wandrien ()
Ответ на: комментарий от fornlr

И тебе прилетит полным набором KDE рантайм с огромной локализацией

Ну а теперь в самодостаточный деб это запакуй. Тебе рантайм прилетать будет с каждым дебом, а не один раз.

Ну серьезно, ты приводишь Steam в пример. Который после установки скачивает целую убунту в качестве рантайма. И это ничего. Это другое?

James_Holden ()
Ответ на: комментарий от fornlr

Хрен знает, я мелком проглядел форум и багтрекер и нашел довольно вменяемые дискуссии. Отнюдь не в духе Гнома.

wandrien ()
Ответ на: комментарий от James_Holden

Ну а теперь в самодостаточный деб это запакуй. Тебе рантайм прилетать будет с каждым дебом, а не один раз

А я что ушибленный не в KDE приложение вот это всё пихать на гигабайт довеса?

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Всмысле? Вот допустим у тебя гном. А ты хочешь Kate, KDevelop и скажем Digikam. При этом плазма тебе нафиг не упала (зацени каламбур).

Через флатпак все это ставится, но прилетит рантайм KDE.

А через дебы самодостаточные все по отдельности - так он прилетит с каждым приложением.

Поэтому конечно, больных нет так делать. Но не потому что это не нужно, а потому что в текущем виде это катастрофа.

James_Holden ()
Ответ на: комментарий от James_Holden

Ну серьезно, ты приводишь Steam в пример. Который после установки скачивает целую убунту в качестве рантайма. И это ничего. Это другое?

Конечно, ибо это нужный рантайм для игр.

А вот когда с Telegram тянется гигабайт КДЕ, то это другое…

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

тебе прилетит полным набором KDE рантайм с огромной локализацией (когда у тебя GNOMe), и GNOMe рантайм, и Nvidia рантайм

KDE и GNOME базируются на одном и том же Freedesktop.

Flatpak дедуплицирует одинаковые файлы между этими рантаймами.

Flatpak и df не отображают реально занимаемое место на ФС из-за обилия хардлинков.

Может, хватит уже раздувать эту тему каждый раз?

commagray ★★★★★ ()
Ответ на: комментарий от fornlr

когда с Telegram тянется гигабайт КДЕ

Это тоже нужный рантайм для игр.

Ну что сейчас, мне брать игру и смотреть по библиотечке в стимовском убунту-рантайме что там для конкретной игры лишнее? Я думаю что найду много чего интересного.

James_Holden ()
Ответ на: комментарий от fornlr

Телегой для линя вообще какие-то утырки занимаются, я бы на них не ориентировался.

Я поставил на пробу kate — он выкачал мне рантаймов на полгига. Так их там действительно около полгига, если ставить пакеты в систему. Только они в системе еще и будут целиком, а тут идут частями.

Потом поставил kicad. Ну да, он жирный, больше гигабайта скачалось. Но он просто сам по себе жирный.

wandrien ()
Ответ на: комментарий от wandrien

Телегой для линя вообще какие-то утырки занимаются, я бы на них не ориентировался.

Это не они занимаются. Им на флэтпак плевать.

fornlr ★★★★★ ()
Ответ на: комментарий от commagray

Ну по правде, он действительно жирный:

# du -hs /var/lib/flatpak/*
674M	/var/lib/flatpak/app
36M	/var/lib/flatpak/appstream
344K	/var/lib/flatpak/exports
6,7G	/var/lib/flatpak/repo
20M	/var/lib/flatpak/runtime
# du -hs /var/lib/flatpak/
7,4G	/var/lib/flatpak/

У меня три приложения установлено. Больше 7 гигов.

Хотя сама проблема высосана из пальца, как по мне. В ноуте 2 ТБ ПЗУ. Уж выделить место для приложений я смогу, если это даст возможность разработчикам более эффективно их поддерживать. Мне не жалко. Не 20 GB же на диске, как в 2001-м…

wandrien ()
Последнее исправление: wandrien (всего исправлений: 1)
Ответ на: комментарий от wandrien

Хотя сама проблема высосана из пальца, как по мне. В ноуте 2 ТБ ПЗУ. Уж выделить место для приложений я смогу, если это даст возможность разработчикам более эффективно их поддерживать.

Мне тоже не жалко. Ну так второе на практике не получается.

Ну и посыл про «там у вендузятников жирно, а тут другое дело» тоже разбивается. Сравнимо получается по «лишнему».

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от wandrien

Да, пардон.

Просто забываю, что не у всех же Btrfs, кхем.

[commagray@Cloudsdale ~]$ du -xhs ~/.local/share/flatpak
4.9G	/home/commagray/.local/share/flatpak
[commagray@Cloudsdale ~]$ btrfs filesystem du ~/.local/share/flatpak -s
     Total   Exclusive  Set shared  Filename
   4.61GiB     4.61GiB       0.00B  /home/commagray/.local/share/flatpak
[commagray@Cloudsdale ~]$ flatpak list --columns=name,application,size
Name                                                   Application ID                                                     Installed size
Tor Browser Launcher                                   com.github.micahflee.torbrowser-launcher                            32.4 MB
Flatseal                                               com.github.tchx84.Flatseal                                           3.7 MB
OBS Studio                                             com.obsproject.Studio                                               49.2 MB
Sublime Merge                                          com.sublimemerge.App                                                12.2 MB
Spot                                                   dev.alextren.Spot                                                   15.6 MB
Lagrange                                               fi.skyjake.Lagrange                                                 21.2 MB
SWH                                                    org.freedesktop.LinuxAudio.Plugins.swh                              57.0 MB
Freedesktop Platform                                   org.freedesktop.Platform                                           736.8 MB
default                                                org.freedesktop.Platform.GL.default                                255.8 MB
default                                                org.freedesktop.Platform.GL.default                                266.1 MB
Intel                                                  org.freedesktop.Platform.VAAPI.Intel                                37.0 MB
Intel                                                  org.freedesktop.Platform.VAAPI.Intel                                45.6 MB
ffmpeg-full                                            org.freedesktop.Platform.ffmpeg-full                                10.6 MB
openh264                                               org.freedesktop.Platform.openh264                                  778.2 kB
Freedesktop SDK                                        org.freedesktop.Sdk                                                  1.7 GB
GNU Image Manipulation Program                         org.gimp.GIMP                                                      337.2 MB
Manual                                                 org.gimp.GIMP.Manual                                               512 bytes
Geary                                                  org.gnome.Geary                                                     24.8 MB
GNOME Application Platform version 3.36                org.gnome.Platform                                                 939.2 MB
GNOME Application Platform version 3.38                org.gnome.Platform                                                 948.8 MB
Apostrophe                                             org.gnome.gitlab.somas.Apostrophe                                  135.8 MB
Inkscape                                               org.inkscape.Inkscape                                              238.9 MB
Adwaita theme                                          org.kde.KStyle.Adwaita                                              16.3 MB
KDE Application Platform                               org.kde.Platform                                                     1.0 GB
QGnomePlatform                                         org.kde.PlatformTheme.QGnomePlatform                                12.4 MB
QtSNI                                                  org.kde.PlatformTheme.QtSNI                                          3.3 MB
QGnomePlatform-decoration                              org.kde.WaylandDecoration.QGnomePlatform-decoration                 12.1 MB
Kdenlive                                               org.kde.kdenlive                                                   144.6 MB
OnionShare                                             org.onionshare.OnionShare                                          139.7 MB
qBittorrent                                            org.qbittorrent.qBittorrent                                         13.2 MB
Telegram Desktop                                       org.telegram.desktop                                                67.3 MB
commagray ★★★★★ ()
Последнее исправление: commagray (всего исправлений: 3)

нет. когда хотелось, то чего-то из этого у меня в системе только не было - в дебиане тогда была только одна из этих трёх, а мне была нужна другая

alt-tab-let ()
Ответ на: комментарий от Poisoned

У флатпака тоже заголовок есть, там должно быть -1 )

Aceler ★★★★★ ()
Ответ на: комментарий от BceM_IIpuBeT

Я вот тут попробовал этот ваш nix. Поставил Firefox через nix в ОС Альт и он не смог открыть ни один сайт по https из-за SEC_ERROR_UNKNOWN_ISSUER.

А всё потому что собран под NixOS, в которой корневые сертификаты лежат в /etc/ssl/certs/ca-certificates.crt, в то время как в альте они лежат /etc/pki/ca-trust/extracted/openssl/ca-bundle.trust.crt.

И всё, Firefox их не видит.

Aceler ★★★★★ ()
Последнее исправление: Aceler (всего исправлений: 1)
Ответ на: комментарий от wandrien

Nix не виноват, потому что они заявляют себя только как пакетный менеджер, а не как формат самодостаточных пакетов. Соответственно, nix и не должен такие ситуации обрабатывать.

Это был ответ на вопрос тов. BceM_IIpuBeT.

Aceler ★★★★★ ()
Последнее исправление: Aceler (всего исправлений: 1)

Я их не ставил, но они почему-то есть.

targitaj ★★★★★ ()
Ответ на: комментарий от Aceler

Вроде как пересобрать nix-пакеты как угодно, хоть в хомяк, на любой ОС вполне возможно. Это в любом случае сорцовый инструмент доставки софта, кэш пакетов там отдельно прикручен. Напрямую с флатпаком сравнивать, разумеется, смысла нет.

wandrien ()

куру от ультимейкера пришлось поставить аппимаджем потому, что других вариантов не было, а так я не хочу засорять систему этими фекальками.

bernd ★★★★★ ()
echo $(snap list | wc -l)-1+$(flatpak list --app | wc -l)-1 | bc
bash: snap: команда не найдена
bash: flatpak: команда не найдена
-2

У меня как-то так.

MikeB ★★★ ()
Ответ на: комментарий от Aceler

Нечего тут стыдиться,

Стыдно мне за похороненную заживо gentoo - несколько лет ленился обновляться и в итоге не смог поставить свежую версию kicad. Пришлось поставить рядом mint и на него смигрировать.

А mint я считал дистрибутивом убунты с адекватным дефолтом и где умеет готовить gnome3. Но про gnome3 я ошибался.

Tanger ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)