LINUX.ORG.RU

Установлены ли у вас приложения при помощи пакетов snap, flatpak или appimage?

 , ,


0

2

Опрос не ставит целью узнать, какой формат пакетов лучше, мы прекрасно с этим справимся в комментах (на самом деле, разумеется, нет). Просто – пользуетесь или не пользуетесь, а если пользуетесь, насколько глубоко.

  1. таких приложений не установлено462 (65%)

    ********************************************************************************************************************************************************************************************************************************************************************************************************************************

  2. установлено до 5 приложений195 (27%)

    ***************************************************************************************************************************************

  3. установлено до 10 приложений37 (5%)

    *************************

  4. установлено 25 и больше8 (1%)

    *****

  5. установлено до 20 приложений7 (1%)

    ****

  6. установлено до 15 приложений5 (1%)

    ***

  7. установлено до 25 приложений2 (0%)

    *

Всего голосов: 716

★★★★★

Проверено: Satori ()

Ноль, скорее всего всех их ни в одной системе у меня и нет.

One ★★★★★ ()
Ответ на: комментарий от Ros

В сравнении с АУР, смысла и правда нет, разве что ради контейнеров.

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

В пункте «не пользуюсь» живу я, т.к. всё что мне нужно обычно есть в репозитории дистрибутива и так. У меня ж Gentoo, а не CentOS.

grem ★★★★★ ()
Ответ на: комментарий от Aceler

Создай опрос «носите ли вы стринги?», а потом возмущайся «набегу хейтеров», заявляющих, что они их не носят.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от token_polyak

Например, когда часть пакетов хочет wxGTK:3.0, а другая wxGTK:3.0-gtk3. До недавнего времени был ещё одновременно доступен wxGTK:2.8

grem ★★★★★ ()

Все приложения из Флатпак, кроме дефолтных и низкоуровневой системщины.

Очень удобно, кстати, рекомендую. У меня сейчас еОС и Федора, а приложения одинаковые, кроме дефолтных.

meliafaro ★★★★★ ()
Последнее исправление: meliafaro (всего исправлений: 1)
Ответ на: комментарий от kirill_rrr

Я ещё не настолько параноик, чтобы изолировать браузер в контейнер или виртуалку.

Так там и не особо уж про изоляцию. На практике во многом это напоминает

https://xkcd.com/1200/

А если вспоминать практически используемые в диком мире пробивки браузеров на линуксах (я одну только помню с PDF.js в Firefox), то от браузера засунутого ещё в какую-то клетку будет больше неудобств, чем защиты.

Так же вон Selinux на десктопной Fedora. Кого он когда спас — трудно сказать. А кому мешался — толпа.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от kirill_rrr

Как указано на оф. сайте:

Ubuntu: Official Ubuntu Repo / Launchpad PPA
Debian: Official Debian Repo
Arch Linux: Install from [community] repository
Gentoo: Install from Gentoo repository
OpenSUSE: Install from OpenSUSE repository
Fedora: Install from RPM Fusion repository
grem ★★★★★ ()

Ересь. Признаю AppImage, как наименее дерьмовый из вариантов, не тащащий за собой кучу зависимостей на уровне рантоймов.

PavelRyzhov ★★ ()

манжаро арч дебиан, стороннего ничего

Zlo ★★★★ ()

Я не осилил сборку colobot gold, и поставил appimage((((

dead_PXL ★★ ()

Установлены ли у вас приложения при помощи пакетов snap, flatpak или appimage?

то есть типа это не создатель ПО решает, как паковать ПО, а юзер?


где вариант «установил то, что было» ?

darkenshvein ★★★★★ ()

Почему не упомянут вариант «распакованный tarball»? Appimage же никуда не ставится тоже.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от Aceler

Ты — это я :)

~ flatpak list --app | wc -l

31

Подозреваю только, что списки очень разные.

CYB3R ★★★★★ ()
Ответ на: комментарий от darkenshvein

вообще-то да. В линуксе принято, что разработчик максимум делает простой тарболл с исходниками, а сборкой, опакечиванием и разруливанием зависимостей заведует мейнтейнер дистрибутива.

Lrrr ★★ ()
Ответ на: комментарий от Lrrr

конечный пользователь и мейнтейнер - два разных человека по скиллам

ну и походу ПО, не оформленное в репы, а в другой формат, разрушает сами принципы дистрибутивов.

darkenshvein ★★★★★ ()

Только Steam через Flatpak.

AppImage - хорошая идея, но лично мне без надобности.

Snap не понимаю зачем существует. Неуниверсальный «универсальный менеджер пакетов».

Gentooshnik ★★★ ()
Последнее исправление: Gentooshnik (всего исправлений: 1)

Ни одного. И не будет.

Zubok ★★★★★ ()
Ответ на: комментарий от kirill_rrr

ии и квесты ещё слишком плохо работают чтобы играть.

Все там нормально работает.

Nervous ★★★★ ()
Ответ на: комментарий от kirill_rrr

Всё там работает. Вот у меня глючит постройка дома на Солстхейме и не продаются артефакты в музей )

Но это совсем не ходовая часть.

Aceler ★★★★★ ()

ничего такого подобного у меня нет, но может я чего не догоняю? объясните масхевность всей этой тулзы, приведите примеры пакетов без которых вы не смыслите свое существование в мире линукса?

amd_amd ★★★ ()
Ответ на: комментарий от amd_amd

все делают упор на то, что типа система «засоряется» обычными пакетами

хотя это херит всё удобства работы с репами, например через синаптик.
очередной пакетным менеджер на полтора пакета
плюс, нормального гуя ко всем этим флатпакам никто не удосужился написать

darkenshvein ★★★★★ ()

Сейчас нет ничего. Хотя раньше до смены диска пользовался(и тогда и сейчас lmde), но не более 3-5 приложений было, Уж не помню каких, и по каким причинам их устанавливал из флэт. В основном ранее старался не использовать, из за размера. Очень долго устанавливались. ИМХО лучше чем snap это флэт. Аппиейдж - х.з, привык к пакетам.

Alexonline ★★★ ()
Последнее исправление: Alexonline (всего исправлений: 1)
Ответ на: комментарий от Bagrov

Официальный Telegram похож на appimage, но точно ли это оно?

Вроде оно, да.

papin-aziat ★★★☆ ()
Ответ на: комментарий от Aceler

Все, что мне было нужно, было в конце 90-х. И есть сейчас, хотя пытаются сделать мой линуксдесктоп неюзабельным.

tereshchenko ★★ ()
Ответ на: комментарий от Aceler

Помни, юный падаван, что в пункте «не пользуюсь» живут виндузятники, яблочники, бсдшники и прочие

Которых ты в отдельный пункт не вынес чтобы нельзя было настолько однозначный вывод сделать?

$ flatpak list
$ snap list
sh: 2: snap: not found

Что-то не думал что у меня флатпак стоит. А про снап думал что есть… fixed

$ flatpak list
sh: 2: flatpak: not found
Tanger ★★★★★ ()
Ответ на: комментарий от Tanger

Которых ты в отдельный пункт не вынес чтобы нельзя было настолько однозначный вывод сделать?

О которых я как обычно забыл. Надо будет в будущем повторить опрос.

А какой дистр? В котором случайно стоит flatpak? :)

Aceler ★★★★★ ()
Последнее исправление: Aceler (всего исправлений: 1)

Где вариант «ХЗ сколько у меня их стоит».

Rodegast ★★★★★ ()
Ответ на: комментарий от Aceler

А какой дистр? В котором случайно стоит flatpak? :)

Стыдно признаться, но mint. Проверил - поставился во время установки системы.

Tanger ★★★★★ ()

Ни один из этих форматов не способен выполнить свою главную задачу: установка программ, доступная пользователю.

Программу из Флатпак невозможно установить, потому что у тебя немного устаревший дистрибутив с неподдерживаемой версией флатпака, в котором еще не завезли механизма обновления.

Снап выносит мозг какими-то внутренними зависимостями, которые надо нетривиально фиксить, и по итогу нифига не работает.

Аппимадж - нужно как-то пользователю объяснять, что на выкачанный файл надо ставить бит исполнения, а в графической среде это не всегда возможно. Привет консоль. Ну и при запуске увидеть, что ядро не той системы и что LIBC не той версии - это обычное дело.

В общем, задача не решена. Свободное распространение ПО в опенсорче в 21 веке по прежнему невозможно.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Ни один из этих форматов не способен выполнить свою главную задачу: установка программ, доступная пользователю.

такой задачи как главной и не было

SNAP: основное назначение IoT и сервера, типа доставка обновлений на устройства. Вот каноничный пример https://www.fing.com/products/fingbox/

FlatPak: тестирование ostree

А что там на вашем десктопе получится, то получится…

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

SNAP: основное назначение IoT и сервера, типа доставка обновлений на устройства

А ostree чем им не подошел?

wandrien ()

Установлены

appimage

Ты хоть понял, что написал?

WitcherGeralt ★★ ()
Ответ на: комментарий от fornlr

Очень странный тогда опрос получается. Спрашивают пользователей десктопного линукса о том, устанавливают ли они ПО через системы, для этого не предназначенные.

Xintrea ★★★★★ ()
Ответ на: комментарий от Xintrea

Предназначенные, но тут уж как получится. Десктопный линукс сам по себе во многом этакая солянка с миру по нитке.

fornlr ★★★★★ ()

Viber пускаю через AppImage. До недавнего времени так же пускал ещё Kdenlive и ещё какой-то видеоредактор, но сейчас у меня Manjaro, и свежий Kdenlive подгоняют прямо в репы. Вообще, из названных форматов больше всего доверяю AppImage, т.к. он по минимуму лезет в систему.

Если же версия какой-то софтины из репозиториев дистрибутива меня устраивает — пользуюсь ей и не гонюсь за версиями.

hobbit ★★★★★ ()

ого. я большинство. я не понимаю зачем snap нужен, чтобы не засирать систему я базы и вякие pgadmin’ы в докере запускаю https://github.com/tz4678/devstack

tz4678 ★★ ()
Ответ на: комментарий от Xintrea

нужно как-то пользователю объяснять, что на выкачанный файл надо ставить бит исполнения, а в графической среде это не всегда возможно. Привет консоль.

Решается инструкцией по установке рядом с кнопочкой «Скачать» твоей программы.
Также интересно, в какой это графической среде невозможно установить бит исполнения. Явно это не Dolphin и не Nautilus (хотя стоп, припоминаю, гномовцы пару лет назад грозились убрать из наутилуса возможность запуска программ вообще, про вещи типа AppImage они явно не подумали, они таки осуществили свою угрозу или одумались)?

Ну и при запуске увидеть, что ядро не той системы и что LIBC не той версии - это обычное дело.

Здесь хотелось бы примеров конкретных. С какими версиями ты делал сборку, и что обнаружилось несовместимого у пользователя.
Нет, я не говорю, что проблемы не существует, но почему-то пряморукие разработчики умудряются делать статические сборки так, что у пользователей проблем нет (из проприетарщиков в качестве положительного примера могу назвать авторов Nero4Linux, ныне, к сожалению, сгинувшего, купленный у них бинарник пережил несколько моих дистрибутивов). Из очевидного — как минимум тот же glibc надо брать постарше.

hobbit ★★★★★ ()
Последнее исправление: hobbit (всего исправлений: 2)
Ответ на: комментарий от hobbit

Да вот недавно свежий Kate хотел поставить на Astra Linux 1.6 из Appimage. Результат ожидаем: у вас LIBC не той версии.

Xintrea ★★★★★ ()

В nixos стоит стим + mesa-git к нему + protonGE. Родной steam протон не запускает с недавних версий, пока чинят решил поставить.

В целом удобно, для проприетарщины даже идеально.

shpinog ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.