LINUX.ORG.RU

Сообщения MikeB

 

USB модемы. Криокамера потекла.

Форум — General

Возникла необходимость купить USB модем.Никогда не пользовался. Как с ними сейчас обстоят дела в Linux? Может быть нюансы есть? На что вообще обратить внимание при покупке?
В технический раздел не стал писать, чтобы не захламлять.

Перемещено beastie из talks

 ,

MikeB ()

Синаптик и менеджер обновлений вылетают с ошибкой. Debian.

Форум — Desktop

Ошибка:

E: Значение «testing» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках

Debian testing/sid amd64

/etc/apt/apt.conf

APT::Default-Release "testing";

/etc/apt/preferences

Package: *
Pin: release a=testing
Pin-Priority: 1100

Package: *
Pin: release a=unstable
Pin-Priority: 200

Package: *
Pin: release a=experemental
Pin-Priority: 100

В sorces.list всё прописано как надо.
Ошибка возникает не постоянно, а время от времени.
По команде: aptitude update тоже выдает ту же ошибку, но дальше проверяет как положено и по команде aptitude upgrade всё нормально обновляет.
Причина не гуглится (мной по крайней мере) . В чём же дело?

 , ,

MikeB ()

Настройка PostgreSQL для работы с программой в wine

Форум — Desktop

Выручайте нуба! Дано:
Debian testing/sid
PostgreSQL 9.3
Wine 1.6.2
Poker Tracker 4 - программа для сбора статистики при игре в онлайн-покер, windows версия, установленная под wine.
Эта программа (PT4) работает с PostgreSQL. Но мне не хотелось бы ставить PostgreSQL под вайном, как предлагает PT4, т.к. есть нативная.
Задача: Заставить PT4 видеть базу данных созданную в нативной PostgreSQL. Гуглёж навел на то, что нужно править pg_hba.conf . Также у меня установлен pgAdmin III. Как заставить программу под вайном работать с нативной PostgreSQL?
Вот что ещё нарыл на форуме Poker Tracker в теме про запуск программы в linux:

You'll need to make sure that you configure PostgreSQL to listen on hosts that are not just localhost - due to the way wine interacts with the system it's like you're on a LAN. The setting you want to change is to set listen_addresses = '*' in the postgresql.conf file. Make sure the line isn't started with a # or that will comment out the change. Restart the PostgreSQL server and you should be able to connect to it via your IP local IP address then (which you can find via ifconfig if you need).

Но я мало что понял из этого...
Спасибо!

 ,

MikeB ()

Debian testing, сломался c-icap

Форум — Desktop

Внезапно сломался пакет. C-icap. Если честно, я смутно представляю зачем он мне нужен, но в системе он установлен.
Debian testing/sid, c-icap 1:0.3.3-2 не хочет обновляться до 1:0.3.3-3, т.к у него в зависимостях libicapapi3 (= 1:0.3.3-2), а установлена 1:0.3.3-3.

Подготовка к распаковке …/c-icap_1%3a0.3.3-3_amd64.deb …
/etc/init.d/c-icap: 69: export: config_dsSocket /var/ru: bad variable name
invoke-rc.d: initscript c-icap, action "stop" failed.
dpkg: предупреждение: подпроцесс старый сценарий pre-removal возвратил код ошибки 2
dpkg: попытка использовать сценарий из нового пакета …
/etc/init.d/c-icap: 69: export: config_dsSocket /var/ru: bad variable name
invoke-rc.d: initscript c-icap, action "stop" failed.
dpkg: ошибка при обработке архива /var/cache/apt/archives/c-icap_1%3a0.3.3-3_amd64.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 2
/etc/init.d/c-icap: 69: export: config_dsSocket /var/ru: bad variable name
invoke-rc.d: initscript c-icap, action "start" failed.
dpkg: ошибка при очистке:
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/c-icap_1%3a0.3.3-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

dpkg: зависимости пакетов не позволяют настроить пакет c-icap:
 c-icap зависит от libicapapi3 (= 1:0.3.3-2), однако:
  Версия libicapapi3 в системе 1:0.3.3-3.

dpkg: ошибка при обработке пакета c-icap (--configure):
 проблемы зависимостей — оставляем не настроенным

В репозиториях jessie и sid уже нет libicapapi3 (= 1:0.3.3-2). Как заставить его обновиться? Может как-то откатить libicapapi3, но где взять старую версию?

 , ,

MikeB ()

Cornerstone

Форум — Talks

«Данная CMS — детище небезызвестной норвежской компании Kommunion. Это решение стало воплощением необычного синтеза христианской мысли и новейших технологий в сфере контент-менеджмента. Работая над дизайном для системы и иконками, нашей главное задачей было передать мысль создателей CornerStone о том, что гармония — это пусть к совершенству. Нам удалось создать современный и одновременно, не перегруженный аккуратный и чистый UI. Каждая новая работа для CornerStone — это еще одна возможность заставить дизайн говорить и делать это убедительно»

Был немного удивлен. Вообще кто-нибудь слышал?
http://www.kommunion.ru/about/visionvalues
http://agente.ru/rus/portfolio/sites/1236.html

PS Кажется проприетарщина

 

MikeB ()

Билл Гейтс не осилил установку обновления Windows 8

Форум — Talks

 , ,

MikeB ()

Не удается установить Draftsight на Debian testing amd64

Форум — Desktop

Debian testing/sid amd64. Drafsight V1R4.0 с офф. сайта, deb-пакет для Ubuntu. Не устанавливается.

# dpkg -i draftSight.deb
dpkg: из-за draftSight.deb, содержащегося в dassault-systemes-draftsight, возникла проблема предварительных зависимостей:
 dassault-systemes-draftsight требует предварительной установки libdirectfb-extra (>= 1.2.7-2)

dpkg: ошибка при обработке параметра draftSight.deb (--install):
 проблема предварительных зависимостей — пакет dassault-systemes-draftsight не будет установлен
При обработке следующих пакетов произошли ошибки:
 draftSight.deb
Но:
dpkg --get-selections libdirectfb-extra
libdirectfb-extra:amd64				install

Версия libdirectfb-extra 1.2.10.0-5.
Раньше таких проблем не было. Что ему нужно? Как установить?
Благодарю.

 ,

MikeB ()

Python с нуля

Форум — Talks

В общем решил я немного самообразоваться и изучить Python. Выбор на него пал по причине, что я немного работаю в Blender и есть желание всё таки освоить FreeCAD. В общем хочу научиться писать скрипты.
Есть несколько книжек в электронном виде:
Россум, Дрейк, Откидач. Язык программирования Python. 2001
Чаплыгин. Учимся программировать вместе с Питоном.
Лутц. Изучаем Python. 4-е издание. 2011
Сузи. Язык программирования Python. Курс лекций.
С чего начать, если я с трудом ориентируюсь в терминологии программирования и весь мой «опыт» связан с Basic на ZXSpectrum и VB (.NET) в MS Visual Studio, в которых ковырялся когда-то?

 ,

MikeB ()

Туплю, как скачать deb-пакет DraftSight?

Форум — Desktop

Что-то я туплю, но не могу скачать сабж.
Вот ссылка http://www.3ds.com/products/draftsight/download-draftsight/ Тыкните носом где .deb.
Недавно нормально скачал и поставил на debian amd64, сейчас 32-битный не могу скачать...

 ,

MikeB ()

Debian, Gnome3, Blender

Галерея — Скриншоты

Решил показать ЛОРу как коротаю свой досуг в Blender (ну и ШГ заодно).
Ковыряюсь понемногу с моделью триплана Fokker Dr I. Что-то затянула меня тема авиации времен первой мировой.
На скриншоте видно превью Cycles Render, материалы и свет не настроены. Финальный рендер думаю делать в Luxrender.
Система Debian testing/sid, практически дефолтный Gnome3. Под окном Blender спрятались ненужные коньки со вторыми часами и погодой.

>>> Просмотр (1280x1024, 973 Kb)

 ,

MikeB ()

Эффекты compiz в ubuntu 12.04 не работают после перезагрузки

Форум — Desktop

Имеется нетбук Dell Inspiron 1012, Intel Atom N450, Intel GMA 3150. На нем установлена Ubuntu 12.04 LTS с практически дефолтной Unity.
Существует одна досадная проблема - не работают эффекты compiz после перезагрузки. Мне всего-то нужно настроить активные углы. Настраивал с помощью утилит ccms и Ubuntu Tweak, «галочки» стоят и в той и в другой. До перезагрузки всё работает отлично.
Гугление только запутывает. Нашел рецепт, где советуют, что нужно прописать активные плагины в файл /usr/share/glib-2.0/schemas/10_compiz-gnome.gschema.override. Но у меня нет этого файла в системе.
Также встречается совет прописать compiz --replace в автозагрузку... Вывод этой команды очень настораживает:

~$ compiz --replace
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend     : gconf
Integration : true
Profile     : unity
Adding plugins
Initializing core options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing snap options...done
Initializing mousepoll options...done
Initializing gnomecompat options...done
Initializing widget options...done
Initializing move options...done
Initializing animation options...done
Initializing place options...done
Initializing wall options...done
Initializing grid options...done
Initializing vpswitch options...done
Initializing resize options...done
Initializing fade options...done
Initializing session options...done
Initializing unitymtgrabhandles options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing workarounds options...done
Initializing scale options...done
Initializing ezoom options...done

(compiz:19476): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed
Initializing unityshell options...done
WARN  2013-01-19 12:34:06 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/libreoffice-writer.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2013-01-19 12:34:06 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/libreoffice-calc.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN  2013-01-19 12:34:06 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/deadbeef.desktop' is using a deprecated format for its actions that will be dropped soon.
ERROR 2013-01-19 12:34:08 unity.glib-gobject <unknown>:0 g_object_unref: assertion `G_IS_OBJECT (object)' failed
Setting Update "expo_edge"
Setting Update "initiate_all_edge"
Setting Update "show_hud"
Setting Update "launcher_hide_mode"
Setting Update "background_color"
Setting Update "panel_opacity"
sh: 1: /lib/libc.so.6: not found
sh: 1: gnome-about: not found
WARN  2013-01-19 12:46:32 unity <unknown>:0 Unable to fetch children: Интерфейс «org.ayatana.bamf.view» для пути /org/ayatana/bamf/application165288446 объекта не найден

ERROR 2013-01-19 12:46:35 unity.glib-gobject <unknown>:0 g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
WARN  2013-01-19 13:00:45 unity.glib.dbusproxy GLibDBusProxy.cpp:283 Calling method "Search" on object path: "/net/launchpad/lens/video" failed: Время ожидания истекло

В чём может быть проблема? Спасибо.

 , ,

MikeB ()

Iceweasel 18.0 из experimental в Debian testing

Форум — Desktop
# aptitude install -t experimental iceweasel
Следующие пакеты будут ЗАМЕНЕНЫ НА БОЛЕЕ СТАРЫЕ: 
  iceweasel 
Следующие пакеты будут УДАЛЕНЫ:
  libmozjs17d{u} xulrunner-17.0{u} 
0 пакетов обновлено, 0 установлено новых, 1 пакетов заменены на старые версии, 2 пакетов отмечено для удаления, и 6 пакетов не обновлено.
Необходимо получить 0 B/1 455 kB архивов. После распаковки освободится 37,0 M байт.
Хотите продолжить? [Y/n/?] n[

Прокомментируйте, пожалуйста.
Гугл говорит проблема не только у меня, но вот из этого мне ничего не ясно: http://comments.gmane.org/gmane.linux.debian.devel.mozilla/12411
Мне моё практически не знание английского не позволяет разобраться.
It should be fixed now. Это вчера было написано. Выходит не пофиксили? Или причина в другом?
Debian testing/sid amd64

 , ,

MikeB ()

Попытка обновления gnome-packagekit заканчивается ошибкой

Форум — Desktop

В общем текущая версия gnome-packagekit 3.4.2-2~exp1пытается «обновиться» до 3.4.2.2 из testing. Когда я ставил 3.4.2-2~exp1 уже не помню.
Система: Debian testing/sid amd64, gnome 3.4.2.

Подготовка к замене пакета gnome-packagekit 3.4.2-2~exp1 (используется файл …/gnome-packagekit_3.4.2-2_amd64.deb) …
Распаковывается замена для пакета gnome-packagekit …
dpkg: ошибка при обработке параметра /var/cache/apt/archives/gnome-packagekit_3.4.2-2_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/man/man1/gpk-install-mime-type.1.gz», который уже имеется в пакете gnome-packagekit-tools 3.4.2-2~exp1
dpkg-deb: ошибка: подпроцесс вставка уничтожен по сигналу (Обрыв канала)
Обрабатываются триггеры для man-db …
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/gnome-packagekit_3.4.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ошибка при установке пакета. Попытка восстановления:
Как побороть? Спасибо!

 ,

MikeB ()

FPDB - Free Poker Database

Форум — Games

Поигрываю в покер на покерстарз. Возникло желание вести базу данных по игрокам, раздачам и т.п.
Естественно выбор пал на fpdb. Программа на питоне, никак не заставлю работать. Ставил зависимости вручную и качал архив с последней версией, ставил.deb пакет предыдущей версии. Делал всё по инструкции в вики, но ввиду слабого английского мог напортачить.

Debian testing/sid amd4, gnome 3.4
Выхлоп:

dragonfly@dragonfly:~$ fpdb
Python 2.7...
Value error parsing header in AFM: ItalicAngle -9,9
Traceback (most recent call last):
  File "/usr/bin/fpdb", line 68, in <module>
    import GuiGraphViewer
  File "/usr/share/pyshared/fpdb/GuiGraphViewer.py", line 37, in <module>
    from matplotlib.figure import Figure
  File "/usr/lib/pymodules/python2.7/matplotlib/figure.py", line 18, in <module>
    from axes import Axes, SubplotBase, subplot_class_factory
  File "/usr/lib/pymodules/python2.7/matplotlib/axes.py", line 14, in <module>
    import matplotlib.axis as maxis
  File "/usr/lib/pymodules/python2.7/matplotlib/axis.py", line 10, in <module>
    import matplotlib.font_manager as font_manager
  File "/usr/lib/pymodules/python2.7/matplotlib/font_manager.py", line 1325, in <module>
    _rebuild()
  File "/usr/lib/pymodules/python2.7/matplotlib/font_manager.py", line 1275, in _rebuild
    fontManager = FontManager()
  File "/usr/lib/pymodules/python2.7/matplotlib/font_manager.py", line 999, in __init__
    self.afmlist = createFontList(self.afmfiles, fontext='afm')
  File "/usr/lib/pymodules/python2.7/matplotlib/font_manager.py", line 567, in createFontList
    prop = afmFontProperty(fpath, font)
  File "/usr/lib/pymodules/python2.7/matplotlib/font_manager.py", line 484, in afmFontProperty
    if font.get_angle() != 0 or name.lower().find('italic') >= 0:
  File "/usr/lib/pymodules/python2.7/matplotlib/afm.py", line 468, in get_angle
    return self._header['ItalicAngle']
KeyError: 'ItalicAngle'

Судя по некоторым знакомым словам что-то со шрифтами связано?
Спасибо!

 , ,

MikeB ()

2gis в wine

Форум — Desktop

Прочитав этот тред, решил установить и себе.

Но что-то не хочет он работать. Выхлоп:

fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (1): stub
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
err:menubuilder:write_freedesktop_mime_type_entry error writing file ~/.local/share/mime/packages/x-wine-extension-/bzw.xml
err:menubuilder:write_freedesktop_association_entry error writing association file "~/.local/share/applications/wine-extension-/bzw.desktop"
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
err:module:import_dll Library WLDAP32.dll (which is needed by L"C:\\Program Files\\2gis\\3.0\\grym.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\2gis\\3.0\\grym.exe" failed, status c0000135

Вроде ему не хватает WLDAP32.dll. Я ставил через winetricks comctl32, где-то нагуглил, что должно помочь, но не помогло.

Скачать эту dll и кинуть в system32?

Wine 1.5.6.

Кастую geekless, KivApple, fads. У кого работает, поделитесь опытом как ставили.

 ,

MikeB ()

Пропали все иконки приложений в gnome-shell

Форум — Desktop

Debian testing/sid amd64

После предпоследнего обновления решил подкорректировать меню gnome c помощью alacarte, в результате этого программа глюканула и я после перезагрузки остался без значков приложений в gnome-shell и доке. Запущенные в данный момент приложения появляются в доке, а всего остального нет.

В логах есть что-то, но я не могу понять имеет ли это отношение к проблеме:

un 30 22:26:25 dragonfly gnome-session[2222]: WARNING: Failed to start app: Unable to start application: Не удалось выполнить процесс-потомок «/usr/lib/at-spi/at-spi-registryd» (Нет такого файла или каталога)
Jun 30 22:26:35 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: Overriding tab label for notebook
Jun 30 22:26:35 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: Overriding tab label for notebook
Jun 30 22:26:35 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: Overriding tab label for notebook
Jun 30 22:26:35 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: Overriding tab label for notebook
Jun 30 22:26:35 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: Overriding tab label for notebook
Jun 30 22:26:36 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: /tmp/buildd/gtk+3.0-3.4.2/./gtk/gtkwidget.c:7117: widget not within a GtkWindow
Jun 30 22:26:39 dragonfly gdm-simple-greeter[3131]: Gtk-CRITICAL: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed
Jun 30 22:26:39 dragonfly gdm-simple-greeter[3131]: Gtk-CRITICAL: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed
Jun 30 22:26:39 dragonfly gdm-simple-greeter[3131]: Gtk-WARNING: gtk_widget_size_allocate(): attempt to allocate widget with width -47 and height -47
Jun 30 22:26:40 dragonfly gdm-simple-greeter[3131]: CRITICAL: get_column_number: assertion `i < gtk_tree_view_get_n_columns (treeview)' failed
Jun 30 22:26:40 dragonfly gdm-simple-greeter[3131]: CRITICAL: get_column_number: assertion `i < gtk_tree_view_get_n_columns (treeview)' failed

Гугл тоже не дает ответа, да я и не знаю как сформулировать правильно запрос.

Вся надежда на ЛОР.

 ,

MikeB ()

Смогут ли подключить интернет?

Форум — Talks

У родителей сдох ADSL-модем/роутер и их провайдер убедил провести кабель (FTTx). Насколько я могу судить, надо будет настраивать VPN (что там будет - pptp или что-то другое я не знаю). Завтра приезжает подрядчик. Родителей успокоили по телефону, что всё настроят как надо и не важно какая система. Фокус в том, что у них Debian Squeeze и даже не установлен network-manager, других пакетов, которые могут понадобится тоже нет.

Как вы считаете смогут подключить и настроить или ограничится тем, что только бросят кабель?

В Talks пишу понятно по какой причине, меня не интересуют техническая сторона (пока), а просто интересно как было у других.

 ,

MikeB ()

TV-тюнер, пульт ДУ, скан-коды клавиатуры

Форум — Multimedia

Имеем tv-тюнер Beholder M63, пульт ДУ. Последнее время замудрил Lirc, пульт перестал определяться. На бехолдеровском форуме есть такое решение с помощью ir-keytable

# ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event4) with:
	Driver ir-kbd-i2c, table rc-behold
	Supported protocols: NEC 
	Enabled protocols: NEC 
	Repeat delay = 500 ms, repeat period = 125 ms

Стандартный /etc/rc_keymaps/behold:

# table behold, type: NEC
0x6b861c KEY_TUNER
0x6b8612 KEY_POWER
0x6b8601 KEY_1
0x6b8602 KEY_2
0x6b8603 KEY_3
0x6b8604 KEY_4
0x6b8605 KEY_5
0x6b8606 KEY_6
0x6b8607 KEY_7
0x6b8608 KEY_8
0x6b8609 KEY_9
0x6b860a KEY_AGAIN
0x6b8600 KEY_0
0x6b8617 KEY_MODE
0x6b8614 KEY_SCREEN
0x6b8610 KEY_ZOOM
0x6b860b KEY_CHANNELUP
0x6b8618 KEY_VOLUMEDOWN
0x6b8611 KEY_MUTE
0x6b860d KEY_INFO
0x6b860f KEY_RECORD
0x6b861b KEY_PLAYPAUSE
0x6b861a KEY_STOP
0x6b860e KEY_TEXT
0x6b861f KEY_RED
0x6b861e KEY_VIDEO
0x6b861d KEY_SLEEP
0x6b8613 KEY_GREEN
0x6b8619 KEY_BLUE
0x6b8658 KEY_SLOW
0x6b865c KEY_CAMERA

Хочу привязать пульт ДУ к vlc, нужно заменить скан-коды на нужные клавиши, но не могу сообразить как их считать и что записывать.

Команда xev выдает следующее, например для клавиши f:

KeyPress event, serial 32, synthetic NO, window 0x4e00001,
    root 0xb8, subw 0x0, time 3328512, (-392,745), root:(329,796),
    state 0x10, keycode 41 (keysym 0x66, f), same_screen YES,
    XLookupString gives 1 bytes: (66) "f"
    XmbLookupString gives 1 bytes: (66) "f"
    XFilterEvent returns: False

KeyRelease event, serial 35, synthetic NO, window 0x4e00001,
    root 0xb8, subw 0x0, time 3328595, (-392,745), root:(329,796),
    state 0x10, keycode 41 (keysym 0x66, f), same_screen YES,
    XLookupString gives 1 bytes: (66) "f"
    XFilterEvent returns: False

Где тут скан-код который нужно записать в /etc/rc_keymaps/behold для кнопки KEY_SCREEN? Сейчас там записано 0x6b8614.

Сиситема в профиле, ядро 3.1.0-1-amd64

Надеюсь на вашу помощь. А если вы не отзоветесь, мы напишем в спортлото на форум Beholder.ru

PS может в «железо» надо было?

MikeB ()

Gtk-Message: Failed to load module «pk-gtk-module»

Форум — Desktop

Debian testing/sid. Задалбывает Gtk-Message: Failed to load module «pk-gtk-module».

Гугление что-то не помогает. Единственное, что я кажется понял, что это происходит когда запускаются gtk2 приложения и связанно это с пакетом packagekit-gtk3-module и багом #649039

Запускаю центр приложений к примеру:

dragonfly@dragonfly:~$ software-center
Gtk-Message: Failed to load module "pk-gtk-module"
WARNING:root:ubuntu-almost-fixed-height-mode extension not available
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:ubuntu-almost-fixed-height-mode extension not available
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:ubuntu-almost-fixed-height-mode extension not available
WARNING:root:No styling hints for Adwaita were found... using Human hints.
/usr/share/software-center/softwarecenter/app.py:636: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.window_main.show_all()
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:No styling hints for Adwaita were found... using Human hints.
WARNING:root:No styling hints for Adwaita were found... using Human hints.
...

Это не полный выхлоп, но в результате я наблюдаю пустое окно с заголовком.

Не работает редактор меню. То что я вижу при попытке снять галочку:

dragonfly@dragonfly:~$ alacarte
Gtk-Message: Failed to load module "pk-gtk-module"
Traceback (most recent call last):
  File "/usr/share/alacarte/Alacarte/MainWindow.py", line 432, in on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 200, in setVisible
    menu_xml = self.__getXmlMenu(self.__getPath(item), dom, dom)
  File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 473, in __getXmlMenu
    node = self.__addXmlMenuElement(element, name, dom)
  File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 484, in __addXmlMenuElement
    return element.appendChild(node)
  File "/usr/lib/python2.7/xml/dom/minidom.py", line 1550, in appendChild
    "two document elements disallowed")
xml.dom.HierarchyRequestErr: two document elements disallowed

При этом слетели все мои настройки меню и поправить я это не могу.

Как это побороть или невозможно пока? Спасибо.

PS Что-то как-то всё плохо совсем (

MikeB ()

[fglrx, Debian testing, gnome 3] вылетают иксы при воспроизведении видео

Форум — Desktop

И снова проблемы! После обновления gnome до 3-ей версии, а также после всех этих проблем с совместимостью xserver-xorg и fglrx... В общем накатил я последние апдейты: fglrx 11.11 и xserver-xorg 1.11. В результате чего при попытке воспроизведения видео в любом из плееров вылетаю иксы.

Xorg.0.log.old:

Backtrace:
[  3758.395] 0: /usr/bin/Xorg (xorg_backtrace+0x26) [0x7ff1f15f48f6]
[  3758.395] 1: /usr/bin/Xorg (0x7ff1f1470000+0x188559) [0x7ff1f15f8559]
[  3758.395] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7ff1f0798000+0xf020) [$
[  3758.395] 3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xs111LookupPrivate+$
[  3758.396] 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xclLookupPrivate+0x$
[  3758.396] 5: /usr/lib/xorg/modules/amdxmm.so (X740XvPutImage+0x12e) [0x7ff1e$
[  3758.396] 6: /usr/bin/Xorg (0x7ff1f1470000+0xa693e) [0x7ff1f151693e]
[  3758.396] 7: /usr/lib/xorg/modules/extensions/libextmod.so (0x7ff1ed347000+0$
[  3758.396] 8: /usr/bin/Xorg (0x7ff1f1470000+0x51f59) [0x7ff1f14c1f59]
[  3758.396] 9: /usr/bin/Xorg (0x7ff1f1470000+0x411ba) [0x7ff1f14b11ba]
[  3758.396] 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xfd) [0x7f$
[  3758.396] 11: /usr/bin/Xorg (0x7ff1f1470000+0x414ad) [0x7ff1f14b14ad]
[  3758.396] Segmentation fault at address 0x20
Fatal server error:
[  3758.396] Caught signal 11 (Segmentation fault). Server aborting
[  3758.396]
[  3758.396]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.

Также в messages появилась ругань pulseaudio:

Nov 20 15:15:38 dragonfly pulseaudio[1206]: [pulseaudio] alsa-mixer.c: Volume element Master has 8 channels. That's too much! I can't handle that!

Я так понимаю pulseaudio притащил gnome 3, до него у меня этого отродясь не было.

Ну и при установке пакетов выдает:

Gtk-Message **: Failed to load module "pk-gtk-module" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97, <> line 1.
Gtk-Message **: Failed to load module "pk-gtk-module" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103, <> line 1.

про последнее нагуглилось что-то, доустановил недостающие пакеты, но не помогло.

Да, и gnome-shell не работает вообще.

MikeB ()

RSS подписка на новые темы