LINUX.ORG.RU

Не удается установить Draftsight на Debian testing amd64

 ,


0

1

Debian testing/sid amd64. Drafsight V1R4.0 с офф. сайта, deb-пакет для Ubuntu. Не устанавливается.

# dpkg -i draftSight.deb
dpkg: из-за draftSight.deb, содержащегося в dassault-systemes-draftsight, возникла проблема предварительных зависимостей:
 dassault-systemes-draftsight требует предварительной установки libdirectfb-extra (>= 1.2.7-2)

dpkg: ошибка при обработке параметра draftSight.deb (--install):
 проблема предварительных зависимостей — пакет dassault-systemes-draftsight не будет установлен
При обработке следующих пакетов произошли ошибки:
 draftSight.deb
Но:
dpkg --get-selections libdirectfb-extra
libdirectfb-extra:amd64				install

Версия libdirectfb-extra 1.2.10.0-5.
Раньше таких проблем не было. Что ему нужно? Как установить?
Благодарю.

★★★

dpkg не разрешает зависимости пакета. После dpkg -i нужно выполнить aptitude -f install (именно так, никаких больше параметров), чтобы поставить зависимости и доустановить пакет.

А этот скачанный пакет архитектуры какой? Сталкивался с тем, что при выводе неудовлетворенных зависимостей не пишется архитектура нужного пакета.

uuwaan ★★ ()
Последнее исправление: uuwaan (всего исправлений: 1)
Ответ на: комментарий от uuwaan

Спасибо! Но

dpkg не разрешает зависимости пакета

Так все зависимости удовлетворены. libdirectfb-extra 1.2.10.0-5 был ранее установлен. Когда ставил предыдущую версию draftsight проблем не возникало.

А этот скачанный пакет архитектуры какой?

Там не указанно вроде нигде, подозреваю 32-х битный.

Может я что не понял, но aptitude -f install предлагает поставить кучу ненужных мне пакетов типа fgrlx, kino, yafaray и т.д.

MikeB ★★★ ()
Ответ на: комментарий от olibjerd

Как, вручную что ли? Ладно, сегодня спать, а то туго соображаю.

MikeB ★★★ ()
Ответ на: комментарий от olibjerd

Спасибо. Но всё равно странно, раньше такого с ним не было, ставился очень просто.

MikeB ★★★ ()
Ответ на: комментарий от olibjerd

Какой нафиг вручную?

dpkg --add-architecture i386
apt-get update
apt-get install libdirectfb-extra:i386
anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.