LINUX.ORG.RU

проблема с драйвером ati в debian lenny


0

1

Пробую установить драйвер для моей ati x600 вот отсюда http://slicks.name/linux/ustanavlivaem-proprietarnyj-drajver-ati-catalyst-9-3-na-debianlenny-amd64.html . Застрял на 5-ом пункте. Вот что пишет:

dpkg-split: ошибка чтения fglrx: Это каталог
dpkg: не удалось обработать параметр fglrx (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
dpkg: предупреждение -- снижение версии fglrx-amdcccle с 1:8-12-4 до 8.593-1.
dpkg: чтобы можно было установить пакет fglrx-amdcccle, необходимо удалить fglrx-control...
dpkg: нет, невозможно продолжить с удаление fglrx-control (вам поможет --auto-deconfigure):
 fglrx-amdcccle зависит от fglrx-control
  пакет fglrx-control будет удалён.
dpkg: относительно fglrx-amdcccle_8.593-1_amd64.deb, содержащего fglrx-amdcccle:
 fglrx-amdcccle конфликтует с fglrx-control
  fglrx-control (версия 1:8-12-4) существует и установлен.
dpkg: не удалось обработать параметр fglrx-amdcccle_8.593-1_amd64.deb (--install):
 конфликт пакетов -- fglrx-amdcccle не будет установлен
dpkg: предупреждение -- снижение версии fglrx-driver с 1:8-12-4 до 8.593-1.
dpkg: относительно fglrx-driver_8.593-1_amd64.deb, содержащего fglrx-driver:
 fglrx-atieventsd конфликтует с fglrx-driver (<< 1:8-4-2)
  пакет fglrx-driver версии 8.593-1 будет установлен.
dpkg: не удалось обработать параметр fglrx-driver_8.593-1_amd64.deb (--install):
 конфликт пакетов -- fglrx-driver не будет установлен
(Чтение базы данных... на данный момент установлено 74276 файлов и каталогов.)
Распаковывается пакет fglrx-driver-dev (из файла fglrx-driver-dev_8.593-1_amd64.deb)...
dpkg: не удалось обработать параметр fglrx-driver-dev_8.593-1_amd64.deb (--install):
 попытка перезаписать /usr/lib/libfglrx_tvout.a, который уже имеется в пакете fglrx-driver
dpkg-split: ошибка чтения fglrx-install: Это каталог
dpkg: не удалось обработать параметр fglrx-install (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
dpkg: предупреждение -- снижение версии fglrx-kernel-src с 1:8-12-4 до 8.593-1.
dpkg: относительно fglrx-kernel-src_8.593-1_amd64.deb, содержащего fglrx-kernel-src:
 fglrx-source конфликтует с fglrx-kernel-src (<< 1:8-4-2)
  пакет fglrx-kernel-src версии 8.593-1 будет установлен.
dpkg: не удалось обработать параметр fglrx-kernel-src_8.593-1_amd64.deb (--install):
 конфликт пакетов -- fglrx-kernel-src не будет установлен
При обработке следующих пакетов произошли ошибки:
 fglrx
 fglrx-amdcccle_8.593-1_amd64.deb
 fglrx-driver_8.593-1_amd64.deb
 fglrx-driver-dev_8.593-1_amd64.deb
 fglrx-install
 fglrx-kernel-src_8.593-1_amd64.deb
Еще пробовал поставить драйвер через sgfxi, но он говорит, что поддержка моей карты прекращена.

Из репозитория поставить, конечно, религия запрещает?

GotF ★★★★★ ()

Перед этим ставили из репозитария? Похоже у вас стоит уже fglrx.

Если так, то удалите и установите эти сгенерированные пакеты.

stormblastt ★★★ ()

Боюсь что поддержка действительно прекращена :) Это ваолне в стиле АТИ :)

Jetty ★★★★★ ()

> fglrx-control (версия 1:8-12-4) существует и установлен.

попробовать
1. отключить репу non-free дистра
2. удалить все пакеты c именем fglrx*
3. и еще разок поставить fglrx по той инструкции

elipse ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.