LINUX.ORG.RU

установка драйвера ATI RS690 на debian squeeze


0

0

Здравствуйте!

После обновления debian до ветки testing начались проблемы с vlc. Полуркал - нашёл эту тему (http://forums.debian.net/viewtopic.php?f=6&t=39931), понял что надо обновлять дрова.

Я так понял, что есть выбор из трёх драйверов: radeonhd, radeon, fglrx

У меня стоит radeonhd, и opengl на нём не работает (по крайней мере vlc не может выводить в opengl), dmesg говорит:
[ 1681.700568] platform radeon_cp.0: firmware: requesting radeon/RS690_cp.bin
[ 1681.769706] [drm] Num pipes: 1
[ 1681.769719] [drm] writeback test succeeded in 1 usecs
[ 1730.654510] [drm:r300_do_cp_cmdbuf] *ERROR* r300_scratch failed

В LOR FAQ по поводу установки ati драйверов идёт ссылка сюда: http://my-note.ru/archives/136.html и предлагается ставить fglrx . Ладно, буду ставить.

Действую по инструкции. Когда выполняю команду dpkg -i fglrx-amdcccle_8.593-1_i386.deb fglrx-driver_8.593-1_i386.deb fglrx-driver-dev_8.593-1_i386.deb fglrx-kernel-src_8.593-1_i386.deb

мне говорится:
(Чтение базы данных ... на данный момент установлено 300355 файлов и каталогов.)
Подготовка к замене пакета fglrx-amdcccle 8.593-1 (используется файл fglrx-amdcccle_8.593-1_i386.deb) ...
Распаковывается замена для пакета fglrx-amdcccle ...
dpkg: относительно fglrx-driver_8.593-1_i386.deb, содержащего fglrx-driver:
fglrx-atieventsd конфликтует с fglrx-driver (<< 1:8-4-2)
пакет fglrx-driver версии 8.593-1 будет установлен.
dpkg: не удалось обработать параметр fglrx-driver_8.593-1_i386.deb (--install):
конфликт пакетов — fglrx-driver не будет установлен
Подготовка к замене пакета fglrx-driver-dev 8.593-1 (используется файл fglrx-driver-dev_8.593-1_i386.deb) ...
Распаковывается замена для пакета fglrx-driver-dev ...
Подготовка к замене пакета fglrx-kernel-src 8.593-1 (используется файл fglrx-kernel-src_8.593-1_i386.deb) ...
Распаковывается замена для пакета fglrx-kernel-src ...
dpkg: зависимости пакетов не позволяют настроить пакет fglrx-amdcccle:
fglrx-amdcccle зависит от fglrx-driver, однако:
Пакет fglrx-driver не установлен.
dpkg: не удалось обработать параметр fglrx-amdcccle (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет fglrx-driver-dev:
fglrx-driver-dev зависит от fglrx-driver, однако:
Пакет fglrx-driver не установлен.
dpkg: не удалось обработать параметр fglrx-driver-dev (--install):
проблемы зависимостей — оставляем не настроенным
Настраивается пакет fglrx-kernel-src (8.593-1) ...
Обрабатываются триггеры для gnome-menus ...
Обрабатываются триггеры для desktop-file-utils ...
При обработке следующих пакетов произошли ошибки:
fglrx-driver_8.593-1_i386.deb
fglrx-amdcccle
fglrx-driver-dev

Что делать? Спасибо!

fglrx не поддерживает X Server 1.7, а именно такой сейчас в squeeze, если не ошибаюсь

MikeB ★★★★ ()

Какие конкретно проблемы с vlc? Показывает кино в углу экрана?

У меня такое было на тестинге. Видео карта ати 1950. Дрова открытые. В сурс.листе поменял репы на sid, обновил xorg и xserver-xorg-video-radeon и исправил репы обратно на тестинг. Проблема исчезла. Еще поставил firmware-linux-nonfree и libgl1-mesa-dri.

----- OpenGL vendor string: DRI R300 Project OpenGL renderer string: Mesa DRI R300 (RV560 7288) 20090101 x86/MMX+/3DNow!+/SSE2 TCL OpenGL version string: 1.5 Mesa 7.6.1

зачем тебе fglrx?

Serge ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.