LINUX.ORG.RU

ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI


0

0

Что можно с этим сделать !? Обыскал весь инет, ничего не нашел! (Для информации, видюха HD4850, скачал последний драйвер ati-driver-installer-9-4-x86.x86_64.run, 32-битная ОС) Установил Debian/lenny с нуля! (Совсем чистая) поставил пакеты: mc ntfs-3g x-window-system kde-base а это необходимые пакеты для установки драйверов: module-assistant build-essential fakeroot dh-make debconf libstdc++5 скачал драйвера с сайта ATI и выполнил команду: sh ati-driver-installer-9-4-x86.x86_64.run --buildpkg Debian/lenny получил 5 файлов, 4 deb пакета и 5-й удалил :) так вот, дальше необходимо установить все 4 деб пакета, ошибка при установке пакета fglrx-driver_8.602-1_i386.deb: dpkg -i fglrx-driver_8.602-1_i386.deb Распаковывается пакет fglrx-driver (из файла fglrx-driver_8.602-1_i386.deb)... Нет отклонения `diversion of /usr/lib/libGL.so.1.2 to /usr/share/fglrx/diversion s/libGL.so.1.2 by fglrx-driver', ничего не удалено Добавляется `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/lib GL.so.1.2 by fglrx-driver' Добавляется `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL .so.1 by fglrx-driver' rmdir: failed to remove `/usr/share/fglrx/diversions': Нет такого файла или ката лога rmdir: failed to remove `/usr/share/fglrx': Нет такого файла или каталога Оставляется `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/lib GL.so.1.2 by fglrx-driver' Оставляется `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL .so.1 by fglrx-driver' Добавляется `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib /fglrx/diversions/libdri.so by fglrx-driver' dpkg: не удалось обработать параметр fglrx-driver_8.602-1_i386.deb (--install): попытка перезаписать /usr/lib/xorg/modules/extensions/libglx.so, который уже им еется в пакете xserver-xorg-core dpkg-deb: подпроцесс paste убит по сигналу (Обрыв канала) Удаляется `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.s o.1 by fglrx-driver' Удаляется `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL .so.1.2 by fglrx-driver' rmdir: failed to remove `/usr/lib/fglrx/diversions': Каталог не пуст rmdir: failed to remove `/usr/lib/fglrx': Каталог не пуст Удаляется `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/f glrx/diversions/libdri.so by fglrx-driver' При обработке следующих пакетов произошли ошибки: fglrx-driver_8.602-1_i386.deb


Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

apt-cache search fglrx
apt-get install (...)

lester ★★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

ээээ......зачем мне ставить fglrx c репозитория, я же хочу поставить пакет fglrx-driver_8.602-1_i386.deb, который я выташил из рановского файла ati или я что-то не так понимаю? обьясни!

deq ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

попробуй:

удалить старое
#apt-get remove fglrx*

и из папки с deb пакетами поставить новый fglrx
#dpkg -i --force-all *.deb

elipse ★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

> ээээ......зачем мне ставить fglrx c репозитория, я же хочу поставить пакет fglrx-driver_8.602-1_i386.deb, который я выташил из рановского файла ati или я что-то не так понимаю? обьясни!

затем, что в репозитории лежат уже собранные протестированные модули для твоего ядра

lester ★★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI


>затем, что в репозитории лежат уже собранные протестированные модули >для твоего ядра


fglrx 9.4 ТОЛЬКО под ведро 2.6.29 из реп дебовских!!

elipse ★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

это пердупреждение :)))

и с удалением fglrx 9.4 могут быть проблемы
не все либы сносятся потом и даже шиш vesa запускалась
- и на трех дебах уже нарвался на этот эффект.

elipse ★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

То есть, мне сейчас установить fglrx 9.2 или другию версию, потом ставить свои пакеты, я правильно понял? И еще момент, обьясните почему у меня не ставятся пакеты, что это за ошибка!

deq ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

>То есть, мне сейчас установить fglrx 9.2 или другию версию, потом ставить свои пакеты, я правильно понял?

верно ,fglrx 9.2 из testing будет оптимально для вашей железки.

fglrx 9.4 советую ставить только из реп и обновить все до Sid

вообще , fglrx драйвера патчат в Debian и лучше брать из дистра
а не абстрактные версии c сайта ati и не привязанные к специфике .:))


>И еще момент, обьясните почему у меня не ставятся пакеты, что это за ошибка!


скажем так - это разорванные зависимости одиночных пакетов ,
--force-all опция в dpkg была для продолжения действий и игнорирования подобных ошибок.


elipse ★★★ ()

Re: ПОМОГИТЕ! Ошибка в ходе установки драйверов ATI

Opyat' problemka! vot spisok paketov, kotorie ya postavil:

fglrx-atieventsd fglrx-driver fglrx-glx fglrx-kernel-2.6.26-1-686 fglrx-kernel-src fglrx-modules-2.6.26-1-686 fglrx-source

v "/etc/X11/xorg.conf" propisano:

Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection

dalee vipolnil komandi:

m-a prepare m-a a-i fglrx modprobe -v fglrx

vrode vse bez oshibok daje iksi zagruzilis', no komanda fglrxinfo vidaet:

# fglrxinfo No protocol specified Error: unable to open display (null)

nadeyus' na vashu pomosh'! p.s. Izvenite za translit, nichego eshe ne nastraival.....muchayus' s drovami :)

deq ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.