LINUX.ORG.RU

ATI + Ubuntu 8.04


0

0

Здраствуйте ЗАхотел поставить драйвера в принципе есть 2 руководства правда они для 7й версии, по первому у меня ничего не заработало решил по второму скачал с сайта драйвера но когда запускал

bash ati-driver-installer-8.36.5-x86.x86_64.run --buildpkg Ubuntu/feisty

то выдало следующий текст

dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/-driver-fglrx/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries. dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/-driver-fglrx/usr/lib/libfglrx_gamma.so.1.0 found in none of the libraries. dpkg-shlibdeps: warning: diversions involved - output may be incorrect diversion by xorg-driver-fglrx from: /usr/lib32/libGL.so.1 dpkg-shlibdeps: warning: diversions involved - output may be incorrect diversion by xorg-driver-fglrx to: /usr/lib32/fglrx/libGL.so.1.xlibmesa dpkg-shlibdeps: warning: diversions involved - output may be incorrect diversion by xorg-driver-fglrx from: /usr/lib32/libGL.so.1.2 dpkg-shlibdeps: warning: diversions involved - output may be incorrect diversion by xorg-driver-fglrx to: /usr/lib32/fglrx/libGL.so.1.2.xlibmesa dpkg-shlibdeps: warning: debian/fglrx-amdcccle/usr/bin/amdcccle shouldn't be linked with libXi.so.6 (it uses none of its symbols). dh_gencontrol -- -VXVERSION= -VXVERSIONMAX=.99 -VXTYPE= -VXSERVER= dpkg-gencontrol: warning: can't parse dependency -driver-fglrx dpkg-gencontrol: error: error occurred while parsing -driver-fglrx dh_gencontrol: command returned error code 65280 make: *** [binary] Error 1 dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2 Removing temporary directory: fglrx-install.Rz9120

Что посоветуете. . .


Re: ATI + Ubuntu 8.04

тваю мать. Там есть специальная программа для установки проприетарных драйверов. Нет, надо обязательно неумеючи руками делать.

amoralyrr ★☆ ()
Ответ на: Re: ATI + Ubuntu 8.04 от amoralyrr

Re: ATI + Ubuntu 8.04

блин...ещё и старый драйвер, которому уже год с лишним взял. Ещё бы нихрена не работает.

amoralyrr ★☆ ()
Ответ на: Re: ATI + Ubuntu 8.04 от amoralyrr

Re: ATI + Ubuntu 8.04

Когда запускаю установку restricted-manager

Заметьте, вместо restricted-manager выбирается jockey-gtk Уже установлена самая новая версия jockey-gtk. обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакет

Вопрос как установить restricted-manager или как работать с jockey-gtk потому как в последнем кроме как закрыть и справка никаких кнопочек нет :-(

Spiky ()

Re: ATI + Ubuntu 8.04

Уважаемые подскажите что делать ведь для того чтобы пользоваться Система/администрирование/драйверы устройств надо сначала все же эти драйверы поставить Скачал новую версию драйверов ati-driver-installer-8-4-x86.x86_64.run потом как в мануале сделал bash ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu/feisty

Далее sudo gedit /etc/default/linux-restricted-modules-common

и вносим изменения по драйверу

DISABLED_MODULES="fglrx"

В каталоге где мы преобразовывали драйвер АТИ запускаем sudo dpkg -i xorg-driver-fglrx_8.36.5-1*.deb sudo dpkg -i fglrx-kernel-source_8.36.5-1*.deb sudo dpkg -i fglrx-amdcccle_8.36.5-1*.deb sudo dpkg -i xorg-driver-fglrx-dev_8.36.5-1*.deb

Удаляем старый драйвер fglrx в /usr/src sudo rm /usr/src/fglrx-kernel*.deb

Собираем модули с помощью MODULE-ASSISTANT

Используем установленный ранее будем использовать консольные команды, а не рекурсивные.

sudo module-assistant prepare sudo module-assistant update sudo module-assistant build fglrx sudo module-assistant install fglrx

spiky@spiky-desktop:~$ sudo module-assistant install fglrx (Чтение базы данных... на данный момент установлено 186107 файлов и каталогов.)

Подготовка к замене пакета fglrx-kernel-2.6.24-16-generic 2:8.476-0ubuntu1+2.6.24-16.30 (используется файл .../fglrx-kernel-2.6.24-16-generic_8.476-0ubuntu1+2.6.24-16.30_amd64.deb)...

Распаковывается замена для пакета fglrx-kernel-2.6.24-16-generic ... dpkg: зависимости пакетов не позволяют настроить пакет fglrx-kernel-2.6.24-16-generic: fglrx-kernel-2.6.24-16-generic зависит от xorg-driver-fglrx (= 2:8.476-0ubuntu1), однако:

Версия xorg-driver-fglrx в системе 1:7.1.0-8-3+2.6.24.12-16.34. dpkg: не удалось обработать параметр fglrx-kernel-2.6.24-16-generic (--install):

проблемы зависимостей -- оставляем не настроенным При обработке следующих пакетов произошли ошибки: fglrx-kernel-2.6.24-16-generic

в итоге он предлогает Пакеты, которые будут УДАЛЕНЫ: fglrx-kernel-2.6.24-16-generic Что посоветуете .????

Spiky ()
Ответ на: Re: ATI + Ubuntu 8.04 от Spiky

Re: ATI + Ubuntu 8.04

Это ППЦ.

Во-первых restricted-manager уже установлен (то самоее система/администрирование/драйверы). Во-вторых дрова fglrx уже стоят в бубунте. В-третьих скачиавть ничего не надо все есть в репозитариях. В-четвертых зайди в restricted-manager (предварительно вернув etc/default/linux-restricted-modules-common к исходному состоянию), И ПОСТАВЬ БЛЯТЬ ГАЛОЧКУ НАПРОТИВ СТРОЧКИ C ATI!!!!

cathode ()

Re: ATI + Ubuntu 8.04

а как насчет не

> bash ati-driver-installer-8.36.5-x86.x86_64.run --buildpkg Ubuntu/feisty

а

>bash ati-driver-installer-8.36.5-x86.x86_64.run --buildpkg Ubuntu/hardy

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.