LINUX.ORG.RU

error a previous installation of fglrx driver detected - не удаётся вычистить из системы останки от предыдущего видеодрайвера

 , , , ,


1

2

Доброго времени суток. Пытаюсь установить видеодрайвер вот этот. Некогда стояла версия этого драйвера за март, 2014 (удалена при помощи sudo /usr/share/ati/amd-uninstall.sh). На неё сверху ставился fglrx из Synaptic (также удалён средствами сначала самого synaptic). После этого была попытка поставить первый упомянутый драйвер. При установке в режиме восстановления выдаёт сообщение:

[Error]A previous installation of fglrx driver detected to be loaded. User must uninstall existing fglrx driver or run install with force option. Forcing the installation is not recommended.

Как решалась проблема:

[ -x /usr/share/ati/fglrx-uninstall.sh ] && /usr/share/ati/fglrx-uninstall.sh
apt-get remove --purge fglrx\* xserver-xorg-video-ati xserver-xorg-video-radeon
apt-get install xserver-xorg-video-ati
apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
dpkg-reconfigure xserver-xorg
apt-get install fglrx-modaliases
Также был удалён glx-diversions, libglx.so

Далее - попытка приведения xorg в жизнеспособное состояние:
dpkg-reconfigure x11-common
Xorg -configure
cp /root/xorg.conf.new /etc/X11/xorg.conf

Не помогло. Там же, в безопасном режиме:

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
Проверка, есть ли какие-то остатки драйвера с последующим их удалением:
sudo aticonfig --initial
sudo aticonfig --uninstall
Проверка статуса и восстановление xorg:
stat /etc/X11/xorg.conf.original-1

Результата нет. Думаю удалить libgl1-mesa-glx, libgl1-mesa-dev, libglu1-mesa, libgl1-mesa-glx:i386, однако, первый и последний тянут за собой много зависимостей; при удалении их начинают удаляться чуть ли не все пакеты, например, libreoffice.
Как найти останки предыдущего fglrx, удалить не повредив нужного и установить новый драйвер?
Debiat 7,6, xfce, vaio eb1e1r, ATI Mobility Radeon 5400. Заранее благодарю за ответы.

mesa не имеет никакого отношения к fglrx. У него (fglrx) своя реализация OpenGL. А ставить программу в обход пакетного манагера — дурная привычка слаководов. Энджой your дебиан

Unicode4all ★★★★★ ()
Ответ на: комментарий от Unicode4all

ставить программу в обход пакетного манагера

Да вот fglrx из synaptic нормально не хочет ставиться - то vlc не хочет работать, то alienarena не хочет запускаться. Со скачанным с сайта таких проблем не было.

maxim_ch ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.