LINUX.ORG.RU
ФорумGames

Не ставится Steam Debian

 ,


0

1
dpkg --add-architecture i386
sudo apt-get install steam

Пакеты, имеющие неудовлетворённые зависимости: steam:i386 : Зависит: libgl1-mesa-dri:i386 но он не будет установлен Зависит: libgl1-mesa-glx:i386 но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

sudo apt-get install libgl1-mesa-dri:i386

Пакеты, имеющие неудовлетворённые зависимости: libgl1-mesa-dri:i386 : Зависит: libdrm-intel1:i386 (>= 2.4.48) но он не будет установлен Зависит: libdrm-nouveau2:i386 (>= 2.4.38) но он не будет установлен Зависит: libdrm-radeon1:i386 (>= 2.4.31) но он не будет установлен Зависит: libdrm2:i386 (>= 2.4.38) но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

sudo apt-get install libdrm-intel1:i386

Следующие пакеты устанавливались автоматически и больше не требуются: cinnamon-desktop-data cinnamon-l10n fonts-sil-gentium fonts-sil-gentium-basic hyphen-en-us libcinnamon-desktop4 libnemo-extension1 nemo-data x11-apps x11-session-utils xinit Для их удаления используйте «apt-get autoremove».

Будут установлены следующие дополнительные пакеты: libdrm2:i386 libpciaccess0:i386 zlib1g:i386

Пакеты, которые будут УДАЛЕНЫ: bijiben brasero caribou caribou-antler cheese default-jre empathy evolution evolution-plugins gdm3 gir1.2-champlain-0.12 gir1.2-clutter-1.0 gir1.2-clutter-gst-2.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0 gir1.2-mutter-3.0 gir1.2-rb-3.0 gir1.2-totem-1.0 gir1.2-webkit-3.0 gnome gnome-contacts gnome-control-center gnome-core gnome-documents gnome-games gnome-getting-started-docs gnome-maps gnome-media gnome-nibbles gnome-online-accounts gnome-session gnome-session-bin gnome-shell gnome-shell-extension-weather gnome-shell-extensions gnome-sound-recorder gnome-sushi gnome-user-guide gnome-video-effects gstreamer1.0-clutter gstreamer1.0-plugins-bad gstreamer1.0-vaapi gvfs gvfs-backends gvfs-daemons gvfs-fuse i965-va-driver libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk23 libcheese7 libclutter-1.0-0 libclutter-gst-2.0-0 libclutter-gtk-1.0-0 libcogl-pango20 libcogl-path20 libcogl20 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl1-mesa libevolution libfarstream-0.2-2 libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglew1.10 libgltf-0.0-0 libglu1-mesa libgoa-backend-1.0-1 libgstreamer-plugins-bad1.0-0 libgstreamer-vaapi1.0-0 libgtkglext1 libmutter0e libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4 libopencv-video2.4 libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-core libreoffice-draw libreoffice-evolution libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-help-ru libreoffice-impress libreoffice-math libreoffice-report-builder-bin libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-writer librhythmbox-core8 libtelepathy-farstream3 libtotem0 libva-drm1 libva-glx1 libva-wayland1 libva-x11-1 libvisual-0.4-plugins libwayland-egl1-mesa libwebkitgtk-3.0-0 libxatracker2 libyelp0 lightsoff mesa-utils metacity mutter mythes-en-us mythes-ru nautilus nautilus-sendto nemo nemo-fileroller openjdk-7-jre plymouth plymouth-themes plymouth-x11 python3-uno quadrapassel rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugins swell-foop task-desktop task-gnome-desktop totem totem-plugins unoconv vlc x11-utils xorg xserver-xephyr xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-modesetting xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware xwayland yelp zenity НОВЫЕ пакеты, которые будут установлены: libdrm-intel1:i386 libdrm2:i386 libpciaccess0:i386 zlib1g:i386 обновлено 0, установлено 4 новых пакетов, для удаления отмечено 180 пакетов, и 1 пакетов не обновлено. Необходимо скачать 238 kБ архивов. После данной операции, объём занятого дискового пространства уменьшится на 744 MB. Хотите продолжить? [Д/н]

Ебилд мне в дебьян! Просто ставь Ubuntu.

anonymous ()

Всё работает, смотри:

# lvcreate -L 10G -ndebian vg0
# mkfs.reiserfs /dev/vg0/debian
# mkdir /tmp/deb
# mount /dev/vg0/debian /tmp/deb/
# debootstrap --arch amd64 jessie /tmp/deb http://ftp.us.debian.org/debian
# mount -o bind /dev/ /tmp/deb/dev/
# mount -t proc none /tmp/deb/proc/
# chroot /tmp/deb/ /bin/bash
root@localhost:/# echo "deb http://http.debian.net/debian/ jessie main contrib non-free" >> /etc/apt/sources.list
root@localhost:/# dpkg --add-architecture i386
root@localhost:/# apt-get update
root@localhost:/# apt-get install steam
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  adwaita-icon-theme aspell aspell-en at-spi2-core colord colord-data dbus dconf-gsettings-backend dconf-service dictionaries-common emacsen-common enchant
  fontconfig fontconfig-config fonts-dejavu-core fonts-liberation gcc-4.9-base:i386 geoclue-2.0 glib-networking glib-networking-common
  glib-networking-services gsettings-desktop-schemas gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x hicolor-icon-theme hunspell-en-us
  iso-codes krb5-locales libaa1 libalgorithm-c3-perl libarchive-extract-perl libasound2 libasound2-data libaspell15 libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libavahi-client3 libavahi-common-data libavahi-common3 libavc1394-0 libbsd0 libbsd0:i386 libc6:i386 libc6-i686:i386 libcaca0
  libcairo-gobject2 libcairo2 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 libcap-ng0 libcdparanoia0 libcgi-fast-perl libcgi-pm-perl
  libclass-c3-perl libclass-c3-xs-perl libcolord2 libcolorhug2 libcpan-meta-perl libcroco3 libcups2 libdata-optlist-perl libdata-section-perl libdatrie1
  libdbus-1-3 libdconf1 libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386
  libdv4 libedit2 libedit2:i386 libelf1 libelf1:i386 libenchant1c2a libexif12 libexpat1 libexpat1:i386 libfcgi-perl libffi6:i386
  libfile-copy-recursive-perl libflac8 libfontconfig1 libfontenc1 libfreetype6 libgcc1:i386 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libglib2.0-0 libglib2.0-data libglu1-mesa
  libgphoto2-6 libgphoto2-l10n libgphoto2-port10 libgpm2 libgraphite2-3 libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0
  libgtk-3-bin libgtk-3-common libgudev-1.0-0 libgusb2 libharfbuzz-icu0 libharfbuzz0b libhunspell-1.3-0 libice6 libiec61883-0 libieee1284-3
  libjack-jackd2-0 libjasper1 libjavascriptcoregtk-3.0-0 libjbig0 libjim0.75 libjpeg62-turbo libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3
  libkeyutils1 libkrb5-3 libkrb5support0 liblcms2-2 libllvm3.5 libllvm3.5:i386 liblog-message-perl liblog-message-simple-perl libltdl7 libmbim-glib4
  libmbim-proxy libmm-glib0 libmodule-build-perl libmodule-pluggable-perl libmodule-signature-perl libmro-compat-perl libnl-3-200 libnl-genl-3-200
  libnotify4 libogg0 libopus0 liborc-0.4-0 libpackage-constants-perl libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libparams-util-perl libpciaccess0 libpciaccess0:i386 libpcsclite1 libpixman-1-0 libpng12-0 libpod-latex-perl libpod-readme-perl libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libproxy1 libqmi-glib1 libqmi-proxy libraw1394-11 libregexp-common-perl librest-0.7-0 librsvg2-2
  librsvg2-common libsamplerate0 libsane libsane-common libsane-extras libsane-extras-common libsecret-1-0 libsecret-common libshout3 libsm6
  libsoftware-license-perl libsoup-gnome2.4-1 libsoup2.4-1 libspeex1 libsqlite3-0 libstdc++6:i386 libsub-exporter-perl libsub-install-perl libtag1-vanilla
  libtag1c2a libtdb1 libterm-ui-perl libtext-soundex-perl libtext-template-perl libthai-data libthai0 libtheora0 libtiff5 libtinfo5:i386 libtxc-dxtn-s2tc0
  libtxc-dxtn-s2tc0:i386 libudev1:i386 libusb-1.0-0 libutempter0 libv4l-0 libv4lconvert0 libvisual-0.4-0 libvisual-0.4-plugins libvorbis0a libvorbisenc2
  libvorbisfile3 libvpx1 libwavpack1 libwayland-client0 libwayland-cursor0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwebp5 libx11-6 libx11-6:i386
  libx11-data libx11-xcb1 libx11-xcb1:i386 libxau6 libxau6:i386 libxaw7 libxcb-dri2-0 libxcb-dri2-0:i386 libxcb-dri3-0 libxcb-dri3-0:i386 libxcb-glx0
  libxcb-glx0:i386 libxcb-present0 libxcb-present0:i386 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-sync1:i386 libxcb1 libxcb1:i386
  libxcomposite1 libxcursor1 libxdamage1 libxdamage1:i386 libxdmcp6 libxdmcp6:i386 libxext6 libxext6:i386 libxfixes3 libxfixes3:i386 libxft2 libxi6
  libxinerama1 libxinerama1:i386 libxkbcommon0 libxml2 libxmu6 libxmuu1 libxpm4 libxrandr2 libxrender1 libxshmfence1 libxshmfence1:i386 libxslt1.1 libxt6
  libxtst6 libxv1 libxxf86dga1 libxxf86vm1 libxxf86vm1:i386 modemmanager notification-daemon perl perl-modules policykit-1 rename sane-utils sgml-base
  shared-mime-info ucf update-inetd usb-modeswitch usb-modeswitch-data wpasupplicant x11-common x11-utils xbitmaps xdg-user-dirs xkb-data xml-core xterm
  xz-utils zenity zenity-common zlib1g:i386

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

Сделай apt-get update и (или) используй aptitude

nutsandmilk ★★★ ()
Suggested packages:
  aspell-doc spellutils dbus-x11 wordlist gvfs hunspell openoffice.org-hunspell openoffice.org-core isoquery libasound2-plugins alsa-utils glibc-doc:i386
  locales:i386 libcanberra-gtk0 libcanberra-pulse cups-common libdv-bin oss-compat libenchant-voikko libgd-tools gphoto2 gtkam gpm krb5-doc krb5-user
  gstreamer-codec-install gnome-codec-install gstreamer1.0-tools jackd2 libjasper-runtime liblcms2-utils opus-tools pciutils pciutils:i386 pcscd
  libraw1394-doc librsvg2-bin avahi-daemon hplip hpoj speex perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl make libb-lint-perl
  libcpanplus-dist-build-perl libcpanplus-perl libfile-checktree-perl libobject-accessor-perl unpaper sgml-base-doc comgt wvdial wpagui
  libengine-pkcs11-openssl mesa-utils debhelper xfonts-cyrillic
Recommended packages:
  libarchive-tar-perl zenity:i386 fonts-liberation:i386
The following NEW packages will be installed:
  adwaita-icon-theme aspell aspell-en at-spi2-core colord colord-data dbus dconf-gsettings-backend dconf-service dictionaries-common emacsen-common enchant
  fontconfig fontconfig-config fonts-dejavu-core fonts-liberation gcc-4.9-base:i386 geoclue-2.0 glib-networking glib-networking-common
  glib-networking-services gsettings-desktop-schemas gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x hicolor-icon-theme hunspell-en-us
  iso-codes krb5-locales libaa1 libalgorithm-c3-perl libarchive-extract-perl libasound2 libasound2-data libaspell15 libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libavahi-client3 libavahi-common-data libavahi-common3 libavc1394-0 libbsd0 libbsd0:i386 libc6:i386 libc6-i686:i386 libcaca0
  libcairo-gobject2 libcairo2 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 libcap-ng0 libcdparanoia0 libcgi-fast-perl libcgi-pm-perl
  libclass-c3-perl libclass-c3-xs-perl libcolord2 libcolorhug2 libcpan-meta-perl libcroco3 libcups2 libdata-optlist-perl libdata-section-perl libdatrie1
  libdbus-1-3 libdconf1 libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386
  libdv4 libedit2 libedit2:i386 libelf1 libelf1:i386 libenchant1c2a libexif12 libexpat1 libexpat1:i386 libfcgi-perl libffi6:i386
  libfile-copy-recursive-perl libflac8 libfontconfig1 libfontenc1 libfreetype6 libgcc1:i386 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libglib2.0-0 libglib2.0-data libglu1-mesa
  libgphoto2-6 libgphoto2-l10n libgphoto2-port10 libgpm2 libgraphite2-3 libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0
  libgtk-3-bin libgtk-3-common libgudev-1.0-0 libgusb2 libharfbuzz-icu0 libharfbuzz0b libhunspell-1.3-0 libice6 libiec61883-0 libieee1284-3
  libjack-jackd2-0 libjasper1 libjavascriptcoregtk-3.0-0 libjbig0 libjim0.75 libjpeg62-turbo libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3
  libkeyutils1 libkrb5-3 libkrb5support0 liblcms2-2 libllvm3.5 libllvm3.5:i386 liblog-message-perl liblog-message-simple-perl libltdl7 libmbim-glib4
  libmbim-proxy libmm-glib0 libmodule-build-perl libmodule-pluggable-perl libmodule-signature-perl libmro-compat-perl libnl-3-200 libnl-genl-3-200
  libnotify4 libogg0 libopus0 liborc-0.4-0 libpackage-constants-perl libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0
  libparams-util-perl libpciaccess0 libpciaccess0:i386 libpcsclite1 libpixman-1-0 libpng12-0 libpod-latex-perl libpod-readme-perl libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libproxy1 libqmi-glib1 libqmi-proxy libraw1394-11 libregexp-common-perl librest-0.7-0 librsvg2-2
  librsvg2-common libsamplerate0 libsane libsane-common libsane-extras libsane-extras-common libsecret-1-0 libsecret-common libshout3 libsm6
  libsoftware-license-perl libsoup-gnome2.4-1 libsoup2.4-1 libspeex1 libsqlite3-0 libstdc++6:i386 libsub-exporter-perl libsub-install-perl libtag1-vanilla
  libtag1c2a libtdb1 libterm-ui-perl libtext-soundex-perl libtext-template-perl libthai-data libthai0 libtheora0 libtiff5 libtinfo5:i386 libtxc-dxtn-s2tc0
  libtxc-dxtn-s2tc0:i386 libudev1:i386 libusb-1.0-0 libutempter0 libv4l-0 libv4lconvert0 libvisual-0.4-0 libvisual-0.4-plugins libvorbis0a libvorbisenc2
  libvorbisfile3 libvpx1 libwavpack1 libwayland-client0 libwayland-cursor0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libwebp5 libx11-6 libx11-6:i386
  libx11-data libx11-xcb1 libx11-xcb1:i386 libxau6 libxau6:i386 libxaw7 libxcb-dri2-0 libxcb-dri2-0:i386 libxcb-dri3-0 libxcb-dri3-0:i386 libxcb-glx0
  libxcb-glx0:i386 libxcb-present0 libxcb-present0:i386 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-sync1:i386 libxcb1 libxcb1:i386
  libxcomposite1 libxcursor1 libxdamage1 libxdamage1:i386 libxdmcp6 libxdmcp6:i386 libxext6 libxext6:i386 libxfixes3 libxfixes3:i386 libxft2 libxi6
  libxinerama1 libxinerama1:i386 libxkbcommon0 libxml2 libxmu6 libxmuu1 libxpm4 libxrandr2 libxrender1 libxshmfence1 libxshmfence1:i386 libxslt1.1 libxt6
  libxtst6 libxv1 libxxf86dga1 libxxf86vm1 libxxf86vm1:i386 modemmanager notification-daemon perl perl-modules policykit-1 rename sane-utils sgml-base
  shared-mime-info steam:i386 ucf update-inetd usb-modeswitch usb-modeswitch-data wpasupplicant x11-common x11-utils xbitmaps xdg-user-dirs xkb-data
  xml-core xterm xz-utils zenity zenity-common zlib1g:i386
0 upgraded, 306 newly installed, 0 to remove and 0 not upgraded.
Need to get 122 MB of archives.
After this operation, 429 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Как видишь произведён разворот чистой базовой системы Debian архитектуры amd64 посредством debootstrap, затем произведён chroot в развёрнутую базовую систему, подключен репозиторий со всеми ветками, подключена 32 битная архитектура (i386), после чего обновлён список доступных пакетов и посредством

kostik87 ★★★★★ ()
Ответ на: комментарий от nutsandmilk

Не думаешь же ты, что он не умеет читать? Ведь в инструкции на debian wiki, тем более на русском языке, описана последовательность действий:

64-битные системы (amd64)
/!\ Инструкции только для Jessie и Sid выпусков.

1. Добавьте «non-free» компонент в /etc/apt/sources.list, например:
# Debian Jessie (testing)
deb http://http.debian.net/debian/ jessie main contrib non-free

2. Включите Multi-Arch и обновите список доступных пакетов:
# dpkg --add-architecture i386
# aptitude update

3. Установите пакет steam:
# aptitude install steam
Ссылку на эту инструкцию в его прошлой теме ему уже дали. Ну всё возможно, может он медленно читает? Ведь www.linux.org.ru/help/lorcode.md он так и не дочитал, всё использует тег [quote][/quote] для размещения выводов команд ...

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 2)
Ответ на: комментарий от anonymous

Спроси автора статьи на Debian Wiki, сходи по ссылке и убедись, что я просто скопировал оттуда текст, дабы показать, что в инструкции всё уже есть.

Ну и использование apt-get или aptitude особой разницы не привносит.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

dpkg --add-architecture i386
sudo apt-get install steam

Ну, я судил по первым двум строкам этого треда

nutsandmilk ★★★ ()
Ответ на: комментарий от kostik87
Я делал всё по инструкции с вики. Я рад, что у тебя работает, но у меня НЕТ.
На форуме только вчера зарегался, аллилуйя, я узнал про [code ,величайшее достижение в жизни наверное.
Итак основная проблема, что при установке, он собирается срубить мне весь гном.
что касается
# lvcreate -L 10G -ndebian vg0
# mkfs.reiserfs /dev/vg0/debian
# mkdir /tmp/deb
# mount /dev/vg0/debian /tmp/deb/
# debootstrap --arch amd64 jessie /tmp/deb http://ftp.us.debian.org/debian
# mount -o bind /dev/ /tmp/deb/dev/
# mount -t proc none /tmp/deb/proc/
# chroot /tmp/deb/ /bin/bash

то половину, я тут не понимаю, и первые 2 команды моему компьютеру не известны. Спасибо за попытки, но я не пытаюсь понять свой уровень навыка линукс, спасибо, я пытаюсь найти решение и разобраться почему это работает так.

DeepDlueIV ()
Ответ на: комментарий от DeepDlueIV

Я тебе уже ответил почему у тебя работает не так, а именно потому, что ты в Debian подключился репозитории от Ubuntu и ставил из них пакеты. Либо разбирайся как вычистить систему, либо просто переустанови её и никогда более не смешивай репозитории от разных дистрибутивов. Вот ответ на вопрос почему у тебя не получаются описанные в инструкции действия.

Впредь в начале подумай, а правильно ли я делаю и какие могут быть последствия, а потом делай.

Повторять твои нелепые действия по подключению репозитория Ubuntu, а затем разбираться как их исправить у меня нет желания. Сам заварил кашу - сам и расхлебывай. Хотя дам все же совет: почитай лог apt и посмотри какие пакеты ставились из репозиториев Ubuntu, удали их, что, возможно, опять же потянет к удалению кучи пакетов. Так что тебе проще пкреставить систему.

Удачи.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kilolife

я прост думал, нафига в дебьяне сразу 2 утилиты с одинаковым функционалом?..

anonymous ()
Ответ на: комментарий от DeepDlueIV

то половину, я тут не понимаю, и первые 2 команды моему компьютеру не известны

Загуглить не пробовал? На самом деле эти команды отношения к твоей проблеме не имеют, они лишь выполнены для получения чистой установки Debian. А так, здесь создаётся новый LVM том, на котором я затем создаю файловую систему, монтирую его, после чего посредством debootsrap делаю разворот чистой Debian системы, о чём я тебе и написал:

kostik87

Как видишь произведён разворот чистой базовой системы Debian архитектуры amd64 посредством debootstrap, затем произведён chroot в развёрнутую базовую систему, подключен репозиторий со всеми ветками, подключена 32 битная архитектура (i386), после чего обновлён список доступных пакетов и посредством

затем делается переход в развёрнутую систему посредством chroot, ну и собственно выполнение действий, указанных в Debian wiki по установке steam. Это всё для того, что бы показать тебе, что описанное в руководстве верно и если бы ты не засрал свою систему левыми репозиториями, то и у тебя бы всё получилось.

kostik87 ★★★★★ ()

dpkg --add-architecture i386

apt-get update

apt-get install steam

buratino ★★★★★ ()

Плавали, знаем. Проблемы в репах интела — отключи их и поставь дрова из родного репозитария.

Kor03d ★★ ()
Ответ на: комментарий от Kor03d

Если верить ТС, то у него подключены вот эти репозитории:

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150908-22:02]/ jessie main 

deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150908-22:02]/ jessie main 

# - Основные репозитории, обновления, безопасность, свободные и несвободные пакеты

deb http://ftp.ru.debian.org/debian/ stable main contrib non-free 
deb-src http://ftp.ru.debian.org/debian/ stable main contrib non-free 

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free 
deb-src http://ftp.debian.org/debian/ jessie-updates main contrib non-free 

deb http://security.debian.org/ jessie/updates main contrib non-free 
deb-src http://security.debian.org/ jessie/updates main contrib non-free 

# - Multimedia

# deb http://www.deb-multimedia.org/ jessie non-free main 

deb http://ppa.launchpad.net/numix/ppa/ubuntu/ vivid main 

#video driver
deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid main 
deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ vivid main  


# deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ vivid main 
# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ vivid main 

#ppa purge
# deb http://archive.ubuntu.com/ubuntu/ lucid-backports multiverse universe restricted main
Debian jessie не могу нагуглить решения (комментарий)

Как видишь, там нет репозитория Intel, зато есть репозиторий от Ubuntu.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Там есть реп xorg-xedgers, оттуда и кривые интеловские дрова.

Kor03d ★★ ()
Ответ на: комментарий от Kor03d

Да, только ты видишь, что этот репозиторий для Ubuntu, а не для Debian.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Дак а как подрубать нужные репы, если их попросту нету? У всех разрабов я наблюдаю одни trusty vivid willy и тд. Где для Деба тогда тянуть свежие дрова кроме как из xorg-edgers ?

DeepDlueIV ()
Ответ на: комментарий от DeepDlueIV

Где для Деба тогда тянуть свежие дрова

Во-первых, если тебе нужны свежие драйверы или попросту свежие версии программ, то ты выбрал не тот дистрибутив, в частности если говорить о Debian Stable, то версии программ в стабильном релизе будут отставать от последних версий программ в лучшем случае на год, а то и более. Но ты можешь установить Debian Testing и постоянно быть на тестируемом релизе. Если тебе нужны именно более новые версии, скажем ядра, xorg-server`а, видео драйверов в стабильном релизе Debian, то есть проект Debian Backports - это официальный репозиторий Debian, в него помещаются пакеты, собранные на основе исходных кодов пакетов из тестируемого релиза. Так же ты можешь смешивать ветки Debian, т.е. подключить репозиторий тестируемого релиза Debian, настроить какие пакеты из него ты хочешь ставить, указать какой релиз при подсчёте зависимостей использовать по умолчанию, ну и собственно ставить пакеты. Но я тебе всё же советую использовать Debian Backports, а то ты и так уже понапихал в систему левых репозиториев, в случае же смешивания веток тоже нужно быть осторожным, поэтому только Debian Backports. Ну и чем тебя не устроила текущая версия драйвера?

У всех разрабов я наблюдаю одни trusty vivid willy и тд

Вот и не надо их подключать. Эти пакеты собраны для другого дистрибутива, да формат у них одинаков, но при подсчёте зависимостей будут проблемы, ты и так уже с нимм столкнулся. Если нет официального репозитория для Debian от авторов программы, то либо используй версию программы, которая есть в официальном репозитории, либо попробуй поставить версию пакета из другого релиза Debian, либо собирай программу из исходников и собирай самостоятельно пакет.

Дак а как подрубать нужные репы, если их попросту нету?

У Debian можно сказать самый большой репозиторий, маловероятно, что в нём чего-либо нет, хотя бы относительно старая версия точно есть.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Да хоть для Федоры, лишь бы работало. Но оно не работает, и надо отключать. Я у ТС не заигнорен случайно?

Kor03d ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.