LINUX.ORG.RU

Проблема с устонвкой wine32:i386

 


0

1

Нужно установить именно этот пакет. При установке хочет удалить 99 пакетов:

aptitude install wine32:i386
Следующие НОВЫЕ пакеты будут установлены:        
  gcc-4.9-base:i386{a} libasound2:i386{a} libbsd0:i386{a} libc6:i386{a} libdb5.3:i386{a} 
  libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a} 
  libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} libexpat1:i386{a} libffi6:i386{a} 
  libfreetype6:i386{a} libgcc1:i386{a} libgcrypt20:i386{a} libgl1-mesa-dri:i386{a} 
  libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} libglib2.0-0:i386{a} libglu1-mesa:i386{a} 
  libgmp10:i386{a} libgnutls-deb0-28:i386{a} libgpg-error0:i386{a} 
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} libhogweed2:i386{a} 
  liblcms2-2:i386{a} libldap-2.4-2:i386{a} libllvm3.8:i386{a} liblzma5:i386{a} libmpg123-0:i386{a} 
  libncurses5:i386{a} libnettle4:i386{a} libopenal1:i386{a} liborc-0.4-0:i386{a} 
  libp11-kit0:i386{a} libpciaccess0:i386{a} libpcre3:i386{a} libpng12-0:i386{a} libsasl2-2:i386{a} 
  libsasl2-modules-db:i386{a} libselinux1:i386{a} libstdc++6:i386{a} libtasn1-6:i386{a} 
  libtinfo5:i386{a} libudev1:i386{a} libwine:i386{a} libwine-gecko-2.21{a} libx11-6:i386{a} 
  libx11-xcb1:i386{a} libxau6:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} 
  libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a} 
  libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxml2:i386{a} 
  libxshmfence1:i386{a} libxxf86vm1:i386{a} wine32:i386 zlib1g:i386{a} 
Следующие пакеты будут обновлены:
  libc6 libgnutls-deb0-28 libhogweed2 liblcms2-2 libmpg123-0 libnettle4 libudev1 libxml2 
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  libasound2-plugins:i386 libc6-i686:i386 libgpm2:i386 libpulse0:i386 libsasl2-modules:i386 
  libtxc-dxtn-s2tc0:i386 libxcursor1:i386 
8 пакетов обновлено, 68 установлено новых, 0 пакетов отмечено для удаления, и 132 пакетов не обновлено.
Необходимо получить 56,7 MB/99,0 MB архивов. После распаковки 269 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libgnutls-openssl27 : Зависит: libgnutls-deb0-28 (= 3.3.8-6+deb8u3) но устанавливается 3.3.8-6+deb8u4.
 udev : Зависит: libudev1 (= 215-17+deb8u5) но устанавливается 215-17+deb8u6.
 libc6-dev : Зависит: libc6 (= 2.19-18+deb8u6) но устанавливается 2.19-18+deb8u7.
открыто: 72; закрыто: 233; отброшено: 46; конфликтует: 51           .Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                 
1)      blueman                                 
2)      bluetooth                               
3)      bluez                                   
4)      build-essential                         
5)      colord                                  
6)      debhelper                               
7)      dh-autoreconf                           
8)      dh-strip-nondeterminism                 
9)      exfat-fuse                              
10)     fuse                                    
11)     fuseiso9660                             
12)     g++                                     
13)     g++-4.9                                 
14)     grub-customizer                         
15)     gscan2pdf                               
16)     gufw                                    
17)     gvfs                                    
18)     gvfs-backends                           
19)     gvfs-daemons                            
20)     gvfs-fuse                               
21)     hplip                                   
22)     initramfs-tools                         
23)     iputils-ping                            
24)     libatk1.0-dev                           
25)     libc6-dev                               
26)     libcairo2-dev                           
27)     libcanberra-pulse                       
28)     libexpat1-dev                           
29)     libfontconfig1-dev                      
30)     libfreetype6-dev                        
31)     libfuse-dev                             
32)     libgdk-pixbuf2.0-dev                    
33)     libgimp2.0-dev                          
34)     libglib2.0-dev                          
35)     libgnutls-openssl27                     
36)     libgtk2.0-dev                           
37)     libpam-systemd                          
38)     libpango1.0-dev                         
39)     libpcre3-dev                            
40)     libpng12-dev                            
41)     libsane                                 
42)     libsane-perl                            
43)     libselinux1-dev                         
44)     libstdc++-4.9-dev                       
45)     libtool                                 
46)     libxft-dev                              
47)     linux-image-4.7.0-0.bpo.1-amd64-unsigned
48)     live-usb-maker-gui                      
49)     mx-apps                                 
50)     mx-system-sounds                        
51)     network-manager                         
52)     network-manager-gnome                   
53)     network-manager-openconnect             
54)     ntfs-3g                                 
55)     policykit-1                             
56)     policykit-1-gnome                       
57)     printer-driver-postscript-hp            
58)     pulseaudio                              
59)     pulseaudio-module-bluetooth             
60)     pulseaudio-module-x11                   
61)     sane-utils                              
62)     sshfs                                   
63)     systemd                                 
64)     testdisk                                
65)     udev                                    
66)     udisks2                                 
67)     unetbootin                              
68)     upower                                  
69)     uuid-dev                                
70)     virtualbox-guest-x11                    
71)     xfce4-power-manager                     
72)     xfce4-power-manager-plugins             
73)     xorg                                    
74)     xserver-xorg                            
75)     xserver-xorg-core                       
76)     xserver-xorg-input-all                  
77)     xserver-xorg-input-evdev                
78)     xserver-xorg-input-mouse                
79)     xserver-xorg-input-synaptics            
80)     xserver-xorg-input-vmmouse              
81)     xserver-xorg-video-all                  
82)     xserver-xorg-video-ati                  
83)     xserver-xorg-video-cirrus               
84)     xserver-xorg-video-fbdev                
85)     xserver-xorg-video-intel                
86)     xserver-xorg-video-mga                  
87)     xserver-xorg-video-modesetting          
88)     xserver-xorg-video-neomagic             
89)     xserver-xorg-video-nouveau              
90)     xserver-xorg-video-openchrome           
91)     xserver-xorg-video-radeon               
92)     xserver-xorg-video-savage               
93)     xserver-xorg-video-siliconmotion        
94)     xserver-xorg-video-sisusb               
95)     xserver-xorg-video-tdfx                 
96)     xserver-xorg-video-trident              
97)     xserver-xorg-video-vesa                 
98)     xserver-xorg-video-vmware               
99)     zlib1g-dev                              



Принять данное решение? [Y/n/q/?] 
Причём если устанавливаю wine то всё впорядке:
Следующие НОВЫЕ пакеты будут установлены:        
  libwine{a} libwine-gecko-2.21{a} wine wine64{a} 
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  wine32:i386 winehq-staging 
0 пакетов обновлено, 4 установлено новых, 0 пакетов отмечено для удаления, и 140 пакетов не обновлено.
Необходимо получить 0 B/58,4 MB архивов. После распаковки 167 MB будет занято.
Хотите продолжить? [Y/n/?] 
Но этот вайн я уже ставил, 32 битные приложения он запускать не умеет даже с переменной WINEARCH=win32. Как мне установить пакет wine32:i386?

Это делал для начала?

# aptitude update
# aptitude safe-upgrade
Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Уже делал. Сейчас выполнил aptitude safe-upgrade не помогло. Мой дистрибутив MX-16.

LEONARDO ()
Ответ на: комментарий от LEONARDO

Мой дистрибутив MX-16.

Это чего такое? В первый раз слышу. :) Может, репозитории поломаны в этом MX-16 и еще не обновились до актуальных? Вообще, какие там репозитории используются: родные дебиановские или какие-то свои? Ну вот, например, набери:

# aptitude versions ^libudev1$

и

# aptitude versions ^udev$
Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 3)
Ответ на: комментарий от Zubok

Это чего такое? В первый раз слышу.

Это не роллинг user-friendly стабильный дистрибутив. Вот сайт https://mxlinux.org/

aptitude versions ^libudev1$

Вот результат

Пакет libudev1:                                         
i   215-17+deb8u5                                                                                  100 
p   215-17+deb8u6                                            stable                                500 

Пакет libudev1:i386:
p   215-17+deb8u6                                            stable                                500
[/bash]
Репозиториев тут очень много

 cat /etc/apt/sources.list.d/*
# Use with Debian Stable/Jessie repositories.
deb http://nl.mxrepo.com/antix/jessie jessie main
# Debian Stable.
deb http://ftp.ru.debian.org/debian/ jessie main contrib non-free 
deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://ftp.ru.debian.org/debian/ jessie main contrib non-free 

# Multimedia Stable.
# Use to install libdvdcss2 and codecs.
#deb http://www.deb-multimedia.org jessie main non-free

#jessie backports 
#deb http://httpredir.debian.org/debian jessie-backports main
# Debian Jessie Updates
deb http://ftp.ru.debian.org/debian/ jessie-updates main contrib non-free
# Mepis Community Main and Test Repos
deb http://nl.mxrepo.com/mx/repo/ mx16 non-free main
# Mepis Community Main and Test Repos
deb http://nl.mxrepo.com/mx/repo/ mx15 main non-free
#deb http://nl.mxrepo.com/mx/testrepo/ mx15 test
# opera
# deb http://deb.opera.com/opera/ stable non-free 

# virtualbox
# deb http://download.virtualbox.org/virtualbox/debian/ jessie contrib
LEONARDO ()
Ответ на: комментарий от LEONARDO

Сейчас выполнил aptitude safe-upgrade не помогло

Ну а что произошло? Ничего? Он хоть обновился? Тогда попробуй тупо переставить явно пакеты, которые конфликтуют. Видно же, что они на маленький шажок отстают по версии. В репозиториях какая-то нестыковка:

# aptitude update
# aptitude reinstall libgnutls-openssl27 udev libc6-dev
Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

aptitude reinstall libgnutls-openssl27 udev libc6-dev

Выводит

Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:          
  libc6-dev libgnutls-openssl27 udev 
0 пакетов обновлено, 0 установлено новых, 3 переустановлено, 0 пакетов отмечено для удаления, и 137 пакетов не обновлено.
Необходимо получить 0 B/231 kB архивов. После распаковки 0 B будет занято.
E: Невозможно найти источник для загрузки «udev:amd64» версии «215-17+deb8u5»
E: Невозможно найти источник для загрузки «udev:amd64» версии «215-17+deb8u5»
E: Внутренняя ошибка: не удалось создать список пакетов для скачивания
Подключил репозиторий
deb http://httpredir.debian.org/debian jessie main 
и выполнил aptitude update, ничего не меняется. Уже новая версия версия доступна https://packages.debian.org/jessie/udev

LEONARDO ()
Ответ на: комментарий от LEONARDO

Невозможно найти источник для загрузки «udev:amd64» версии «215-17+deb8u5»

А его уже и нет в репозиториях, а он его пытается поставить. То есть списки пакетов на компе у тебя какие-то старые и он по ним пытается поставить старые версии, хотя уже новые должны быть, раз в репах все есть. Предлагаю удалить списки с компа и заново update сделать. Почему они не обновляются, я не могу сразу так сказать:

# rm -rf /var/lib/apt/lists/* (аккуратно!)
# aptitude update
# aptitude safe-upgrade

Может, он доступа к какому-то репозиторию от тебя не имеет? Попробуй еще, скажем, поменять ru на fi в некоторых адресах репозиториев Debian.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)
Ответ на: комментарий от Zubok

Я исходники скачал, если не получится то буду компилировать. reinstall не работает, только install

Следующие пакеты будут обновлены:                
  libudev1 udev 
2 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 129 пакетов не обновлено.
Необходимо получить 935 kB/1 165 kB архивов. После распаковки 1 024 B будет занято.
Хотите продолжить? [Y/n/?] 
[/bash]

LEONARDO ()
Ответ на: комментарий от LEONARDO

Должно получиться. Компилировать - это прямо какой-то BDSM. Зачем? Видно же, что проблема в списках, в обновлении списков. По какой-то причине они старые и не обновились после aptitude update. Вот я предположил, что репозиторий не отзывался у тебя, поэтому списки остались старыми. Но это не факт. Расскажи, что получается.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Просто когда компилируешь можно всё подстроить и оптимизировать скриптом .configure. Сейчас удалил тормознутый репозиторий antix и ftp://ftp.debian и поставил эти пакеты. Загружается 53 мегабайта. Всё установилось и работает, проблема решена.

LEONARDO ()
Ответ на: комментарий от LEONARDO

Сейчас удалил тормознутый репозиторий antix

deb http://nl.mxrepo.com/antix/jessie jessie main

А что это за репозиторий? Я правильно понимаю, что это пакеты, которых нет в дистрибутиве Debian и которые содержат дополнительные пакеты этого MX-16. Если да, то, может, его и не стоило удалять? Я глянул в Packages. http://nl.mxrepo.com/antix/jessie/dists/jessie/main/binary-i386/Packages. Тут вроде не так много всего. Некоторые пакеты с суффиксом -antix.

Zubok ★★★★★ ()

Debian-based? Почему я не удивлен.

А почему ты не хочешь поставить просто wine? Он же сейчас мультиархитектурный везде, в том числе и в jessie. Он должен сам подтащить все необходимые либы.

meliafaro ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.