LINUX.ORG.RU

debian, dist-upgrade хочет удалить все i386 пакеты


0

1

Сегодня решил сделать апгрейд.
Аутпут:

root@debian:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libc-bin libc-dev-bin libc6 libc6-dbg libc6-dev libc6-dev-i386 libc6-i386
The following packages will be upgraded:
  locales multiarch-support
2 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
Need to get 5,864 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ftp.fi.debian.org/debian/ wheezy-proposed-updates/main multiarch-support amd64 2.13-38+deb7u1 [150 kB]
Get:2 http://ftp.fi.debian.org/debian/ wheezy-proposed-updates/main locales all 2.13-38+deb7u1 [5,714 kB]
Fetched 5,864 kB in 12s (480 kB/s)                                             
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 292156 files and directories currently installed.)
Preparing to replace multiarch-support 2.13-38 (using .../multiarch-support_2.13-38+deb7u1_amd64.deb) ...
Unpacking replacement multiarch-support ...
Setting up multiarch-support (2.13-38+deb7u1) ...
(Reading database ... 292156 files and directories currently installed.)
Preparing to replace locales 2.13-38 (using .../locales_2.13-38+deb7u1_all.deb) ...
Unpacking replacement locales ...
Processing triggers for man-db ...
Setting up locales (2.13-38+deb7u1) ...
Generating locales (this might take a while)...
  en_US.ISO-8859-1... done
  en_US.ISO-8859-15... done
  en_US.UTF-8... done
  ru_RU.ISO-8859-5... done
  ru_RU.CP1251... done
  ru_RU.KOI8-R... done
  ru_RU.UTF-8... done
Generation complete.
root@debian:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  freeglut3:i386 gens:i386 google-earth-stable gtk2-engines:i386
  gtk2-engines-pixbuf:i386 ia32-libs ia32-libs-gtk ia32-libs-gtk-i386:i386
  ia32-libs-i386:i386 lesstif2:i386 libaacplus2:i386 libacl1:i386
  libart-2.0-2:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386
  libatk1.0-0:i386 libattr1:i386 libaudio2:i386 libaudiofile1:i386
  libavahi-client3:i386 libavahi-common3:i386 libavcodec53:i386
  libavutil51:i386 libbsd0:i386 libc6:i386 libc6-i686:i386 libcaca0:i386
  libcairo-gobject2:i386 libcairo2:i386 libcanberra-gtk-module:i386
  libcanberra-gtk0:i386 libcanberra-gtk3-0:i386 libcanberra-gtk3-module:i386
  libcanberra-pulse:i386 libcanberra0:i386 libcap2:i386 libcolord1:i386
  libcomerr2:i386 libcrystalhd3:i386 libcups2:i386 libcurl3:i386
  libdatrie1:i386 libdb5.1:i386 libdbus-1-3:i386 libdbus-glib-1-2:i386
  libdirac-encoder0:i386 libdirectfb-1.2-9:i386 libdrm-intel1:i386
  libdrm-nouveau1a:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
  libesd0:i386 libexif12:i386 libexpat1:i386 libfaac0:i386 libffi5:i386
  libflac8:i386 libfltk1.1:i386 libfontconfig1:i386 libfreetype6:i386
  libgail-common:i386 libgail18:i386 libgcc1:i386 libgconf-2-4:i386
  libgconf2-4:i386 libgcrypt11:i386 libgd2-xpm:i386 libgdbm3:i386
  libgdk-pixbuf2.0-0:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
  libgl1-nvidia-glx:i386 libglapi-mesa:i386 libglib1.2:i386 libglib2.0-0:i386
  libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386
  libgphoto2-port0:i386 libgpm2:i386 libgsm1:i386 libgssapi-krb5-2:i386
  libgtk-3-0:i386 libgtk2.0-0:i386 libice6:i386 libidn11:i386
  libieee1284-3:i386 libjack0:i386 libjasper1:i386 libjbig0:i386
  libjpeg62:i386 libjpeg8:i386 libjson0:i386 libk5crypto3:i386
  libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386
  liblcms2-2:i386 libldap-2.4-2:i386 libltdl7:i386 liblua5.1-0:i386
  liblzma5:i386 liblzo2-2:i386 libmng1:i386 libmp3lame0:i386 libmpg123-0:i386
  libncurses5:i386 libncursesw5:i386 libnspr4:i386 libnspr4-0d:i386
  libnss3:i386 libnss3-1d:i386 libnvidia-compiler:i386 libodbc1:i386
  libogg0:i386 libopenal1:i386 libopencore-amrnb0:i386 libopencore-amrwb0:i386
  libopenjpeg2:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpam0g:i386
  libpango1.0-0:i386 libpciaccess0:i386 libpcre3:i386 libpixman-1-0:i386
  libpng12-0:i386 libpopt0:i386 libpulse0:i386 libqt4-dbus:i386
  libqt4-network:i386 libqt4-script:i386 libqt4-test:i386 libqt4-xml:i386
  libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 librtmp0:i386
  libsamplerate0:i386 libsane:i386 libsane-extras:i386 libsasl2-2:i386
  libsasl2-modules:i386 libschroedinger-1.0-0:i386 libsdl-ttf2.0-0:i386
  libsdl1.2debian:i386 libselinux1:i386 libsigc++-2.0-0c2a:i386 libslang2:i386
  libsm6:i386 libsndfile1:i386 libspeex1:i386 libspeexdsp1:i386
  libsqlite3-0:i386 libssh2-1:i386 libssl1.0.0:i386 libstdc++5:i386
  libstdc++6:i386 libsvga1:i386 libsysfs2:i386 libtasn1-3:i386 libtdb1:i386
  libthai0:i386 libtheora0:i386 libtiff4:i386 libtinfo5:i386 libts-0.0-0:i386
  libusb-0.1-4:i386 libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386
  libva1:i386 libvdpau1:i386 libvo-aacenc0:i386 libvo-amrwbenc0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libvorbisfile3:i386 libvpx1:i386
  libwine:i386 libwine-alsa:i386 libwine-bin:i386 libwine-cms:i386
  libwine-gl:i386 libwine-openal:i386 libwmf0.2-7:i386 libwrap0:i386
  libx11-6:i386 libx11-xcb1:i386 libx264-124:i386 libx86-1:i386 libxau6:i386
  libxaw7:i386 libxcb-glx0:i386 libxcb-render-util0:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386
  libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386
  libxi6:i386 libxinerama1:i386 libxml2:i386 libxmu6:i386 libxmuu1:i386
  libxp6:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386 libxslt1.1:i386
  libxss1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libxvidcore4:i386
  libxxf86vm1:i386 nvidia-libopencl1:i386 nvidia-opencl-icd:i386
  nvidia-vdpau-driver:i386 odbcinst1debian2:i386 teamviewer wine-bin:i386
  xaw3dg:i386 zlib1g:i386
The following NEW packages will be installed:
  wine64-bin
The following packages will be upgraded:
  libc-bin libc-dev-bin libc6 libc6-dbg libc6-dev libc6-dev-i386 libc6-i386
7 upgraded, 1 newly installed, 233 to remove and 0 not upgraded.
Need to get 16.7 MB/16.8 MB of archives.
After this operation, 727 MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

Я их не хочу удалять) Что нужно сделать?

apt-mark maual wine-bin:i386, лал.

anonymous ()

Я их не хочу удалять) Что нужно сделать?

А у тебя какая архитектура в настоящий момент? Если amd64, то зачем тебе эти пакеты для i386?

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Я их не хочу удалять) Что нужно сделать?

А у тебя какая архитектура в настоящий момент? Если amd64, то зачем тебе эти пакеты для i386?

Подозреваю что:

teamviewer, wine-bin:i386

Deleted ()

google-earth-stable

оно еще живо?

Deleted ()
Ответ на: комментарий от Deleted

М-м-м, может быть. Тогда, я бы не стал пока тупо помечать все библиотеки как поставленные вручную. Лучше разобраться в доках по apt, как правильно держать у себя две архитектуры одновременно и как правильно проводить обновления. Наверняка что-то в конфиг можно вписать. Я помню, было там что-то такое - список архитектур прописать можно. Надо найти.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Я помню, было там что-то такое - список архитектур прописать можно.

dpkg-architecture add i386 ? Оно только загружает пакеты из выбранной архитектуры и дает их ставить. Вообще странное поведение у ТС.

Deleted ()
Ответ на: комментарий от Deleted

Мне кажется, что у него из-за wine. У него как раз wine-bin:386 сносится, а wine64-bin ставится. Скорее всего, все эти библиотеки wine и притащил.

Zubok ★★★★★ ()

Он скорее всего вот эту жабу google-earth-stable хочет удалить и все что оно натянуло.

hbars ★★★★ ()

Посмотри вот это.

https://wiki.debian.org/Multiarch/HOWTO

Я не могу сказать, это ли, потому что еще сижу на oldstable и, к тому же, на одной архитектуре.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Вот ты почти и допёр до того, что написано во втором посте :3

anonymous ()
Ответ на: комментарий от hbars

Не, мне кажется, что как раз google-earth - это следствие, а не причина. Идет попытка удалить какую-то важную библиотеку для него, а он уже за компанию. А этот google-earth - он нативный или wine?

Zubok ★★★★★ ()
Ответ на: комментарий от anonymous

Ну, это пока наиболее реальное предположение. Ведь даже если из-за wine, то почему он сносится тогда? Это же разные пакеты. Единственное, что могу предположить, что они вместе могут конфликтовать. Пусть, конечно, попробует wine сделать manual. Но не факт, что причина в том, как он установлен. Его тогда hold надо будет делать. Но прежде надо разобраться.

Zubok ★★★★★ ()

А все пакеты wine64 у тебя тоже стоят или только wine?

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Через apt-cache show пусть посмотрит что из этих 3 пакетов у него тянет больщую часть библиотек. wine64 в debian урезанный до жути кстати.

Deleted ()
Ответ на: комментарий от Deleted

Лучше aptitude -D -s dist-upgrade

     -D, --show-deps
           For commands that will install or remove packages (install,
           full-upgrade, etc), show brief explanations of automatic
           installations and removals.

       -s, --simulate
           In command-line mode, print the actions that would normally be
           performed, but don't actually perform them. This does not require
           root privileges. In the visual interface, always open the cache in
           read-only mode regardless of whether you are root.

Zubok ★★★★★ ()

А ты upgrade с чего на что делаешь? На sid? В sid теперь так для wine:

dep: wine32 (>= 1.6.1-6)
          Windows API implementation - 32-bit binary loader 
or wine64 (>= 1.6.1-6)
          Windows API implementation - 64-bit binary loader 

То есть wine теперь метапакет. Значит, надо оба wine (32, 64) ставить. Иначе он только один поставит для удовлетворения зависимости. В jessie же wine и wine64.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

mark manual абсолютно ни при чём, потому что gens:i386, например, установлен вручную.

root@debian:~# aptitude -D -s dist-upgrade
The following packages will be upgraded: 
  libc-bin  libc-dev-bin  libc6{b} (B: libc6:i386)  libc6-dbg  libc6-dev  
  libc6-dev-i386  libc6-i386  
7 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.7 MB of archives. After unpacking 63.5 kB will be used.
The following packages have unmet dependencies:
 libc6 : Breaks: libc6:i386 (!= 2.13-38+deb7u1) but 2.13-38 is installed.
 libc6:i386 : Depends: libc-bin:i386 (= 2.13-38) but it is not going to be installed.
              Breaks: libc6 (!= 2.13-38) but 2.13-38+deb7u1 is to be installed.
open: 25; closed: 347; defer: 18; conflict: 72                                 .The following actions will resolve these dependencies:

       Remove the following packages:                                           
1)       freeglut3:i386                                                         
2)       gens:i386                                                              
---
пакеты
---
                                                 
233)     xaw3dg:i386                                                            
234)     zlib1g:i386                                                            

       Leave the following dependencies unresolved:                             
235)     libcanberra-gtk0:i386 recommends libcanberra-gtk-module:i386           
236)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386 (>= 7.2)          
237)     libncurses5:i386 recommends libgpm2:i386                               
238)     libncursesw5:i386 recommends libgpm2:i386                              
239)     libopenal1:i386 recommends libasound2:i386 (>= 1.0.16)                 
240)     libqtgui4:i386 recommends libcups2:i386                                
241)     libslang2:i386 recommends libpng12-0:i386                              
242)     libwine:i386 recommends libgsm1:i386 (>= 1.0.13)                       
243)     libwine:i386 recommends libv4l-0:i386 (>= 0.5.0)                       
244)     q4wine recommends wine64-bin | wine64-bin-unstable | wine | wine1.2 | w


Accept this solution? [Y/n/q/?] 
Sergei_Alekseev ()
Ответ на: комментарий от Sergei_Alekseev

Однако вот у тебя строчка libc6{b} (B: libc6:i386). Она говорит о том, что пакет ломается и пишет почему. Все, похоже, из-за него. Теперь надо разобраться, чего ему не нравится.

Да у меня wheezy, забыл написать. Апгрейд пакетов я делаю)

С wheezy на wheezy?

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Sergei_Alekseev

Какие репы подключены? Что в sources.list?

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

А, это были какие-то глюки в репах.
После apt-get update, apt-get upgrade, apt-get dist-upgrade по новой,
всё обновилось без ошибок.
Видимо я попал в момент, когда пакеты заливались.
Извиняюсь, что отнял время из-за ерунды.

Sergei_Alekseev ()
Ответ на: комментарий от Deleted

Зачем вообще нужен Google Earth, если есть Google Maps? Функционал же одинаков. Если б у него хоть карты оффлайновые были, а так просто нативное ненужно, по сути говоря.

MiniRoboDancer ★☆ ()
Ответ на: комментарий от MiniRoboDancer

Да мне и то, и другое не нужно особенно)
Пусть будет, мне не мешает.
А i386 у меня из-за других программ, которых нет amd64.
Kega Fusion, например.

Sergei_Alekseev ()
Ответ на: комментарий от Zubok

Нативный и ужасно кривой.
Под x32 не видел как работает - не скажу, но под x64 это что-то.

hbars ★★★★ ()
Ответ на: комментарий от Sergei_Alekseev

А, это были какие-то глюки в репах.

Или просто забыл update сделать перед upgrade, или какая-то репа оказалась в момент update недоступной. В итоге - неактуальные списки пакетов.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Нет, update, я не забыл сделать.
Я постил баг, сейчас пришел ответ -

...it's just that the amd64 package has just been
uploaded, and the i386 packages isn't available yet. It should be
available in a few hours.

Sergei_Alekseev ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.