LINUX.ORG.RU

unmet dependencies

 


0

2

Debian 10

root@home:/home/admin# apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libgl1-mesa-dri : Depends: libc6 (>= 2.29) but 2.24-11+deb9u4 is installed
                   Depends: libdrm-amdgpu1 (>= 2.4.100) but 2.4.74-1 is installed
                   Depends: libdrm2 (>= 2.4.75) but 2.4.74-1 is installed
                   Depends: libllvm9 (>= 1:9~svn298832-1~) but it is not installed
                   Depends: libsensors5 (>= 1:3.5.0) but it is not installed
 libgl1-mesa-dri:i386 : Depends: libc6:i386 (>= 2.29) but it is not installed
                        Depends: libdrm-amdgpu1:i386 (>= 2.4.100) but it is not installed
                        Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not installed
                        Depends: libdrm-nouveau2:i386 (>= 2.4.66) but it is not installed
                        Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not installed
                        Depends: libdrm2:i386 (>= 2.4.75) but it is not installed
                        Depends: libelf1:i386 (>= 0.142) but it is not installed
                        Depends: libexpat1:i386 (>= 2.0.1) but it is not installed
                        Depends: libgcc1:i386 (>= 1:4.2) but it is not installed
                        Depends: libglapi-mesa:i386 but it is not installed
                        Depends: libllvm9:i386 (>= 1:9~svn298832-1~) but it is not installed
                        Depends: libsensors5:i386 (>= 1:3.5.0) but it is not installed
                        Depends: libstdc++6:i386 (>= 5.2) but it is not installed
                        Depends: zlib1g:i386 (>= 1:1.1.4) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
root@home:/home/admin# 

как вылечить?