LINUX.ORG.RU

i386 библиотеки для Ubuntu 14.10 x86_64

 , , ,


0

1

Всем привет.

Не могу установить сабж. Сделал:

$ sudo dpkg --add-architecture i386
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade

$ sudo dpkg --print-architecture
amd64

$ cat /var/lib/dpkg/arch
amd64
i386

$ sudo apt-get install libsdl1.2:i386 libgtk2.0-0:i386 libsdl-image1.2:i386 libsdl-ttf2.0-0:i386 libglu1-mesa:i386 libopenal-dev:i386 libsndfile1-dev:i386
Reading package lists... Done
Building dependency tree 
Reading state information... Done
Package libgtk2.0-0:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libgtk2.0-common libgdk-pixbuf2.0-0

Package libsdl1.2:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libsdl1.2:i386' has no installation candidate
E: Package 'libgtk2.0-0:i386' has no installation candidate
E: Unable to locate package libsdl-image1.2
E: Couldn't find any package by regex 'libsdl-image1.2'
E: Unable to locate package libsdl-ttf2.0-0
E: Couldn't find any package by regex 'libsdl-ttf2.0-0'
E: Unable to locate package libopenal-dev
E: Unable to locate package libsndfile1-dev

libc6:i386 установлен. Не знаю, что еще можно сделать.

P.S. я сдуру удалил все i386 пакеты из системы, в надежде, что переустановка спасет отца русской демократии. Среди этих пакетов были и важные (вроде дров для видео, gcc-4.9:i386 ну и т.д.). Теперь они все не устанваливаются (ошибки те же, что и в приведенном выше логe).

Ответ на: комментарий от dvrts

Ничего не дает.

$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  at bbswitch-dkms dkms libcuda1-331-updates lsb-security ncurses-term nvidia-prime nvidia-settings pax screen-resolution-extra
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
maverik ★★ ()
Ответ на: комментарий от SevikL

Кэп, залогинтесь. Это понятно, что нет жалоб. Но устанавливать нужные пакеты он не хочет. Вообще ни один i386 пакет он теперь не хочет устанавливать.

maverik ★★ ()
Ответ на: комментарий от maverik

Вообще ни один i386 пакет он теперь не хочет устанавливать.

Покажи все файлы в /etc/apt/sources.list.d

proud_anon ★★★★★ ()
Ответ на: комментарий от maverik
sudo apt-get install libpng12-0:i386
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия libpng12-0:i386.

кэп умывает руки, УМВР. без всяких выкрутасов с add-architecture, кстати

SevikL ★★★★★ ()
Ответ на: комментарий от proud_anon
$ sudo apt-get install 'libsdl1.2debian:i386'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libsdl1.2debian:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libsdl1.2debian:i386' has no installation candidate

$ sudo apt-get install libgtk2.0-0:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgtk2.0-0:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libgtk2.0-common libgdk-pixbuf2.0-0

E: Package 'libgtk2.0-0:i386' has no installation candidate

$ sudo apt-get install libgtk2.0-common:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libgtk2.0-common' instead of 'libgtk2.0-common:i386'
libgtk2.0-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
$  lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:        14.10
Codename:       utopic

Кажется, все сломалось.

maverik ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.