LINUX.ORG.RU

Не удается обновить систему, проблема с зависимостями

 


0

1

Добрый вечер, пытаюсь обновить систему командами sudo aptitude update; sudo aptitude dist-upgrade Вот вывод:

Чтение списков пакетов...
Построение дерева зависимостей...
Чтение информации о состоянии...
Чтение информации о расширенных состояниях...
Инициализация состояний пакетов...
Чтение описаний задач...
Следующие НОВЫЕ пакеты будут установлены:
  adwaita-icon-theme{a} ... wwwconfig-common{u} 
Следующие пакеты будут обновлены:
  accountsservice ...zlib1g 
1350 пакетов обновлено, 652 установлено новых, 271 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 1,452 MB архивов. После распаковки 1,045 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 xserver-xorg-video-rendition : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-s3virge : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 gcc-4.9-base : Ломает: gcc-4.7-base (< 4.7.3) но установлен 4.7.2-5 
 xserver-xorg-video-apm : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-ark : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-sis : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 python3-uno : Конфликтует: python-uno но устанавливается 1:4.3.3-2.
 xserver-xorg-video-s3 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-tseng : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 python-uno : Конфликтует: python3-uno но устанавливается 1:4.3.3-2.
 gcc-4.8-base : Ломает: gcc-4.7-base (< 4.7.3) но установлен 4.7.2-5 
 iputils-arping : Конфликтует: arping но устанавливается 2.14-1.
 xserver-xorg-video-i128 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-chips : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-voodoo : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 xserver-xorg-video-i740 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
 arping : Конфликтует: iputils-arping но устанавливается 3:20121221-5+b2.
 db5.1-util : Ломает: libdb5.1 (< 5.1.29-8~) но установлен 5.1.29-5 
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:                         
1)      cpp-4.7                                         
2)      db5.1-util                                      
3)      gcc-4.7                                         
4)      gcc-4.7-base                                    
5)      python-uno                                      
6)      xserver-xorg-video-apm                          
7)      xserver-xorg-video-ark                          
8)      xserver-xorg-video-chips                        
9)      xserver-xorg-video-i128                         
10)     xserver-xorg-video-i740                         
11)     xserver-xorg-video-rendition                    
12)     xserver-xorg-video-s3                           
13)     xserver-xorg-video-s3virge                      
14)     xserver-xorg-video-sis                          
15)     xserver-xorg-video-tseng                        
16)     xserver-xorg-video-voodoo                       

      Сохранить для следующих пакетов их текущие версии:
17)     iputils-arping [Не установлен]                  

      Оставить следующие зависимости неразрешёнными:    
18)     network-manager рекомендует iputils-arping      


Принять данное решение? [Y/n/q/?]

Список пакетов в выводе пришлось сократить. Как можно решить проблему? Заранее спасибо.

Попробуй в интерактивном режиме обновить поэтапно. И стоит почистить систему то мусора. Не думаю, что xserver-xorg-video-voodoo или -s3 необходимы

at ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.