LINUX.ORG.RU

[ATI, fglrx, Debian testing] Снова проблемы


0

1
Следующие НОВЫЕ пакеты будут установлены:        
  fglrx-driver{b} 
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  fglrx-glx-ia32 
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 6 пакетов не обновлено.
Необходимо получить 8 539 kB архивов. После распаковки 23,8 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  fglrx-driver: Зависит: xorg-video-abi-10 который является виртуальным пакетом. или
                                xorg-video-abi-8 который является виртуальным пакетом. или
                                xorg-video-abi-6.0 который является виртуальным пакетом.
                Зависит: xserver-xorg-core (< 2:1.10.99) но установлен 2:1.11.1-1 
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     fglrx-driver [Не установлен]

Ну вот опять... Обновился в тестинг xserver-xorg-core и началось! Я как всегда ушами прохлопал зависимости.

Пока переполз на xserver-xorg-video-radeon, Blender не работает. Печаль.

★★★

Из интереса можно подключить репозиории sid и настроить apt pinning, чтобы недостающие зависимости брались оттуда.

А как не работает Blender? Может быть, ему нужно правильный libGL подсунуть?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Sid подключен. Там так получилось, что в тестинге и сиде xserver-xorg-core одинаковая версия 1.11.1-1, а в стейбл 1.7.7-13. Аptitude разрешил зависимости понизив версии xserver-xorg-core и связанных пакетов, правда я до этого подключил репозиторий squeeze-backports, оттуда он и стянул нужные версии.

А Blender просто сразу вылетал, в консоль я что-то не посмотрел на что ругается.

MikeB ★★★ ()

AMD слоупочит, 11-9 до сих пор не отрелизили, 11-8 не умеет x.org 1.11. В сиде недели две назад уже на full-upgrade аптитуда начала предлагать снести fglrx, сегодня это доехало и до тестинга.

leave ★★★★★ ()

Откытывай иксы. snapshot.debian.org в руки и вперед!

З.Ы. Не забывайте про этот замечательный сайт.

Pavval ★★★★★ ()
Ответ на: комментарий от MikeB

Можно чуть поподробнее: как именно aptitude разрешил зависимости? Я подключит backports, но все равно вижу тоже, что и у вас в первом сообщении.

Unforgiven ()
Ответ на: комментарий от daemonpnz

Что-то я не понял: добавили они поддержку X.Org 1.11 или нет? Где ченджлог?

leave ★★★★★ ()
Ответ на: комментарий от leave

Changelog'а нет. АМД его зажлобила. Вот что народ на форониксе пишет:

Umm... yeah: - tested on 3.1-rc7 kernel - fglrx doesn't need a patch to work with it (just like 11.8), and radeon hd 4850; - i don't see rainbow bar in GNOME3 although other bad things stayed, like slow window moving or strange flickering/garbages rendered whenever i will run kde app with systray icon - i've also tested it on xorg-server 1.11.1 from arch's [testing] repository but it's not working with it... - many files inside this driver is different, but there's no new files, so it's easier for a maintainers to update

So i actually hope that this 11.9 was put there by a mistake and a better version of 11.9 will be uploaded today ;P If not, well... Michael you were wrong about incoming xserver 1.11.x support ;P

the catalyst 11.10 is the one with the new xserver support. because of ubuntu 11.10

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

Мда. Я не то чтобы против послоупочить иногда, но затягивать с поддержкой свежих иксов два месяца - это как-то чересчур ( Что ж, будем дальше жить на safe-upgrade )

leave ★★★★★ ()
Ответ на: комментарий от leave

Кстати, не факт, что и в следующей версии будет поддержка, потому что ориентируются они на убунту, а в 11.10 убунте будет ксорг 1.10.4

daemonpnz ★★★★★ ()

Да уж... А я то понадеялся когда увидел, что вышел 11.9...

MikeB ★★★ ()

А я брал ядро и иксы из stable, а все остальное из testing. Вроде все ок было

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

С ядром проблем вроде нет и не было, а с иксами наверное без разницы откуда, в backports поновее.

MikeB ★★★ ()
Ответ на: комментарий от MikeB

ну на моем буке не получается использовать ядра выше 2.6.32, с ними система намертво виснет при опросе интерфейса wlan0

N1ghtmare ★★ ()

Я тоже один раз проморгал этот момент, когда dist-upgrade тихо снёс драйвер а замены не нашёл. плевался недели 3. Уже даже думал на оффтопик пересесть. Когда сделали драйвер - вроде всё со скрипом заработало. При этом всё равно глюков куча, производительность низкая.

С официального сайта дрова так и не удалось ни разу установить. Всегда какие-то проблемы.

sirex ()
Ответ на: комментарий от sirex

В общем я уже окончательно перешел на свободные дрова.

MikeB ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.