LINUX.ORG.RU

Видео карта от AMD на Debian Testing

 , , ,


1

1

Пытаюсь поставить проприретарный драйвер (производительность открытого весьма не устраивает) для ATI на Debian Testing, но не получается:

# apt-get install fglrx-driver
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 fglrx-driver : Зависит: xorg-video-abi-15 но он не может быть установлен или
                                xorg-video-abi-14 но он не может быть установлен или
                                xorg-video-abi-13 но он не может быть установлен или
                                xorg-video-abi-12 или
                                xorg-video-abi-11 но он не может быть установлен или
                                xorg-video-abi-10 но он не может быть установлен или
                                xorg-video-abi-8 но он не может быть установлен или
                                xorg-video-abi-6.0 но он не может быть установлен
                Рекомендует: fglrx-modules-dkms (= 1:14.4.2-1) но он не будет установлен или
                                        fglrx-kernel-14.4.2
                Рекомендует: libgl1-fglrx-glx (= 1:14.4.2-1) но он не будет установлен
                Рекомендует: libgl1-fglrx-glx-i386
                Рекомендует: fglrx-atieventsd но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Пробовал ставить из sid и experimental, но ошибка та же.

★★★★★

Рекомендует: libgl1-fglrx-glx-i386

Помочь не смогу, но уверен что у вас спросят это в будущем какая разрядность ОС?

abs ★★★ ()
Ответ на: комментарий от i-rinat

А ещё я где-то видел, что можно как-то поставить из experimental или sid репозитория без даунгрейда

KivApple ★★★★★ ()
Ответ на: комментарий от i-rinat
$ sudo apt-get update
В кэше http://snapshot.debian.org testing InRelease
E: Файл Release для http://snapshot.debian.org/archive/debian/20140609T102922Z/dists/testing/InRelease просрочен (недостоверный начиная с 68д 3ч 18мин 8с). Обновление этого репозитория производиться не будет.

Что не так?

KivApple ★★★★★ ()

производительность открытого весьма не устраивает

забанься толстячок, на свободных дровишках все игры летают, что пробовал

anonymous ()

Такое бывает в репах дебиана. Через некоторое время фиксят.

roman77 ★★★★★ ()
Ответ на: комментарий от KivApple

проблема в том, что эта видяха не старая, а проблема тут в выборе дистрибутива, у меня сейчас ядро 3.16.1 и соответственно более новый драйвер, а он сидя на 3,2 естественно имеет проблемы.

erzent ☆☆ ()
Ответ на: комментарий от i-rinat
$ sudo apt-get install xserver-xorg-core=2:1.15.1-1 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  app-install-data apper apper-data appstream-index cdparanoia cdrdao dvd+rw-tools growisofs hyphen-en-us k3b k3b-data k3b-i18n kdeaccessibility kdesudo
  libappstream1 libdebconf-kde0 libepoxy0 libflac++6 libgee2 libk3b6 libk3b6-extracodecs libkcddb4 libkcompactdisc4 liblistaller-glib0 libmusicbrainz5-0
  libpackagekit-qt2-6 libqapt-runtime libqapt1 libreoffice libreoffice-help-en-us libreoffice-kde listaller mythes-en-us python3-pykde4 python3-pyqt4
  python3-sip python3-software-properties qapt-batch software-properties-common software-properties-kde sudo unattended-upgrades vcdimager x11-apps
  x11-session-utils xinit
Для их удаления используйте «apt-get autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  task-desktop xorg xserver-xorg xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-modesetting xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware
Пакеты, будут заменены на более СТАРЫЕ версии:
  xserver-xorg-core
обновлено 0, установлено 0 новых пакетов, 1 пакетов заменены на старые версии, для удаления отмечено 30 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 2 794 kБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 9 404 kB.
Хотите продолжить? [Д/н] n
Аварийное завершение.

Как заставить apt-get даунгрейдить не удаляя?

KivApple ★★★★★ ()
Ответ на: комментарий от Freyr69

вот когда на тестинге будут ядра после их релиза, без переделки и выпиливания куча новых утилит, тогда то, что я написал будет не верно.

erzent ☆☆ ()
Ответ на: комментарий от erzent

а проблема тут в выборе дистрибутива, у меня сейчас ядро 3.16.1 и соответственно более новый драйвер, а он сидя на 3,2 естественно имеет проблемы.

Ты путаешь со stable веткой, вот там 3.2. А в testing сейчас 3.14.15: https://packages.debian.org/jessie/linux-image-3.14-2-amd64. Для любителей посвежее есть ветка experimental, но там по-разному бывает, иногда новые версии через день-два появляются, иногда задержки значительно больше.

Я понимаю, что ты адинишь семейство RHEL, но стоит быть хотя бы в курсе основных фактов из других дистрибутивов. Крупных семейств не так уж и много.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

у меня о дебиане остался только негатив, экспериментальная ветка не стабильнее Fedora, тестинг часто не имеет многих обновлений, их почему то выпиливают. Я сначала думал сделать файловые сервера на дебиане, декабре прошлого года, потому что у меня дома дебиан 5 ещё под это. Но был очень огорчён версией btrfs в тестинге, 2008 года..... Так что файловые сервера на Fedora 20, правда обновляются они ток при важных обновлениях btrfs.

erzent ☆☆ ()
Ответ на: комментарий от erzent

Да-да, я понял. Debian плохой из-за старой версии btrfs. Океюшки.

i-rinat ★★★★★ ()
Ответ на: комментарий от steemandlinux

http://www.youtube.com/channel/UCh1UanySk_Ht0WRfo4O9STw

омг, зачем?

Кстати попробуй сделать RT запись в H264 на своей нвидиа, мы поржем.

Смехуечки! Первый копипаст команды из гугла на запись видео.

http://www.youtube.com/watch?v=9GlccQsxdus&feature=youtu.be

roman77 ★★★★★ ()

В testing fglrx-driver вообще выпилен с июля.
В unstable проблема описанная тобой висит в багтрекере.

Shadow1251 ()
Ответ на: комментарий от steemandlinux

Нет. Почему ты отвечаешь вопросом на вопрос?

anonymous ()
Ответ на: комментарий от roman77

Надо же, в ссаной gentoo нет поддержки opencl в ебилде ffmpeg. Пнул этих ушлёпков в багзилле.

anonymous ()
Ответ на: комментарий от steemandlinux

Хах, даже по ютубу видно что 70-80% эффектов выключены, прям вайн какой-то :d

haku ★★★★★ ()
Ответ на: комментарий от roman77

В шикарных проприентарных дровах нет поддержки nvidia shadowplay, а в открытых intel и amd поддержка аналогичной технологии есть.

steemandlinux ★★★★★ ()
Ответ на: комментарий от steemandlinux

Пишут что под wayland будет, недавно egl+gles запилили, значит и это будет.

anonymous ()
Ответ на: комментарий от steemandlinux

аналогичной технологии

Это ты так про opencl, или аппартный кодер? Если второе, где почитать?

anonymous ()
Ответ на: комментарий от anonymous

Я разве про дистрибутив? Я про архитип «пользователей» дебиана, которых среди реальных пользователей дебиана те самые 95%.

daemonpnz ★★★★★ ()
Ответ на: комментарий от KivApple

R9 270X, ядро 3.15.10, никаких различий в производительности между проприетарным на ядре 3.13 и свободным драйвером на текущем ядре на глаз не заметил...

...кроме того, что проприетарный крашится всё время))

Pyroman-Shizofrenik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.