LINUX.ORG.RU

Установка Fglrx

 ,


0

1

Установил себе Ubuntu 14.04 LTS. Решил поставить проприетарный драйвер. Делал по разным гайдам, остановился на этом - https://help.ubuntu.com/community/BinaryDriverHowto/AMD В общем :

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (rev ff)
$ sudo apt-get install fglrx
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 fglrx : Зависит: xorg-video-abi-11 но он не может быть установлен или
                         xorg-video-abi-12 но он не может быть установлен или
                         xorg-video-abi-13 но он не может быть установлен или
                         xorg-video-abi-14 но он не может быть установлен или
                         xorg-video-abi-15
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Ну если хочет, то давай установлю:
$ sudo apt-get install xorg-video-abi-15
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Заметьте, вместо «xorg-video-abi-15» выбирается «xserver-xorg-core»
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libcheese-gtk23 : Зависит: libclutter-gtk-1.0-0 (>= 0.91.8) но он не будет установлен
                   Зависит: libcogl15 (>= 1.15.8) но он не будет установлен
 libcheese7 : Зависит: libclutter-gst-2.0-0 (>= 0.10.0) но он не будет установлен
              Зависит: gstreamer1.0-clutter но он не будет установлен
 libclutter-1.0-0 : Зависит: libcogl-pango15 (>= 1.15.8) но он не будет установлен
                    Зависит: libcogl15 (>= 1.15.8) но он не будет установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
http://itmages.ru/image/view/2447909/7b43c6f6 - это если deb-пакетом ставить с сайта. Что в таком случае делать господа?

UPD: есть мысли по поводу 3,16 ядра. Что скажете, не в нем причина?

Ответ на: комментарий от moddi3

Сталкивался. Должно помочь:

sudo apt-get install libcheese*
Драйвер можешь попробовать взять с proposed. Туда последний каталист бэкпортировали.

Solar ()
Ответ на: комментарий от moddi3

ХЗ. Fglrx особо не пользовался, недавно приобрел компьютер с amd, вот и воспользовался. По аналогии с nvidia обе ветки драйвера должны обновляться.

Solar ()
Ответ на: комментарий от Solar

Ну в общем огромное спасибо, проблема решена после твоей команды дальше просто что просит то и ставить а в конце Fglrx

moddi3 ()
Ответ на: комментарий от moddi3

Всегда пожалуйста. С проприетарными драйвера всегда проблемы. Чем свободный драйвер не устраивает? У amd он высого качества.

Solar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.